Issue when installing development environment from 2.7 branch

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Issue when installing development environment from 2.7 branch

Dimitris Karakostis

Hello everyone, 

Recently I tried to install a new dev environment using the branch 2.7 but I keep getting an error related to OWSLib:

   "Could not find a version that satisfies the requirement OWSLib==0.14-dev"

I checked the requirements.txt and I see that the OWSLib package is commented out.(https://github.com/GeoNode/geonode/blob/2.7.x/requirements.txt)

I actually uncommented it and rerun the installation but I keep getting the same error. I tried to use the master branch as well but there is the same.

Everything works well with 2.6 releases but 2.6 uses a previous version of OWSLib as well. Does anyone has similar issues?

I would like to make some contributions so I guess its better if I work on 2.7 or master. 

Thanks 

Cheers

Dimitris




_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel
Reply | Threaded
Open this post in threaded view
|

Re: Issue when installing development environment from 2.7 branch

Alessio Fabiani-2
Try to pip uninstall all owslib packages you are on the system

Regards,

Alessio Fabiani

==
GeoServer Professional Services from the experts! Visit http://goo.gl/it488V for more information.
==

Ing. Alessio Fabiani

@alfa7691
Founder/Technical Lead


GeoSolutions S.A.S.
Via di Montramito 3/A
55054  Massarosa (LU)
Italy
phone: +39 0584 962313
fax:     +39 0584 1660272
mob:   +39 331 6233686

http://www.geo-solutions.it
http://twitter.com/geosolutions_it

-------------------------------------------------------

AVVERTENZE AI SENSI DEL D.Lgs. 196/2003

Le informazioni contenute in questo messaggio di posta elettronica e/o nel/i file/s allegato/i sono da considerarsi strettamente riservate. Il loro utilizzo è consentito esclusivamente al destinatario del messaggio, per le finalità indicate nel messaggio stesso. Qualora riceviate questo messaggio senza esserne il destinatario, Vi preghiamo cortesemente di darcene notizia via e-mail e di procedere alla distruzione del messaggio stesso, cancellandolo dal Vostro sistema. Conservare il messaggio stesso, divulgarlo anche in parte, distribuirlo ad altri soggetti, copiarlo, od utilizzarlo per finalità diverse, costituisce comportamento contrario ai principi dettati dal D.Lgs. 196/2003.

The information in this message and/or attachments, is intended solely for the attention and use of the named addressee(s) and may be confidential or proprietary in nature or covered by the provisions of privacy act (Legislative Decree June, 30 2003, no.196 - Italy's New Data Protection Code).Any use not in accord with its purpose, any disclosure, reproduction, copying, distribution, or either dissemination, either whole or partial, is strictly forbidden except previous formal approval of the named addressee(s). If you are not the intended recipient, please contact immediately the sender by telephone, fax or e-mail and delete the information in this message that has been received in error. The sender does not give any warranty or accept liability as the content, accuracy or completeness of sent messages and accepts no responsibility  for changes made after they were sent or for other risks which arise as a result of e-mail transmission, viruses, etc.


On Thu, Sep 7, 2017 at 12:13 PM, Dimitris Karakostis <[hidden email]> wrote:

Hello everyone, 

Recently I tried to install a new dev environment using the branch 2.7 but I keep getting an error related to OWSLib:

   "Could not find a version that satisfies the requirement OWSLib==0.14-dev"

I checked the requirements.txt and I see that the OWSLib package is commented out.(https://github.com/GeoNode/geonode/blob/2.7.x/requirements.txt)

I actually uncommented it and rerun the installation but I keep getting the same error. I tried to use the master branch as well but there is the same.

Everything works well with 2.6 releases but 2.6 uses a previous version of OWSLib as well. Does anyone has similar issues?

I would like to make some contributions so I guess its better if I work on 2.7 or master. 

Thanks 

Cheers

Dimitris




_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel
Reply | Threaded
Open this post in threaded view
|

Re: Issue when installing development environment from 2.7 branch

Simo D
Dimitris I see in pypi there's owslib 0.14 try to pip install owslib==0.14 instead and see if geonode works.

2017-09-07 12:18 GMT+02:00 Alessio Fabiani <[hidden email]>:
Try to pip uninstall all owslib packages you are on the system

Regards,

Alessio Fabiani

==
GeoServer Professional Services from the experts! Visit http://goo.gl/it488V for more information.
==

Ing. Alessio Fabiani

@alfa7691
Founder/Technical Lead


GeoSolutions S.A.S.
Via di Montramito 3/A
55054  Massarosa (LU)
Italy
phone: <a href="tel:+39%200584%20962313" value="+390584962313" target="_blank">+39 0584 962313
fax:     <a href="tel:+39%200584%20166%200272" value="+3905841660272" target="_blank">+39 0584 1660272
mob:   <a href="tel:+39%20331%20623%203686" value="+393316233686" target="_blank">+39 331 6233686

http://www.geo-solutions.it
http://twitter.com/geosolutions_it

-------------------------------------------------------

AVVERTENZE AI SENSI DEL D.Lgs. 196/2003

Le informazioni contenute in questo messaggio di posta elettronica e/o nel/i file/s allegato/i sono da considerarsi strettamente riservate. Il loro utilizzo è consentito esclusivamente al destinatario del messaggio, per le finalità indicate nel messaggio stesso. Qualora riceviate questo messaggio senza esserne il destinatario, Vi preghiamo cortesemente di darcene notizia via e-mail e di procedere alla distruzione del messaggio stesso, cancellandolo dal Vostro sistema. Conservare il messaggio stesso, divulgarlo anche in parte, distribuirlo ad altri soggetti, copiarlo, od utilizzarlo per finalità diverse, costituisce comportamento contrario ai principi dettati dal D.Lgs. 196/2003.

The information in this message and/or attachments, is intended solely for the attention and use of the named addressee(s) and may be confidential or proprietary in nature or covered by the provisions of privacy act (Legislative Decree June, 30 2003, no.196 - Italy's New Data Protection Code).Any use not in accord with its purpose, any disclosure, reproduction, copying, distribution, or either dissemination, either whole or partial, is strictly forbidden except previous formal approval of the named addressee(s). If you are not the intended recipient, please contact immediately the sender by telephone, fax or e-mail and delete the information in this message that has been received in error. The sender does not give any warranty or accept liability as the content, accuracy or completeness of sent messages and accepts no responsibility  for changes made after they were sent or for other risks which arise as a result of e-mail transmission, viruses, etc.


On Thu, Sep 7, 2017 at 12:13 PM, Dimitris Karakostis <[hidden email]> wrote:

Hello everyone, 

Recently I tried to install a new dev environment using the branch 2.7 but I keep getting an error related to OWSLib:

   "Could not find a version that satisfies the requirement OWSLib==0.14-dev"

I checked the requirements.txt and I see that the OWSLib package is commented out.(https://github.com/GeoNode/geonode/blob/2.7.x/requirements.txt)

I actually uncommented it and rerun the installation but I keep getting the same error. I tried to use the master branch as well but there is the same.

Everything works well with 2.6 releases but 2.6 uses a previous version of OWSLib as well. Does anyone has similar issues?

I would like to make some contributions so I guess its better if I work on 2.7 or master. 

Thanks 

Cheers

Dimitris




_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel




--
Simone 

_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel
Reply | Threaded
Open this post in threaded view
|

Re: Issue when installing development environment from 2.7 branch

Dimitris Karakostis

Thanks guys, 


I uninstalled owslib (also checked for remaining files in site-packages). It seems everything is deleted properly but still I keep getting the same error message: 

 Could not find a version that satisfies the requirement OWSLib==0.14-dev (from GeoNode==2.7.dev20170906114728) (from versions: 0.1.0, 0.2.0, 0.2.1, 0.3, 0.3.1, 0.4.0, 0.5.0, 0.5.1, 0.6.0, 0.6.1, 0.7.0, 0.7.1, 0.7.2, 0.8.0, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.8.5, 0.8.6, 0.8.7, 0.8.8, 0.8.9, 0.8.10, 0.8.11, 0.8.12, 0.8.13, 0.9.0, 0.9.1, 0.9.2, 0.10.0, 0.10.1, 0.10.3, 0.11.0, 0.11.1, 0.11.2, 0.12.0, 0.13.0, 0.14.0) No matching distribution found for OWSLib==0.14-dev (from GeoNode==2.7.dev20170906114728)

I also tried to install OWSLib==0.14 separately. It is installed successfully but when I try to install the rest of the requirements, I get the same error. 
I will keep trying and write here if I find something.




On Thu, Sep 7, 2017 at 1:24 PM, Simone Dalmasso <[hidden email]> wrote:
Dimitris I see in pypi there's owslib 0.14 try to pip install owslib==0.14 instead and see if geonode works.

2017-09-07 12:18 GMT+02:00 Alessio Fabiani <[hidden email]>:
Try to pip uninstall all owslib packages you are on the system

Regards,

Alessio Fabiani

==
GeoServer Professional Services from the experts! Visit http://goo.gl/it488V for more information.
==

Ing. Alessio Fabiani

@alfa7691
Founder/Technical Lead


GeoSolutions S.A.S.
Via di Montramito 3/A
55054  Massarosa (LU)
Italy
phone: <a href="tel:+39%200584%20962313" value="+390584962313" target="_blank">+39 0584 962313
fax:     <a href="tel:+39%200584%20166%200272" value="+3905841660272" target="_blank">+39 0584 1660272
mob:   <a href="tel:+39%20331%20623%203686" value="+393316233686" target="_blank">+39 331 6233686

http://www.geo-solutions.it
http://twitter.com/geosolutions_it

-------------------------------------------------------

AVVERTENZE AI SENSI DEL D.Lgs. 196/2003

Le informazioni contenute in questo messaggio di posta elettronica e/o nel/i file/s allegato/i sono da considerarsi strettamente riservate. Il loro utilizzo è consentito esclusivamente al destinatario del messaggio, per le finalità indicate nel messaggio stesso. Qualora riceviate questo messaggio senza esserne il destinatario, Vi preghiamo cortesemente di darcene notizia via e-mail e di procedere alla distruzione del messaggio stesso, cancellandolo dal Vostro sistema. Conservare il messaggio stesso, divulgarlo anche in parte, distribuirlo ad altri soggetti, copiarlo, od utilizzarlo per finalità diverse, costituisce comportamento contrario ai principi dettati dal D.Lgs. 196/2003.

The information in this message and/or attachments, is intended solely for the attention and use of the named addressee(s) and may be confidential or proprietary in nature or covered by the provisions of privacy act (Legislative Decree June, 30 2003, no.196 - Italy's New Data Protection Code).Any use not in accord with its purpose, any disclosure, reproduction, copying, distribution, or either dissemination, either whole or partial, is strictly forbidden except previous formal approval of the named addressee(s). If you are not the intended recipient, please contact immediately the sender by telephone, fax or e-mail and delete the information in this message that has been received in error. The sender does not give any warranty or accept liability as the content, accuracy or completeness of sent messages and accepts no responsibility  for changes made after they were sent or for other risks which arise as a result of e-mail transmission, viruses, etc.


On Thu, Sep 7, 2017 at 12:13 PM, Dimitris Karakostis <[hidden email]> wrote:

Hello everyone, 

Recently I tried to install a new dev environment using the branch 2.7 but I keep getting an error related to OWSLib:

   "Could not find a version that satisfies the requirement OWSLib==0.14-dev"

I checked the requirements.txt and I see that the OWSLib package is commented out.(https://github.com/GeoNode/geonode/blob/2.7.x/requirements.txt)

I actually uncommented it and rerun the installation but I keep getting the same error. I tried to use the master branch as well but there is the same.

Everything works well with 2.6 releases but 2.6 uses a previous version of OWSLib as well. Does anyone has similar issues?

I would like to make some contributions so I guess its better if I work on 2.7 or master. 

Thanks 

Cheers

Dimitris




_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel




--
Simone 


_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel
Reply | Threaded
Open this post in threaded view
|

Re: Issue when installing development environment from 2.7 branch

Alessio Fabiani-2
Thing is, that version it is not yet published on pypi, therefore it should be downloaded from git directly.

Quite strange your pip utility does not do it automatically. Do you have the latest pip version? Try with "pip install pip --upgrade" to get the 9.0.1+ one.

Otherwise you will need to revert back to older versions and thus manually modify requirements.txt and setup.py



Regards,

Alessio Fabiani

==
GeoServer Professional Services from the experts! Visit http://goo.gl/it488V for more information.
==

Ing. Alessio Fabiani

@alfa7691
Founder/Technical Lead


GeoSolutions S.A.S.
Via di Montramito 3/A
55054  Massarosa (LU)
Italy
phone: +39 0584 962313
fax:     +39 0584 1660272
mob:   +39 331 6233686

http://www.geo-solutions.it
http://twitter.com/geosolutions_it

-------------------------------------------------------

AVVERTENZE AI SENSI DEL D.Lgs. 196/2003

Le informazioni contenute in questo messaggio di posta elettronica e/o nel/i file/s allegato/i sono da considerarsi strettamente riservate. Il loro utilizzo è consentito esclusivamente al destinatario del messaggio, per le finalità indicate nel messaggio stesso. Qualora riceviate questo messaggio senza esserne il destinatario, Vi preghiamo cortesemente di darcene notizia via e-mail e di procedere alla distruzione del messaggio stesso, cancellandolo dal Vostro sistema. Conservare il messaggio stesso, divulgarlo anche in parte, distribuirlo ad altri soggetti, copiarlo, od utilizzarlo per finalità diverse, costituisce comportamento contrario ai principi dettati dal D.Lgs. 196/2003.

The information in this message and/or attachments, is intended solely for the attention and use of the named addressee(s) and may be confidential or proprietary in nature or covered by the provisions of privacy act (Legislative Decree June, 30 2003, no.196 - Italy's New Data Protection Code).Any use not in accord with its purpose, any disclosure, reproduction, copying, distribution, or either dissemination, either whole or partial, is strictly forbidden except previous formal approval of the named addressee(s). If you are not the intended recipient, please contact immediately the sender by telephone, fax or e-mail and delete the information in this message that has been received in error. The sender does not give any warranty or accept liability as the content, accuracy or completeness of sent messages and accepts no responsibility  for changes made after they were sent or for other risks which arise as a result of e-mail transmission, viruses, etc.


On Thu, Sep 7, 2017 at 2:44 PM, Dimitris Karakostis <[hidden email]> wrote:

Thanks guys, 


I uninstalled owslib (also checked for remaining files in site-packages). It seems everything is deleted properly but still I keep getting the same error message: 

 Could not find a version that satisfies the requirement OWSLib==0.14-dev (from GeoNode==2.7.dev20170906114728) (from versions: 0.1.0, 0.2.0, 0.2.1, 0.3, 0.3.1, 0.4.0, 0.5.0, 0.5.1, 0.6.0, 0.6.1, 0.7.0, 0.7.1, 0.7.2, 0.8.0, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.8.5, 0.8.6, 0.8.7, 0.8.8, 0.8.9, 0.8.10, 0.8.11, 0.8.12, 0.8.13, 0.9.0, 0.9.1, 0.9.2, 0.10.0, 0.10.1, 0.10.3, 0.11.0, 0.11.1, 0.11.2, 0.12.0, 0.13.0, 0.14.0) No matching distribution found for OWSLib==0.14-dev (from GeoNode==2.7.dev20170906114728)

I also tried to install OWSLib==0.14 separately. It is installed successfully but when I try to install the rest of the requirements, I get the same error. 
I will keep trying and write here if I find something.




On Thu, Sep 7, 2017 at 1:24 PM, Simone Dalmasso <[hidden email]> wrote:
Dimitris I see in pypi there's owslib 0.14 try to pip install owslib==0.14 instead and see if geonode works.

2017-09-07 12:18 GMT+02:00 Alessio Fabiani <[hidden email]>:
Try to pip uninstall all owslib packages you are on the system

Regards,

Alessio Fabiani

==
GeoServer Professional Services from the experts! Visit http://goo.gl/it488V for more information.
==

Ing. Alessio Fabiani

@alfa7691
Founder/Technical Lead


GeoSolutions S.A.S.
Via di Montramito 3/A
55054  Massarosa (LU)
Italy
phone: <a href="tel:+39%200584%20962313" value="+390584962313" target="_blank">+39 0584 962313
fax:     <a href="tel:+39%200584%20166%200272" value="+3905841660272" target="_blank">+39 0584 1660272
mob:   <a href="tel:+39%20331%20623%203686" value="+393316233686" target="_blank">+39 331 6233686

http://www.geo-solutions.it
http://twitter.com/geosolutions_it

-------------------------------------------------------

AVVERTENZE AI SENSI DEL D.Lgs. 196/2003

Le informazioni contenute in questo messaggio di posta elettronica e/o nel/i file/s allegato/i sono da considerarsi strettamente riservate. Il loro utilizzo è consentito esclusivamente al destinatario del messaggio, per le finalità indicate nel messaggio stesso. Qualora riceviate questo messaggio senza esserne il destinatario, Vi preghiamo cortesemente di darcene notizia via e-mail e di procedere alla distruzione del messaggio stesso, cancellandolo dal Vostro sistema. Conservare il messaggio stesso, divulgarlo anche in parte, distribuirlo ad altri soggetti, copiarlo, od utilizzarlo per finalità diverse, costituisce comportamento contrario ai principi dettati dal D.Lgs. 196/2003.

The information in this message and/or attachments, is intended solely for the attention and use of the named addressee(s) and may be confidential or proprietary in nature or covered by the provisions of privacy act (Legislative Decree June, 30 2003, no.196 - Italy's New Data Protection Code).Any use not in accord with its purpose, any disclosure, reproduction, copying, distribution, or either dissemination, either whole or partial, is strictly forbidden except previous formal approval of the named addressee(s). If you are not the intended recipient, please contact immediately the sender by telephone, fax or e-mail and delete the information in this message that has been received in error. The sender does not give any warranty or accept liability as the content, accuracy or completeness of sent messages and accepts no responsibility  for changes made after they were sent or for other risks which arise as a result of e-mail transmission, viruses, etc.


On Thu, Sep 7, 2017 at 12:13 PM, Dimitris Karakostis <[hidden email]> wrote:

Hello everyone, 

Recently I tried to install a new dev environment using the branch 2.7 but I keep getting an error related to OWSLib:

   "Could not find a version that satisfies the requirement OWSLib==0.14-dev"

I checked the requirements.txt and I see that the OWSLib package is commented out.(https://github.com/GeoNode/geonode/blob/2.7.x/requirements.txt)

I actually uncommented it and rerun the installation but I keep getting the same error. I tried to use the master branch as well but there is the same.

Everything works well with 2.6 releases but 2.6 uses a previous version of OWSLib as well. Does anyone has similar issues?

I would like to make some contributions so I guess its better if I work on 2.7 or master. 

Thanks 

Cheers

Dimitris




_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel




--
Simone 


_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel
Reply | Threaded
Open this post in threaded view
|

Re: Issue when installing development environment from 2.7 branch

Simo D
Dimitris, it's because the dependency is in the setup.py https://github.com/GeoNode/geonode/blob/2.7.x/setup.py#L92

so if you installed the 0.14 you can comment that line, test and if it works make a PR with the dependency fix both in setup.py and requirements.txt ^^ :D

ty

2017-09-07 14:51 GMT+02:00 Alessio Fabiani <[hidden email]>:
Thing is, that version it is not yet published on pypi, therefore it should be downloaded from git directly.

Quite strange your pip utility does not do it automatically. Do you have the latest pip version? Try with "pip install pip --upgrade" to get the 9.0.1+ one.

Otherwise you will need to revert back to older versions and thus manually modify requirements.txt and setup.py



Regards,

Alessio Fabiani

==
GeoServer Professional Services from the experts! Visit http://goo.gl/it488V for more information.
==

Ing. Alessio Fabiani

@alfa7691
Founder/Technical Lead


GeoSolutions S.A.S.
Via di Montramito 3/A
55054  Massarosa (LU)
Italy
phone: <a href="tel:+39%200584%20962313" value="+390584962313" target="_blank">+39 0584 962313
fax:     <a href="tel:+39%200584%20166%200272" value="+3905841660272" target="_blank">+39 0584 1660272
mob:   <a href="tel:+39%20331%20623%203686" value="+393316233686" target="_blank">+39 331 6233686

http://www.geo-solutions.it
http://twitter.com/geosolutions_it

-------------------------------------------------------

AVVERTENZE AI SENSI DEL D.Lgs. 196/2003

Le informazioni contenute in questo messaggio di posta elettronica e/o nel/i file/s allegato/i sono da considerarsi strettamente riservate. Il loro utilizzo è consentito esclusivamente al destinatario del messaggio, per le finalità indicate nel messaggio stesso. Qualora riceviate questo messaggio senza esserne il destinatario, Vi preghiamo cortesemente di darcene notizia via e-mail e di procedere alla distruzione del messaggio stesso, cancellandolo dal Vostro sistema. Conservare il messaggio stesso, divulgarlo anche in parte, distribuirlo ad altri soggetti, copiarlo, od utilizzarlo per finalità diverse, costituisce comportamento contrario ai principi dettati dal D.Lgs. 196/2003.

The information in this message and/or attachments, is intended solely for the attention and use of the named addressee(s) and may be confidential or proprietary in nature or covered by the provisions of privacy act (Legislative Decree June, 30 2003, no.196 - Italy's New Data Protection Code).Any use not in accord with its purpose, any disclosure, reproduction, copying, distribution, or either dissemination, either whole or partial, is strictly forbidden except previous formal approval of the named addressee(s). If you are not the intended recipient, please contact immediately the sender by telephone, fax or e-mail and delete the information in this message that has been received in error. The sender does not give any warranty or accept liability as the content, accuracy or completeness of sent messages and accepts no responsibility  for changes made after they were sent or for other risks which arise as a result of e-mail transmission, viruses, etc.


On Thu, Sep 7, 2017 at 2:44 PM, Dimitris Karakostis <[hidden email]> wrote:

Thanks guys, 


I uninstalled owslib (also checked for remaining files in site-packages). It seems everything is deleted properly but still I keep getting the same error message: 

 Could not find a version that satisfies the requirement OWSLib==0.14-dev (from GeoNode==2.7.dev20170906114728) (from versions: 0.1.0, 0.2.0, 0.2.1, 0.3, 0.3.1, 0.4.0, 0.5.0, 0.5.1, 0.6.0, 0.6.1, 0.7.0, 0.7.1, 0.7.2, 0.8.0, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.8.5, 0.8.6, 0.8.7, 0.8.8, 0.8.9, 0.8.10, 0.8.11, 0.8.12, 0.8.13, 0.9.0, 0.9.1, 0.9.2, 0.10.0, 0.10.1, 0.10.3, 0.11.0, 0.11.1, 0.11.2, 0.12.0, 0.13.0, 0.14.0) No matching distribution found for OWSLib==0.14-dev (from GeoNode==2.7.dev20170906114728)

I also tried to install OWSLib==0.14 separately. It is installed successfully but when I try to install the rest of the requirements, I get the same error. 
I will keep trying and write here if I find something.




On Thu, Sep 7, 2017 at 1:24 PM, Simone Dalmasso <[hidden email]> wrote:
Dimitris I see in pypi there's owslib 0.14 try to pip install owslib==0.14 instead and see if geonode works.

2017-09-07 12:18 GMT+02:00 Alessio Fabiani <[hidden email]>:
Try to pip uninstall all owslib packages you are on the system

Regards,

Alessio Fabiani

==
GeoServer Professional Services from the experts! Visit http://goo.gl/it488V for more information.
==

Ing. Alessio Fabiani

@alfa7691
Founder/Technical Lead


GeoSolutions S.A.S.
Via di Montramito 3/A
55054  Massarosa (LU)
Italy
phone: <a href="tel:+39%200584%20962313" value="+390584962313" target="_blank">+39 0584 962313
fax:     <a href="tel:+39%200584%20166%200272" value="+3905841660272" target="_blank">+39 0584 1660272
mob:   <a href="tel:+39%20331%20623%203686" value="+393316233686" target="_blank">+39 331 6233686

http://www.geo-solutions.it
http://twitter.com/geosolutions_it

-------------------------------------------------------

AVVERTENZE AI SENSI DEL D.Lgs. 196/2003

Le informazioni contenute in questo messaggio di posta elettronica e/o nel/i file/s allegato/i sono da considerarsi strettamente riservate. Il loro utilizzo è consentito esclusivamente al destinatario del messaggio, per le finalità indicate nel messaggio stesso. Qualora riceviate questo messaggio senza esserne il destinatario, Vi preghiamo cortesemente di darcene notizia via e-mail e di procedere alla distruzione del messaggio stesso, cancellandolo dal Vostro sistema. Conservare il messaggio stesso, divulgarlo anche in parte, distribuirlo ad altri soggetti, copiarlo, od utilizzarlo per finalità diverse, costituisce comportamento contrario ai principi dettati dal D.Lgs. 196/2003.

The information in this message and/or attachments, is intended solely for the attention and use of the named addressee(s) and may be confidential or proprietary in nature or covered by the provisions of privacy act (Legislative Decree June, 30 2003, no.196 - Italy's New Data Protection Code).Any use not in accord with its purpose, any disclosure, reproduction, copying, distribution, or either dissemination, either whole or partial, is strictly forbidden except previous formal approval of the named addressee(s). If you are not the intended recipient, please contact immediately the sender by telephone, fax or e-mail and delete the information in this message that has been received in error. The sender does not give any warranty or accept liability as the content, accuracy or completeness of sent messages and accepts no responsibility  for changes made after they were sent or for other risks which arise as a result of e-mail transmission, viruses, etc.


On Thu, Sep 7, 2017 at 12:13 PM, Dimitris Karakostis <[hidden email]> wrote:

Hello everyone, 

Recently I tried to install a new dev environment using the branch 2.7 but I keep getting an error related to OWSLib:

   "Could not find a version that satisfies the requirement OWSLib==0.14-dev"

I checked the requirements.txt and I see that the OWSLib package is commented out.(https://github.com/GeoNode/geonode/blob/2.7.x/requirements.txt)

I actually uncommented it and rerun the installation but I keep getting the same error. I tried to use the master branch as well but there is the same.

Everything works well with 2.6 releases but 2.6 uses a previous version of OWSLib as well. Does anyone has similar issues?

I would like to make some contributions so I guess its better if I work on 2.7 or master. 

Thanks 

Cheers

Dimitris




_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel




--
Simone 


_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel




--
Simone 

_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel
Reply | Threaded
Open this post in threaded view
|

Re: Issue when installing development environment from 2.7 branch

Dimitris Karakostis
This actually was it. But there are some new errors I will need to solve. If it makes sense I can make a pull request with the OWSLib=0.14 both in setup.py and requirements.txt.

Cheers and thanks again.

On Thu, Sep 7, 2017 at 2:58 PM, Simone Dalmasso <[hidden email]> wrote:
Dimitris, it's because the dependency is in the setup.py https://github.com/GeoNode/geonode/blob/2.7.x/setup.py#L92

so if you installed the 0.14 you can comment that line, test and if it works make a PR with the dependency fix both in setup.py and requirements.txt ^^ :D

ty

2017-09-07 14:51 GMT+02:00 Alessio Fabiani <[hidden email]>:
Thing is, that version it is not yet published on pypi, therefore it should be downloaded from git directly.

Quite strange your pip utility does not do it automatically. Do you have the latest pip version? Try with "pip install pip --upgrade" to get the 9.0.1+ one.

Otherwise you will need to revert back to older versions and thus manually modify requirements.txt and setup.py



Regards,

Alessio Fabiani

==
GeoServer Professional Services from the experts! Visit http://goo.gl/it488V for more information.
==

Ing. Alessio Fabiani

@alfa7691
Founder/Technical Lead


GeoSolutions S.A.S.
Via di Montramito 3/A
55054  Massarosa (LU)
Italy
phone: <a href="tel:+39%200584%20962313" value="+390584962313" target="_blank">+39 0584 962313
fax:     <a href="tel:+39%200584%20166%200272" value="+3905841660272" target="_blank">+39 0584 1660272
mob:   <a href="tel:+39%20331%20623%203686" value="+393316233686" target="_blank">+39 331 6233686

http://www.geo-solutions.it
http://twitter.com/geosolutions_it

-------------------------------------------------------

AVVERTENZE AI SENSI DEL D.Lgs. 196/2003

Le informazioni contenute in questo messaggio di posta elettronica e/o nel/i file/s allegato/i sono da considerarsi strettamente riservate. Il loro utilizzo è consentito esclusivamente al destinatario del messaggio, per le finalità indicate nel messaggio stesso. Qualora riceviate questo messaggio senza esserne il destinatario, Vi preghiamo cortesemente di darcene notizia via e-mail e di procedere alla distruzione del messaggio stesso, cancellandolo dal Vostro sistema. Conservare il messaggio stesso, divulgarlo anche in parte, distribuirlo ad altri soggetti, copiarlo, od utilizzarlo per finalità diverse, costituisce comportamento contrario ai principi dettati dal D.Lgs. 196/2003.

The information in this message and/or attachments, is intended solely for the attention and use of the named addressee(s) and may be confidential or proprietary in nature or covered by the provisions of privacy act (Legislative Decree June, 30 2003, no.196 - Italy's New Data Protection Code).Any use not in accord with its purpose, any disclosure, reproduction, copying, distribution, or either dissemination, either whole or partial, is strictly forbidden except previous formal approval of the named addressee(s). If you are not the intended recipient, please contact immediately the sender by telephone, fax or e-mail and delete the information in this message that has been received in error. The sender does not give any warranty or accept liability as the content, accuracy or completeness of sent messages and accepts no responsibility  for changes made after they were sent or for other risks which arise as a result of e-mail transmission, viruses, etc.


On Thu, Sep 7, 2017 at 2:44 PM, Dimitris Karakostis <[hidden email]> wrote:

Thanks guys, 


I uninstalled owslib (also checked for remaining files in site-packages). It seems everything is deleted properly but still I keep getting the same error message: 

 Could not find a version that satisfies the requirement OWSLib==0.14-dev (from GeoNode==2.7.dev20170906114728) (from versions: 0.1.0, 0.2.0, 0.2.1, 0.3, 0.3.1, 0.4.0, 0.5.0, 0.5.1, 0.6.0, 0.6.1, 0.7.0, 0.7.1, 0.7.2, 0.8.0, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.8.5, 0.8.6, 0.8.7, 0.8.8, 0.8.9, 0.8.10, 0.8.11, 0.8.12, 0.8.13, 0.9.0, 0.9.1, 0.9.2, 0.10.0, 0.10.1, 0.10.3, 0.11.0, 0.11.1, 0.11.2, 0.12.0, 0.13.0, 0.14.0) No matching distribution found for OWSLib==0.14-dev (from GeoNode==2.7.dev20170906114728)

I also tried to install OWSLib==0.14 separately. It is installed successfully but when I try to install the rest of the requirements, I get the same error. 
I will keep trying and write here if I find something.




On Thu, Sep 7, 2017 at 1:24 PM, Simone Dalmasso <[hidden email]> wrote:
Dimitris I see in pypi there's owslib 0.14 try to pip install owslib==0.14 instead and see if geonode works.

2017-09-07 12:18 GMT+02:00 Alessio Fabiani <[hidden email]>:
Try to pip uninstall all owslib packages you are on the system

Regards,

Alessio Fabiani

==
GeoServer Professional Services from the experts! Visit http://goo.gl/it488V for more information.
==

Ing. Alessio Fabiani

@alfa7691
Founder/Technical Lead


GeoSolutions S.A.S.
Via di Montramito 3/A
55054  Massarosa (LU)
Italy
phone: <a href="tel:+39%200584%20962313" value="+390584962313" target="_blank">+39 0584 962313
fax:     <a href="tel:+39%200584%20166%200272" value="+3905841660272" target="_blank">+39 0584 1660272
mob:   <a href="tel:+39%20331%20623%203686" value="+393316233686" target="_blank">+39 331 6233686

http://www.geo-solutions.it
http://twitter.com/geosolutions_it

-------------------------------------------------------

AVVERTENZE AI SENSI DEL D.Lgs. 196/2003

Le informazioni contenute in questo messaggio di posta elettronica e/o nel/i file/s allegato/i sono da considerarsi strettamente riservate. Il loro utilizzo è consentito esclusivamente al destinatario del messaggio, per le finalità indicate nel messaggio stesso. Qualora riceviate questo messaggio senza esserne il destinatario, Vi preghiamo cortesemente di darcene notizia via e-mail e di procedere alla distruzione del messaggio stesso, cancellandolo dal Vostro sistema. Conservare il messaggio stesso, divulgarlo anche in parte, distribuirlo ad altri soggetti, copiarlo, od utilizzarlo per finalità diverse, costituisce comportamento contrario ai principi dettati dal D.Lgs. 196/2003.

The information in this message and/or attachments, is intended solely for the attention and use of the named addressee(s) and may be confidential or proprietary in nature or covered by the provisions of privacy act (Legislative Decree June, 30 2003, no.196 - Italy's New Data Protection Code).Any use not in accord with its purpose, any disclosure, reproduction, copying, distribution, or either dissemination, either whole or partial, is strictly forbidden except previous formal approval of the named addressee(s). If you are not the intended recipient, please contact immediately the sender by telephone, fax or e-mail and delete the information in this message that has been received in error. The sender does not give any warranty or accept liability as the content, accuracy or completeness of sent messages and accepts no responsibility  for changes made after they were sent or for other risks which arise as a result of e-mail transmission, viruses, etc.


On Thu, Sep 7, 2017 at 12:13 PM, Dimitris Karakostis <[hidden email]> wrote:

Hello everyone, 

Recently I tried to install a new dev environment using the branch 2.7 but I keep getting an error related to OWSLib:

   "Could not find a version that satisfies the requirement OWSLib==0.14-dev"

I checked the requirements.txt and I see that the OWSLib package is commented out.(https://github.com/GeoNode/geonode/blob/2.7.x/requirements.txt)

I actually uncommented it and rerun the installation but I keep getting the same error. I tried to use the master branch as well but there is the same.

Everything works well with 2.6 releases but 2.6 uses a previous version of OWSLib as well. Does anyone has similar issues?

I would like to make some contributions so I guess its better if I work on 2.7 or master. 

Thanks 

Cheers

Dimitris




_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel




--
Simone 


_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel




--
Simone 


_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel
Reply | Threaded
Open this post in threaded view
|

Re: Issue when installing development environment from 2.7 branch

Alessio Fabiani-2
Currently 0.14dev fixes some owslib issues not yet released. We can revert them to 0.14 but we will lose those ones.

Regards,

Alessio Fabiani

==
GeoServer Professional Services from the experts! Visit http://goo.gl/it488V for more information.
==

Ing. Alessio Fabiani

@alfa7691
Founder/Technical Lead


GeoSolutions S.A.S.
Via di Montramito 3/A
55054  Massarosa (LU)
Italy
phone: +39 0584 962313
fax:     +39 0584 1660272
mob:   +39 331 6233686

http://www.geo-solutions.it
http://twitter.com/geosolutions_it

-------------------------------------------------------

AVVERTENZE AI SENSI DEL D.Lgs. 196/2003

Le informazioni contenute in questo messaggio di posta elettronica e/o nel/i file/s allegato/i sono da considerarsi strettamente riservate. Il loro utilizzo è consentito esclusivamente al destinatario del messaggio, per le finalità indicate nel messaggio stesso. Qualora riceviate questo messaggio senza esserne il destinatario, Vi preghiamo cortesemente di darcene notizia via e-mail e di procedere alla distruzione del messaggio stesso, cancellandolo dal Vostro sistema. Conservare il messaggio stesso, divulgarlo anche in parte, distribuirlo ad altri soggetti, copiarlo, od utilizzarlo per finalità diverse, costituisce comportamento contrario ai principi dettati dal D.Lgs. 196/2003.

The information in this message and/or attachments, is intended solely for the attention and use of the named addressee(s) and may be confidential or proprietary in nature or covered by the provisions of privacy act (Legislative Decree June, 30 2003, no.196 - Italy's New Data Protection Code).Any use not in accord with its purpose, any disclosure, reproduction, copying, distribution, or either dissemination, either whole or partial, is strictly forbidden except previous formal approval of the named addressee(s). If you are not the intended recipient, please contact immediately the sender by telephone, fax or e-mail and delete the information in this message that has been received in error. The sender does not give any warranty or accept liability as the content, accuracy or completeness of sent messages and accepts no responsibility  for changes made after they were sent or for other risks which arise as a result of e-mail transmission, viruses, etc.


On Thu, Sep 7, 2017 at 4:24 PM, Dimitris Karakostis <[hidden email]> wrote:
This actually was it. But there are some new errors I will need to solve. If it makes sense I can make a pull request with the OWSLib=0.14 both in setup.py and requirements.txt.

Cheers and thanks again.

On Thu, Sep 7, 2017 at 2:58 PM, Simone Dalmasso <[hidden email]> wrote:
Dimitris, it's because the dependency is in the setup.py https://github.com/GeoNode/geonode/blob/2.7.x/setup.py#L92

so if you installed the 0.14 you can comment that line, test and if it works make a PR with the dependency fix both in setup.py and requirements.txt ^^ :D

ty

2017-09-07 14:51 GMT+02:00 Alessio Fabiani <[hidden email]>:
Thing is, that version it is not yet published on pypi, therefore it should be downloaded from git directly.

Quite strange your pip utility does not do it automatically. Do you have the latest pip version? Try with "pip install pip --upgrade" to get the 9.0.1+ one.

Otherwise you will need to revert back to older versions and thus manually modify requirements.txt and setup.py



Regards,

Alessio Fabiani

==
GeoServer Professional Services from the experts! Visit http://goo.gl/it488V for more information.
==

Ing. Alessio Fabiani

@alfa7691
Founder/Technical Lead


GeoSolutions S.A.S.
Via di Montramito 3/A
55054  Massarosa (LU)
Italy
phone: <a href="tel:+39%200584%20962313" value="+390584962313" target="_blank">+39 0584 962313
fax:     <a href="tel:+39%200584%20166%200272" value="+3905841660272" target="_blank">+39 0584 1660272
mob:   <a href="tel:+39%20331%20623%203686" value="+393316233686" target="_blank">+39 331 6233686

http://www.geo-solutions.it
http://twitter.com/geosolutions_it

-------------------------------------------------------

AVVERTENZE AI SENSI DEL D.Lgs. 196/2003

Le informazioni contenute in questo messaggio di posta elettronica e/o nel/i file/s allegato/i sono da considerarsi strettamente riservate. Il loro utilizzo è consentito esclusivamente al destinatario del messaggio, per le finalità indicate nel messaggio stesso. Qualora riceviate questo messaggio senza esserne il destinatario, Vi preghiamo cortesemente di darcene notizia via e-mail e di procedere alla distruzione del messaggio stesso, cancellandolo dal Vostro sistema. Conservare il messaggio stesso, divulgarlo anche in parte, distribuirlo ad altri soggetti, copiarlo, od utilizzarlo per finalità diverse, costituisce comportamento contrario ai principi dettati dal D.Lgs. 196/2003.

The information in this message and/or attachments, is intended solely for the attention and use of the named addressee(s) and may be confidential or proprietary in nature or covered by the provisions of privacy act (Legislative Decree June, 30 2003, no.196 - Italy's New Data Protection Code).Any use not in accord with its purpose, any disclosure, reproduction, copying, distribution, or either dissemination, either whole or partial, is strictly forbidden except previous formal approval of the named addressee(s). If you are not the intended recipient, please contact immediately the sender by telephone, fax or e-mail and delete the information in this message that has been received in error. The sender does not give any warranty or accept liability as the content, accuracy or completeness of sent messages and accepts no responsibility  for changes made after they were sent or for other risks which arise as a result of e-mail transmission, viruses, etc.


On Thu, Sep 7, 2017 at 2:44 PM, Dimitris Karakostis <[hidden email]> wrote:

Thanks guys, 


I uninstalled owslib (also checked for remaining files in site-packages). It seems everything is deleted properly but still I keep getting the same error message: 

 Could not find a version that satisfies the requirement OWSLib==0.14-dev (from GeoNode==2.7.dev20170906114728) (from versions: 0.1.0, 0.2.0, 0.2.1, 0.3, 0.3.1, 0.4.0, 0.5.0, 0.5.1, 0.6.0, 0.6.1, 0.7.0, 0.7.1, 0.7.2, 0.8.0, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.8.5, 0.8.6, 0.8.7, 0.8.8, 0.8.9, 0.8.10, 0.8.11, 0.8.12, 0.8.13, 0.9.0, 0.9.1, 0.9.2, 0.10.0, 0.10.1, 0.10.3, 0.11.0, 0.11.1, 0.11.2, 0.12.0, 0.13.0, 0.14.0) No matching distribution found for OWSLib==0.14-dev (from GeoNode==2.7.dev20170906114728)

I also tried to install OWSLib==0.14 separately. It is installed successfully but when I try to install the rest of the requirements, I get the same error. 
I will keep trying and write here if I find something.




On Thu, Sep 7, 2017 at 1:24 PM, Simone Dalmasso <[hidden email]> wrote:
Dimitris I see in pypi there's owslib 0.14 try to pip install owslib==0.14 instead and see if geonode works.

2017-09-07 12:18 GMT+02:00 Alessio Fabiani <[hidden email]>:
Try to pip uninstall all owslib packages you are on the system

Regards,

Alessio Fabiani

==
GeoServer Professional Services from the experts! Visit http://goo.gl/it488V for more information.
==

Ing. Alessio Fabiani

@alfa7691
Founder/Technical Lead


GeoSolutions S.A.S.
Via di Montramito 3/A
55054  Massarosa (LU)
Italy
phone: <a href="tel:+39%200584%20962313" value="+390584962313" target="_blank">+39 0584 962313
fax:     <a href="tel:+39%200584%20166%200272" value="+3905841660272" target="_blank">+39 0584 1660272
mob:   <a href="tel:+39%20331%20623%203686" value="+393316233686" target="_blank">+39 331 6233686

http://www.geo-solutions.it
http://twitter.com/geosolutions_it

-------------------------------------------------------

AVVERTENZE AI SENSI DEL D.Lgs. 196/2003

Le informazioni contenute in questo messaggio di posta elettronica e/o nel/i file/s allegato/i sono da considerarsi strettamente riservate. Il loro utilizzo è consentito esclusivamente al destinatario del messaggio, per le finalità indicate nel messaggio stesso. Qualora riceviate questo messaggio senza esserne il destinatario, Vi preghiamo cortesemente di darcene notizia via e-mail e di procedere alla distruzione del messaggio stesso, cancellandolo dal Vostro sistema. Conservare il messaggio stesso, divulgarlo anche in parte, distribuirlo ad altri soggetti, copiarlo, od utilizzarlo per finalità diverse, costituisce comportamento contrario ai principi dettati dal D.Lgs. 196/2003.

The information in this message and/or attachments, is intended solely for the attention and use of the named addressee(s) and may be confidential or proprietary in nature or covered by the provisions of privacy act (Legislative Decree June, 30 2003, no.196 - Italy's New Data Protection Code).Any use not in accord with its purpose, any disclosure, reproduction, copying, distribution, or either dissemination, either whole or partial, is strictly forbidden except previous formal approval of the named addressee(s). If you are not the intended recipient, please contact immediately the sender by telephone, fax or e-mail and delete the information in this message that has been received in error. The sender does not give any warranty or accept liability as the content, accuracy or completeness of sent messages and accepts no responsibility  for changes made after they were sent or for other risks which arise as a result of e-mail transmission, viruses, etc.


On Thu, Sep 7, 2017 at 12:13 PM, Dimitris Karakostis <[hidden email]> wrote:

Hello everyone, 

Recently I tried to install a new dev environment using the branch 2.7 but I keep getting an error related to OWSLib:

   "Could not find a version that satisfies the requirement OWSLib==0.14-dev"

I checked the requirements.txt and I see that the OWSLib package is commented out.(https://github.com/GeoNode/geonode/blob/2.7.x/requirements.txt)

I actually uncommented it and rerun the installation but I keep getting the same error. I tried to use the master branch as well but there is the same.

Everything works well with 2.6 releases but 2.6 uses a previous version of OWSLib as well. Does anyone has similar issues?

I would like to make some contributions so I guess its better if I work on 2.7 or master. 

Thanks 

Cheers

Dimitris




_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel




--
Simone 


_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel




--
Simone 


_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel
Reply | Threaded
Open this post in threaded view
|

Re: Issue when installing development environment from 2.7 branch

Alessio Fabiani-2

Regards,

Alessio Fabiani

==
GeoServer Professional Services from the experts! Visit http://goo.gl/it488V for more information.
==

Ing. Alessio Fabiani

@alfa7691
Founder/Technical Lead


GeoSolutions S.A.S.
Via di Montramito 3/A
55054  Massarosa (LU)
Italy
phone: +39 0584 962313
fax:     +39 0584 1660272
mob:   +39 331 6233686

http://www.geo-solutions.it
http://twitter.com/geosolutions_it

-------------------------------------------------------

AVVERTENZE AI SENSI DEL D.Lgs. 196/2003

Le informazioni contenute in questo messaggio di posta elettronica e/o nel/i file/s allegato/i sono da considerarsi strettamente riservate. Il loro utilizzo è consentito esclusivamente al destinatario del messaggio, per le finalità indicate nel messaggio stesso. Qualora riceviate questo messaggio senza esserne il destinatario, Vi preghiamo cortesemente di darcene notizia via e-mail e di procedere alla distruzione del messaggio stesso, cancellandolo dal Vostro sistema. Conservare il messaggio stesso, divulgarlo anche in parte, distribuirlo ad altri soggetti, copiarlo, od utilizzarlo per finalità diverse, costituisce comportamento contrario ai principi dettati dal D.Lgs. 196/2003.

The information in this message and/or attachments, is intended solely for the attention and use of the named addressee(s) and may be confidential or proprietary in nature or covered by the provisions of privacy act (Legislative Decree June, 30 2003, no.196 - Italy's New Data Protection Code).Any use not in accord with its purpose, any disclosure, reproduction, copying, distribution, or either dissemination, either whole or partial, is strictly forbidden except previous formal approval of the named addressee(s). If you are not the intended recipient, please contact immediately the sender by telephone, fax or e-mail and delete the information in this message that has been received in error. The sender does not give any warranty or accept liability as the content, accuracy or completeness of sent messages and accepts no responsibility  for changes made after they were sent or for other risks which arise as a result of e-mail transmission, viruses, etc.


On Fri, Sep 8, 2017 at 8:29 AM, Francesco Bartoli <[hidden email]> wrote:
Guys,

in cases like these why not temporarily declare the dependency in this way?


as I also don't see any tag/branch 0.14-dev. 

Sent from Nylas Mail, the best free email app for work

On set 7 2017, at 4:27 pm, Alessio Fabiani <[hidden email]> wrote:
Currently 0.14dev fixes some owslib issues not yet released. We can revert them to 0.14 but we will lose those ones.

Regards,

Alessio Fabiani

==
GeoServer Professional Services from the experts! Visit http://goo.gl/it488V for more information.
==

Ing. Alessio Fabiani

@alfa7691
Founder/Technical Lead


GeoSolutions S.A.S.
Via di Montramito 3/A
55054  Massarosa (LU)
Italy
phone: <a href="tel:0584%20962313" value="+390584962313" target="_blank">+39 0584 962313
fax:     <a href="tel:0584%20166%200272" value="+3905841660272" target="_blank">+39 0584 1660272
mob:   <a href="tel:331%20623%203686" value="+393316233686" target="_blank">+39 331 6233686

http://www.geo-solutions.it
http://twitter.com/geosolutions_it

-------------------------------------------------------

AVVERTENZE AI SENSI DEL D.Lgs. 196/2003

Le informazioni contenute in questo messaggio di posta elettronica e/o nel/i file/s allegato/i sono da considerarsi strettamente riservate. Il loro utilizzo è consentito esclusivamente al destinatario del messaggio, per le finalità indicate nel messaggio stesso. Qualora riceviate questo messaggio senza esserne il destinatario, Vi preghiamo cortesemente di darcene notizia via e-mail e di procedere alla distruzione del messaggio stesso, cancellandolo dal Vostro sistema. Conservare il messaggio stesso, divulgarlo anche in parte, distribuirlo ad altri soggetti, copiarlo, od utilizzarlo per finalità diverse, costituisce comportamento contrario ai principi dettati dal D.Lgs. 196/2003.

The information in this message and/or attachments, is intended solely for the attention and use of the named addressee(s) and may be confidential or proprietary in nature or covered by the provisions of privacy act (Legislative Decree June, 30 2003, no.196 - Italy's New Data Protection Code).Any use not in accord with its purpose, any disclosure, reproduction, copying, distribution, or either dissemination, either whole or partial, is strictly forbidden except previous formal approval of the named addressee(s). If you are not the intended recipient, please contact immediately the sender by telephone, fax or e-mail and delete the information in this message that has been received in error. The sender does not give any warranty or accept liability as the content, accuracy or completeness of sent messages and accepts no responsibility  for changes made after they were sent or for other risks which arise as a result of e-mail transmission, viruses, etc.


On Thu, Sep 7, 2017 at 4:24 PM, Dimitris Karakostis <[hidden email]> wrote:
This actually was it. But there are some new errors I will need to solve. If it makes sense I can make a pull request with the OWSLib=0.14 both in setup.py and requirements.txt.

Cheers and thanks again.

On Thu, Sep 7, 2017 at 2:58 PM, Simone Dalmasso <[hidden email]> wrote:
Dimitris, it's because the dependency is in the setup.py https://github.com/GeoNode/geonode/blob/2.7.x/setup.py#L92

so if you installed the 0.14 you can comment that line, test and if it works make a PR with the dependency fix both in setup.py and requirements.txt ^^ :D

ty

2017-09-07 14:51 GMT+02:00 Alessio Fabiani <[hidden email]>:
Thing is, that version it is not yet published on pypi, therefore it should be downloaded from git directly.

Quite strange your pip utility does not do it automatically. Do you have the latest pip version? Try with "pip install pip --upgrade" to get the 9.0.1+ one.

Otherwise you will need to revert back to older versions and thus manually modify requirements.txt and setup.py



Regards,

Alessio Fabiani

==
GeoServer Professional Services from the experts! Visit http://goo.gl/it488V for more information.
==

Ing. Alessio Fabiani

@alfa7691
Founder/Technical Lead


GeoSolutions S.A.S.
Via di Montramito 3/A
55054  Massarosa (LU)
Italy
phone: +39 0584 962313
fax:     +39 0584 1660272
mob:   +39 331 6233686

http://www.geo-solutions.it
http://twitter.com/geosolutions_it

-------------------------------------------------------

AVVERTENZE AI SENSI DEL D.Lgs. 196/2003

Le informazioni contenute in questo messaggio di posta elettronica e/o nel/i file/s allegato/i sono da considerarsi strettamente riservate. Il loro utilizzo è consentito esclusivamente al destinatario del messaggio, per le finalità indicate nel messaggio stesso. Qualora riceviate questo messaggio senza esserne il destinatario, Vi preghiamo cortesemente di darcene notizia via e-mail e di procedere alla distruzione del messaggio stesso, cancellandolo dal Vostro sistema. Conservare il messaggio stesso, divulgarlo anche in parte, distribuirlo ad altri soggetti, copiarlo, od utilizzarlo per finalità diverse, costituisce comportamento contrario ai principi dettati dal D.Lgs. 196/2003.

The information in this message and/or attachments, is intended solely for the attention and use of the named addressee(s) and may be confidential or proprietary in nature or covered by the provisions of privacy act (Legislative Decree June, 30 2003, no.196 - Italy's New Data Protection Code).Any use not in accord with its purpose, any disclosure, reproduction, copying, distribution, or either dissemination, either whole or partial, is strictly forbidden except previous formal approval of the named addressee(s). If you are not the intended recipient, please contact immediately the sender by telephone, fax or e-mail and delete the information in this message that has been received in error. The sender does not give any warranty or accept liability as the content, accuracy or completeness of sent messages and accepts no responsibility  for changes made after they were sent or for other risks which arise as a result of e-mail transmission, viruses, etc.


On Thu, Sep 7, 2017 at 2:44 PM, Dimitris Karakostis <[hidden email]> wrote:

Thanks guys, 


I uninstalled owslib (also checked for remaining files in site-packages). It seems everything is deleted properly but still I keep getting the same error message: 

 Could not find a version that satisfies the requirement OWSLib==0.14-dev (from GeoNode==2.7.dev20170906114728) (from versions: 0.1.0, 0.2.0, 0.2.1, 0.3, 0.3.1, 0.4.0, 0.5.0, 0.5.1, 0.6.0, 0.6.1, 0.7.0, 0.7.1, 0.7.2, 0.8.0, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.8.5, 0.8.6, 0.8.7, 0.8.8, 0.8.9, 0.8.10, 0.8.11, 0.8.12, 0.8.13, 0.9.0, 0.9.1, 0.9.2, 0.10.0, 0.10.1, 0.10.3, 0.11.0, 0.11.1, 0.11.2, 0.12.0, 0.13.0, 0.14.0) No matching distribution found for OWSLib==0.14-dev (from GeoNode==2.7.dev20170906114728)

I also tried to install OWSLib==0.14 separately. It is installed successfully but when I try to install the rest of the requirements, I get the same error. 
I will keep trying and write here if I find something.




On Thu, Sep 7, 2017 at 1:24 PM, Simone Dalmasso <[hidden email]> wrote:
Dimitris I see in pypi there's owslib 0.14 try to pip install owslib==0.14 instead and see if geonode works.

2017-09-07 12:18 GMT+02:00 Alessio Fabiani <[hidden email]>:
Try to pip uninstall all owslib packages you are on the system

Regards,

Alessio Fabiani

==
GeoServer Professional Services from the experts! Visit http://goo.gl/it488V for more information.
==

Ing. Alessio Fabiani

@alfa7691
Founder/Technical Lead


GeoSolutions S.A.S.
Via di Montramito 3/A
55054  Massarosa (LU)
Italy
phone: +39 0584 962313
fax:     +39 0584 1660272
mob:   +39 331 6233686

http://www.geo-solutions.it
http://twitter.com/geosolutions_it

-------------------------------------------------------

AVVERTENZE AI SENSI DEL D.Lgs. 196/2003

Le informazioni contenute in questo messaggio di posta elettronica e/o nel/i file/s allegato/i sono da considerarsi strettamente riservate. Il loro utilizzo è consentito esclusivamente al destinatario del messaggio, per le finalità indicate nel messaggio stesso. Qualora riceviate questo messaggio senza esserne il destinatario, Vi preghiamo cortesemente di darcene notizia via e-mail e di procedere alla distruzione del messaggio stesso, cancellandolo dal Vostro sistema. Conservare il messaggio stesso, divulgarlo anche in parte, distribuirlo ad altri soggetti, copiarlo, od utilizzarlo per finalità diverse, costituisce comportamento contrario ai principi dettati dal D.Lgs. 196/2003.

The information in this message and/or attachments, is intended solely for the attention and use of the named addressee(s) and may be confidential or proprietary in nature or covered by the provisions of privacy act (Legislative Decree June, 30 2003, no.196 - Italy's New Data Protection Code).Any use not in accord with its purpose, any disclosure, reproduction, copying, distribution, or either dissemination, either whole or partial, is strictly forbidden except previous formal approval of the named addressee(s). If you are not the intended recipient, please contact immediately the sender by telephone, fax or e-mail and delete the information in this message that has been received in error. The sender does not give any warranty or accept liability as the content, accuracy or completeness of sent messages and accepts no responsibility  for changes made after they were sent or for other risks which arise as a result of e-mail transmission, viruses, etc.


On Thu, Sep 7, 2017 at 12:13 PM, Dimitris Karakostis <[hidden email]> wrote:

Hello everyone, 

Recently I tried to install a new dev environment using the branch 2.7 but I keep getting an error related to OWSLib:

   "Could not find a version that satisfies the requirement OWSLib==0.14-dev"

I checked the requirements.txt and I see that the OWSLib package is commented out.(https://github.com/GeoNode/geonode/blob/2.7.x/requirements.txt)

I actually uncommented it and rerun the installation but I keep getting the same error. I tried to use the master branch as well but there is the same.

Everything works well with 2.6 releases but 2.6 uses a previous version of OWSLib as well. Does anyone has similar issues?

I would like to make some contributions so I guess its better if I work on 2.7 or master. 

Thanks 

Cheers

Dimitris




_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel




--
Simone 


_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel




--
Simone 


_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel


_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel


_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel