Quantcast

Invert color ramp not working?

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Invert color ramp not working?

Paolo Cavallini
Hi all.
In a recent master, raster properties, if I check the flag "invert color
ramp", I do not get the expected result, but the old ugly red-blue ramp:
anyone confirms?
Thanks.

--
Paolo Cavallini - Faunalia
www.faunalia.eu
Full contact details at www.faunalia.eu/pc
Nuovi corsi QGIS e PostGIS: http://www.faunalia.it/calendario

_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Invert color ramp not working?

Radim Blazek-2
On Fri, Oct 19, 2012 at 9:52 PM, Paolo Cavallini <[hidden email]> wrote:
> Hi all.
> In a recent master, raster properties, if I check the flag "invert color
> ramp", I do not get the expected result, but the old ugly red-blue ramp:

Invert color was missing in pseudocolor renderer, fixed. The question
is what is it expected to do. I have used
      red = 255 - red;
      green = 255 - green;
      blue = 255 - blue;
which is used for multiband color (both master and 1.8) but in 1.8
pseudocolor red and blue were switched instead.

You are probably expecting the classification to be done in reverse order?

I think that invert color has little/no sense for pseudocolor and
multiband color as it is implemented in master or/and was in 1.8. For
pseudo color it should be moved to "Generate new color map" options,
for multiband color just removed.

In any case, legend is not correct if invert color is used.

Radim

> anyone confirms?
> Thanks.
>
> --
> Paolo Cavallini - Faunalia
> www.faunalia.eu
> Full contact details at www.faunalia.eu/pc
> Nuovi corsi QGIS e PostGIS: http://www.faunalia.it/calendario
>
> _______________________________________________
> Qgis-developer mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/qgis-developer
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Invert color ramp not working?

Paolo Cavallini
Il 25/10/2012 02:52, Radim Blazek ha scritto:
> You are probably expecting the classification to be done in reverse order?
Yes.
>
> I think that invert color has little/no sense for pseudocolor and
> multiband color as it is implemented in master or/and was in 1.8. For
> pseudo color it should be moved to "Generate new color map" options,
> for multiband color just removed.
seems good. can we disable the invert for multibands?
>
> In any case, legend is not correct if invert color is used.
I believe this should be fixed anyway.
Thanks a lot.

--
Paolo Cavallini - Faunalia
www.faunalia.eu
Full contact details at www.faunalia.eu/pc
Nuovi corsi QGIS e PostGIS: http://www.faunalia.it/calendario

_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Invert color ramp not working?

Etienne Tourigny-3
In reply to this post by Radim Blazek-2
It would be better for the invert ramps to be inside the "Generate new
color map" box, and invert the order of the color ramp, instead of
inverting the rgb colours.

Like the 1-band raster colour table plugin did (it does not work with master).

Unless someone disagrees I'll look into implementing that.

Etienne

On Wed, Oct 24, 2012 at 3:52 PM, Radim Blazek <[hidden email]> wrote:

> On Fri, Oct 19, 2012 at 9:52 PM, Paolo Cavallini <[hidden email]> wrote:
>> Hi all.
>> In a recent master, raster properties, if I check the flag "invert color
>> ramp", I do not get the expected result, but the old ugly red-blue ramp:
>
> Invert color was missing in pseudocolor renderer, fixed. The question
> is what is it expected to do. I have used
>       red = 255 - red;
>       green = 255 - green;
>       blue = 255 - blue;
> which is used for multiband color (both master and 1.8) but in 1.8
> pseudocolor red and blue were switched instead.
>
> You are probably expecting the classification to be done in reverse order?
>
> I think that invert color has little/no sense for pseudocolor and
> multiband color as it is implemented in master or/and was in 1.8. For
> pseudo color it should be moved to "Generate new color map" options,
> for multiband color just removed.
>
> In any case, legend is not correct if invert color is used.
>
> Radim
>
>> anyone confirms?
>> Thanks.
>>
>> --
>> Paolo Cavallini - Faunalia
>> www.faunalia.eu
>> Full contact details at www.faunalia.eu/pc
>> Nuovi corsi QGIS e PostGIS: http://www.faunalia.it/calendario
>>
>> _______________________________________________
>> Qgis-developer mailing list
>> [hidden email]
>> http://lists.osgeo.org/mailman/listinfo/qgis-developer
> _______________________________________________
> Qgis-developer mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/qgis-developer
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Invert color ramp not working?

Radim Blazek-2
On Mon, Oct 29, 2012 at 8:16 PM, Etienne Tourigny
<[hidden email]> wrote:
> It would be better for the invert ramps to be inside the "Generate new
> color map" box, and invert the order of the color ramp, instead of
> inverting the rgb colours.

I have done that already on Saturday a8934a28.

Radim

> Like the 1-band raster colour table plugin did (it does not work with master).
>
> Unless someone disagrees I'll look into implementing that.
>
> Etienne
>
> On Wed, Oct 24, 2012 at 3:52 PM, Radim Blazek <[hidden email]> wrote:
>> On Fri, Oct 19, 2012 at 9:52 PM, Paolo Cavallini <[hidden email]> wrote:
>>> Hi all.
>>> In a recent master, raster properties, if I check the flag "invert color
>>> ramp", I do not get the expected result, but the old ugly red-blue ramp:
>>
>> Invert color was missing in pseudocolor renderer, fixed. The question
>> is what is it expected to do. I have used
>>       red = 255 - red;
>>       green = 255 - green;
>>       blue = 255 - blue;
>> which is used for multiband color (both master and 1.8) but in 1.8
>> pseudocolor red and blue were switched instead.
>>
>> You are probably expecting the classification to be done in reverse order?
>>
>> I think that invert color has little/no sense for pseudocolor and
>> multiband color as it is implemented in master or/and was in 1.8. For
>> pseudo color it should be moved to "Generate new color map" options,
>> for multiband color just removed.
>>
>> In any case, legend is not correct if invert color is used.
>>
>> Radim
>>
>>> anyone confirms?
>>> Thanks.
>>>
>>> --
>>> Paolo Cavallini - Faunalia
>>> www.faunalia.eu
>>> Full contact details at www.faunalia.eu/pc
>>> Nuovi corsi QGIS e PostGIS: http://www.faunalia.it/calendario
>>>
>>> _______________________________________________
>>> Qgis-developer mailing list
>>> [hidden email]
>>> http://lists.osgeo.org/mailman/listinfo/qgis-developer
>> _______________________________________________
>> Qgis-developer mailing list
>> [hidden email]
>> http://lists.osgeo.org/mailman/listinfo/qgis-developer
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Invert color ramp not working?

Etienne Tourigny-3
Great! I hadn't noticed, thanks

On Mon, Oct 29, 2012 at 5:29 PM, Radim Blazek <[hidden email]> wrote:

> On Mon, Oct 29, 2012 at 8:16 PM, Etienne Tourigny
> <[hidden email]> wrote:
>> It would be better for the invert ramps to be inside the "Generate new
>> color map" box, and invert the order of the color ramp, instead of
>> inverting the rgb colours.
>
> I have done that already on Saturday a8934a28.
>
> Radim
>
>> Like the 1-band raster colour table plugin did (it does not work with master).
>>
>> Unless someone disagrees I'll look into implementing that.
>>
>> Etienne
>>
>> On Wed, Oct 24, 2012 at 3:52 PM, Radim Blazek <[hidden email]> wrote:
>>> On Fri, Oct 19, 2012 at 9:52 PM, Paolo Cavallini <[hidden email]> wrote:
>>>> Hi all.
>>>> In a recent master, raster properties, if I check the flag "invert color
>>>> ramp", I do not get the expected result, but the old ugly red-blue ramp:
>>>
>>> Invert color was missing in pseudocolor renderer, fixed. The question
>>> is what is it expected to do. I have used
>>>       red = 255 - red;
>>>       green = 255 - green;
>>>       blue = 255 - blue;
>>> which is used for multiband color (both master and 1.8) but in 1.8
>>> pseudocolor red and blue were switched instead.
>>>
>>> You are probably expecting the classification to be done in reverse order?
>>>
>>> I think that invert color has little/no sense for pseudocolor and
>>> multiband color as it is implemented in master or/and was in 1.8. For
>>> pseudo color it should be moved to "Generate new color map" options,
>>> for multiband color just removed.
>>>
>>> In any case, legend is not correct if invert color is used.
>>>
>>> Radim
>>>
>>>> anyone confirms?
>>>> Thanks.
>>>>
>>>> --
>>>> Paolo Cavallini - Faunalia
>>>> www.faunalia.eu
>>>> Full contact details at www.faunalia.eu/pc
>>>> Nuovi corsi QGIS e PostGIS: http://www.faunalia.it/calendario
>>>>
>>>> _______________________________________________
>>>> Qgis-developer mailing list
>>>> [hidden email]
>>>> http://lists.osgeo.org/mailman/listinfo/qgis-developer
>>> _______________________________________________
>>> Qgis-developer mailing list
>>> [hidden email]
>>> http://lists.osgeo.org/mailman/listinfo/qgis-developer
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer
Loading...