Internal Server Error while checking proxy.cgi

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Internal Server Error while checking proxy.cgi

shyam megha

Hi guys,


Am using Apache 2.4 as server and pasted the proxy.cgi in its cgi-bin folder. Even though apache is working it is not working with proxy.cgi file.

I have also set path to the python.exe in the first line of the proxy.cgi script

!C:/Python33/python 

It gives the error as below

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [hidden email] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Thx in advance.

reagrds,


Sam


_______________________________________________
Users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/openlayers-users
Reply | Threaded
Open this post in threaded view
|

Re: Internal Server Error while checking proxy.cgi

rdell

I have had that error when the first lint of a .cgi script is incorrect.

Mine looks like

#!c:/Python26/python.exe -u

 

I would suggest you work with changes to the first line

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of shyam megha
Sent: Tuesday, November 26, 2013 3:07 AM
To: openlayers-users
Subject: [OpenLayers-Users] Internal Server Error while checking proxy.cgi

 

Hi guys,

 

Am using Apache 2.4 as server and pasted the proxy.cgi in its cgi-bin folder. Even though apache is working it is not working with proxy.cgi file.

 

I have also set path to the python.exe in the first line of the proxy.cgi script

 

!C:/Python33/python 

 

It gives the error as below

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [hidden email] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Thx in advance.

reagrds,

 

Sam


_______________________________________________
Users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/openlayers-users
Reply | Threaded
Open this post in threaded view
|

Re: Internal Server Error while checking proxy.cgi

shiv_sms
In reply to this post by shyam megha
Apache 2.4 does not have cgi module enabled by default. So try enabling that with "a2enmod cgi" and see if it works.


On Tue, Nov 26, 2013 at 1:37 PM, shyam megha <[hidden email]> wrote:

Hi guys,


Am using Apache 2.4 as server and pasted the proxy.cgi in its cgi-bin folder. Even though apache is working it is not working with proxy.cgi file.

I have also set path to the python.exe in the first line of the proxy.cgi script

!C:/Python33/python 

It gives the error as below

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [hidden email] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Thx in advance.

reagrds,


Sam


_______________________________________________
Users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/openlayers-users


_______________________________________________
Users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/openlayers-users