Installing r.green is not possible

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Installing r.green is not possible

Annemarie Pfeiffer
Dear Sir or Madam,

as part of my master's thesis I would like to use the tool  
r.green.hydro with all its functions. After I've completed all the  
steps of your detailed online installation guide, Grass-Gis will  
create a field called "Energy." The functions of this field are grayed  
out and can not be executed. After entering the r.green.install -x  
command, you also receive the message that the python libraries  
numexpr and scipy are not available. After I installed these manually,  
the message did not occur anymore, but the functions in "Energy" were  
also not executable and still written in gray.
Additionally, when you load Grass-GIS into the black console, you see  
the following message:

Details: Can not find the executable r.green.hydro ....
r.green.hydro ...: Unable to fetch interface description for command  
'r.green.hydro ....' "

Since I would benefit greatly from the use of the tool for my  
explorations, I would be very grateful if you could help me with my  
problem.

With best regards
Annemarie Pfeiffer



Mit freundlichen Grüßen
Annemarie Pfeiffer

_______________________________________________
grass-web mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/grass-web
Reply | Threaded
Open this post in threaded view
|

Re: Installing r.green is not possible

Markus Neteler
Dear Annemarie,

Which GRASS GIS version do you use, and on which operating system?
I have tried to install it myself, on a Linux system:


GRASS 7.8.2dev (nc_spm_08):~ > g.extension r.green
Fetching <r.green> from GRASS GIS Addons repository (be patient)...
Compiling...
Traceback (most recent call last):
  File "/home/mneteler/tmp/grass7-mneteler-20201/tmpfggv6w9y/r.green/scripts/r.green.hydro.structure",
line 139, in <module>
    from libgreen.checkparameter import check_required_columns, exception2error
ModuleNotFoundError: No module named 'libgreen'
make[2]: *** [/home/mneteler/software/grass78_git/dist.x86_64-pc-linux-gnu/include/Make/Html.make:14:
r.green.hydro.structure.tmp.html] Error 1
/home/mneteler/tmp/grass7-mneteler-20201/tmpfggv6w9y/r.green/scripts/r.green.install:35:
DeprecationWarning: the imp module is deprecated in favour of
importlib; see the module's documentation for alternative uses
  import imp
Installing...
/usr/bin/install: cannot stat
'/home/mneteler/tmp/grass7-mneteler-20201/tmpfggv6w9y/r.green/docs/html/r.green.hydro.structure.html':
No such file or directory
make[2]: *** [/home/mneteler/software/grass78_git/dist.x86_64-pc-linux-gnu/include/Make/Script.make:36:
install] Error 1
Updating addons metadata file...
Updating private addons metadata file...
WARNING: No addons metadata available. Addons metadata file not updated.
Installation of <r.green> successfully finished

GRASS 7.8.2dev (nc_spm_08):~ > r.green.
r.green.biomassfor.co2          r.green.biomassfor.recommended
r.green.gshp.theoretical        r.green.hydro.financial
r.green.hydro.technical
r.green.biomassfor.financial    r.green.biomassfor.technical
r.green.hydro.closest           r.green.hydro.optimal
r.green.hydro.theoretical
r.green.biomassfor.impact       r.green.biomassfor.theoretical
r.green.hydro.delplants         r.green.hydro.planning
r.green.install
r.green.biomassfor.legal        r.green.gshp.technical
r.green.hydro.discharge         r.green.hydro.structure

Some issue seems to be there with "libgreen".

Do you see the same error?

Best regards,

Markus

On Wed, Nov 6, 2019 at 11:38 AM Annemarie Pfeiffer
<[hidden email]> wrote:

>
> Dear Sir or Madam,
>
> as part of my master's thesis I would like to use the tool
> r.green.hydro with all its functions. After I've completed all the
> steps of your detailed online installation guide, Grass-Gis will
> create a field called "Energy." The functions of this field are grayed
> out and can not be executed. After entering the r.green.install -x
> command, you also receive the message that the python libraries
> numexpr and scipy are not available. After I installed these manually,
> the message did not occur anymore, but the functions in "Energy" were
> also not executable and still written in gray.
> Additionally, when you load Grass-GIS into the black console, you see
> the following message:
>
> Details: Can not find the executable r.green.hydro ....
> r.green.hydro ...: Unable to fetch interface description for command
> 'r.green.hydro ....' "
>
> Since I would benefit greatly from the use of the tool for my
> explorations, I would be very grateful if you could help me with my
> problem.
>
> With best regards
> Annemarie Pfeiffer
>
>
>
> Mit freundlichen Grüßen
> Annemarie Pfeiffer
>
> _______________________________________________
> grass-web mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/grass-web



--
Markus Neteler, PhD
https://www.mundialis.de - free data with free software
https://grass.osgeo.org
https://courses.neteler.org/blog
_______________________________________________
grass-web mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/grass-web
Reply | Threaded
Open this post in threaded view
|

Re: Installing r.green is not possible

Annemarie Pfeiffer
Dear Markus,

Thank you for your reply. I use the GRASS GIS version 7.8.1 with  
Microsoft Windows. I have now installed Linux as a virtual machine and  
will try again today to install and use the tools. With me similar  
error codes occur as with you. The fact that the error codes are  
different could also be due to the different operating systems  
(Windows / Linux). The applications can be successfully installed, but  
their execution fails. If it helps, I can also gladly send you my  
error codes with Windows.

Best regards,
Annemarie


Zitat von Markus Neteler <[hidden email]>:

> Dear Annemarie,
>
> Which GRASS GIS version do you use, and on which operating system?
> I have tried to install it myself, on a Linux system:
>
>
> GRASS 7.8.2dev (nc_spm_08):~ > g.extension r.green
> Fetching <r.green> from GRASS GIS Addons repository (be patient)...
> Compiling...
> Traceback (most recent call last):
>   File  
> "/home/mneteler/tmp/grass7-mneteler-20201/tmpfggv6w9y/r.green/scripts/r.green.hydro.structure",
> line 139, in <module>
>     from libgreen.checkparameter import check_required_columns,  
> exception2error
> ModuleNotFoundError: No module named 'libgreen'
> make[2]: ***  
> [/home/mneteler/software/grass78_git/dist.x86_64-pc-linux-gnu/include/Make/Html.make:14:
> r.green.hydro.structure.tmp.html] Error 1
> /home/mneteler/tmp/grass7-mneteler-20201/tmpfggv6w9y/r.green/scripts/r.green.install:35:
> DeprecationWarning: the imp module is deprecated in favour of
> importlib; see the module's documentation for alternative uses
>   import imp
> Installing...
> /usr/bin/install: cannot stat
> '/home/mneteler/tmp/grass7-mneteler-20201/tmpfggv6w9y/r.green/docs/html/r.green.hydro.structure.html':
> No such file or directory
> make[2]: ***  
> [/home/mneteler/software/grass78_git/dist.x86_64-pc-linux-gnu/include/Make/Script.make:36:
> install] Error 1
> Updating addons metadata file...
> Updating private addons metadata file...
> WARNING: No addons metadata available. Addons metadata file not updated.
> Installation of <r.green> successfully finished
>
> GRASS 7.8.2dev (nc_spm_08):~ > r.green.
> r.green.biomassfor.co2          r.green.biomassfor.recommended
> r.green.gshp.theoretical        r.green.hydro.financial
> r.green.hydro.technical
> r.green.biomassfor.financial    r.green.biomassfor.technical
> r.green.hydro.closest           r.green.hydro.optimal
> r.green.hydro.theoretical
> r.green.biomassfor.impact       r.green.biomassfor.theoretical
> r.green.hydro.delplants         r.green.hydro.planning
> r.green.install
> r.green.biomassfor.legal        r.green.gshp.technical
> r.green.hydro.discharge         r.green.hydro.structure
>
> Some issue seems to be there with "libgreen".
>
> Do you see the same error?
>
> Best regards,
>
> Markus
>
> On Wed, Nov 6, 2019 at 11:38 AM Annemarie Pfeiffer
> <[hidden email]> wrote:
>>
>> Dear Sir or Madam,
>>
>> as part of my master's thesis I would like to use the tool
>> r.green.hydro with all its functions. After I've completed all the
>> steps of your detailed online installation guide, Grass-Gis will
>> create a field called "Energy." The functions of this field are grayed
>> out and can not be executed. After entering the r.green.install -x
>> command, you also receive the message that the python libraries
>> numexpr and scipy are not available. After I installed these manually,
>> the message did not occur anymore, but the functions in "Energy" were
>> also not executable and still written in gray.
>> Additionally, when you load Grass-GIS into the black console, you see
>> the following message:
>>
>> Details: Can not find the executable r.green.hydro ....
>> r.green.hydro ...: Unable to fetch interface description for command
>> 'r.green.hydro ....' "
>>
>> Since I would benefit greatly from the use of the tool for my
>> explorations, I would be very grateful if you could help me with my
>> problem.
>>
>> With best regards
>> Annemarie Pfeiffer
>>
>>
>>
>> Mit freundlichen Grüßen
>> Annemarie Pfeiffer
>>
>> _______________________________________________
>> grass-web mailing list
>> [hidden email]
>> https://lists.osgeo.org/mailman/listinfo/grass-web
>
>
>
> --
> Markus Neteler, PhD
> https://www.mundialis.de - free data with free software
> https://grass.osgeo.org
> https://courses.neteler.org/blog



Mit freundlichen Grüßen
Annemarie Pfeiffer

_______________________________________________
grass-web mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/grass-web
Reply | Threaded
Open this post in threaded view
|

Re: Installing r.green is not possible

Markus Neteler
Dear Annemarie,

The best option will be to contact the authors of the module (see the
related manual page).
I haven't used r.green yet, so I am not much of help here.

Maybe it is just some "silly" PYTHONPATH error. (?)

Hope you can contact them at EURAC,

best
Markus



On Wed, Nov 13, 2019 at 2:31 PM Annemarie Pfeiffer
<[hidden email]> wrote:

>
> Dear Markus,
>
> Thank you for your reply. I use the GRASS GIS version 7.8.1 with
> Microsoft Windows. I have now installed Linux as a virtual machine and
> will try again today to install and use the tools. With me similar
> error codes occur as with you. The fact that the error codes are
> different could also be due to the different operating systems
> (Windows / Linux). The applications can be successfully installed, but
> their execution fails. If it helps, I can also gladly send you my
> error codes with Windows.
>
> Best regards,
> Annemarie
>
>
> Zitat von Markus Neteler <[hidden email]>:
>
> > Dear Annemarie,
> >
> > Which GRASS GIS version do you use, and on which operating system?
> > I have tried to install it myself, on a Linux system:
> >
> >
> > GRASS 7.8.2dev (nc_spm_08):~ > g.extension r.green
> > Fetching <r.green> from GRASS GIS Addons repository (be patient)...
> > Compiling...
> > Traceback (most recent call last):
> >   File
> > "/home/mneteler/tmp/grass7-mneteler-20201/tmpfggv6w9y/r.green/scripts/r.green.hydro.structure",
> > line 139, in <module>
> >     from libgreen.checkparameter import check_required_columns,
> > exception2error
> > ModuleNotFoundError: No module named 'libgreen'
> > make[2]: ***
> > [/home/mneteler/software/grass78_git/dist.x86_64-pc-linux-gnu/include/Make/Html.make:14:
> > r.green.hydro.structure.tmp.html] Error 1
> > /home/mneteler/tmp/grass7-mneteler-20201/tmpfggv6w9y/r.green/scripts/r.green.install:35:
> > DeprecationWarning: the imp module is deprecated in favour of
> > importlib; see the module's documentation for alternative uses
> >   import imp
> > Installing...
> > /usr/bin/install: cannot stat
> > '/home/mneteler/tmp/grass7-mneteler-20201/tmpfggv6w9y/r.green/docs/html/r.green.hydro.structure.html':
> > No such file or directory
> > make[2]: ***
> > [/home/mneteler/software/grass78_git/dist.x86_64-pc-linux-gnu/include/Make/Script.make:36:
> > install] Error 1
> > Updating addons metadata file...
> > Updating private addons metadata file...
> > WARNING: No addons metadata available. Addons metadata file not updated.
> > Installation of <r.green> successfully finished
> >
> > GRASS 7.8.2dev (nc_spm_08):~ > r.green.
> > r.green.biomassfor.co2          r.green.biomassfor.recommended
> > r.green.gshp.theoretical        r.green.hydro.financial
> > r.green.hydro.technical
> > r.green.biomassfor.financial    r.green.biomassfor.technical
> > r.green.hydro.closest           r.green.hydro.optimal
> > r.green.hydro.theoretical
> > r.green.biomassfor.impact       r.green.biomassfor.theoretical
> > r.green.hydro.delplants         r.green.hydro.planning
> > r.green.install
> > r.green.biomassfor.legal        r.green.gshp.technical
> > r.green.hydro.discharge         r.green.hydro.structure
> >
> > Some issue seems to be there with "libgreen".
> >
> > Do you see the same error?
> >
> > Best regards,
> >
> > Markus
> >
> > On Wed, Nov 6, 2019 at 11:38 AM Annemarie Pfeiffer
> > <[hidden email]> wrote:
> >>
> >> Dear Sir or Madam,
> >>
> >> as part of my master's thesis I would like to use the tool
> >> r.green.hydro with all its functions. After I've completed all the
> >> steps of your detailed online installation guide, Grass-Gis will
> >> create a field called "Energy." The functions of this field are grayed
> >> out and can not be executed. After entering the r.green.install -x
> >> command, you also receive the message that the python libraries
> >> numexpr and scipy are not available. After I installed these manually,
> >> the message did not occur anymore, but the functions in "Energy" were
> >> also not executable and still written in gray.
> >> Additionally, when you load Grass-GIS into the black console, you see
> >> the following message:
> >>
> >> Details: Can not find the executable r.green.hydro ....
> >> r.green.hydro ...: Unable to fetch interface description for command
> >> 'r.green.hydro ....' "
> >>
> >> Since I would benefit greatly from the use of the tool for my
> >> explorations, I would be very grateful if you could help me with my
> >> problem.
> >>
> >> With best regards
> >> Annemarie Pfeiffer
> >>
> >>
> >>
> >> Mit freundlichen Grüßen
> >> Annemarie Pfeiffer
> >>
> >> _______________________________________________
> >> grass-web mailing list
> >> [hidden email]
> >> https://lists.osgeo.org/mailman/listinfo/grass-web
> >
_______________________________________________
grass-web mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/grass-web
Reply | Threaded
Open this post in threaded view
|

Re: Installing r.green is not possible

Zambelli Pietro
In reply to this post by Markus Neteler
Dear Annamarie,

sorry for the delay, finally yesterday I did have time to test the installation process on my machine and I got a similar error highlight by Markus regarding the libgreen/libhydro it seems that the makefile as it is is not any more able to handle some internal library.

To get the module installed and working you could

Download the source code with:

$ g.extension extension=r.green -d

you will get a message similar to the follow:

Fetching <r.green> from GRASS GIS Addons repository (be patient)...

To compile run:
make MODULE_TOPDIR=/usr/lib64/grass78 \
     RUN_GISRC=/tmp/grass7-pietro-65803/gisrc \
     BIN=/tmp/grass7-pietro-65803/tmpixl0y9dg/r.green/bin\
     HTMLDIR=/tmp/grass7-pietro-65803/tmpixl0y9dg/r.green/docs/html \
     RESTDIR=/tmp/grass7-pietro-65803/tmpixl0y9dg/r.green/docs/rest \
     MANBASEDIR=/tmp/grass7-pietro-65803/tmpixl0y9dg/r.green/docs/man \
     SCRIPTDIR=/tmp/grass7-pietro-65803/tmpixl0y9dg/r.green/scripts \
     STRINGDIR=/tmp/grass7-pietro-65803/tmpixl0y9dg/r.green \
     ETC=/tmp/grass7-pietro-65803/tmpixl0y9dg/r.green/etc\
     SOURCE_URL=https://trac.osgeo.org/grass/browser/grass-addons/grass7/

To install run:
make MODULE_TOPDIR=/usr/lib64/grass78 \
     ARCH_DISTDIR=/tmp/grass7-pietro-65803/tmpixl0y9dg/r.green \
INST_DIR=/home/pietro/.grass7/addons install

Path to the source code:
/tmp/grass7-pietro-65803/tmpixl0y9dg/r.green

Before executing the command suggested by g.extension module you have to set the PYTHONPATH variable as follow:

export PYTHONPATH=<your r.green path>:<your r.green path>/r.green.hydro:$PYTHONPATH

So in my case is:

export PYTHONPATH=/tmp/grass7-pietro-65803/tmpixl0y9dg/r.green:/tmp/grass7-pietro-65803/tmpixl0y9dg/r.green/r.green.hydro:$PYTHONPATH

Please let me know if the above command fix your issue, if not please provide more details regarding your OS/configuration and your errors.

Best regards

Pietro


---
Pietro Zambelli
Eurac Research
 
Institute for Renewable Energy 
Tel  +39 0471 055 684
Fax +39 0471 055 699
 

Via A.Volta 13/A

39100 Bozen/Bolzano

 
Legal Seat
Drususallee/Viale Druso 1
I-39100 Bozen/Bolzano
 
 
According to regulation (EU) 2016/679 this transmission is intended only for the use of the addressee and may contain confidential information. If you receive this transmission in error, please notify the sender immediately by email and delete all copies of this message and any attachments.


From: Markus Neteler <[hidden email]>
Sent: 11 November 2019 18:46
To: Annemarie Pfeiffer <[hidden email]>
Cc: GRASS-web <[hidden email]>; andre grosse-stoltenberg <[hidden email]>
Subject: Re: [GRASS-web] Installing r.green is not possible
 
Dear Annemarie,

Which GRASS GIS version do you use, and on which operating system?
I have tried to install it myself, on a Linux system:


GRASS 7.8.2dev (nc_spm_08):~ > g.extension r.green
Fetching <r.green> from GRASS GIS Addons repository (be patient)...
Compiling...
Traceback (most recent call last):
  File "/home/mneteler/tmp/grass7-mneteler-20201/tmpfggv6w9y/r.green/scripts/r.green.hydro.structure",
line 139, in <module>
    from libgreen.checkparameter import check_required_columns, exception2error
ModuleNotFoundError: No module named 'libgreen'
make[2]: *** [/home/mneteler/software/grass78_git/dist.x86_64-pc-linux-gnu/include/Make/Html.make:14:
r.green.hydro.structure.tmp.html] Error 1
/home/mneteler/tmp/grass7-mneteler-20201/tmpfggv6w9y/r.green/scripts/r.green.install:35:
DeprecationWarning: the imp module is deprecated in favour of
importlib; see the module's documentation for alternative uses
  import imp
Installing...
/usr/bin/install: cannot stat
'/home/mneteler/tmp/grass7-mneteler-20201/tmpfggv6w9y/r.green/docs/html/r.green.hydro.structure.html':
No such file or directory
make[2]: *** [/home/mneteler/software/grass78_git/dist.x86_64-pc-linux-gnu/include/Make/Script.make:36:
install] Error 1
Updating addons metadata file...
Updating private addons metadata file...
WARNING: No addons metadata available. Addons metadata file not updated.
Installation of <r.green> successfully finished

GRASS 7.8.2dev (nc_spm_08):~ > r.green.
r.green.biomassfor.co2          r.green.biomassfor.recommended
r.green.gshp.theoretical        r.green.hydro.financial
r.green.hydro.technical
r.green.biomassfor.financial    r.green.biomassfor.technical
r.green.hydro.closest           r.green.hydro.optimal
r.green.hydro.theoretical
r.green.biomassfor.impact       r.green.biomassfor.theoretical
r.green.hydro.delplants         r.green.hydro.planning
r.green.install
r.green.biomassfor.legal        r.green.gshp.technical
r.green.hydro.discharge         r.green.hydro.structure

Some issue seems to be there with "libgreen".

Do you see the same error?

Best regards,

Markus

On Wed, Nov 6, 2019 at 11:38 AM Annemarie Pfeiffer
<[hidden email]> wrote:
>
> Dear Sir or Madam,
>
> as part of my master's thesis I would like to use the tool
> r.green.hydro with all its functions. After I've completed all the
> steps of your detailed online installation guide, Grass-Gis will
> create a field called "Energy." The functions of this field are grayed
> out and can not be executed. After entering the r.green.install -x
> command, you also receive the message that the python libraries
> numexpr and scipy are not available. After I installed these manually,
> the message did not occur anymore, but the functions in "Energy" were
> also not executable and still written in gray.
> Additionally, when you load Grass-GIS into the black console, you see
> the following message:
>
> Details: Can not find the executable r.green.hydro ....
> r.green.hydro ...: Unable to fetch interface description for command
> 'r.green.hydro ....' "
>
> Since I would benefit greatly from the use of the tool for my
> explorations, I would be very grateful if you could help me with my
> problem.
>
> With best regards
> Annemarie Pfeiffer
>
>
>
> Mit freundlichen Grüßen
> Annemarie Pfeiffer
>
> _______________________________________________
> grass-web mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/grass-web



--
Markus Neteler, PhD
https://www.mundialis.de - free data with free software
https://grass.osgeo.org
https://courses.neteler.org/blog

_______________________________________________
grass-web mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/grass-web
Reply | Threaded
Open this post in threaded view
|

Re: Installing r.green is not possible

Markus Neteler
In reply to this post by Markus Neteler
Dear Annemarie,

Here a belated update:

On Mon, Nov 11, 2019 at 6:46 PM Markus Neteler <[hidden email]> wrote:

>
> Dear Annemarie,
>
> Which GRASS GIS version do you use, and on which operating system?
> I have tried to install it myself, on a Linux system:
>
>
> GRASS 7.8.2dev (nc_spm_08):~ > g.extension r.green
> Fetching <r.green> from GRASS GIS Addons repository (be patient)...
> Compiling...
> Traceback (most recent call last):
>   File "/home/mneteler/tmp/grass7-mneteler-20201/tmpfggv6w9y/r.green/scripts/r.green.hydro.structure",
> line 139, in <module>
>     from libgreen.checkparameter import check_required_columns, exception2error
> ModuleNotFoundError: No module named 'libgreen'

This error has just been fixed thanks to Tomáš Zigo (in
https://github.com/OSGeo/grass-addons/pull/225).

Best regards,

Markus
_______________________________________________
grass-web mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/grass-web