Installation Mapbender22 in MySQL

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Installation Mapbender22 in MySQL

Ronald Woita
Hallo Liste,

habe gerade Mapbender 22 installiert und den kompletten Datenbestand aus MB 21 (incl. GUI's + Userverwaltung) rübergeschaufelt.
Die Datenmigration hat denn auch recht probemlos funktioniert ;-)
Umgebung :
SLES 8
MySQL 4.0.21 <-- hier Mapbender drin
Postgresql 7.4.6
PHP 4.3.10

bis dato aufgetretene Probleme :
Bei Auswahl eines Layers (in treeGDE)  für einen GetFeatureInfoRequest mittels Modul
'FeatureInfo1' bekomme ich immer den Alert 'Please Select a Layer !'
Die WMS-Dienste sind aber sauber, da selbige Konstellation in MB 21 funktioniert.

In meiner Konfiguration ist der MB in MySQL, die Flächenberechnung braucht aber PostGIS.
in der aktuellen mod_evalArea.php (v 1.9) aus dem CVS klappt das nicht, da nur die connect-Daten
für MySQL übergeben werden.
Lösung : habe ersteinmal die alte Datei (v 1.6) aus MB21 genommen, und die pgsql.conf wieder in
das conf-Verzeichnis kopiert.

Und hier noch ein paar eher banale Sachen :
Modul 'SelectMapSize' fehlt im mysql_data.sql Skript
Modul 'mapbender' : in der gui1 steht der Wert für Left auf -59, Anzeige aber erst ab 1
gleiches gilt für 'dragMapsize'


schöne Grüße von der Ostsee

Ronald

--
Ronald Woita
Hansestadt Rostock
Kataster-, Vermessungs- und Liegenschaftsamt
Holbeinplatz 14, 18069 Rostock
email: [hidden email]
phone: +49 (0)381 - 381 6256



-------------------------------------------------------
This SF.Net email is sponsored by the JBoss Inc.  Get Certified Today
Register for a JBoss Training Course.  Free Certification Exam
for All Training Attendees Through End of 2005. For more info visit:
<a href="http://ads.osdn.com/?ad_idv28&alloc_id845&op=click">http://ads.osdn.com/?ad_idv28&alloc_id845&op=click
_______________________________________________
Mapbender-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mapbender-users
Reply | Threaded
Open this post in threaded view
|

AW: Installation Mapbender22 in MySQL

Schönhammer, Herbert
Hallo Liste,

zur Meldung "Please select a layer !":

In der bei uns installierten MB 2.2 Version ist es dem MapBender egal, welche Layer der Benutzer per "FeatureInfo-Häkchen" interaktiv auswählt.
Der Mapbender frägt IMMER GENAU die Layer an, die in der Datenbank (über die admin-gui) per default auf info_default=true gestellt sind.
Wenn eben kein Layer mit info_default=true vorhanden, erscheint immer die Meldung "Please select a layer!". Ganz egal wieviele Häkchen interaktiv gesetzt wurden.

Ich habe das Problem bereits gestern direkt an ccgis weitergegeben. Ich hoffe demnächst hierzu eine Aussage (in der Liste?) zu bekommen.

Mit freundlichen Grüßen

Schönhammer Herbert
Dipl.-Ing.(FH), Dipl.-Inf.

Stadt Regensburg
Amt für Vermessung und Statistik
D.-Martin-Luther-Straße 1
93047 Regensburg

Tel.: 0941 / 507-2662
Fax: 0941 / 507-4866


-----Ursprüngliche Nachricht-----
Von: [hidden email] [mailto:[hidden email]] Im Auftrag von Ronald Woita
Gesendet: Donnerstag, 17. November 2005 11:56
An: [hidden email]
Betreff: [Mapbender-users] Installation Mapbender22 in MySQL


Hallo Liste,

habe gerade Mapbender 22 installiert und den kompletten Datenbestand aus MB 21 (incl. GUI's + Userverwaltung) rübergeschaufelt.
Die Datenmigration hat denn auch recht probemlos funktioniert ;-)
Umgebung :
SLES 8
MySQL 4.0.21 <-- hier Mapbender drin
Postgresql 7.4.6
PHP 4.3.10

bis dato aufgetretene Probleme :
Bei Auswahl eines Layers (in treeGDE)  für einen GetFeatureInfoRequest mittels Modul
'FeatureInfo1' bekomme ich immer den Alert 'Please Select a Layer !'
Die WMS-Dienste sind aber sauber, da selbige Konstellation in MB 21 funktioniert.

In meiner Konfiguration ist der MB in MySQL, die Flächenberechnung braucht aber PostGIS.
in der aktuellen mod_evalArea.php (v 1.9) aus dem CVS klappt das nicht, da nur die connect-Daten
für MySQL übergeben werden.
Lösung : habe ersteinmal die alte Datei (v 1.6) aus MB21 genommen, und die pgsql.conf wieder in
das conf-Verzeichnis kopiert.

Und hier noch ein paar eher banale Sachen :
Modul 'SelectMapSize' fehlt im mysql_data.sql Skript
Modul 'mapbender' : in der gui1 steht der Wert für Left auf -59, Anzeige aber erst ab 1
gleiches gilt für 'dragMapsize'


schöne Grüße von der Ostsee

Ronald

--
Ronald Woita
Hansestadt Rostock
Kataster-, Vermessungs- und Liegenschaftsamt
Holbeinplatz 14, 18069 Rostock
email: [hidden email]
phone: +49 (0)381 - 381 6256



-------------------------------------------------------
This SF.Net email is sponsored by the JBoss Inc.  Get Certified Today
Register for a JBoss Training Course.  Free Certification Exam
for All Training Attendees Through End of 2005. For more info visit:
<a href="http://ads.osdn.com/?ad_idv28&alloc_id845&op=ick">http://ads.osdn.com/?ad_idv28&alloc_id845&op=ick
_______________________________________________
Mapbender-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mapbender-users


-------------------------------------------------------
This SF.Net email is sponsored by the JBoss Inc.  Get Certified Today
Register for a JBoss Training Course.  Free Certification Exam
for All Training Attendees Through End of 2005. For more info visit:
<a href="http://ads.osdn.com/?ad_idv28&alloc_id845&op=click">http://ads.osdn.com/?ad_idv28&alloc_id845&op=click
_______________________________________________
Mapbender-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mapbender-users
Reply | Threaded
Open this post in threaded view
|

Re: AW: Installation Mapbender22 in MySQL

Uli Rothstein
Hallo,

in der neuen map.php
(http://cvs.sourceforge.net/viewcvs.py/mapbender/mapbender/http/javascripts/map.php?rev=1.27&view=log)
ist dieses Problem (zur Meldung "Please select a layer!") gelöst.
Bitte die Datei im Ordner ../mapbender/http/javascripts austauschen.

Viele Grüße
Uli

> Hallo Liste,
>
> zur Meldung "Please select a layer !":
>
> In der bei uns installierten MB 2.2 Version ist es dem MapBender egal,
> welche Layer der Benutzer per "FeatureInfo-Häkchen" interaktiv auswählt.
> Der Mapbender frägt IMMER GENAU die Layer an, die in der Datenbank (über
> die admin-gui) per default auf info_default=true gestellt sind.
> Wenn eben kein Layer mit info_default=true vorhanden, erscheint immer die
> Meldung "Please select a layer!". Ganz egal wieviele Häkchen interaktiv
> gesetzt wurden.
>
> Ich habe das Problem bereits gestern direkt an ccgis weitergegeben. Ich
> hoffe demnächst hierzu eine Aussage (in der Liste?) zu bekommen.
>
> Mit freundlichen Grüßen
>
> Schönhammer Herbert
> Dipl.-Ing.(FH), Dipl.-Inf.
>
> Stadt Regensburg
> Amt für Vermessung und Statistik
> D.-Martin-Luther-Straße 1
> 93047 Regensburg
>
> Tel.: 0941 / 507-2662
> Fax: 0941 / 507-4866
>
>
> -----Ursprüngliche Nachricht-----
> Von: [hidden email]
> [mailto:[hidden email]] Im Auftrag von Ronald
> Woita
> Gesendet: Donnerstag, 17. November 2005 11:56
> An: [hidden email]
> Betreff: [Mapbender-users] Installation Mapbender22 in MySQL
>
>
> Hallo Liste,
>
> habe gerade Mapbender 22 installiert und den kompletten Datenbestand aus
> MB 21 (incl. GUI's + Userverwaltung) rübergeschaufelt.
> Die Datenmigration hat denn auch recht probemlos funktioniert ;-)
> Umgebung :
> SLES 8
> MySQL 4.0.21 <-- hier Mapbender drin
> Postgresql 7.4.6
> PHP 4.3.10
>
> bis dato aufgetretene Probleme :
> Bei Auswahl eines Layers (in treeGDE)  für einen GetFeatureInfoRequest
> mittels Modul
> 'FeatureInfo1' bekomme ich immer den Alert 'Please Select a Layer !'
> Die WMS-Dienste sind aber sauber, da selbige Konstellation in MB 21
> funktioniert.
>
> In meiner Konfiguration ist der MB in MySQL, die Flächenberechnung braucht
> aber PostGIS.
> in der aktuellen mod_evalArea.php (v 1.9) aus dem CVS klappt das nicht, da
> nur die connect-Daten
> für MySQL übergeben werden.
> Lösung : habe ersteinmal die alte Datei (v 1.6) aus MB21 genommen, und die
> pgsql.conf wieder in
> das conf-Verzeichnis kopiert.
>
> Und hier noch ein paar eher banale Sachen :
> Modul 'SelectMapSize' fehlt im mysql_data.sql Skript
> Modul 'mapbender' : in der gui1 steht der Wert für Left auf -59, Anzeige
> aber erst ab 1
> gleiches gilt für 'dragMapsize'
>
>
> schöne Grüße von der Ostsee
>
> Ronald
>
> --
> Ronald Woita
> Hansestadt Rostock
> Kataster-, Vermessungs- und Liegenschaftsamt
> Holbeinplatz 14, 18069 Rostock
> email: [hidden email]
> phone: +49 (0)381 - 381 6256
>
>
>
> -------------------------------------------------------
> This SF.Net email is sponsored by the JBoss Inc.  Get Certified Today
> Register for a JBoss Training Course.  Free Certification Exam
> for All Training Attendees Through End of 2005. For more info visit:
> <a href="http://ads.osdn.com/?ad_idv28&alloc_id845&op=ick">http://ads.osdn.com/?ad_idv28&alloc_id845&op=ick
> _______________________________________________
> Mapbender-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/mapbender-users
>
>
> -------------------------------------------------------
> This SF.Net email is sponsored by the JBoss Inc.  Get Certified Today
> Register for a JBoss Training Course.  Free Certification Exam
> for All Training Attendees Through End of 2005. For more info visit:
> <a href="http://ads.osdn.com/?ad_idv28&alloc_id845&op=click">http://ads.osdn.com/?ad_idv28&alloc_id845&op=click
> _______________________________________________
> Mapbender-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/mapbender-users
>




-------------------------------------------------------
This SF.Net email is sponsored by the JBoss Inc.  Get Certified Today
Register for a JBoss Training Course.  Free Certification Exam
for All Training Attendees Through End of 2005. For more info visit:
http://ads.osdn.com/?ad_id=7628&alloc_id=16845&op=click
_______________________________________________
Mapbender-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mapbender-users