Idioma Español por defecto Geonetwork 2.10.4

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
24 messages Options
12
Reply | Threaded
Open this post in threaded view
|

Idioma Español por defecto Geonetwork 2.10.4

cbeltran
Hola,

Me podrían ayudar, necesito establecer el idioma español de forma predeterminada en mi Geonetwork 2.10.4

Lo intenté:

En index.html

window.location = "srv / en / main.home" + búsqueda; por window.location = "srv / es / main.home" + buscar;

En config.xml

<idioma> en </ idioma> por <idioma> es </ idioma> 

Pero no funciona.

gracias
Reply | Threaded
Open this post in threaded view
|

Re: Idioma Español por defecto Geonetwork 2.10.4

Jose Garcia
Hola Carlos

Respecto a la 2.10.4 te recomendaría esperar (por ahora la he quitado de
sourceforge), al final se han descubierto algunos errores en el harvester
CSW que estamos mirando.

De todas formas respecto a la interface de usuario, para si usas la UI
html5ui (por defecto) en vez de la clásica, tienes que cambiar en el
fichero config-overrides-html5ui-props.xml:

        <widget.url>../../srv/eng/search</widget.url>

a

        <widget.url>../../srv/spa/search</widget.url>

Saludos,
Jose García


On Wed, Oct 29, 2014 at 10:58 PM, cbeltran <[hidden email]> wrote:

> Hola,
>
> Me podrían ayudar, necesito establecer el idioma español de forma
> predeterminada en mi Geonetwork 2.10.4
>
> Lo intenté:
>
> En index.html
>
> window.location = "srv / en / main.home" + búsqueda; por window.location =
> "srv / es / main.home" + buscar;
>
> En config.xml
>
> <idioma> en </ idioma> por <idioma> es </ idioma>
>
> Pero no funciona.
>
> gracias
>
>
>
> --
> View this message in context:
> http://osgeo-org.1560.x6.nabble.com/Idioma-Espa-ol-por-defecto-Geonetwork-2-10-4-tp5170283.html
> Sent from the GeoNetwork users español mailing list archive at Nabble.com.
>
>
> ------------------------------------------------------------------------------
> _______________________________________________
> GeoNetwork-usuarios-es mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-usuarios-es
>



--

*GeoCat Bridge for ArcGIS allows instant publishing of data and metadata on
GeoServer and GeoNetwork. Visit http://geocat.net <http://geocat.net/> for
details. _________________________Jose GarcíaGeoCat bvVeenderweg 136721 WD
BennekomThe Netherlandshttp://GeoCat.net <http://geocat.net/>*
------------------------------------------------------------------------------
_______________________________________________
GeoNetwork-usuarios-es mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-usuarios-es
Reply | Threaded
Open this post in threaded view
|

Re: Idioma Español por defecto Geonetwork 2.10.4

cbeltran
Hola Jose, Muchas gracias por tu aporte.

Respecto a lo de la versión del geonetwork, voy a seguir utilizando la 2.10.3 hasta que se corrijan los errores en la 2.10.4.

Algo que me ha pasado en la 2.10.3 cuando hago la modificación para el idioma español por defecto es que al tratar de insertar un nuevo metadato los campos no aparecen con el label original, me explico:
por ejemplo escojo la plantilla (iso 19139) De plantilla para el vector de datos en ISO19139 (multilingue)
Uno de los campos se llama "Tipo de Dato" y me aparece es como "gmd:dateType" y las variables de la lista desplegable de ese campo no se cargan. Estuve revisando y encontré que había que verificar si los siguientes archivos se encontraban en la instalación de geonetwork:

https://github.com/geonetwork/core-geonetwork/blob/develop/schemas/iso19139/src/main/plugin/iso19139/loc/spa/codelists.xml and

https://github.com/geonetwork/core-geonetwork/blob/develop/schemas/iso19139/src/main/plugin/iso19139/loc/spa/labels.xml

Efectivamente ya revisé esos archivos y se encuentran en mi instalación de geonetwork.

Sabes a que se deba el error cuando configuro para que sea el idioma español por defecto?

Adjunto imagen:



Otra cosita adicional, si quiero configurar la interfaz html 5 GUI en geonetwork 2.10.3 solo se cambia esta línea:

Clásico:

<client type="redirect" widget="false" url="main.home" />

Por

HTML 5:
<client type="redirect" widget="true" url="../../srv/eng/search" createParameter="#create" stateId="s" />

Hay que hacer algo más?

Gracias por toda tu ayuda.
Reply | Threaded
Open this post in threaded view
|

Re: Idioma Español por defecto Geonetwork 2.10.4

cbeltran
Hola Jose

Te cuento que he instalado de nuevo la versión 2.10.3. Le he configurado para que por defecto aparezca con la interfaz html5, hasta acá todo muy bien. El inconveniente se genera cuando estoy en idioma español, voy a generar un nuevo metadato. Te adjunto las imágenes.






Y finalmente cuanto voy a insertar un nuevo metadato en idioma español, pasa algo curioso con los campos que te adjunto en esta imagen.



Te agradezco la ayuda que me puedas brindar al respecto.

Muchas gracias.

Reply | Threaded
Open this post in threaded view
|

Re: Idioma Español por defecto Geonetwork 2.10.4

Jose Garcia
Hola

Respecto al editor de metadatos de la UI html5, edita el fichero
geonetwork/WEB-INF/data/config/schema_plugins/iso19139/loc/spa/labels.xml y
añade esto al final:

<element name="gml:TimePeriodTypeCHOICE_ELEMENT2">
<label>Fecha de inicio</label>
<description>Selecciona la fecha de inicio</description>
</element>
<element name="gml:TimePeriodTypeCHOICE_ELEMENT3">
<label>Fecha de fin</label>
<description>Selecciona la fecha de fin</description>
</element>

Voy a actualizarlo en github para la siguiente versión.


Respecto a la interface clásica, por por las imágenes parece que no está
cargando bien el fichero de labels.xml y/o codelist.xml. Esto suele pasar
si tienen algún error, pero lo he probado con 2.10.3 y el editor muestra
todo bien para mí.

Saludos,
Jose García

2014-10-30 21:45 GMT+01:00 cbeltran <[hidden email]>:

> Hola Jose
>
> Te cuento que he instalado de nuevo la versión 2.10.3. Le he configurado
> para que por defecto aparezca con la interfaz html5, hasta acá todo muy
> bien. El inconveniente se genera cuando estoy en idioma español, voy a
> generar un nuevo metadato. Te adjunto las imágenes.
>
> <http://osgeo-org.1560.x6.nabble.com/file/n5170484/geo1.png>
> <http://osgeo-org.1560.x6.nabble.com/file/n5170484/geo2.png>
> <http://osgeo-org.1560.x6.nabble.com/file/n5170484/geo3.png>
> <http://osgeo-org.1560.x6.nabble.com/file/n5170484/geo4.png>
>
> Y finalmente cuanto voy a insertar un nuevo metadato en idioma español,
> pasa
> algo curioso con los campos que te adjunto en esta imagen.
>
> <http://osgeo-org.1560.x6.nabble.com/file/n5170484/geo5.png>
>
> Te agradezco la ayuda que me puedas brindar al respecto.
>
> Muchas gracias.
>
>
>
>
>
> --
> View this message in context:
> http://osgeo-org.1560.x6.nabble.com/Idioma-Espa-ol-por-defecto-Geonetwork-2-10-4-tp5170283p5170484.html
> Sent from the GeoNetwork users español mailing list archive at Nabble.com.
>
>
> ------------------------------------------------------------------------------
> _______________________________________________
> GeoNetwork-usuarios-es mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-usuarios-es
>



--

*GeoCat Bridge for ArcGIS allows instant publishing of data and metadata on
GeoServer and GeoNetwork. Visit http://geocat.net <http://geocat.net/> for
details. _________________________Jose GarcíaGeoCat bvVeenderweg 136721 WD
BennekomThe Netherlandshttp://GeoCat.net <http://geocat.net/>*
------------------------------------------------------------------------------
_______________________________________________
GeoNetwork-usuarios-es mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-usuarios-es
Reply | Threaded
Open this post in threaded view
|

Re: Idioma Español por defecto Geonetwork 2.10.4

cbeltran
Hola,

Muchísimas gracias Jose por tu ayuda y colaboración, hice el cambio para los campos que me indicas y funcionan correctamente.

Te consulto sobre lo del idioma, cómo sería la configuración de dejar por defecto el idioma Español para esta versión 2.10.3 con html5 gui??? y a su vez de la lista desplegable de idiomas que solo queden Español e Inglés, sé que en la interfaz clásica se puede hacer en config-gui.xml:


 <languages>
     <ara/>
     <cat/>
     <chi/>
     <dut/>
     <eng/>
     <fin/>
     <fre/>
     <ger/>
     <ita/>
     <nor/>
     <pol/>
     <por/>
     <rus/>
     <spa/>
     <tur/>
 </languages>

Ya se comentando los idiomas que no se desean o eliminando la línea, pero no sé como es para la versión html5.


Muchas gracias por toda tu ayuda.

Saludos.
Reply | Threaded
Open this post in threaded view
|

Re: Idioma Español por defecto Geonetwork 2.10.4

Jose Garcia
Hola

Tienes que cambiar en el fichero
geonetwork/WEB-INF/config-overrides-html5ui-props.xml:

        <widget.url>../../srv/eng/search</widget.url>

a

        <widget.url>../../srv/spa/search</widget.url>

Saludos,
Jose García


2014-10-31 16:23 GMT+01:00 cbeltran <[hidden email]>:

> Hola,
>
> Muchísimas gracias Jose por tu ayuda y colaboración, hice el cambio para
> los
> campos que me indicas y funcionan correctamente.
>
> Te consulto sobre lo del idioma, cómo sería la configuración de dejar por
> defecto el idioma Español para esta versión 2.10.3 con html5 gui??? y a su
> vez de la lista desplegable de idiomas que solo queden Español e Inglés, sé
> que en la interfaz clásica se puede hacer en config-gui.xml:
>
>
>  <languages>
>      <ara/>
>      <cat/>
>      <chi/>
>      <dut/>
>      <eng/>
>      <fin/>
>      <fre/>
>      <ger/>
>      <ita/>
>      <nor/>
>      <pol/>
>      <por/>
>      <rus/>
>      <spa/>
>      <tur/>
>  </languages>
>
> Ya se comentando los idiomas que no se desean o eliminando la línea, pero
> no
> sé como es para la versión html5.
>
>
> Muchas gracias por toda tu ayuda.
>
> Saludos.
>
>
>
>
> --
> View this message in context:
> http://osgeo-org.1560.x6.nabble.com/Idioma-Espa-ol-por-defecto-Geonetwork-2-10-4-tp5170283p5170641.html
> Sent from the GeoNetwork users español mailing list archive at Nabble.com.
>
>
> ------------------------------------------------------------------------------
> _______________________________________________
> GeoNetwork-usuarios-es mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-usuarios-es
>



--

*GeoCat Bridge for ArcGIS allows instant publishing of data and metadata on
GeoServer and GeoNetwork. Visit http://geocat.net <http://geocat.net/> for
details. _________________________Jose GarcíaGeoCat bvVeenderweg 136721 WD
BennekomThe Netherlandshttp://GeoCat.net <http://geocat.net/>*
------------------------------------------------------------------------------
_______________________________________________
GeoNetwork-usuarios-es mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-usuarios-es
Reply | Threaded
Open this post in threaded view
|

Re: Idioma Español por defecto Geonetwork 2.10.4

cbeltran
Hola

Solo es cambiar ese archivo??, porque hice el cambio pero sigue por defecto el idioma inglés..

Gracias
Reply | Threaded
Open this post in threaded view
|

Re: Idioma Español por defecto Geonetwork 2.10.4

smgatti
This post has NOT been accepted by the mailing list yet.
Buenos dias, tengo una configuracion de GN con Oracle con TOMCAT6 y tengo el mismo problema cbeltran.
He cambiado la referencia a spa en el archivo que indicaron pero no cambia a español.
Algun otro dato?

GRacias!
Reply | Threaded
Open this post in threaded view
|

Re: Idioma Español por defecto Geonetwork 2.10.4

cbeltran
Hola Compañero,

Hice la modificación igual que tú, pero continúa por defecto en Inglés, no se generó ningún cambio al respecto con el tema del idioma.

Jose nos puede dar mas luces sobre el inconveniente, esperemos nos siga colaborando al respecto.

Gracias
Reply | Threaded
Open this post in threaded view
|

Re: Idioma Español por defecto Geonetwork 2.10.4

smgatti
En este link

https://www.mail-archive.com/geonetwork-usuarios-es@lists.sourceforge.net/msg00145.html

estan las directivas con las que pude cambiar el idioma por defecto a Español

Espero te sirva

Saludos
Silvia
Reply | Threaded
Open this post in threaded view
|

Re: Idioma Español por defecto Geonetwork 2.10.4

smgatti
In reply to this post by cbeltran
Funciona en IE no en Chrome o Firefox
Reply | Threaded
Open this post in threaded view
|

Re: Idioma Español por defecto Geonetwork 2.10.4

Jose Garcia
In reply to this post by smgatti
Hola

El link se refiere a la UI clásica, en la UI basada en ExtJs la
configuración es diferente. Intento probar hoy la configuración que envié
para verificar si se me pasó algún paso.

Saludos,
Jose García

On Wed, Nov 5, 2014 at 4:17 PM, smgatti <[hidden email]> wrote:

> En este link
>
>
> https://www.mail-archive.com/geonetwork-usuarios-es@.../msg00145.html
>
> estan las directivas con las que pude cambiar el idioma por defecto a
> Español
>
> Espero te sirva
>
> Saludos
> Silvia
>
>
>
> --
> View this message in context:
> http://osgeo-org.1560.x6.nabble.com/Idioma-Espa-ol-por-defecto-Geonetwork-2-10-4-tp5170283p5171409.html
> Sent from the GeoNetwork users español mailing list archive at Nabble.com.
>
>
> ------------------------------------------------------------------------------
> _______________________________________________
> GeoNetwork-usuarios-es mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-usuarios-es
>



--

*GeoCat Bridge for ArcGIS allows instant publishing of data and metadata on
GeoServer and GeoNetwork. Visit http://geocat.net <http://geocat.net/> for
details. _________________________Jose GarcíaGeoCat bvVeenderweg 136721 WD
BennekomThe Netherlandshttp://GeoCat.net <http://geocat.net/>*
------------------------------------------------------------------------------
_______________________________________________
GeoNetwork-usuarios-es mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-usuarios-es
Reply | Threaded
Open this post in threaded view
|

Re: Idioma Español por defecto Geonetwork 2.10.4

delawen
In reply to this post by smgatti
On Wed, Nov 5, 2014 at 4:21 PM, smgatti <[hidden email]> wrote:

> Funciona en IE no en Chrome o Firefox
>

Pues son cambios agnósticos al tipo de navegador.

Si te pasa eso revisa dos cosas:
 * Caché de los navegadores
 * Idioma por defecto en la configuración del navegador

Como dicen por ahí: si la caché de Chrome fuera más agresiva te escupiría a
la cara.


> --
> View this message in context:
> http://osgeo-org.1560.x6.nabble.com/Idioma-Espa-ol-por-defecto-Geonetwork-2-10-4-tp5170283p5171413.html
> Sent from the GeoNetwork users español mailing list archive at Nabble.com.
>
>
> ------------------------------------------------------------------------------
> _______________________________________________
> GeoNetwork-usuarios-es mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-usuarios-es
>
------------------------------------------------------------------------------
_______________________________________________
GeoNetwork-usuarios-es mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-usuarios-es
Reply | Threaded
Open this post in threaded view
|

Re: Idioma Español por defecto Geonetwork 2.10.4

smgatti
Gracias Maria por tu aporte, siempre olvido estos temas de caches y otras yerbas.
Todo funcionó correctamente

Silvia
Reply | Threaded
Open this post in threaded view
|

Re: Idioma Español por defecto Geonetwork 2.10.4

cbeltran
Compañero smgatti

Tú estas haciendo la configuración del idioma Español para cual interfaz de Geonetwork?

Para la clásica?

Para la html5 gui?

Gracias
Reply | Threaded
Open this post in threaded view
|

Re: Idioma Español por defecto Geonetwork 2.10.4

Jose Garcia
Hola

Acabo de probarlo en una instalación nueva de 2.10.3 y con los siguientes
cambios me funciona bien en español la UI html5:

*geonetwork/index.html*

window.location="srv/*spa*/home" + search;

*geonetwork/WEB-INF/config-overrides-html5ui-props.xml*

<widget.url>../../srv/*spa*/search</widget.url>

Ten en cuenta que tendrás que reiniciar la aplicación, ya que el 2o fichero
se carga en el arranque.

Lo he probado con varios navegadores y me va bien. Si tuvieras problemas,
prueba a ver si se soluciona limpiando la cache.

Saludos,
Jose García

2014-11-05 17:05 GMT+01:00 cbeltran <[hidden email]>:

> Compañero smgatti
>
> Tú estas haciendo la configuración del idioma Español para cual interfaz de
> Geonetwork?
>
> Para la clásica?
>
> Para la html5 gui?
>
> Gracias
>
>
>
> --
> View this message in context:
> http://osgeo-org.1560.x6.nabble.com/Idioma-Espa-ol-por-defecto-Geonetwork-2-10-4-tp5170283p5171424.html
> Sent from the GeoNetwork users español mailing list archive at Nabble.com.
>
>
> ------------------------------------------------------------------------------
> _______________________________________________
> GeoNetwork-usuarios-es mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-usuarios-es
>



--

*GeoCat Bridge for ArcGIS allows instant publishing of data and metadata on
GeoServer and GeoNetwork. Visit http://geocat.net <http://geocat.net/> for
details. _________________________Jose GarcíaGeoCat bvVeenderweg 136721 WD
BennekomThe Netherlandshttp://GeoCat.net <http://geocat.net/>*
------------------------------------------------------------------------------
_______________________________________________
GeoNetwork-usuarios-es mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-usuarios-es
Reply | Threaded
Open this post in threaded view
|

Re: Idioma Español por defecto Geonetwork 2.10.4

cbeltran
Hola Jose

Adicional a la configuración que me indicas , tuve que hacerlo también en:

/opt/tomcat/webapps/geonetwork/WEB-INF/config-gui.xml

<client type="redirect" widget="true" url="../../srv/spa/search" createParameter="#create" stateId="s" />

Ya me esta funcionando perfecto.

Muchas gracias por tu ayuda.
Reply | Threaded
Open this post in threaded view
|

Re: Idioma Español por defecto Geonetwork 2.10.4

Jose Garcia
Hola

En principio esto último no debería de hacer falta (al menos en la
instalación que he probado no ha hecho falta) ya que la url se debe de
cambiar con el valor definido en *config-overrides-html5ui-props.xml*

De todas formas me alegro que te funcione.

Saludos,
Jose García


2014-11-05 17:29 GMT+01:00 cbeltran <[hidden email]>:

> Hola Jose
>
> Adicional a la configuración que me indicas , tuve que hacerlo también en:
>
> /opt/tomcat/webapps/geonetwork/WEB-INF/config-gui.xml
>
> <client type="redirect" widget="true" url="../../srv/spa/search"
> createParameter="#create" stateId="s" />
>
> Ya me esta funcionando perfecto.
>
> Muchas gracias por tu ayuda.
>
>
>
> --
> View this message in context:
> http://osgeo-org.1560.x6.nabble.com/Idioma-Espa-ol-por-defecto-Geonetwork-2-10-4-tp5170283p5171431.html
> Sent from the GeoNetwork users español mailing list archive at Nabble.com.
>
>
> ------------------------------------------------------------------------------
> _______________________________________________
> GeoNetwork-usuarios-es mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-usuarios-es
>



--

*GeoCat Bridge for ArcGIS allows instant publishing of data and metadata on
GeoServer and GeoNetwork. Visit http://geocat.net <http://geocat.net/> for
details. _________________________Jose GarcíaGeoCat bvVeenderweg 136721 WD
BennekomThe Netherlandshttp://GeoCat.net <http://geocat.net/>*
------------------------------------------------------------------------------
_______________________________________________
GeoNetwork-usuarios-es mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-usuarios-es
Reply | Threaded
Open this post in threaded view
|

Re: Idioma Español por defecto Geonetwork 2.10.4

cbeltran
Hola Jose

Tú me podrías indicar como es la configuración para habilitar en Geonetwork 2.10.3 la interfaz HTML5, porque lo ví en un post que solo era insertar esta línea:

<client type="redirect" widget="true" url="../../srv/spa/search" createParameter="#create" stateId="s" />

En config-gui.xml.

Es este el proceso???

Gracias
12