I this list is for bugs?

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

I this list is for bugs?

Alon Barzilai

Hi,

I am new in this list, and I encountered in a bug. I hope this is the right place to post it.

when using a coordinate system with vertical datum ( egm96_15.gtx in my case) for latitude 89.9999999999999  I get a crash.

this table is 1440 by 721 and when calculating the index for the table, the calculation is line 721, and then a crash.

the calculation if this index is at pj_apply_vgridshift.c  lines 139- 144. grid_iy is 720.

I can provide more information and code sample, if needed.
I am using proj through GDAL. so the code sample I have is with GDAL api.


Regards,
Alon.









_______________________________________________
Proj mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/proj
Reply | Threaded
Open this post in threaded view
|

Re: I this list is for bugs?

Andre Joost
Am 30.11.2017 um 06:57 schrieb Alon Barzilai:
> Hi,
>
> I am new in this list, and I encountered in a bug. I hope this is the right
> place to post it.
>
> when using a coordinate system with vertical datum ( egm96_15.gtx in my case)

Have you got the latest version of the file from 2014? There was an
older version from 2010 shipped until recently with OSGEO4W.

HTH,
André Joost

_______________________________________________
Proj mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/proj
Reply | Threaded
Open this post in threaded view
|

Re: I this list is for bugs?

Even Rouault-2

On jeudi 30 novembre 2017 13:34:50 CET Andre Joost wrote:

> Am 30.11.2017 um 06:57 schrieb Alon Barzilai:

> > Hi,

> >

> > I am new in this list, and I encountered in a bug. I hope this is the

> > right

> > place to post it.

> >

> > when using a coordinate system with vertical datum ( egm96_15.gtx in my

> > case)

> Have you got the latest version of the file from 2014? There was an

> older version from 2010 shipped until recently with OSGEO4W.

 

I don't think that's the issue.

 

This sounds like

https://github.com/OSGeo/proj.4/issues/396

which has been fixed in proj master per

https://github.com/OSGeo/proj.4/commit/d64a5508c1efbc1ca6e126d959e19cf879462863

 

Even

 

--

Spatialys - Geospatial professional services

http://www.spatialys.com


_______________________________________________
Proj mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/proj
Reply | Threaded
Open this post in threaded view
|

Re: I this list is for bugs?

Alon Barzilai
This really sound like the same problem.

I am using 4.9.3 and trying to apply a patch.
I downloaded the master version, and this file (pj_apply_vgridshift.c) is very different from what I have.
is there a patch I can use?
I applied my own patch and it is working, however, I prefer a a patch made by the author.


Alon.

On 11/30/2017 2:50 PM, Even Rouault wrote:

On jeudi 30 novembre 2017 13:34:50 CET Andre Joost wrote:

> Am 30.11.2017 um 06:57 schrieb Alon Barzilai:

> > Hi,

> >

> > I am new in this list, and I encountered in a bug. I hope this is the

> > right

> > place to post it.

> >

> > when using a coordinate system with vertical datum ( egm96_15.gtx in my

> > case)

> Have you got the latest version of the file from 2014? There was an

> older version from 2010 shipped until recently with OSGEO4W.

 

I don't think that's the issue.

 

This sounds like

https://github.com/OSGeo/proj.4/issues/396

which has been fixed in proj master per

https://github.com/OSGeo/proj.4/commit/d64a5508c1efbc1ca6e126d959e19cf879462863

 

Even

 

--

Spatialys - Geospatial professional services

http://www.spatialys.com



_______________________________________________
Proj mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/proj


_______________________________________________
Proj mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/proj
Reply | Threaded
Open this post in threaded view
|

Re: I this list is for bugs?

Alon Barzilai
In reply to this post by Andre Joost
Thanks,
I Actually used the old version, so now I switched the the new one.
however, using the new version do not fix the bug.

Alon.


On 11/30/2017 2:34 PM, Andre Joost wrote:
Am 30.11.2017 um 06:57 schrieb Alon Barzilai:
Hi,

I am new in this list, and I encountered in a bug. I hope this is the right
place to post it.

when using a coordinate system with vertical datum ( egm96_15.gtx in my case)
Have you got the latest version of the file from 2014? There was an 
older version from 2010 shipped until recently with OSGEO4W.

HTH,
André Joost

_______________________________________________
Proj mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/proj



_______________________________________________
Proj mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/proj
Reply | Threaded
Open this post in threaded view
|

Re: I this list is for bugs?

Alon Barzilai
In reply to this post by Alon Barzilai
replying to myself:

 I just noticed you sent the patch.
thanks, even.

Alon


On 11/30/2017 5:59 PM, Alon Barzilai wrote:
This really sound like the same problem.

I am using 4.9.3 and trying to apply a patch.
I downloaded the master version, and this file (pj_apply_vgridshift.c) is very different from what I have.
is there a patch I can use?
I applied my own patch and it is working, however, I prefer a a patch made by the author.


Alon.

On 11/30/2017 2:50 PM, Even Rouault wrote:

On jeudi 30 novembre 2017 13:34:50 CET Andre Joost wrote:

> Am 30.11.2017 um 06:57 schrieb Alon Barzilai:

> > Hi,

> >

> > I am new in this list, and I encountered in a bug. I hope this is the

> > right

> > place to post it.

> >

> > when using a coordinate system with vertical datum ( egm96_15.gtx in my

> > case)

> Have you got the latest version of the file from 2014? There was an

> older version from 2010 shipped until recently with OSGEO4W.

 

I don't think that's the issue.

 

This sounds like

https://github.com/OSGeo/proj.4/issues/396

which has been fixed in proj master per

https://github.com/OSGeo/proj.4/commit/d64a5508c1efbc1ca6e126d959e19cf879462863

 

Even

 

--

Spatialys - Geospatial professional services

http://www.spatialys.com



_______________________________________________
Proj mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/proj



_______________________________________________
Proj mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/proj


_______________________________________________
Proj mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/proj
Reply | Threaded
Open this post in threaded view
|

Re: I this list is for bugs?

Even Rouault-2
In reply to this post by Alon Barzilai

On jeudi 30 novembre 2017 18:09:33 CET Alon Barzilai wrote:

> Thanks,

> I Actually used the old version, so now I switched the the new one.

> however, using the new version do not fix the bug.

 

Please provide a reproducable way of exercising the issue

 

Even

 

>

> Alon.

>

>

> On 11/30/2017 2:34 PM, Andre Joost wrote:

> Am 30.11.2017 um 06:57 schrieb Alon Barzilai:

> Hi,

>

> I am new in this list, and I encountered in a bug. I hope this is the right

> place to post it.

>

> when using a coordinate system with vertical datum ( egm96_15.gtx in my

> case) Have you got the latest version of the file from 2014? There was an

> older version from 2010 shipped until recently with OSGEO4W.

>

> HTH,

> André Joost

>

> _______________________________________________

> Proj mailing list

> [hidden email]

> http://lists.maptools.org/mailman/listinfo/proj

 

 

--

Spatialys - Geospatial professional services

http://www.spatialys.com


_______________________________________________
Proj mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/proj
Reply | Threaded
Open this post in threaded view
|

Re: I this list is for bugs?

Alon Barzilai

Hi,

This is the same issue that you fixed. (https://github.com/OSGeo/proj.4/issues/396)

before the fix, I got the crash using old or new version of the data file

Thank you!

Alon


On 11/30/2017 6:13 PM, Even Rouault wrote:

On jeudi 30 novembre 2017 18:09:33 CET Alon Barzilai wrote:

> Thanks,

> I Actually used the old version, so now I switched the the new one.

> however, using the new version do not fix the bug.

 

Please provide a reproducable way of exercising the issue

 

Even

 

>

> Alon.

>

>

> On 11/30/2017 2:34 PM, Andre Joost wrote:

> Am 30.11.2017 um 06:57 schrieb Alon Barzilai:

> Hi,

>

> I am new in this list, and I encountered in a bug. I hope this is the right

> place to post it.

>

> when using a coordinate system with vertical datum ( egm96_15.gtx in my

> case) Have you got the latest version of the file from 2014? There was an

> older version from 2010 shipped until recently with OSGEO4W.

>

> HTH,

> André Joost

>

> _______________________________________________

> Proj mailing list

> [hidden email]

> http://lists.maptools.org/mailman/listinfo/proj

 

 

--

Spatialys - Geospatial professional services

http://www.spatialys.com



_______________________________________________
Proj mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/proj