How to upgrade php and openssl versions?

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

How to upgrade php and openssl versions?

sharat
This post has NOT been accepted by the mailing list yet.
Hi,

I'm currently using the MS4W - version 3.0-beta11.

It has PHP 5.3.2 and OpenSSL 0.9.8m

Symantec web security has been warning me of critical vulnerabilities and pointed out these 2 versions as the reason. Saying I need to update them, etc etc. And the clients have been complaining too.

I have 2 questions here.

1. How do I fix this issue?
2. If i have to update PHP and OpenSSL, how do i do it without effecting the proper functioning of my mapserver? (Coz PHP and OpenSSL have been part of the MS4W package)

Any help is greatly appreciated.

Thanks,

Sharat