How to publish WMS services through MapGuide

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

How to publish WMS services through MapGuide

swimming123
This post was updated on .
I try to publish my own WMS services using AIMS2013 or MapGuide Open Source follow this instruction: http://beingcivil.typepad.com/my_weblog/2012/07/creating-a-wms-service-in-aims-2013.html. Then I try to test it locally using just a URL like this:

http://gistest2013/mapserver2013/mapagent/mapagent.fcgi?REQUEST=GetMap&VERSION=1.1.1&SRS=EPSG:3401&BBOX=-17947.118222967,5973796.69083132,-12306.204602391,5977818.35532628&FORMAT=image/jpeg&WIDTH=600&HEIGHT=600

I expect to get a map image. But it always ask me to enter credentials. I try use various usernames and passwords: windows authentication credentials, MapGuide users, MapGuide Built-in account for WMS users, all failed, see image : .

Anyone can help me with this?
Reply | Threaded
Open this post in threaded view
|

Re: How to publish WMS services through MapGuide

Rémy Gourrat
When you try to connect to your WMS

do you use exactly the same URL as the URL in the parameter field " Server Name " ?

for you, you just have to localhost with IIS, and you can only use with a WMS WMS client on the same PC as the mapguide server.

It is a good customer of WMS , very effective Gaia to experiment
http://thecarbonproject.azurewebsites.net/Products/Gaia

Rémy
-----Message d'origine-----
De : [hidden email] [mailto:[hidden email]] De la part de swimming123
Envoyé : lundi 5 janvier 2015 21:12
À : [hidden email]
Objet : [mapguide-users] How to publish WMS services through MapGuide

I try to publish my own WMS services using AIMS2013 or MapGuide Open Source follow this instruction:
http://beingcivil.typepad.com/my_weblog/2012/07/creating-a-wms-service-in-aims-2013.html.
Then I try to test it locally using just a URL like this:

http://localhost/mapguide/mapagent/mapagent.fcgi?REQUEST=GetMap&VERSION=1.1.1&SRS=EPSG:3401&BBOX=-17947.118222967,5973796.69083132,-12306.204602391,5977818.35532628&FORMAT=image/jpeg&WIDTH=600&HEIGHT=600

I expect to get a map image. But it always ask me to enter credentials. I try use various usernames and passwords: windows authentication credentials, MapGuide users, MapGuide Built-in account for WMS users, all failed, see image :
<http://osgeo-org.1560.x6.nabble.com/file/n5180103/wms_creation.png> .

Anyone can help me with this?




--
View this message in context: http://osgeo-org.1560.x6.nabble.com/How-to-publish-WMS-services-through-MapGuide-tp5180103.html
Sent from the MapGuide Users mailing list archive at Nabble.com.
_______________________________________________
mapguide-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapguide-users

--
This message has been scanned for viruses and dangerous content by MailScanner, and is believed to be clean.

_______________________________________________
mapguide-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapguide-users
AG-Carto - Bayonne
Reply | Threaded
Open this post in threaded view
|

Re: How to publish WMS services through MapGuide

swimming123
Yes, I use exactly the same URL, I tested both localhost and gistest2013 server name. Thanks for the information of Gaia.
Reply | Threaded
Open this post in threaded view
|

Re: How to publish WMS services through MapGuide

Reservoirdog
In reply to this post by swimming123
Did you change anything on the wms user credentials?
I had a problem with AIMS2014, where i changed the standard wms-user/password...
after that i couldn't connect anymore,and got the authentication box when trying to connect...