Harvesting Geoerver WFS, bad-xml-response

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Harvesting Geoerver WFS, bad-xml-response

useher
Hello all!

i am trying to harvest metadata from a geoserver(2.11.x) wfs with
geonetwork(3.4.0) using the following GetFeature-Request:

> <wfs:GetFeature xmlns:wfs="http://www.opengis.net/wfs" service="WFS" version="1.1.0">
>   <wfs:Query typeName="namespace:layer" />
> </wfs:GetFeature>


The harvester drops the following error message:

> bad-xml-response
>
>  an hour ago
>
> No response or problem getting response from https://url/geoserver/namespace/wfs?: <wfs:GetFeature xmlns:wfs="http://www.opengis.net/wfs" service="WFS" version="1.1.0"> <wfs:Query typeName="namespace:layer" /> </wfs:GetFeature>
>
> org.fao.geonet.kernel.harvest.harvester.wfsfeatures.Harvester Harvester.java (247) #harvestResponse
> org.fao.geonet.kernel.harvest.harvester.wfsfeatures.Harvester Harvester.java (229) #harvest
> org.fao.geonet.kernel.harvest.harvester.wfsfeatures.WfsFeaturesHarvester WfsFeaturesHarvester.java (151) #doHarvest
> org.fao.geonet.kernel.harvest.harvester.AbstractHarvester$HarvestWithIndexProcessor AbstractHarvester.java (649) #process
> org.fao.geonet.kernel.harvest.harvester.AbstractHarvester AbstractHarvester.java (721) #harvest
> org.fao.geonet.kernel.harvest.harvester.HarvesterJob HarvesterJob.java (57) #execute
> org.quartz.core.JobRunShell JobRunShell.java (213) #run
> org.quartz.simpl.SimpleThreadPool$WorkerThread SimpleThreadPool.java (557) #run

if i use wget to check the request with the getfeature statement in a
file, a response is generated:

> wget --http-user=me --http-passwd=mypass --post-file=wfs_request.xml -O output.xml --header="Content-Type: text/xml" https://url/geoserver/namespace/wfs?


So where and what am i doing wrong?

Thank you in advance


_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: Harvesting Geoerver WFS, bad-xml-response

Francois Prunayre
Hi, what are you trying to do - create metadata records for each feature
types or create directory based on features ?
If it is feature type, then you have to use the OGC service harvester and
choose WFS for protocol. That harvester support WMS/WCS/WFS/WPS. The other
one about WFSFeature is using Stylesheet to create fragments and may
require some advanced config (and I don't really know how to help on this).

HTH.

Francois


Le ven. 14 déc. 2018 à 07:34, Uwe Seher <[hidden email]> a écrit :

> Hello all!
>
> i am trying to harvest metadata from a geoserver(2.11.x) wfs with
> geonetwork(3.4.0) using the following GetFeature-Request:
>
> > <wfs:GetFeature xmlns:wfs="http://www.opengis.net/wfs" service="WFS"
> version="1.1.0">
> >   <wfs:Query typeName="namespace:layer" />
> > </wfs:GetFeature>
>
>
> The harvester drops the following error message:
>
> > bad-xml-response
> >
> >  an hour ago
> >
> > No response or problem getting response from
> https://url/geoserver/namespace/wfs?: <wfs:GetFeature xmlns:wfs="
> http://www.opengis.net/wfs" service="WFS" version="1.1.0"> <wfs:Query
> typeName="namespace:layer" /> </wfs:GetFeature>
> >
> > org.fao.geonet.kernel.harvest.harvester.wfsfeatures.Harvester
> Harvester.java (247) #harvestResponse
> > org.fao.geonet.kernel.harvest.harvester.wfsfeatures.Harvester
> Harvester.java (229) #harvest
> > org.fao.geonet.kernel.harvest.harvester.wfsfeatures.WfsFeaturesHarvester
> WfsFeaturesHarvester.java (151) #doHarvest
> >
> org.fao.geonet.kernel.harvest.harvester.AbstractHarvester$HarvestWithIndexProcessor
> AbstractHarvester.java (649) #process
> > org.fao.geonet.kernel.harvest.harvester.AbstractHarvester
> AbstractHarvester.java (721) #harvest
> > org.fao.geonet.kernel.harvest.harvester.HarvesterJob HarvesterJob.java
> (57) #execute
> > org.quartz.core.JobRunShell JobRunShell.java (213) #run
> > org.quartz.simpl.SimpleThreadPool$WorkerThread SimpleThreadPool.java
> (557) #run
>
> if i use wget to check the request with the getfeature statement in a
> file, a response is generated:
>
> > wget --http-user=me --http-passwd=mypass --post-file=wfs_request.xml -O
> output.xml --header="Content-Type: text/xml"
> https://url/geoserver/namespace/wfs?
>
>
> So where and what am i doing wrong?
>
> Thank you in advance
>
>
> _______________________________________________
> GeoNetwork-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-users
> GeoNetwork OpenSource is maintained at
> http://sourceforge.net/projects/geonetwork
>

_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: Harvesting Geoerver WFS, bad-xml-response

useher
Thank you!
I am trying to get metadata
for each feature in a WFS. We have some tracking data from vessels in
a layer or a layer with project-areas for which i want to create a
metadata-record for each feature.
So i need to dive a little deeper.

Best regards
Uwe

PS: ust for ininformation: This is the fourth attempt sending a
message to the list. The former three ended up in an automatic mail
response from the IT-Helpdesk for the university of Queensland.
Changing my mailaddress in the list or the client did not help, this
here is written in the google webmailer, like the first attempt. Maybe
this info is helpful for someone ;)

Am Fr., 14. Dez. 2018 um 08:05 Uhr schrieb Francois Prunayre
<[hidden email]>:

>
> Hi, what are you trying to do - create metadata records for each feature types or create directory based on features ?
> If it is feature type, then you have to use the OGC service harvester and choose WFS for protocol. That harvester support WMS/WCS/WFS/WPS. The other one about WFSFeature is using Stylesheet to create fragments and may require some advanced config (and I don't really know how to help on this).
>
> HTH.
>
> Francois
>
>
> Le ven. 14 déc. 2018 à 07:34, Uwe Seher <[hidden email]> a écrit :
>>
>> Hello all!
>>
>> i am trying to harvest metadata from a geoserver(2.11.x) wfs with
>> geonetwork(3.4.0) using the following GetFeature-Request:
>>
>> > <wfs:GetFeature xmlns:wfs="http://www.opengis.net/wfs" service="WFS" version="1.1.0">
>> >   <wfs:Query typeName="namespace:layer" />
>> > </wfs:GetFeature>
>>
>>
>> The harvester drops the following error message:
>>
>> > bad-xml-response
>> >
>> >  an hour ago
>> >
>> > No response or problem getting response from https://url/geoserver/namespace/wfs?: <wfs:GetFeature xmlns:wfs="http://www.opengis.net/wfs" service="WFS" version="1.1.0"> <wfs:Query typeName="namespace:layer" /> </wfs:GetFeature>
>> >
>> > org.fao.geonet.kernel.harvest.harvester.wfsfeatures.Harvester Harvester.java (247) #harvestResponse
>> > org.fao.geonet.kernel.harvest.harvester.wfsfeatures.Harvester Harvester.java (229) #harvest
>> > org.fao.geonet.kernel.harvest.harvester.wfsfeatures.WfsFeaturesHarvester WfsFeaturesHarvester.java (151) #doHarvest
>> > org.fao.geonet.kernel.harvest.harvester.AbstractHarvester$HarvestWithIndexProcessor AbstractHarvester.java (649) #process
>> > org.fao.geonet.kernel.harvest.harvester.AbstractHarvester AbstractHarvester.java (721) #harvest
>> > org.fao.geonet.kernel.harvest.harvester.HarvesterJob HarvesterJob.java (57) #execute
>> > org.quartz.core.JobRunShell JobRunShell.java (213) #run
>> > org.quartz.simpl.SimpleThreadPool$WorkerThread SimpleThreadPool.java (557) #run
>>
>> if i use wget to check the request with the getfeature statement in a
>> file, a response is generated:
>>
>> > wget --http-user=me --http-passwd=mypass --post-file=wfs_request.xml -O output.xml --header="Content-Type: text/xml" https://url/geoserver/namespace/wfs?
>>
>>
>> So where and what am i doing wrong?
>>
>> Thank you in advance
>>
>>
>> _______________________________________________
>> GeoNetwork-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/geonetwork-users
>> GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork


_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: Harvesting Geoerver WFS, bad-xml-response

Francois Prunayre
I suppose you already had a look to
https://geonetwork-opensource.org/manuals/trunk/en/user-guide/harvesting/harvesting-wfs-features.html,
and you'll have to create a conversion for your feature into a complete
metadata record. Example provided only create Extent, Contact or keywords I
think.

Francois



Le ven. 14 déc. 2018 à 08:17, Uwe Seher <[hidden email]> a écrit :

> Thank you!
> I am trying to get metadata
> for each feature in a WFS. We have some tracking data from vessels in
> a layer or a layer with project-areas for which i want to create a
> metadata-record for each feature.
> So i need to dive a little deeper.
>
> Best regards
> Uwe
>
> PS: ust for ininformation: This is the fourth attempt sending a
> message to the list. The former three ended up in an automatic mail
> response from the IT-Helpdesk for the university of Queensland.
> Changing my mailaddress in the list or the client did not help, this
> here is written in the google webmailer, like the first attempt. Maybe
> this info is helpful for someone ;)
>
> Am Fr., 14. Dez. 2018 um 08:05 Uhr schrieb Francois Prunayre
> <[hidden email]>:
> >
> > Hi, what are you trying to do - create metadata records for each feature
> types or create directory based on features ?
> > If it is feature type, then you have to use the OGC service harvester
> and choose WFS for protocol. That harvester support WMS/WCS/WFS/WPS. The
> other one about WFSFeature is using Stylesheet to create fragments and may
> require some advanced config (and I don't really know how to help on this).
> >
> > HTH.
> >
> > Francois
> >
> >
> > Le ven. 14 déc. 2018 à 07:34, Uwe Seher <[hidden email]> a écrit :
> >>
> >> Hello all!
> >>
> >> i am trying to harvest metadata from a geoserver(2.11.x) wfs with
> >> geonetwork(3.4.0) using the following GetFeature-Request:
> >>
> >> > <wfs:GetFeature xmlns:wfs="http://www.opengis.net/wfs" service="WFS"
> version="1.1.0">
> >> >   <wfs:Query typeName="namespace:layer" />
> >> > </wfs:GetFeature>
> >>
> >>
> >> The harvester drops the following error message:
> >>
> >> > bad-xml-response
> >> >
> >> >  an hour ago
> >> >
> >> > No response or problem getting response from
> https://url/geoserver/namespace/wfs?: <wfs:GetFeature xmlns:wfs="
> http://www.opengis.net/wfs" service="WFS" version="1.1.0"> <wfs:Query
> typeName="namespace:layer" /> </wfs:GetFeature>
> >> >
> >> > org.fao.geonet.kernel.harvest.harvester.wfsfeatures.Harvester
> Harvester.java (247) #harvestResponse
> >> > org.fao.geonet.kernel.harvest.harvester.wfsfeatures.Harvester
> Harvester.java (229) #harvest
> >> >
> org.fao.geonet.kernel.harvest.harvester.wfsfeatures.WfsFeaturesHarvester
> WfsFeaturesHarvester.java (151) #doHarvest
> >> >
> org.fao.geonet.kernel.harvest.harvester.AbstractHarvester$HarvestWithIndexProcessor
> AbstractHarvester.java (649) #process
> >> > org.fao.geonet.kernel.harvest.harvester.AbstractHarvester
> AbstractHarvester.java (721) #harvest
> >> > org.fao.geonet.kernel.harvest.harvester.HarvesterJob
> HarvesterJob.java (57) #execute
> >> > org.quartz.core.JobRunShell JobRunShell.java (213) #run
> >> > org.quartz.simpl.SimpleThreadPool$WorkerThread SimpleThreadPool.java
> (557) #run
> >>
> >> if i use wget to check the request with the getfeature statement in a
> >> file, a response is generated:
> >>
> >> > wget --http-user=me --http-passwd=mypass --post-file=wfs_request.xml
> -O output.xml --header="Content-Type: text/xml"
> https://url/geoserver/namespace/wfs?
> >>
> >>
> >> So where and what am i doing wrong?
> >>
> >> Thank you in advance
> >>
> >>
> >> _______________________________________________
> >> GeoNetwork-users mailing list
> >> [hidden email]
> >> https://lists.sourceforge.net/lists/listinfo/geonetwork-users
> >> GeoNetwork OpenSource is maintained at
> http://sourceforge.net/projects/geonetwork
>

_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork