Gn3.10.0 installation problem

classic Classic list List threaded Threaded
6 messages Options
tac
Reply | Threaded
Open this post in threaded view
|

Gn3.10.0 installation problem

tac
I am doing a clean install of GN3.10.0 - empty PostGIS database, empty
external data folder.  Redhat Linux 6, Java 8, Jetty 9.4. GeoNetwork
appears to load fine, mefs load without error, metadata displays fine. 
I checked and the PostGIS database is nicely populated, and the provided
data resources are in the external folder in the correct spots. 
However, subsequently I cannot access the resources for display and
download, nor do the thumbnails display.  So - there appears to be a
problem accessing the external folder.  No hints in the log file.  Any
suggestions?



_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: Gn3.10.0 installation problem

Francois Prunayre
Hi Terry, even with the default samples ?
We have some issues related to MEF in 3.10.0 but it is more related to
download as MEF or harvesting 3.10.0 with GeoNetwork protocol. Import as
MEF should work fine.
If you add a thumbnail, the thumbnail can be found in the datadirectory ?
Any exception when you try to load the thumbnail using the API URL for
example ?

Francois

Le mer. 12 févr. 2020 à 07:14, Terry <[hidden email]> a écrit :

> I am doing a clean install of GN3.10.0 - empty PostGIS database, empty
> external data folder.  Redhat Linux 6, Java 8, Jetty 9.4. GeoNetwork
> appears to load fine, mefs load without error, metadata displays fine.
> I checked and the PostGIS database is nicely populated, and the provided
> data resources are in the external folder in the correct spots.
> However, subsequently I cannot access the resources for display and
> download, nor do the thumbnails display.  So - there appears to be a
> problem accessing the external folder.  No hints in the log file.  Any
> suggestions?
>
>
>
> _______________________________________________
> GeoNetwork-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-users
> GeoNetwork OpenSource is maintained at
> http://sourceforge.net/projects/geonetwork
>

_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
tac
Reply | Threaded
Open this post in threaded view
|

Re: Gn3.10.0 installation problem

tac
Yes - even with the default samples (the ones with thumbnails, like
Africa) .  Links to external thumbnails - I have a few like this - do
display.

And yes, the resources are present in the folder structure.  If I add a
thumbnail, it is accepted but I cannot see it.

I tried (this is a wonderful feature) :

curl -X GET
"http://soggy.zoology.ubc.ca:8080/geonetwork/srv/api/0.1/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments?sort=name&approved=true&filter=*.*"
-H  "accept: application/json" -H  "X-XSRF-TOKEN:
0d0a0f35-c45f-4aca-a860-84b548a40cca"

with response:

[{"url":"http://localhost:8080/geonetwork/srv/api/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.pdf","size":148906,"lastModification":1532203210430,"filename":"58531064-0207-4e4a-b3c1-cc2a91aad05b.pdf","id":"58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.pdf","visibility":"PRIVATE"},{"url":"http://localhost:8080/geonetwork/srv/api/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.png","size":162851,"lastModification":1532203210403,"filename":"58531064-0207-4e4a-b3c1-cc2a91aad05b.png","id":"58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.png","visibility":"PUBLIC"},{"url":"http://localhost:8080/geonetwork/srv/api/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.xlsx","size":275986,"lastModification":1532203210418,"filename":"58531064-0207-4e4a-b3c1-cc2a91aad05b.xlsx","id":"58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.xlsx","visibility":"PRIVATE"

I cannot access these three items normally.  With the recent mef upload,
I had changed the link "http://soggy.zoology.ubc.ca:8080" to
http://localhost:8080".  I see the curl uses the more specific format. 
I could reload the mefs with soggy explicitly, if this is an important
difference.

On 2020-02-12 12:07 a.m., Francois Prunayre wrote:

> Hi Terry, even with the default samples ?
> We have some issues related to MEF in 3.10.0 but it is more related to
> download as MEF or harvesting 3.10.0 with GeoNetwork protocol. Import
> as MEF should work fine.
> If you add a thumbnail, the thumbnail can be found in the datadirectory ?
> Any exception when you try to load the thumbnail using the API URL for
> example ?
>
> Francois
>
> Le mer. 12 févr. 2020 à 07:14, Terry <[hidden email]
> <mailto:[hidden email]>> a écrit :
>
>     I am doing a clean install of GN3.10.0 - empty PostGIS database,
>     empty
>     external data folder.  Redhat Linux 6, Java 8, Jetty 9.4. GeoNetwork
>     appears to load fine, mefs load without error, metadata displays
>     fine.
>     I checked and the PostGIS database is nicely populated, and the
>     provided
>     data resources are in the external folder in the correct spots.
>     However, subsequently I cannot access the resources for display and
>     download, nor do the thumbnails display.  So - there appears to be a
>     problem accessing the external folder.  No hints in the log file. 
>     Any
>     suggestions?
>
>
>
>     _______________________________________________
>     GeoNetwork-users mailing list
>     [hidden email]
>     <mailto:[hidden email]>
>     https://lists.sourceforge.net/lists/listinfo/geonetwork-users
>     GeoNetwork OpenSource is maintained at
>     http://sourceforge.net/projects/geonetwork
>


_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
tac
Reply | Threaded
Open this post in threaded view
|

Re: Gn3.10.0 installation problem

tac
I misspoke a bit.  If I use "Add resources" to add a thumbnail, the app
complains but says "add anyway?" which I do, then it adds and the
thumbnail is visible.

On 2020-02-12 9:23 a.m., terry wrote:

> -------- Forwarded Message --------
> Subject: Re: [GeoNetwork-users] Gn3.10.0 installation problem
> Date: Wed, 12 Feb 2020 09:22:47 -0800
> From: terry <[hidden email]>
> To: Francois Prunayre <[hidden email]>,
> [hidden email]
>
>
>
> Yes - even with the default samples (the ones with thumbnails, like
> Africa) .  Links to external thumbnails - I have a few like this - do
> display.
>
> And yes, the resources are present in the folder structure.  If I add
> a thumbnail, it is accepted but I cannot see it.
>
> I tried (this is a wonderful feature) :
>
> curl -X GET
> "http://soggy.zoology.ubc.ca:8080/geonetwork/srv/api/0.1/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments?sort=name&approved=true&filter=*.*"
> -H  "accept: application/json" -H  "X-XSRF-TOKEN:
> 0d0a0f35-c45f-4aca-a860-84b548a40cca"
>
> with response:
> [{"url":"http://localhost:8080/geonetwork/srv/api/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.pdf","size":148906,"lastModification":1532203210430,"filename":"58531064-0207-4e4a-b3c1-cc2a91aad05b.pdf","id":"58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.pdf","visibility":"PRIVATE"},{"url":"http://localhost:8080/geonetwork/srv/api/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.png","size":162851,"lastModification":1532203210403,"filename":"58531064-0207-4e4a-b3c1-cc2a91aad05b.png","id":"58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.png","visibility":"PUBLIC"},{"url":"http://localhost:8080/geonetwork/srv/api/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.xlsx","size":275986,"lastModification":1532203210418,"filename":"58531064-0207-4e4a-b3c1-cc2a91aad05b.xlsx","id":"58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.xlsx","visibility":"PRIVATE"
> I cannot access these three items normally.  With the recent mef
> upload, I had changed the link "http://soggy.zoology.ubc.ca:8080" to
> http://localhost:8080". I see the curl uses the more specific format. 
> I could reload the mefs with soggy explicitly, if this is an important
> difference.
>
> On 2020-02-12 12:07 a.m., Francois Prunayre wrote:
>> Hi Terry, even with the default samples ?
>> We have some issues related to MEF in 3.10.0 but it is more related
>> to download as MEF or harvesting 3.10.0 with GeoNetwork protocol.
>> Import as MEF should work fine.
>> If you add a thumbnail, the thumbnail can be found in the datadirectory ?
>> Any exception when you try to load the thumbnail using the API URL
>> for example ?
>>
>> Francois
>>
>> Le mer. 12 févr. 2020 à 07:14, Terry <[hidden email]
>> <mailto:[hidden email]>> a écrit :
>>
>>     I am doing a clean install of GN3.10.0 - empty PostGIS database,
>>     empty
>>     external data folder.  Redhat Linux 6, Java 8, Jetty 9.4. GeoNetwork
>>     appears to load fine, mefs load without error, metadata displays
>>     fine.
>>     I checked and the PostGIS database is nicely populated, and the
>>     provided
>>     data resources are in the external folder in the correct spots.
>>     However, subsequently I cannot access the resources for display and
>>     download, nor do the thumbnails display.  So - there appears to be a
>>     problem accessing the external folder.  No hints in the log
>>     file.  Any
>>     suggestions?
>>
>>
>>
>>     _______________________________________________
>>     GeoNetwork-users mailing list
>>     [hidden email]
>>     <mailto:[hidden email]>
>>     https://lists.sourceforge.net/lists/listinfo/geonetwork-users
>>     GeoNetwork OpenSource is maintained at
>>     http://sourceforge.net/projects/geonetwork
>>
>


_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: Gn3.10.0 installation problem

Francois Prunayre
So you've to configure host parameter in the admin > settings first.
See
https://geonetwork-opensource.org/manuals/trunk/en/administrator-guide/configuring-the-catalog/system-configuration.html#catalog-server
Francois

Le mer. 12 févr. 2020 à 18:46, Terry <[hidden email]> a écrit :

> I misspoke a bit.  If I use "Add resources" to add a thumbnail, the app
> complains but says "add anyway?" which I do, then it adds and the thumbnail
> is visible.
>
> On 2020-02-12 9:23 a.m., terry wrote:
>
> -------- Forwarded Message --------
> Subject: Re: [GeoNetwork-users] Gn3.10.0 installation problem
> Date: Wed, 12 Feb 2020 09:22:47 -0800
> From: terry <[hidden email]> <[hidden email]>
> To: Francois Prunayre <[hidden email]> <[hidden email]>,
> [hidden email]
>
> Yes - even with the default samples (the ones with thumbnails, like
> Africa) .  Links to external thumbnails - I have a few like this - do
> display.
>
> And yes, the resources are present in the folder structure.  If I add a
> thumbnail, it is accepted but I cannot see it.
>
> I tried (this is a wonderful feature) :
>
> curl -X GET
> "http://soggy.zoology.ubc.ca:8080/geonetwork/srv/api/0.1/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments?sort=name&approved=true&filter=*.*"
> <http://soggy.zoology.ubc.ca:8080/geonetwork/srv/api/0.1/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments?sort=name&approved=true&filter=*.*>
> -H  "accept: application/json" -H  "X-XSRF-TOKEN:
> 0d0a0f35-c45f-4aca-a860-84b548a40cca"
>
> with response:
>
> [
>   {
>     "url": "http://localhost:8080/geonetwork/srv/api/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.pdf" <http://localhost:8080/geonetwork/srv/api/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.pdf>,
>     "size": 148906,
>     "lastModification": 1532203210430,
>     "filename": "58531064-0207-4e4a-b3c1-cc2a91aad05b.pdf",
>     "id": "58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.pdf",
>     "visibility": "PRIVATE"
>   },
>   {
>     "url": "http://localhost:8080/geonetwork/srv/api/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.png" <http://localhost:8080/geonetwork/srv/api/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.png>,
>     "size": 162851,
>     "lastModification": 1532203210403,
>     "filename": "58531064-0207-4e4a-b3c1-cc2a91aad05b.png",
>     "id": "58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.png",
>     "visibility": "PUBLIC"
>   },
>   {
>     "url": "http://localhost:8080/geonetwork/srv/api/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.xlsx" <http://localhost:8080/geonetwork/srv/api/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.xlsx>,
>     "size": 275986,
>     "lastModification": 1532203210418,
>     "filename": "58531064-0207-4e4a-b3c1-cc2a91aad05b.xlsx",
>     "id": "58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.xlsx",
>     "visibility": "PRIVATE"
>
> I cannot access these three items normally.  With the recent mef upload, I
> had changed the link "http://soggy.zoology.ubc.ca:8080"
> <http://soggy.zoology.ubc.ca:8080> to http://localhost:8080".  I see the
> curl uses the more specific format.  I could reload the mefs with soggy
> explicitly, if this is an important difference.
>
> On 2020-02-12 12:07 a.m., Francois Prunayre wrote:
>
> Hi Terry, even with the default samples ?
> We have some issues related to MEF in 3.10.0 but it is more related to
> download as MEF or harvesting 3.10.0 with GeoNetwork protocol. Import as
> MEF should work fine.
> If you add a thumbnail, the thumbnail can be found in the datadirectory ?
> Any exception when you try to load the thumbnail using the API URL for
> example ?
>
> Francois
>
> Le mer. 12 févr. 2020 à 07:14, Terry <[hidden email]> a écrit :
>
>> I am doing a clean install of GN3.10.0 - empty PostGIS database, empty
>> external data folder.  Redhat Linux 6, Java 8, Jetty 9.4. GeoNetwork
>> appears to load fine, mefs load without error, metadata displays fine.
>> I checked and the PostGIS database is nicely populated, and the provided
>> data resources are in the external folder in the correct spots.
>> However, subsequently I cannot access the resources for display and
>> download, nor do the thumbnails display.  So - there appears to be a
>> problem accessing the external folder.  No hints in the log file.  Any
>> suggestions?
>>
>>
>>
>> _______________________________________________
>> GeoNetwork-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/geonetwork-users
>> GeoNetwork OpenSource is maintained at
>> http://sourceforge.net/projects/geonetwork
>>
>
>
>

_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
tac
Reply | Threaded
Open this post in threaded view
|

Re: Gn3.10.0 installation problem

tac
That solved the problem.  Thank you very much.  I need to work on my
reading comprehension skills ;->

On 2020-02-12 11:30 p.m., Francois Prunayre wrote:

> So you've to configure host parameter in the admin > settings first.
> See
> https://geonetwork-opensource.org/manuals/trunk/en/administrator-guide/configuring-the-catalog/system-configuration.html#catalog-server
> Francois
>
> Le mer. 12 févr. 2020 à 18:46, Terry <[hidden email]
> <mailto:[hidden email]>> a écrit :
>
>     I misspoke a bit.  If I use "Add resources" to add a thumbnail,
>     the app complains but says "add anyway?" which I do, then it adds
>     and the thumbnail is visible.
>
>     On 2020-02-12 9:23 a.m., terry wrote:
>>     -------- Forwarded Message --------
>>     Subject: Re: [GeoNetwork-users] Gn3.10.0 installation problem
>>     Date: Wed, 12 Feb 2020 09:22:47 -0800
>>     From: terry <[hidden email]> <mailto:[hidden email]>
>>     To: Francois Prunayre <[hidden email]>
>>     <mailto:[hidden email]>,
>>     [hidden email]
>>     <mailto:[hidden email]>
>>
>>
>>
>>     Yes - even with the default samples (the ones with thumbnails,
>>     like Africa) .  Links to external thumbnails - I have a few like
>>     this - do display.
>>
>>     And yes, the resources are present in the folder structure.  If I
>>     add a thumbnail, it is accepted but I cannot see it.
>>
>>     I tried (this is a wonderful feature) :
>>
>>     curl -X GET
>>     "http://soggy.zoology.ubc.ca:8080/geonetwork/srv/api/0.1/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments?sort=name&approved=true&filter=*.*"
>>     <http://soggy.zoology.ubc.ca:8080/geonetwork/srv/api/0.1/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments?sort=name&approved=true&filter=*.*>
>>     -H  "accept: application/json" -H  "X-XSRF-TOKEN:
>>     0d0a0f35-c45f-4aca-a860-84b548a40cca"
>>
>>     with response:
>>     [{"url":"http://localhost:8080/geonetwork/srv/api/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.pdf"
>>     <http://localhost:8080/geonetwork/srv/api/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.pdf>,"size":148906,"lastModification":1532203210430,"filename":"58531064-0207-4e4a-b3c1-cc2a91aad05b.pdf","id":"58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.pdf","visibility":"PRIVATE"},{"url":"http://localhost:8080/geonetwork/srv/api/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.png"
>>     <http://localhost:8080/geonetwork/srv/api/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.png>,"size":162851,"lastModification":1532203210403,"filename":"58531064-0207-4e4a-b3c1-cc2a91aad05b.png","id":"58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.png","visibility":"PUBLIC"},{"url":"http://localhost:8080/geonetwork/srv/api/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.xlsx"
>>     <http://localhost:8080/geonetwork/srv/api/records/58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.xlsx>,"size":275986,"lastModification":1532203210418,"filename":"58531064-0207-4e4a-b3c1-cc2a91aad05b.xlsx","id":"58531064-0207-4e4a-b3c1-cc2a91aad05b/attachments/58531064-0207-4e4a-b3c1-cc2a91aad05b.xlsx","visibility":"PRIVATE"
>>     I cannot access these three items normally.  With the recent mef
>>     upload, I had changed the link "http://soggy.zoology.ubc.ca:8080"
>>     <http://soggy.zoology.ubc.ca:8080> to http://localhost:8080". I
>>     see the curl uses the more specific format.  I could reload the
>>     mefs with soggy explicitly, if this is an important difference.
>>
>>     On 2020-02-12 12:07 a.m., Francois Prunayre wrote:
>>>     Hi Terry, even with the default samples ?
>>>     We have some issues related to MEF in 3.10.0 but it is more
>>>     related to download as MEF or harvesting 3.10.0 with GeoNetwork
>>>     protocol. Import as MEF should work fine.
>>>     If you add a thumbnail, the thumbnail can be found in the
>>>     datadirectory ?
>>>     Any exception when you try to load the thumbnail using the API
>>>     URL for example ?
>>>
>>>     Francois
>>>
>>>     Le mer. 12 févr. 2020 à 07:14, Terry <[hidden email]
>>>     <mailto:[hidden email]>> a écrit :
>>>
>>>         I am doing a clean install of GN3.10.0 - empty PostGIS
>>>         database, empty
>>>         external data folder.  Redhat Linux 6, Java 8, Jetty 9.4.
>>>         GeoNetwork
>>>         appears to load fine, mefs load without error, metadata
>>>         displays fine.
>>>         I checked and the PostGIS database is nicely populated, and
>>>         the provided
>>>         data resources are in the external folder in the correct spots.
>>>         However, subsequently I cannot access the resources for
>>>         display and
>>>         download, nor do the thumbnails display.  So - there appears
>>>         to be a
>>>         problem accessing the external folder.  No hints in the log
>>>         file.  Any
>>>         suggestions?
>>>
>>>
>>>
>>>         _______________________________________________
>>>         GeoNetwork-users mailing list
>>>         [hidden email]
>>>         <mailto:[hidden email]>
>>>         https://lists.sourceforge.net/lists/listinfo/geonetwork-users
>>>         GeoNetwork OpenSource is maintained at
>>>         http://sourceforge.net/projects/geonetwork
>>>
>>
>


_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork