Getting error message when try to open packagemanagement.php

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Getting error message when try to open packagemanagement.php

ketan7880
Hi I am getting following error when trying to open packagemanagement.php

"PHP Warning:  getdate() [function.getdate]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Australia/Melbourne' for '10.0/no DST' instead in C:\Program Files\OSGeo\MapGuide\Web\www\mapadmin\packagemanagement.php on line 65"

any Idea?

I try to change that to date_default_timezone_set() and getting this error,

"PHP Warning:  date_default_timezone_set() expects exactly 1 parameter, 0 given in C:\Program Files\OSGeo\MapGuide\Web\www\mapadmin\packagemanagement.php on line 65"
Reply | Threaded
Open this post in threaded view
|

Re: Getting error message when try to open packagemanagement.php

zspitzer
this is yet another aspect of PHP which really sucks IMHO

anyway, the error indicates that date_default_timezone_set wants a parameter,
aka the timezone to be passed

try this instead
date_default_timezone_set('Australia/Melbourne')

z

On Thu, Jul 19, 2012 at 1:33 PM, ketan7880 <[hidden email]> wrote:

> Hi I am getting following error when trying to open packagemanagement.php
>
> *"PHP Warning:  getdate() [ function.getdate function.getdate ]: It is not
> safe to rely on the system's timezone settings. You are *required* to use
> the date.timezone setting or the date_default_timezone_set() function. In
> case you used any of those methods and you are still getting this warning,
> you most likely misspelled the timezone identifier. We selected
> 'Australia/Melbourne' for '10.0/no DST' instead in C:\Program
> Files\OSGeo\MapGuide\Web\www\mapadmin\packagemanagement.php on line 65"*
>
> any Idea?
>
> I try to change that to date_default_timezone_set() and getting this error,
>
> *"PHP Warning:  date_default_timezone_set() expects exactly 1 parameter, 0
> given in C:\Program
> Files\OSGeo\MapGuide\Web\www\mapadmin\packagemanagement.php on line 65"*
>
> --
> View this message in context: http://osgeo-org.1560.n6.nabble.com/Getting-error-message-when-try-to-open-packagemanagement-php-tp4989235.html
> Sent from the MapGuide Users mailing list archive at Nabble.com.
> _______________________________________________
> mapguide-users mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/mapguide-users



--
Zac Spitzer
Solution Architect / Director
Ennoble Consultancy Australia
http://www.ennoble.com.au
http://zacster.blogspot.com
+61 405 847 168
_______________________________________________
mapguide-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapguide-users
Reply | Threaded
Open this post in threaded view
|

Re: Getting error message when try to open packagemanagement.php

ketan7880
In reply to this post by ketan7880
thanks mate.

that's workout perfectly.