GetFeatureInfo on an WFS-Client-Layer

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

GetFeatureInfo on an WFS-Client-Layer

Jörg Thomsen
Hi,

I am confused, does GetFeatureInfo on an WFS-Client-Layer work?
The Capablites say the layer ist queryable, but the request-answer ist
'no object fond'.

Jörg


--
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Aufwind durch Wissen!

Qualifizierte Open Source Schulungen bei der
http://www.foss-akademie.de/
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~


_________________________________________________

MapMedia
Kartographie und raumbezogene Informationssysteme

Gillweg 3, 14193 Berlin
fon: +49 30 89 06 82-70
fax: +49 30 89 09 53-21
mail: [hidden email]
net:  www.mapmedia.de
_________________________________________________


Geschäftsführer: G. v. Tschirnhaus, J. Thomsen, P. Stamm
Registergericht, Berlin - Amtsgericht Charlottenburg,
HRB 89625, Umsatzsteuer-Identnummer: DE 813794062
_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

RE GetFeatureInfo on an WFS-Client-Layer

Steve.Toutant
GetFeatureInfo is a WMS request, not WFS.
More details would help, to help..



Jörg Thomsen <[hidden email]>@lists.osgeo.org
Envoyé par : [hidden email]

2015-06-01 11:20

Veuillez répondre à
[hidden email]

A
"[hidden email]" <[hidden email]>
cc
Objet
[mapserver-users] GetFeatureInfo on an WFS-Client-Layer







Hi,

I am confused, does GetFeatureInfo on an WFS-Client-Layer work?
The Capablites say the layer ist queryable, but the request-answer ist
'no object fond'.

Jörg


--
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Aufwind durch Wissen!

Qualifizierte Open Source Schulungen bei der
http://www.foss-akademie.de/
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~


_________________________________________________

MapMedia
Kartographie und raumbezogene Informationssysteme

Gillweg 3, 14193 Berlin
fon: +49 30 89 06 82-70
fax: +49 30 89 09 53-21
mail: [hidden email]
net:  
www.mapmedia.de
_________________________________________________


Geschäftsführer: G. v. Tschirnhaus, J. Thomsen, P. Stamm
Registergericht, Berlin - Amtsgericht Charlottenburg,
HRB 89625, Umsatzsteuer-Identnummer: DE 813794062
_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users



_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: RE GetFeatureInfo on an WFS-Client-Layer

Jörg Thomsen
Hello  Steve,

Am 02.06.2015 um 14:08 schrieb [hidden email]:
> GetFeatureInfo is a WMS request, not WFS.
> More details would help, to help..

>> I am confused, does GetFeatureInfo on an WFS-Client-Layer work?
>> The Capablites say the layer ist queryable, but the request-answer ist
>> 'no object fond'.

you are right. But my problem is a WFS-*client* Layer: My datasource is
a WFS and I want to provide a WMS. GetMap works on that wms-Layer, but
not GetFeatureInfo. GetFeatureInfo is enabled, but the answer is always
'no object found'.

I would like to know if this generally should work, because I think
mapserver only requests the gml temporarily to render the map and then
there is no geodata for answering a later featureinfo-request.

I tested with 6.4

Jörg
_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: RE GetFeatureInfo on an WFS-Client-Layer

Steve.Toutant
I'm confused , do you mean that you have a WFS layer that you want to publish as a WMS?
Could you send the layer definition of your mapfile?
Also have a look at TEMPLATE and DUMP in the layer def




Jörg Thomsen <[hidden email]>@lists.osgeo.org
Envoyé par : [hidden email]

2015-06-02 08:51

Veuillez répondre à
[hidden email]

A
"[hidden email]" <[hidden email]>
cc
Objet
Re: [mapserver-users] RE  GetFeatureInfo on an WFS-Client-Layer







Hello  Steve,

Am 02.06.2015 um 14:08 schrieb [hidden email]:
> GetFeatureInfo is a WMS request, not WFS.
> More details would help, to help..

>> I am confused, does GetFeatureInfo on an WFS-Client-Layer work?
>> The Capablites say the layer ist queryable, but the request-answer ist
>> 'no object fond'.

you are right. But my problem is a WFS-*client* Layer: My datasource is
a WFS and I want to provide a WMS. GetMap works on that wms-Layer, but
not GetFeatureInfo. GetFeatureInfo is enabled, but the answer is always
'no object found'.

I would like to know if this generally should work, because I think
mapserver only requests the gml temporarily to render the map and then
there is no geodata for answering a later featureinfo-request.

I tested with 6.4

Jörg
_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users




_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: RE GetFeatureInfo on an WFS-Client-Layer

Jörg Thomsen


Am 02.06.2015 um 14:59 schrieb [hidden email]:
> I'm confused , do you mean that you have a WFS layer that you want to
> publish as a WMS?
> Could you send the layer definition of your mapfile?
> Also have a look at TEMPLATE and DUMP in the layer def

this is my mapfile:
http://tib.osmct.de/berlin_boris_wfs.map

it has a template and dump is deprecated as I know.

Jörg

> *Jörg Thomsen <[hidden email]>@lists.osgeo.org*
> Envoyé par : [hidden email]
>
> 2015-06-02 08:51
> Veuillez répondre à
> [hidden email]
>
>
>
> A
> "[hidden email]" <[hidden email]>
> cc
>
> Objet
> Re: [mapserver-users] RE  GetFeatureInfo on an WFS-Client-Layer
>
>
>
>
>
>
>
>
>
>
> Hello  Steve,
>
> Am 02.06.2015 um 14:08 schrieb [hidden email]:
>> GetFeatureInfo is a WMS request, not WFS.
>> More details would help, to help..
>
>>> I am confused, does GetFeatureInfo on an WFS-Client-Layer work?
>>> The Capablites say the layer ist queryable, but the request-answer ist
>>> 'no object fond'.
>
> you are right. But my problem is a WFS-*client* Layer: My datasource is
> a WFS and I want to provide a WMS. GetMap works on that wms-Layer, but
> not GetFeatureInfo. GetFeatureInfo is enabled, but the answer is always
> 'no object found'.
>
> I would like to know if this generally should work, because I think
> mapserver only requests the gml temporarily to render the map and then
> there is no geodata for answering a later featureinfo-request.
>
> I tested with 6.4
>
> Jörg
> _______________________________________________
> mapserver-users mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/mapserver-users
>
>
>

_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: RE GetFeatureInfo on an WFS-Client-Layer

Pasquale Di Donato-2
Hi Jörg,

I'm not really an expert but your GetFeature request returns:

<fis:GEMEINDE>......</fis:GEMEINDE>
<fis:BEZIRK>.......</fis:BEZIRK>
<fis:BRW>......</fis:BRW>

Maybe your gml_include should be something like:

'gml_include_items' 'fis:GEMEINDE, fis:BEZIRK, fis:BRW'



On Tue, Jun 2, 2015 at 3:27 PM, Jörg Thomsen <[hidden email]> wrote:


Am <a href="tel:02.06.2015" value="+3902062015">02.06.2015 um 14:59 schrieb [hidden email]:
> I'm confused , do you mean that you have a WFS layer that you want to
> publish as a WMS?
> Could you send the layer definition of your mapfile?
> Also have a look at TEMPLATE and DUMP in the layer def

this is my mapfile:
http://tib.osmct.de/berlin_boris_wfs.map

it has a template and dump is deprecated as I know.

Jörg

> *Jörg Thomsen <[hidden email]>@lists.osgeo.org*
> Envoyé par : [hidden email]
>
> 2015-06-02 08:51
> Veuillez répondre à
> [hidden email]
>
>
>
> A
>       "[hidden email]" <[hidden email]>
> cc
>
> Objet
>       Re: [mapserver-users] RE  GetFeatureInfo on an WFS-Client-Layer
>
>
>
>
>
>
>
>
>
>
> Hello  Steve,
>
> Am <a href="tel:02.06.2015" value="+3902062015">02.06.2015 um 14:08 schrieb [hidden email]:
>> GetFeatureInfo is a WMS request, not WFS.
>> More details would help, to help..
>
>>> I am confused, does GetFeatureInfo on an WFS-Client-Layer work?
>>> The Capablites say the layer ist queryable, but the request-answer ist
>>> 'no object fond'.
>
> you are right. But my problem is a WFS-*client* Layer: My datasource is
> a WFS and I want to provide a WMS. GetMap works on that wms-Layer, but
> not GetFeatureInfo. GetFeatureInfo is enabled, but the answer is always
> 'no object found'.
>
> I would like to know if this generally should work, because I think
> mapserver only requests the gml temporarily to render the map and then
> there is no geodata for answering a later featureinfo-request.
>
> I tested with 6.4
>
> Jörg
> _______________________________________________
> mapserver-users mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/mapserver-users
>
>
>

_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users


_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: RE GetFeatureInfo on an WFS-Client-Layer

lars.schylberg
In reply to this post by Jörg Thomsen
I think that You need to declare a

"wms_include_items" "all"

in the LAYER METADATA section.

or
'wms_include_items' 'GEMEINDE, BEZIRK, BRW'


if You just would like to expose a some items.

/Lars S.


-----Originalmeddelande-----

> Från: "Jörg Thomsen" <[hidden email]>
> Till: [hidden email]
> Datum: 2015-06-02 15:27
> Ämne: Re: [mapserver-users] RE GetFeatureInfo on an WFS-Client-Layer
>
> Am 02.06.2015 um 14:59 schrieb [hidden email]:
> > I'm confused , do you mean that you have a WFS layer that you want to
> > publish as a WMS?
> > Could you send the layer definition of your mapfile?
> > Also have a look at TEMPLATE and DUMP in the layer def
>
> this is my mapfile:
> http://tib.osmct.de/berlin_boris_wfs.map
>
> it has a template and dump is deprecated as I know.
>
> Jörg
>
> > *Jörg Thomsen <[hidden email]>@lists.osgeo.org*
> > Envoyé par : [hidden email]
> >
> > 2015-06-02 08:51
> > Veuillez répondre à
> > [hidden email]
> >
> >
> >      
> > A
> >      "[hidden email]" <[hidden email]>
> > cc
> >      
> > Objet
> >      Re: [mapserver-users] RE  GetFeatureInfo on an WFS-Client-Layer
> >
> >
> >      
> >
> >
> >
> >
> >
> >
> >
> > Hello  Steve,
> >
> > Am 02.06.2015 um 14:08 schrieb [hidden email]:
> >> GetFeatureInfo is a WMS request, not WFS.
> >> More details would help, to help..
> >
> >>> I am confused, does GetFeatureInfo on an WFS-Client-Layer work?
> >>> The Capablites say the layer ist queryable, but the request-answer ist
> >>> 'no object fond'.
> >
> > you are right. But my problem is a WFS-*client* Layer: My datasource is
> > a WFS and I want to provide a WMS. GetMap works on that wms-Layer, but
> > not GetFeatureInfo. GetFeatureInfo is enabled, but the answer is always
> > 'no object found'.
> >
> > I would like to know if this generally should work, because I think
> > mapserver only requests the gml temporarily to render the map and then
> > there is no geodata for answering a later featureinfo-request.
> >
> > I tested with 6.4
> >
> > Jörg
> > _______________________________________________
> > mapserver-users mailing list
> > [hidden email]
> > http://lists.osgeo.org/mailman/listinfo/mapserver-users
> >
> >
> >
>
> _______________________________________________
> mapserver-users mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/mapserver-users

--

_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users