GetFeature (WFS1.1.0) returns MultiCurve instead of MultiLineString

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

GetFeature (WFS1.1.0) returns MultiCurve instead of MultiLineString

Dominik Gärner

Hi,

upgrading Geoserver from 2.7.3 to 2.8.0 results in some changes in the response of WFS (1.1.0) GetFeature requests. I have a normal Shape source with geometry type MultiLineString. In Geoserver 2.7.3 (and earlier) GetFeature und DescribeFeature returns MultiLineString to this layer. In the newer version 2.8.0 the GetFeature returns a MultiCurve (even though the layer itself and DescribeFeature is still telling MultiLineString).

 

Is this a bug or is there a reason for it? Can I change this behaviour (my application connected to Geoserver can’t handle MultiCurves)?

 

Best Regards

Dominik

 

-- 

Dominik Gärner
GRINTEC GmbH
Anzengrubergasse 6, 8010 Graz, Austria
Tel: +43(316)383706-0
mailto:[hidden email]
http://www.grintec.com

FN 47845k Handelsgericht Graz


------------------------------------------------------------------------------

_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: GetFeature (WFS1.1.0) returns MultiCurve instead of MultiLineString

Stefano Iacovella
Ciao Dominik,

I am just trying it with 2.7.3
I receive a MultiLineString with GML 3.1 or GML 2, but the same features are returned as MultiCurve if I ask it for GML 3.2
What GML version is your response?

Cheers,

Stefano

---------------------------------------------------
41.95581N 12.52854E


http://www.linkedin.com/in/stefanoiacovella

http://twitter.com/#!/Iacovellas

2015-11-18 9:21 GMT+01:00 Dominik Gärner <[hidden email]>:

Hi,

upgrading Geoserver from 2.7.3 to 2.8.0 results in some changes in the response of WFS (1.1.0) GetFeature requests. I have a normal Shape source with geometry type MultiLineString. In Geoserver 2.7.3 (and earlier) GetFeature und DescribeFeature returns MultiLineString to this layer. In the newer version 2.8.0 the GetFeature returns a MultiCurve (even though the layer itself and DescribeFeature is still telling MultiLineString).

 

Is this a bug or is there a reason for it? Can I change this behaviour (my application connected to Geoserver can’t handle MultiCurves)?

 

Best Regards

Dominik

 

-- 

Dominik Gärner
GRINTEC GmbH
Anzengrubergasse 6, 8010 Graz, Austria
Tel: +43(316)383706-0
mailto:[hidden email]
http://www.grintec.com

FN 47845k Handelsgericht Graz


------------------------------------------------------------------------------

_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users



------------------------------------------------------------------------------

_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users