Geoserver not working in AWS

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Geoserver not working in AWS

GeoServer - User mailing list
I have a geoserver to post GFS data running on AWS  without issues. Problem
is I need to migrate this account to another one as the original one is
being closed (long story).
The original setup has three instances one for the master another for the
slave and another for ssh access.
I did images of each instance and launched them on the new account, I
configured all networks on the same way as in the original. everything seems
to work fine until I do the harvesting I get this:

* Could not resolve host: text
* Closing connection 0
000*   Trying 10.0.0.5...
* TCP_NODELAY set
* Connected to 10.0.0.5 (10.0.0.5) port 8080 (#1)
* Server auth using Basic with user 'user'
> POST
> /geoserver/rest/workspaces/global/coveragestores/gfs_025/external.imagemosaic
> HTTP/1.1
> Host: 10.0.0.5:8080
> Authorization: Basic blablhblhablahblahblahblahlah
> User-Agent: curl/7.53.1
> Accept: */*
> Content-Length: 38
>
* upload completely sent off: 38 out of 38 bytes
< HTTP/1.1 500
< X-Frame-Options: SAMEORIGIN
< Transfer-Encoding: chunked
< Date: Thu, 06 Sep 2018 15:37:11 GMT
< Connection: close
<
Failed to create reader from file:data/global/gfs_025 and hints Hints:
  REPOSITORY       = org.geoserver.catalog.CatalogRepository@dsf8ds98fa
  EXECUTOR_SERVICE =
java.util.concurrent.ThreadPoolExecutor@9879afdsad[Running, pool size = 0,
active threads = 0, queued tasks = 0, completed tasks = 0]
System defaults:
  LENIENT_DATUM_SHIFT              = true
  STYLE_FACTORY                    = StyleFactoryImpl
  GRID_COVERAGE_FACTORY            = GridCoverageFactory
    TILE_ENCODING                  = null
  FORCE_LONGITUDE_FIRST_AXIS_ORDER = true
  FORCE_AXIS_ORDER_HONORING        = http
  COMPARISON_TOLERANCE             = 1.0E-8
  FILTER_FACTORY                   = FilterFactoryImpl
  FEATURE_FACTORY                  =
org.geotools.feature.LenientFeatureFactoryImpl@ds876ydsaf
* Closing connection 1


Any Idea of what may be happening?



--
Sent from: http://osgeo-org.1560.x6.nabble.com/GeoServer-User-f3786390.html

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Geoserver-users mailing list

Please make sure you read the following two resources before posting to this list:
- Earning your support instead of buying it, but Ian Turton: http://www.ianturton.com/talks/foss4g.html#/
- The GeoServer user list posting guidelines: http://geoserver.org/comm/userlist-guidelines.html

If you want to request a feature or an improvement, also see this: https://github.com/geoserver/geoserver/wiki/Successfully-requesting-and-integrating-new-features-and-improvements-in-GeoServer


[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: Geoserver not working in AWS

jnewmoyer
My first guess would some file system access issue to the "gfs_025" dir. Either it can't see it, or doesn't have correct perms. 


Jason Newmoyer
Newmoyer Geospatial Solutions
843.606.0424

On Thu, Sep 6, 2018 at 12:15 PM, j.liria--- via Geoserver-users <[hidden email]> wrote:
I have a geoserver to post GFS data running on AWS  without issues. Problem
is I need to migrate this account to another one as the original one is
being closed (long story).
The original setup has three instances one for the master another for the
slave and another for ssh access.
I did images of each instance and launched them on the new account, I
configured all networks on the same way as in the original. everything seems
to work fine until I do the harvesting I get this:

* Could not resolve host: text
* Closing connection 0
000*   Trying 10.0.0.5...
* TCP_NODELAY set
* Connected to 10.0.0.5 (10.0.0.5) port 8080 (#1)
* Server auth using Basic with user 'user'
> POST
> /geoserver/rest/workspaces/global/coveragestores/gfs_025/external.imagemosaic
> HTTP/1.1
> Host: 10.0.0.5:8080
> Authorization: Basic blablhblhablahblahblahblahlah
> User-Agent: curl/7.53.1
> Accept: */*
> Content-Length: 38
>
* upload completely sent off: 38 out of 38 bytes
< HTTP/1.1 500
< X-Frame-Options: SAMEORIGIN
< Transfer-Encoding: chunked
< Date: Thu, 06 Sep 2018 15:37:11 GMT
< Connection: close
<
Failed to create reader from file:data/global/gfs_025 and hints Hints:
  REPOSITORY       = org.geoserver.catalog.CatalogRepository@dsf8ds98fa
  EXECUTOR_SERVICE =
java.util.concurrent.ThreadPoolExecutor@9879afdsad[Running, pool size = 0,
active threads = 0, queued tasks = 0, completed tasks = 0]
System defaults:
  LENIENT_DATUM_SHIFT              = true
  STYLE_FACTORY                    = StyleFactoryImpl
  GRID_COVERAGE_FACTORY            = GridCoverageFactory
    TILE_ENCODING                  = null
  FORCE_LONGITUDE_FIRST_AXIS_ORDER = true
  FORCE_AXIS_ORDER_HONORING        = http
  COMPARISON_TOLERANCE             = 1.0E-8
  FILTER_FACTORY                   = FilterFactoryImpl
  FEATURE_FACTORY                  =
org.geotools.feature.LenientFeatureFactoryImpl@ds876ydsaf
* Closing connection 1


Any Idea of what may be happening?



--
Sent from: http://osgeo-org.1560.x6.nabble.com/GeoServer-User-f3786390.html

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Geoserver-users mailing list

Please make sure you read the following two resources before posting to this list:
- Earning your support instead of buying it, but Ian Turton: http://www.ianturton.com/talks/foss4g.html#/
- The GeoServer user list posting guidelines: http://geoserver.org/comm/userlist-guidelines.html

If you want to request a feature or an improvement, also see this: https://github.com/geoserver/geoserver/wiki/Successfully-requesting-and-integrating-new-features-and-improvements-in-GeoServer


[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users



_______________________________________________
Geoserver-users mailing list

Please make sure you read the following two resources before posting to this list:
- Earning your support instead of buying it, but Ian Turton: http://www.ianturton.com/talks/foss4g.html#/
- The GeoServer user list posting guidelines: http://geoserver.org/comm/userlist-guidelines.html

If you want to request a feature or an improvement, also see this: https://github.com/geoserver/geoserver/wiki/Successfully-requesting-and-integrating-new-features-and-improvements-in-GeoServer


[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: Geoserver not working in AWS

GeoServer - User mailing list
So indeed in the end it was just the tomcat/conf/context.xml file that was
pointing to the psql database using the DNS of the old AWS instance, I
changed it and everything worked fine :)
Thanks!



--
Sent from: http://osgeo-org.1560.x6.nabble.com/GeoServer-User-f3786390.html


_______________________________________________
Geoserver-users mailing list

Please make sure you read the following two resources before posting to this list:
- Earning your support instead of buying it, but Ian Turton: http://www.ianturton.com/talks/foss4g.html#/
- The GeoServer user list posting guidelines: http://geoserver.org/comm/userlist-guidelines.html

If you want to request a feature or an improvement, also see this: https://github.com/geoserver/geoserver/wiki/Successfully-requesting-and-integrating-new-features-and-improvements-in-GeoServer


[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users