Geonetwork 3.4.3 metadata ISO19139-3

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Geonetwork 3.4.3 metadata ISO19139-3

BartV
Hi all,
Is there anybody using GEONETWORK 3.4.3 version with the new ISO19139-3 standard?
If so is it working properly or not? If it is working can someone attach a template of a working .xml metadata?

Thanks in advance

Bartolomeo

_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: Geonetwork 3.4.3 metadata ISO19139-3

Francois Prunayre
Hi,

Le mer. 3 avr. 2019 à 15:09, Ventura Bartolomeo <
[hidden email]> a écrit :

> Hi all,
> Is there anybody using GEONETWORK 3.4.3 version with the new ISO19139-3
> standard?

If so is it working properly or not? If it is working can someone attach a
> template of a working .xml metadata?
>

ISO19115-3 is only maintained on latest GeoNetwork version for now. Some
old branches may be working with 3.4 but are not updated anymore. Note also
that
https://github.com/metadata101/iso19115-3
is now replaced by
https://github.com/metadata101/iso19115-3.2018
which contains last version of the schema.

Both schemas are used in production on different places (eg. Ifremer,
Walloon region).

You always have templates in
https://github.com/metadata101/iso19115-3.2018/tree/3.7.x/src/main/plugin/iso19115-3.2018/templates
to start working with.

Cheers.

Francois




> Thanks in advance
>
> Bartolomeo
>
> _______________________________________________
> GeoNetwork-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-users
> GeoNetwork OpenSource is maintained at
> http://sourceforge.net/projects/geonetwork
>

_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: Geonetwork 3.4.3 metadata ISO19139-3

BartV
Hi,
Thanks for your answer. Actually, I started from one of these templates and I solved a series of error I got using GN 3.4.3 to have a fully validate metadata 19115-3.

The only remaining error is this one:

Constraints related to access and use Conditions applying to access and use is missing.

I do not know if it is related to the GN version or not.
To skip this doubt, I will update my geonetwork version to the latest one and I try to see if I will get the same error or not.

For completeness of information, I tried to validate the examples on that webpage and all of them are not validated because of errors on SCHEMA implementation and INSPIRE schema. I will repeat this operation with the latest GN also for those files.

I will let you know.

Cheers,

Bartolomeo




From: Francois Prunayre <[hidden email]>
Sent: Friday, April 12, 2019 08:45
To: Ventura Bartolomeo <[hidden email]>
Cc: [hidden email]
Subject: Re: [GeoNetwork-users] Geonetwork 3.4.3 metadata ISO19139-3

Hi,

Le mer. 3 avr. 2019 à 15:09, Ventura Bartolomeo <[hidden email]<mailto:[hidden email]>> a écrit :
Hi all,
Is there anybody using GEONETWORK 3.4.3 version with the new ISO19139-3 standard?
If so is it working properly or not? If it is working can someone attach a template of a working .xml metadata?

ISO19115-3 is only maintained on latest GeoNetwork version for now. Some old branches may be working with 3.4 but are not updated anymore. Note also that
https://github.com/metadata101/iso19115-3
is now replaced by
https://github.com/metadata101/iso19115-3.2018
which contains last version of the schema.

Both schemas are used in production on different places (eg. Ifremer, Walloon region).

You always have templates in https://github.com/metadata101/iso19115-3.2018/tree/3.7.x/src/main/plugin/iso19115-3.2018/templates to start working with.

Cheers.

Francois



Thanks in advance

Bartolomeo

_______________________________________________
GeoNetwork-users mailing list
[hidden email]<mailto:[hidden email]>
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork

_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: Geonetwork 3.4.3 metadata ISO19139-3

Francois Prunayre
Hi,

Le ven. 12 avr. 2019 à 09:50, Ventura Bartolomeo <
[hidden email]> a écrit :

> Hi,
>
> Thanks for your answer. Actually, I started from one of these templates
> and I solved a series of error I got using GN 3.4.3 to have a fully
> validate metadata 19115-3.
>
>
>
> The only remaining error is this one:
>
> *Constraints related to access and use** Conditions applying to access
> and use is missing.*
>
>
>

Sounds related to that schematron rule
https://github.com/metadata101/iso19115-3.2018/blob/a1e4bb285cd57cc0aa34b98f902db110a0a32b7c/src/main/plugin/iso19115-3.2018/schematron/schematron-rules-inspire.sch#L623

You can try to do some check if the rule is correct or not.

Francois



> I do not know if it is related to the GN version or not.
>
> To skip this doubt, I will update my geonetwork version to the latest one
> and I try to see if I will get the same error or not.
>
>
> For completeness of information, I tried to validate the examples on that
> webpage and all of them are not validated because of errors on SCHEMA
> implementation and INSPIRE schema. I will repeat this operation with the
> latest GN also for those files.
>
>
>
> I will let you know.
>
>
>
> Cheers,
>
>
>
> Bartolomeo
>
>
>
>
>
>
>
>
>
> *From:* Francois Prunayre <[hidden email]>
> *Sent:* Friday, April 12, 2019 08:45
> *To:* Ventura Bartolomeo <[hidden email]>
> *Cc:* [hidden email]
> *Subject:* Re: [GeoNetwork-users] Geonetwork 3.4.3 metadata ISO19139-3
>
>
>
> Hi,
>
>
>
> Le mer. 3 avr. 2019 à 15:09, Ventura Bartolomeo <
> [hidden email]> a écrit :
>
> Hi all,
> Is there anybody using GEONETWORK 3.4.3 version with the new ISO19139-3
> standard?
>
> If so is it working properly or not? If it is working can someone attach a
> template of a working .xml metadata?
>
>
>
> ISO19115-3 is only maintained on latest GeoNetwork version for now. Some
> old branches may be working with 3.4 but are not updated anymore. Note also
> that
>
> https://github.com/metadata101/iso19115-3
>
> is now replaced by
>
> https://github.com/metadata101/iso19115-3.2018
>
> which contains last version of the schema.
>
>
>
> Both schemas are used in production on different places (eg. Ifremer,
> Walloon region).
>
>
>
> You always have templates in
> https://github.com/metadata101/iso19115-3.2018/tree/3.7.x/src/main/plugin/iso19115-3.2018/templates
> to start working with.
>
>
>
> Cheers.
>
>
>
> Francois
>
>
>
>
>
>
>
> Thanks in advance
>
> Bartolomeo
>
> _______________________________________________
> GeoNetwork-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-users
> GeoNetwork OpenSource is maintained at
> http://sourceforge.net/projects/geonetwork
>
>

_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: Geonetwork 3.4.3 metadata ISO19139-3

BartV
In reply to this post by BartV
Hi all,
I'm trying to follow the steps for adding the plugin here
https://github.com/metadata101/iso19115-3.2018

I cloned the ISO 19115-3:2018 schema plugin in the folder:
geonetwork\WEB-INF\data\data\resources\xml\schemas

But I can't perform the step where I should add the new module to the schema/pom.xml

Could you please tell me where I can find this pom.xml file?
I checked all the pom.xml files in the geonetwork folder but none of them contain the <modules> tag.


Could you also please confirm that the next two steps are referring to the following file?

webapps\geonetwork\META-INF\maven\org.geonetwork-opensource\web-app\pom.xml

Thanks,

Bartolomeo


-----Original Message-----
From: Ventura Bartolomeo <[hidden email]>
Sent: Friday, April 12, 2019 09:51
To: Francois Prunayre <[hidden email]>
Cc: [hidden email]
Subject: Re: [GeoNetwork-users] Geonetwork 3.4.3 metadata ISO19139-3

Hi,
Thanks for your answer. Actually, I started from one of these templates and I solved a series of error I got using GN 3.4.3 to have a fully validate metadata 19115-3.

The only remaining error is this one:

Constraints related to access and use Conditions applying to access and use is missing.

I do not know if it is related to the GN version or not.
To skip this doubt, I will update my geonetwork version to the latest one and I try to see if I will get the same error or not.

For completeness of information, I tried to validate the examples on that webpage and all of them are not validated because of errors on SCHEMA implementation and INSPIRE schema. I will repeat this operation with the latest GN also for those files.

I will let you know.

Cheers,

Bartolomeo




From: Francois Prunayre <[hidden email]>
Sent: Friday, April 12, 2019 08:45
To: Ventura Bartolomeo <[hidden email]>
Cc: [hidden email]
Subject: Re: [GeoNetwork-users] Geonetwork 3.4.3 metadata ISO19139-3

Hi,

Le mer. 3 avr. 2019 à 15:09, Ventura Bartolomeo <[hidden email]<mailto:[hidden email]>> a écrit :
Hi all,
Is there anybody using GEONETWORK 3.4.3 version with the new ISO19139-3 standard?
If so is it working properly or not? If it is working can someone attach a template of a working .xml metadata?

ISO19115-3 is only maintained on latest GeoNetwork version for now. Some old branches may be working with 3.4 but are not updated anymore. Note also that
https://github.com/metadata101/iso19115-3
is now replaced by
https://github.com/metadata101/iso19115-3.2018
which contains last version of the schema.

Both schemas are used in production on different places (eg. Ifremer, Walloon region).

You always have templates in https://github.com/metadata101/iso19115-3.2018/tree/3.7.x/src/main/plugin/iso19115-3.2018/templates to start working with.

Cheers.

Francois



Thanks in advance

Bartolomeo

_______________________________________________
GeoNetwork-users mailing list
[hidden email]<mailto:[hidden email]>
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork

_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork

_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: Geonetwork 3.4.3 metadata ISO19139-3

Ndeville
Hi Bartolomeo,

In the core-geonetwork folder (before compiling), there is a small shell script "add-schema.sh" that does everything for you :)

When you are in the core-geonetwork folder,  type in:

./add-schema.sh iso19115-3 https://github.com/metadata101/iso19115-3.2018 3.5.x

and you should be fine.

Cheers,

Nicolas


On 16/04/19 16:11, Ventura Bartolomeo wrote:

Hi all,
I'm trying to follow the steps for adding the plugin here
https://github.com/metadata101/iso19115-3.2018

I cloned the ISO 19115-3:2018 schema plugin in the folder:
geonetwork\WEB-INF\data\data\resources\xml\schemas

But I can't perform the step where I should add the new module to the schema/pom.xml

Could you please tell me where I can find this pom.xml file?
I checked all the pom.xml files in the geonetwork folder but none of them contain the <modules> tag.


Could you also please confirm that the next two steps are referring to the following file?

webapps\geonetwork\META-INF\maven\org.geonetwork-opensource\web-app\pom.xml

Thanks,

Bartolomeo


-----Original Message-----
From: Ventura Bartolomeo <[hidden email]><mailto:[hidden email]>
Sent: Friday, April 12, 2019 09:51
To: Francois Prunayre <[hidden email]><mailto:[hidden email]>
Cc: [hidden email]<mailto:[hidden email]>
Subject: Re: [GeoNetwork-users] Geonetwork 3.4.3 metadata ISO19139-3

Hi,
Thanks for your answer. Actually, I started from one of these templates and I solved a series of error I got using GN 3.4.3 to have a fully validate metadata 19115-3.

The only remaining error is this one:

Constraints related to access and use Conditions applying to access and use is missing.

I do not know if it is related to the GN version or not.
To skip this doubt, I will update my geonetwork version to the latest one and I try to see if I will get the same error or not.

For completeness of information, I tried to validate the examples on that webpage and all of them are not validated because of errors on SCHEMA implementation and INSPIRE schema. I will repeat this operation with the latest GN also for those files.

I will let you know.

Cheers,

Bartolomeo




From: Francois Prunayre <[hidden email]><mailto:[hidden email]>
Sent: Friday, April 12, 2019 08:45
To: Ventura Bartolomeo <[hidden email]><mailto:[hidden email]>
Cc: [hidden email]<mailto:[hidden email]>
Subject: Re: [GeoNetwork-users] Geonetwork 3.4.3 metadata ISO19139-3

Hi,

Le mer. 3 avr. 2019 à 15:09, Ventura Bartolomeo <[hidden email]<mailto:[hidden email]><mailto:[hidden email]><mailto:[hidden email]>> a écrit :
Hi all,
Is there anybody using GEONETWORK 3.4.3 version with the new ISO19139-3 standard?
If so is it working properly or not? If it is working can someone attach a template of a working .xml metadata?

ISO19115-3 is only maintained on latest GeoNetwork version for now. Some old branches may be working with 3.4 but are not updated anymore. Note also that
https://github.com/metadata101/iso19115-3
is now replaced by
https://github.com/metadata101/iso19115-3.2018
which contains last version of the schema.

Both schemas are used in production on different places (eg. Ifremer, Walloon region).

You always have templates in https://github.com/metadata101/iso19115-3.2018/tree/3.7.x/src/main/plugin/iso19115-3.2018/templates to start working with.

Cheers.

Francois



Thanks in advance

Bartolomeo

_______________________________________________
GeoNetwork-users mailing list
[hidden email]<mailto:[hidden email]><mailto:[hidden email]><mailto:[hidden email]>
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork

_______________________________________________
GeoNetwork-users mailing list
[hidden email]<mailto:[hidden email]>
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork

_______________________________________________
GeoNetwork-users mailing list
[hidden email]<mailto:[hidden email]>
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork


--
Nicolas de Ville
Belgian Marine Data Centre (BMDC)
OD-Nature, Royal Belgian Institute of Natural Sciences
02/627.42.79
www.bmdc.be<http://www.bmdc.be>
geonetwork.bmdc.be

_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: Geonetwork 3.4.3 metadata ISO19139-3

Ndeville
In reply to this post by BartV
Hi Bartolomeo,

In the core-geonetwork folder (before compiling), there is a small shell
script "add-schema.sh" that does everything for you :)

When you are in the core-geonetwork folder,  type in:

./add-schema.sh iso19115-3 https://github.com/metadata101/iso19115-3.2018
3.5.x

and you should be fine.

Cheers,

Nicolas



--
Sent from: http://osgeo-org.1560.x6.nabble.com/GeoNetwork-users-f3860293.html


_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: Geonetwork 3.4.3 metadata ISO19139-3

Francois Prunayre
Hi,

Le mar. 16 avr. 2019 à 16:48, Ndeville <[hidden email]> a
écrit :

> Hi Bartolomeo,
>
> In the core-geonetwork folder (before compiling), there is a small shell
> script "add-schema.sh" that does everything for you :)
>
> When you are in the core-geonetwork folder,  type in:
>
> ./add-schema.sh iso19115-3 https://github.com/metadata101/iso19115-3.2018
> 3.5.x
>

Mind that the schema id is iso19115-3.2018 and not iso19115-3. Note also
that this schema which includes 2018 amendment is still under development
and will only be supported on current GeoNetwork master branch (ie. 3.7.x+).

Francois



>
> and you should be fine.
>
> Cheers,
>
> Nicolas
>
>
>
> --
> Sent from:
> http://osgeo-org.1560.x6.nabble.com/GeoNetwork-users-f3860293.html
>
>
> _______________________________________________
> GeoNetwork-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-users
> GeoNetwork OpenSource is maintained at
> http://sourceforge.net/projects/geonetwork
>

_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: Geonetwork 3.4.3 metadata ISO19139-3

BartV
In reply to this post by Ndeville
Hi Nicolas,
Thanks for your reply.

Do you mean I have to clone the entire core-geonetwork repository and then run the script?

Because now I'm using the geonetwork.war file to run geonetwork using tomcat9.
In my case, may not be enough to run the script? Am I right?


Thanks for your support and patience,

Cheer,

Bartolomeo


-----Original Message-----
From: Ndeville <[hidden email]>
Sent: Tuesday, April 16, 2019 16:28
To: [hidden email]
Subject: Re: [GeoNetwork-users] Geonetwork 3.4.3 metadata ISO19139-3

Hi Bartolomeo,

In the core-geonetwork folder (before compiling), there is a small shell script "add-schema.sh" that does everything for you :)

When you are in the core-geonetwork folder,  type in:

./add-schema.sh iso19115-3 https://github.com/metadata101/iso19115-3.2018
3.5.x

and you should be fine.

Cheers,

Nicolas



--
Sent from: http://osgeo-org.1560.x6.nabble.com/GeoNetwork-users-f3860293.html


_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork


_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: Geonetwork 3.4.3 metadata ISO19139-3

BartV
In reply to this post by Francois Prunayre
Hi all,
A short update: using the .2018 schemas I got this error

mvn clean install -DskipTests
[INFO] Scanning for projects...
[ERROR] The build could not read 1 project -> [Help 1]
[ERROR]
[ERROR]   The project org.geonetwork-opensource:schema-iso19115-3.2018:3.5 (/opt/tomcat/webapps/core-geonetwork/schemas/iso19115-3/pom.xml) has 1 error
[ERROR]     Non-resolvable parent POM: Failure to find org.geonetwork-opensource:schemas:pom:3.5 in https://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced and 'parent.relativePath' points at wrong local POM @ line 6, column 10 -> [Help 2]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
[ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/UnresolvableModelException

Maybe it could be useful to know

Cheers,

Bart

-----Original Message-----
From: Francois Prunayre <[hidden email]>
Sent: Tuesday, April 16, 2019 17:34
To: Ndeville <[hidden email]>
Cc: [hidden email]
Subject: Re: [GeoNetwork-users] Geonetwork 3.4.3 metadata ISO19139-3

Hi,

Le mar. 16 avr. 2019 à 16:48, Ndeville <[hidden email]> a écrit :

> Hi Bartolomeo,
>
> In the core-geonetwork folder (before compiling), there is a small
> shell script "add-schema.sh" that does everything for you :)
>
> When you are in the core-geonetwork folder,  type in:
>
> ./add-schema.sh iso19115-3
> https://github.com/metadata101/iso19115-3.2018
> 3.5.x
>

Mind that the schema id is iso19115-3.2018 and not iso19115-3. Note also that this schema which includes 2018 amendment is still under development and will only be supported on current GeoNetwork master branch (ie. 3.7.x+).

Francois



>
> and you should be fine.
>
> Cheers,
>
> Nicolas
>
>
>
> --
> Sent from:
> http://osgeo-org.1560.x6.nabble.com/GeoNetwork-users-f3860293.html
>
>
> _______________________________________________
> GeoNetwork-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-users
> GeoNetwork OpenSource is maintained at
> http://sourceforge.net/projects/geonetwork
>

_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork

_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: Geonetwork 3.4.3 metadata ISO19139-3

BartV
In reply to this post by BartV
Hi all,
I also tried the iso19115-3 schema plugin but it does not work the maven cmd:

mvn clean install -DskipTests
[INFO] Scanning for projects...
Downloading: https://repo.maven.apache.org/maven2/org/geonetwork-opensource/schemas/3.5/schemas-3.5.pom
[ERROR] The build could not read 1 project -> [Help 1]
[ERROR]
[ERROR]   The project org.geonetwork-opensource:schema-iso19115-3:3.5 (/opt/tomcat/webapps/core-geonetwork/schemas/iso19115-3/pom.xml) has 1 error
[ERROR]     Non-resolvable parent POM: Could not find artifact org.geonetwork-opensource:schemas:pom:3.5 in central (https://repo.maven.apache.org/maven2) and 'parent.relativePath' points at wrong local POM @ line 5, column 10 -> [Help 2]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
[ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/UnresolvableModelException

Is The webpage not available any more.?


Thanks

Bart

-----Original Message-----
From: Ventura Bartolomeo
Sent: Wednesday, April 17, 2019 07:41
To: Ndeville <[hidden email]>; [hidden email]
Subject: RE: [GeoNetwork-users] Geonetwork 3.4.3 metadata ISO19139-3

Hi Nicolas,
Thanks for your reply.

Do you mean I have to clone the entire core-geonetwork repository and then run the script?

Because now I'm using the geonetwork.war file to run geonetwork using tomcat9.
In my case, may not be enough to run the script? Am I right?


Thanks for your support and patience,

Cheer,

Bartolomeo


-----Original Message-----
From: Ndeville <[hidden email]>
Sent: Tuesday, April 16, 2019 16:28
To: [hidden email]
Subject: Re: [GeoNetwork-users] Geonetwork 3.4.3 metadata ISO19139-3

Hi Bartolomeo,

In the core-geonetwork folder (before compiling), there is a small shell script "add-schema.sh" that does everything for you :)

When you are in the core-geonetwork folder,  type in:

./add-schema.sh iso19115-3 https://github.com/metadata101/iso19115-3.2018
3.5.x

and you should be fine.

Cheers,

Nicolas



--
Sent from: http://osgeo-org.1560.x6.nabble.com/GeoNetwork-users-f3860293.html


_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork


_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork