[Geomoose-users] experimenting with Geomoose 3

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[Geomoose-users] experimenting with Geomoose 3

Brent Fraser

Hey all,

I'm experimenting with map backgrounds in 3.0. 

Is it possible to use Google maps as a background?

Is it possible to use radio buttons instead of check boxes?   I've tried using
    <group title="Backgrounds" expand="true" multiple="false">
but it doesn't work.

Can I set a background layer on by default (e.g. status="on")?

Thanks!

-- 
Best Regards,
Brent Fraser

_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users
Reply | Threaded
Open this post in threaded view
|

Re: [Geomoose-users] experimenting with Geomoose 3

blammo
Hi Brent,

One way to do it is through the URL.

The layers are now remembered there ( as well as bbox/scale):


Jim has done quite a bit of work with setting default settings for GeoMoose via Apache as well.  We have a default MapFile set up for example that has a set of default layers set to “on”.

I believe the Google basemapping has been a problem to work with recently without a Google Map Key, and it’s been purposely left out of the demo.

bobb


On Oct 26, 2017, at 9:35 AM, Brent Fraser <[hidden email]> wrote:

Hey all,

I'm experimenting with map backgrounds in 3.0. 

Is it possible to use Google maps as a background?

Is it possible to use radio buttons instead of check boxes?   I've tried using
    <group title="Backgrounds" expand="true" multiple="false">
but it doesn't work.

Can I set a background layer on by default (e.g. status="on")?

Thanks!

-- 
Best Regards,
Brent Fraser
_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users



"C makes it easy to shoot yourself in the foot; C++ makes it harder, but when you do, it blows away your whole leg." 
- Bjarne Stroustrup




_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users
Reply | Threaded
Open this post in threaded view
|

Re: [Geomoose-users] experimenting with Geomoose 3

Dan Little-2
1. WRT to Google layers: No, we will not be able to offer Google Maps API Imagery as a background. There are both legal and technical reasons for this.  We've been recommending MapBox imagery to folks as a competitive alternative. 

2. Settings 'status="on"' on a background layer should turn it on.  I believe there's a bug with the  catalog where the catalog based status definitions may not be working right now. Go to the <layer> entry in the <map-source> and set status='on'.

3. We have not implemented the radio button style groups.  They were actually pretty bug prone in the 2.X series and implementing them again hasn't been a high priority. 


On Thu, Oct 26, 2017 at 10:43 AM, Basques, Bob (CI-StPaul) <[hidden email]> wrote:
Hi Brent,

One way to do it is through the URL.

The layers are now remembered there ( as well as bbox/scale):


Jim has done quite a bit of work with setting default settings for GeoMoose via Apache as well.  We have a default MapFile set up for example that has a set of default layers set to “on”.

I believe the Google basemapping has been a problem to work with recently without a Google Map Key, and it’s been purposely left out of the demo.

bobb


On Oct 26, 2017, at 9:35 AM, Brent Fraser <[hidden email]> wrote:

Hey all,

I'm experimenting with map backgrounds in 3.0. 

Is it possible to use Google maps as a background?

Is it possible to use radio buttons instead of check boxes?   I've tried using
    <group title="Backgrounds" expand="true" multiple="false">
but it doesn't work.

Can I set a background layer on by default (e.g. status="on")?

Thanks!

-- 
Best Regards,
Brent Fraser
_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users



"C makes it easy to shoot yourself in the foot; C++ makes it harder, but when you do, it blows away your whole leg." 
- Bjarne Stroustrup




_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users


_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users
Reply | Threaded
Open this post in threaded view
|

Re: [Geomoose-users] experimenting with Geomoose 3

Brent Fraser
In reply to this post by blammo
Hey bobb,
 
  1. Google maps:  not only is it not in the demo, there's no code (that I can find).  We have to use a Key with Bing so I don't think that's a problem.
  2. radio buttons: I may have to hit F12 with debug.html!
  3. Yes I saw the settings in the URL (and the "tracker" refs in the app.js), but I found the answer; it is now set in the map source def, e.g.:
    <map-source name="ags" type="ags">
        <url>https://services.arcgisonline.com/ArcGIS/rest/services/NatGeo_World_Map/MapServer</url>
        <layer name="NatGeo_World_Map" status="on"/>
(sooo many things to document!)
 
 
 

From: "Basques, Bob (CI-StPaul)" <[hidden email]>
Sent: Thursday, October 26, 2017 9:44 AM
To:
Cc: "GeoMOOSE Users List" <[hidden email]>
Subject: Re: [Geomoose-users] experimenting with Geomoose 3
 
Hi Brent,
 
One way to do it is through the URL.
 
The layers are now remembered there ( as well as bbox/scale):
 
 
Jim has done quite a bit of work with setting default settings for GeoMoose via Apache as well.  We have a default MapFile set up for example that has a set of default layers set to “on”.
 
I believe the Google basemapping has been a problem to work with recently without a Google Map Key, and it’s been purposely left out of the demo.
 
bobb
 
 
On Oct 26, 2017, at 9:35 AM, Brent Fraser <[hidden email]> wrote:
 

Hey all,

I'm experimenting with map backgrounds in 3.0. 

Is it possible to use Google maps as a background?

Is it possible to use radio buttons instead of check boxes?   I've tried using
    <group title="Backgrounds" expand="true" multiple="false">
but it doesn't work.

Can I set a background layer on by default (e.g. status="on")?

Thanks!

--
Best Regards,
Brent Fraser
_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users
 

 
"C makes it easy to shoot yourself in the foot; C++ makes it harder, but when you do, it blows away your whole leg." 
- Bjarne Stroustrup
 

_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users

Attachment 1 (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [Geomoose-users] experimenting with Geomoose 3

Dan Little-2
The catalog not working is likely a bug. Or at least worth discussion of map-source vs catalog.

On Thu, Oct 26, 2017 at 11:05 AM, Brent Fraser <[hidden email]> wrote:
Hey bobb,
 
  1. Google maps:  not only is it not in the demo, there's no code (that I can find).  We have to use a Key with Bing so I don't think that's a problem.
  2. radio buttons: I may have to hit F12 with debug.html!
  3. Yes I saw the settings in the URL (and the "tracker" refs in the app.js), but I found the answer; it is now set in the map source def, e.g.:
    <map-source name="ags" type="ags">
        <url>https://services.arcgisonline.com/ArcGIS/rest/services/NatGeo_World_Map/MapServer</url>
        <layer name="NatGeo_World_Map" status="on"/>
(sooo many things to document!)
 
 
 

From: "Basques, Bob (CI-StPaul)" <[hidden email]>
Sent: Thursday, October 26, 2017 9:44 AM
To:
Cc: "GeoMOOSE Users List" <[hidden email]>
Subject: Re: [Geomoose-users] experimenting with Geomoose 3
 
Hi Brent,
 
One way to do it is through the URL.
 
The layers are now remembered there ( as well as bbox/scale):
 
 
Jim has done quite a bit of work with setting default settings for GeoMoose via Apache as well.  We have a default MapFile set up for example that has a set of default layers set to “on”.
 
I believe the Google basemapping has been a problem to work with recently without a Google Map Key, and it’s been purposely left out of the demo.
 
bobb
 
 
On Oct 26, 2017, at 9:35 AM, Brent Fraser <[hidden email]> wrote:
 

Hey all,

I'm experimenting with map backgrounds in 3.0. 

Is it possible to use Google maps as a background?

Is it possible to use radio buttons instead of check boxes?   I've tried using
    <group title="Backgrounds" expand="true" multiple="false">
but it doesn't work.

Can I set a background layer on by default (e.g. status="on")?

Thanks!

-- 
Best Regards,
Brent Fraser
_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users
 

 
"C makes it easy to shoot yourself in the foot; C++ makes it harder, but when you do, it blows away your whole leg." 
- Bjarne Stroustrup
 

_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users


_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users
Reply | Threaded
Open this post in threaded view
|

Re: [Geomoose-users] experimenting with Geomoose 3

Brent Fraser
Hey Dan,
 
  I'd prefer to have it in the Catalog since from an implementor's point of view, that's what you want turned on.  And if you use a single map-source in more than one Catalog entry it could get a little convoluted if it is in the map-source.
 
Thanks!
Brent
 
 
 

From: "Dan Little" <[hidden email]>
Sent: Thursday, October 26, 2017 10:06 AM
To: "Brent Fraser" <[hidden email]>
Cc: "Basques, Bob (CI-StPaul)" <[hidden email]>, "GeoMOOSE Users List" <[hidden email]>
Subject: Re: [Geomoose-users] experimenting with Geomoose 3
 
The catalog not working is likely a bug. Or at least worth discussion of map-source vs catalog.
 
On Thu, Oct 26, 2017 at 11:05 AM, Brent Fraser <[hidden email]> wrote:
Hey bobb,
 
  1. Google maps:  not only is it not in the demo, there's no code (that I can find).  We have to use a Key with Bing so I don't think that's a problem.
  2. radio buttons: I may have to hit F12 with debug.html!
  3. Yes I saw the settings in the URL (and the "tracker" refs in the app.js), but I found the answer; it is now set in the map source def, e.g.:
    <map-source name="ags" type="ags">
        <url>https://services.arcgisonline.com/ArcGIS/rest/services/NatGeo_World_Map/MapServer</url>
        <layer name="NatGeo_World_Map" status="on"/>
(sooo many things to document!)
 
 
 

From: "Basques, Bob (CI-StPaul)" <[hidden email]>
Sent: Thursday, October 26, 2017 9:44 AM
To:
Cc: "GeoMOOSE Users List" <[hidden email]>
Subject: Re: [Geomoose-users] experimenting with Geomoose 3
 
Hi Brent,
 
One way to do it is through the URL.
 
The layers are now remembered there ( as well as bbox/scale):
 
 
Jim has done quite a bit of work with setting default settings for GeoMoose via Apache as well.  We have a default MapFile set up for example that has a set of default layers set to “on”.
 
I believe the Google basemapping has been a problem to work with recently without a Google Map Key, and it’s been purposely left out of the demo.
 
bobb
 
 
On Oct 26, 2017, at 9:35 AM, Brent Fraser <[hidden email]> wrote:
 

Hey all,

I'm experimenting with map backgrounds in 3.0. 

Is it possible to use Google maps as a background?

Is it possible to use radio buttons instead of check boxes?   I've tried using
    <group title="Backgrounds" expand="true" multiple="false">
but it doesn't work.

Can I set a background layer on by default (e.g. status="on")?

Thanks!

--
Best Regards,
Brent Fraser
_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users
 

 
"C makes it easy to shoot yourself in the foot; C++ makes it harder, but when you do, it blows away your whole leg." 
- Bjarne Stroustrup
 

_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users

_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users
Reply | Threaded
Open this post in threaded view
|

Re: [Geomoose-users] experimenting with Geomoose 3

Dan Little-2
Actually, what's actually *on* is the <layer> in the <map-source>.  The status setting in the catalog was only meant to be a "helper".  The advantage of having the status in the <map-source> is that you can turn that layer on, seamlessly, regardless of how many places its listed in the catalog.

That said we should likely file a bug to support 'status="on"' in the catalog.

On Thu, Oct 26, 2017 at 11:18 AM, Brent Fraser <[hidden email]> wrote:
Hey Dan,
 
  I'd prefer to have it in the Catalog since from an implementor's point of view, that's what you want turned on.  And if you use a single map-source in more than one Catalog entry it could get a little convoluted if it is in the map-source.
 
Thanks!
Brent
 
 
 

From: "Dan Little" <[hidden email]>
Sent: Thursday, October 26, 2017 10:06 AM
To: "Brent Fraser" <[hidden email]>
Cc: "Basques, Bob (CI-StPaul)" <[hidden email]>, "GeoMOOSE Users List" <[hidden email]>

Subject: Re: [Geomoose-users] experimenting with Geomoose 3
 
The catalog not working is likely a bug. Or at least worth discussion of map-source vs catalog.
 
On Thu, Oct 26, 2017 at 11:05 AM, Brent Fraser <[hidden email]> wrote:
Hey bobb,
 
  1. Google maps:  not only is it not in the demo, there's no code (that I can find).  We have to use a Key with Bing so I don't think that's a problem.
  2. radio buttons: I may have to hit F12 with debug.html!
  3. Yes I saw the settings in the URL (and the "tracker" refs in the app.js), but I found the answer; it is now set in the map source def, e.g.:
    <map-source name="ags" type="ags">
        <url>https://services.arcgisonline.com/ArcGIS/rest/services/NatGeo_World_Map/MapServer</url>
        <layer name="NatGeo_World_Map" status="on"/>
(sooo many things to document!)
 
 
 

From: "Basques, Bob (CI-StPaul)" <[hidden email]>
Sent: Thursday, October 26, 2017 9:44 AM
To:
Cc: "GeoMOOSE Users List" <[hidden email]>
Subject: Re: [Geomoose-users] experimenting with Geomoose 3
 
Hi Brent,
 
One way to do it is through the URL.
 
The layers are now remembered there ( as well as bbox/scale):
 
 
Jim has done quite a bit of work with setting default settings for GeoMoose via Apache as well.  We have a default MapFile set up for example that has a set of default layers set to “on”.
 
I believe the Google basemapping has been a problem to work with recently without a Google Map Key, and it’s been purposely left out of the demo.
 
bobb
 
 
On Oct 26, 2017, at 9:35 AM, Brent Fraser <[hidden email]> wrote:
 

Hey all,

I'm experimenting with map backgrounds in 3.0. 

Is it possible to use Google maps as a background?

Is it possible to use radio buttons instead of check boxes?   I've tried using
    <group title="Backgrounds" expand="true" multiple="false">
but it doesn't work.

Can I set a background layer on by default (e.g. status="on")?

Thanks!

-- 
Best Regards,
Brent Fraser
_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users
 

 
"C makes it easy to shoot yourself in the foot; C++ makes it harder, but when you do, it blows away your whole leg." 
- Bjarne Stroustrup
 

_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users


_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users