[Geomoose-users] Migration: install GeoMoose 2.9 on UNIX

Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[Geomoose-users] Migration: install GeoMoose 2.9 on UNIX

aborruso
Hi all,
I have a GeoMoose 2.9 installation based on MS4W 3.1.4.
Now I must migrate it to a UNIX environment.

I know [1] I must have a "pretty full feature MapServer build" and my question is: what's the simplest Ubuntu starting point to compile this Mapserver build? 
The 16.04  release? Is it better the 14.04?

Thank you very much




--
___________________

Andrea Borruso
website: https://medium.com/tantotanto
38° 7' 48" N, 13° 21' 9" E, EPSG:4326
___________________

"cercare e saper riconoscere chi e cosa,
 in mezzo all’inferno, non è inferno, 
e farlo durare, e dargli spazio"

Italo Calvino

_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users
Reply | Threaded
Open this post in threaded view
|

Re: [Geomoose-users] Migration: install GeoMoose 2.9 on UNIX

Dan Little-2
The easiest way to go is using the Ubuntu GIS PPA and installing from packages. 

On Oct 2, 2017 03:21, "andy" <[hidden email]> wrote:
Hi all,
I have a GeoMoose 2.9 installation based on MS4W 3.1.4.
Now I must migrate it to a UNIX environment.

I know [1] I must have a "pretty full feature MapServer build" and my question is: what's the simplest Ubuntu starting point to compile this Mapserver build? 
The 16.04  release? Is it better the 14.04?

Thank you very much




--
___________________

Andrea Borruso
website: https://medium.com/tantotanto
38° 7' 48" N, 13° 21' 9" E, EPSG:4326
___________________

"cercare e saper riconoscere chi e cosa,
 in mezzo all’inferno, non è inferno, 
e farlo durare, e dargli spazio"

Italo Calvino

_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users

_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users
Reply | Threaded
Open this post in threaded view
|

Re: [Geomoose-users] Migration: install GeoMoose 2.9 on UNIX

aborruso
Hi Dan,
thank you!

On 2 October 2017 at 13:21, Dan Little <[hidden email]> wrote:
The easiest way to go is using the Ubuntu GIS PPA and installing from packages. 

Does the Ubuntu GIS PPA contain a mapserver binary with?

--with-php=[path to php includes]
--with-agg=[path to agg libs]
--with-gd=[path to gd libs]
--with-wfs
--with-wmsclient
--with-wfsclient
--with-postgis
--with-proj=[path to proj]
--with-geos=[path to geos-config]/geos-config
--with-freetype=[path to freetype]
--with-gdal=[path to gdal-config]/gdal-config
--with-ogr

Best regards,

Andrea


--
___________________

Andrea Borruso
website: https://medium.com/tantotanto
38° 7' 48" N, 13° 21' 9" E, EPSG:4326
___________________

"cercare e saper riconoscere chi e cosa,
 in mezzo all’inferno, non è inferno, 
e farlo durare, e dargli spazio"

Italo Calvino

_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users
Reply | Threaded
Open this post in threaded view
|

Re: [Geomoose-users] Migration: install GeoMoose 2.9 on UNIX

Jim Klassen-2

The thing to watch out for is if PHP MapScript is working which you are likely using for the services GeoMoose 2.9 (unless you rewrote them custom in another language).  16.04 introduced PHP 7 which at least initially broke PHP MapScript.  I haven't kept up to date with if this has been resolved or not, but this might make Ubuntu 14.04 easier than 16.04.


On 10/02/2017 06:24 AM, andy wrote:
Hi Dan,
thank you!

On 2 October 2017 at 13:21, Dan Little <[hidden email]> wrote:
The easiest way to go is using the Ubuntu GIS PPA and installing from packages. 

Does the Ubuntu GIS PPA contain a mapserver binary with?

--with-php=[path to php includes]
--with-agg=[path to agg libs]
--with-gd=[path to gd libs]
--with-wfs
--with-wmsclient
--with-wfsclient
--with-postgis
--with-proj=[path to proj]
--with-geos=[path to geos-config]/geos-config
--with-freetype=[path to freetype]
--with-gdal=[path to gdal-config]/gdal-config
--with-ogr

Best regards,

Andrea


--
___________________

Andrea Borruso
website: https://medium.com/tantotanto
38° 7' 48" N, 13° 21' 9" E, EPSG:4326
___________________

"cercare e saper riconoscere chi e cosa,
 in mezzo all’inferno, non è inferno, 
e farlo durare, e dargli spazio"

Italo Calvino


_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users


_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users