[Geomoose-users] GM3 and Font Awesome 5

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[Geomoose-users] GM3 and Font Awesome 5

KevinG
Looking for some guidance to use Font Awesome v5.x in my GM 3 application.
Is this possible, or am I stuck with v4.7?
Thanks.

_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users
Reply | Threaded
Open this post in threaded view
|

Re: [Geomoose-users] GM3 and Font Awesome 5

James Klassen-2

On Fri, Jan 11, 2019, 18:23 Kevin Grootendorst <[hidden email] wrote:
Looking for some guidance to use Font Awesome v5.x in my GM 3 application.
Is this possible, or am I stuck with v4.7?
Thanks.
_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users

_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users
Reply | Threaded
Open this post in threaded view
|

Re: [Geomoose-users] GM3 and Font Awesome 5

KevinG
Thanks, Jim
The index.html doesn't seem to like the Free CDN from Font Awesome (https://origin.fontawesome.com/start), so I wasn't sure if GM was reading version 4 locally.


On Fri, 11 Jan 2019 at 19:36, James Klassen <[hidden email]> wrote:

On Fri, Jan 11, 2019, 18:23 Kevin Grootendorst <[hidden email] wrote:
Looking for some guidance to use Font Awesome v5.x in my GM 3 application.
Is this possible, or am I stuck with v4.7?
Thanks.
_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users

_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users
Reply | Threaded
Open this post in threaded view
|

Re: [Geomoose-users] GM3 and Font Awesome 5

James Klassen-2
I'm pretty sure it is pulled in as a node_module as part of the build.

We try to avoid baking in pulling libraries from CDNs where possible because that breaks for non-internet connected use (OSGeo Live, some development work, etc.) and some sites don't want to send the user to third party sites (due to risks of tracking, injection, etc.)




On Jan 11, 2019 21:36, "Kevin Grootendorst" <[hidden email]> wrote:
Thanks, Jim
The index.html doesn't seem to like the Free CDN from Font Awesome (https://origin.fontawesome.com/start), so I wasn't sure if GM was reading version 4 locally.


On Fri, 11 Jan 2019 at 19:36, James Klassen <[hidden email]> wrote:

On Fri, Jan 11, 2019, 18:23 Kevin Grootendorst <[hidden email] wrote:
Looking for some guidance to use Font Awesome v5.x in my GM 3 application.
Is this possible, or am I stuck with v4.7?
Thanks.
_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users


_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users
Reply | Threaded
Open this post in threaded view
|

Re: [Geomoose-users] GM3 and Font Awesome 5

KevinG
Hi Jim,
I installed FA 5 locally and it's all good now.
Thanks for the info.
Kevin

On Fri, 11 Jan 2019 at 22:55, James Klassen <[hidden email]> wrote:
I'm pretty sure it is pulled in as a node_module as part of the build.

We try to avoid baking in pulling libraries from CDNs where possible because that breaks for non-internet connected use (OSGeo Live, some development work, etc.) and some sites don't want to send the user to third party sites (due to risks of tracking, injection, etc.)




On Jan 11, 2019 21:36, "Kevin Grootendorst" <[hidden email]> wrote:
Thanks, Jim
The index.html doesn't seem to like the Free CDN from Font Awesome (https://origin.fontawesome.com/start), so I wasn't sure if GM was reading version 4 locally.


On Fri, 11 Jan 2019 at 19:36, James Klassen <[hidden email]> wrote:

On Fri, Jan 11, 2019, 18:23 Kevin Grootendorst <[hidden email] wrote:
Looking for some guidance to use Font Awesome v5.x in my GM 3 application.
Is this possible, or am I stuck with v4.7?
Thanks.
_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users


_______________________________________________
Geomoose-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-users