GeometryUnmanagedAPI

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

GeometryUnmanagedAPI

makoychan
This post has NOT been accepted by the mailing list yet.
Hi,

Ive downloaded on nuget the osgeo files and ive created a web api to list coordinate system, on development it was running fine. But as soon as i deployed it on my local iis and on the server i get the error

Unable to load DLL 'GeometryUnmanagedApi': The specified module could not be found, but the osgeo files are on the bin folders.

I tried copying files on inetserv, but no luck.

Ive downloaded 64bit, my machine is 64bit and iis is 7.5 on local and 8.5 in server.

Hope someone has an idea, been stuck here for almost 2 days.
Reply | Threaded
Open this post in threaded view
|

Re: GeometryUnmanagedAPI

Jackie Ng
Get process monitor (https://technet.microsoft.com/en-us/sysinternals/processmonitor.aspx)

Listen to file system activity (the file cabinet icon on the toolbar). To make things more manageable, apply a filter so that you only care about cases where Status <> SUCCESS.

Then look for logged entries where GeometryUnmanagedApi.dll is being attempted to be accessed.

You want to check for:

 1. An attempt has been made to load GeometryUnmanagedApi.dll
 2. The paths that windows tried to search for this dll. Your application bin path should've been one of them.

Please use the mapguide-users list in the future for such questions.

- Jackie