GeoNetwork 2.0.3

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

GeoNetwork 2.0.3

Andrea Carboni-2
Hi all,

I have just uploaded geonetwork 2.0.3 on sourceforge.
This is a fix release until geonetwork 2.1. To upgrade
your geonetwork 2.0.2 installation, you have to copy
these files:

web/loc/en/xml/strings.xml
web/WEB-INF/config.xml
web/WEB-INF/lib/geonetwork.jar
web/WEB-INF/lib/migration.jar
web/WEB-INF/lib/setup.jar
web/xml/schemas/iso19115/schema.xsd
web/xml/user-profiles.xml
web/xsl/metadata-thumbnail.xsl
web/xsl/metadata.xsl
web/xsl/rss-search.xsl
jetty/ext/org.mortbay.jetty.plus.jar

So the migration steps are:

- install GN 2.0.3 somewhere
- copy all files (except for config.xml) into proper folders
- edit your GN 2.0.2 config.xml file and add these lines
  (mainly for UNEP users):

    <service name="rss.search">
      <class name=".services.main.Search">
        <param name="maxSummaryKeys" value="10" />
      </class>
      <output forward="rss.present" />
    </service>
    <!-- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -->
    <service name="rss.present">
      <class name=".services.main.Result">
        <param name="maxRecords" value="10" />
      </class>
      <output sheet="rss-search.xsl" contentType="text/xml; charset=UTF-8">
        <call name="siteURL" class=".guiservices.util.GetSiteURL" />
      </output>
    </service>

This is the list of fixes:

- Added 'author' to the RoleCd codelist

- Fixed bug with user list: if the user is an Administrator but with id other
  than 1 only a subset of the groups where shown

- Fixed validation bug when adding a new metadata

- Fixed bug with thumbnails stylesheet: now the 'back' button is correctly
  shown

- Fixed "Services is not a subcontext" exception with Z39.50

- Fixed problem with IPv6 protocol: geonetwork was unable to handle the
  0:0:0:0:0:0:0:1 local address.

- Fixed a security hole: using sql injection was possible to login into geonetwork

- Fixed command string in HTTP/1.0 XML requests


Cheers,
Andrea