GeoMoose 2.x retirement

Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

GeoMoose 2.x retirement

James Klassen-2
I think it is time to officially retire support for the GeoMoose 2.x series.  To that end, I would like to notify our users (ahead of time) by making an announcement on geomoose-users, and adding appropriate news items/noting the status on appropriate places on the GeoMoose website.

What say ye?


Draft announcement:

============================================

GeoMoose 2.x is getting long in the tooth and plans to retire in April 2019.

Summary:

Due to GeoMoose 2.x requiring now very old versions of it dependences it
is becoming increasingly difficult to support.  As such, the GeoMoose
team is announcing retirement for the GeoMoose 2.x series as April 2019.

This doesn't mean your older GeoMoose installations will suddenly stop
working.  However, the GeoMoose 2.9 demo (on
https://demo.geomoose.org/2.9) will be shutdown and the development team
won't have ready access to develop and test changes to the 2.x series. 
As such, the GeoMoose team recommends upgrading to GeoMoose 3.x.


Details:

GeoMoose 2.x requires old versions of Dojo (1.6) and OpenLayers (2.13). 
Neither of these libraries are currently under development or supported
upstream.  Updating to current versions of these libraries requires
major reworking of the GeoMoose 2.x code.  (In fact, this is what
prompted the development of the GeoMoose 3.x series).

The bigger problem is that PHP services shipped with GeoMoose 2.x
require PHP 5 and PHP MapScript.  These don't exist in recent Linux
distributions (e.g. Debian Stretch/Ubuntu 16.04 and newer).  The April
2019 date is set to coincide with Ubuntu 14.04 EOL.

============================================


_______________________________________________
geomoose-psc mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-psc
Reply | Threaded
Open this post in threaded view
|

Re: GeoMoose 2.x retirement

Dan Little-2
+1. 

On Mon, Oct 15, 2018, 19:33 Jim Klassen <[hidden email]> wrote:
I think it is time to officially retire support for the GeoMoose 2.x series.  To that end, I would like to notify our users (ahead of time) by making an announcement on geomoose-users, and adding appropriate news items/noting the status on appropriate places on the GeoMoose website.

What say ye?


Draft announcement:

============================================

GeoMoose 2.x is getting long in the tooth and plans to retire in April 2019.

Summary:

Due to GeoMoose 2.x requiring now very old versions of it dependences it
is becoming increasingly difficult to support.  As such, the GeoMoose
team is announcing retirement for the GeoMoose 2.x series as April 2019.

This doesn't mean your older GeoMoose installations will suddenly stop
working.  However, the GeoMoose 2.9 demo (on
https://demo.geomoose.org/2.9) will be shutdown and the development team
won't have ready access to develop and test changes to the 2.x series. 
As such, the GeoMoose team recommends upgrading to GeoMoose 3.x.


Details:

GeoMoose 2.x requires old versions of Dojo (1.6) and OpenLayers (2.13). 
Neither of these libraries are currently under development or supported
upstream.  Updating to current versions of these libraries requires
major reworking of the GeoMoose 2.x code.  (In fact, this is what
prompted the development of the GeoMoose 3.x series).

The bigger problem is that PHP services shipped with GeoMoose 2.x
require PHP 5 and PHP MapScript.  These don't exist in recent Linux
distributions (e.g. Debian Stretch/Ubuntu 16.04 and newer).  The April
2019 date is set to coincide with Ubuntu 14.04 EOL.

============================================


_______________________________________________
geomoose-psc mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-psc

_______________________________________________
geomoose-psc mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-psc
Reply | Threaded
Open this post in threaded view
|

Re: GeoMoose 2.x retirement

Eli Adam
+1

This will be ~1.5 years after the first release of 3.0.

Eli
On Mon, Oct 15, 2018 at 5:50 PM Dan Little <[hidden email]> wrote:

>
> +1.
>
> On Mon, Oct 15, 2018, 19:33 Jim Klassen <[hidden email]> wrote:
>>
>> I think it is time to officially retire support for the GeoMoose 2.x series.  To that end, I would like to notify our users (ahead of time) by making an announcement on geomoose-users, and adding appropriate news items/noting the status on appropriate places on the GeoMoose website.
>>
>> What say ye?
>>
>>
>> Draft announcement:
>>
>> ============================================
>>
>> GeoMoose 2.x is getting long in the tooth and plans to retire in April 2019.
>>
>> Summary:
>>
>> Due to GeoMoose 2.x requiring now very old versions of it dependences it
>> is becoming increasingly difficult to support.  As such, the GeoMoose
>> team is announcing retirement for the GeoMoose 2.x series as April 2019.
>>
>> This doesn't mean your older GeoMoose installations will suddenly stop
>> working.  However, the GeoMoose 2.9 demo (on
>> https://demo.geomoose.org/2.9) will be shutdown and the development team
>> won't have ready access to develop and test changes to the 2.x series.
>> As such, the GeoMoose team recommends upgrading to GeoMoose 3.x.
>>
>>
>> Details:
>>
>> GeoMoose 2.x requires old versions of Dojo (1.6) and OpenLayers (2.13).
>> Neither of these libraries are currently under development or supported
>> upstream.  Updating to current versions of these libraries requires
>> major reworking of the GeoMoose 2.x code.  (In fact, this is what
>> prompted the development of the GeoMoose 3.x series).
>>
>> The bigger problem is that PHP services shipped with GeoMoose 2.x
>> require PHP 5 and PHP MapScript.  These don't exist in recent Linux
>> distributions (e.g. Debian Stretch/Ubuntu 16.04 and newer).  The April
>> 2019 date is set to coincide with Ubuntu 14.04 EOL.
>>
>> ============================================
>>
>>
>> _______________________________________________
>> geomoose-psc mailing list
>> [hidden email]
>> https://lists.osgeo.org/mailman/listinfo/geomoose-psc
>
> _______________________________________________
> geomoose-psc mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/geomoose-psc
_______________________________________________
geomoose-psc mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-psc
Reply | Threaded
Open this post in threaded view
|

Re: GeoMoose 2.x retirement

TC Haddad

+1
I've asked around, and this idea doesn't seem to be causing any heartburn.

On Tue, Oct 16, 2018 at 7:45 AM Eli Adam <[hidden email]> wrote:
+1

This will be ~1.5 years after the first release of 3.0.

Eli
On Mon, Oct 15, 2018 at 5:50 PM Dan Little <[hidden email]> wrote:
>
> +1.
>
> On Mon, Oct 15, 2018, 19:33 Jim Klassen <[hidden email]> wrote:
>>
>> I think it is time to officially retire support for the GeoMoose 2.x series.  To that end, I would like to notify our users (ahead of time) by making an announcement on geomoose-users, and adding appropriate news items/noting the status on appropriate places on the GeoMoose website.
>>
>> What say ye?
>>
>>
>> Draft announcement:
>>
>> ============================================
>>
>> GeoMoose 2.x is getting long in the tooth and plans to retire in April 2019.
>>
>> Summary:
>>
>> Due to GeoMoose 2.x requiring now very old versions of it dependences it
>> is becoming increasingly difficult to support.  As such, the GeoMoose
>> team is announcing retirement for the GeoMoose 2.x series as April 2019.
>>
>> This doesn't mean your older GeoMoose installations will suddenly stop
>> working.  However, the GeoMoose 2.9 demo (on
>> https://demo.geomoose.org/2.9) will be shutdown and the development team
>> won't have ready access to develop and test changes to the 2.x series.
>> As such, the GeoMoose team recommends upgrading to GeoMoose 3.x.
>>
>>
>> Details:
>>
>> GeoMoose 2.x requires old versions of Dojo (1.6) and OpenLayers (2.13).
>> Neither of these libraries are currently under development or supported
>> upstream.  Updating to current versions of these libraries requires
>> major reworking of the GeoMoose 2.x code.  (In fact, this is what
>> prompted the development of the GeoMoose 3.x series).
>>
>> The bigger problem is that PHP services shipped with GeoMoose 2.x
>> require PHP 5 and PHP MapScript.  These don't exist in recent Linux
>> distributions (e.g. Debian Stretch/Ubuntu 16.04 and newer).  The April
>> 2019 date is set to coincide with Ubuntu 14.04 EOL.
>>
>> ============================================
>>
>>
>> _______________________________________________
>> geomoose-psc mailing list
>> [hidden email]
>> https://lists.osgeo.org/mailman/listinfo/geomoose-psc
>
> _______________________________________________
> geomoose-psc mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/geomoose-psc
_______________________________________________
geomoose-psc mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-psc

_______________________________________________
geomoose-psc mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-psc
Reply | Threaded
Open this post in threaded view
|

Re: GeoMoose 2.x retirement

blammo
In reply to this post by James Klassen-2
+1

On Oct 15, 2018, at 7:33 PM, Jim Klassen <[hidden email]> wrote:

I think it is time to officially retire support for the GeoMoose 2.x series.  To that end, I would like to notify our users (ahead of time) by making an announcement on geomoose-users, and adding appropriate news items/noting the status on appropriate places on the GeoMoose website.

What say ye?


Draft announcement:

============================================

GeoMoose 2.x is getting long in the tooth and plans to retire in April 2019.

Summary:

Due to GeoMoose 2.x requiring now very old versions of it dependences it
is becoming increasingly difficult to support.  As such, the GeoMoose
team is announcing retirement for the GeoMoose 2.x series as April 2019.

This doesn't mean your older GeoMoose installations will suddenly stop
working.  However, the GeoMoose 2.9 demo (on
https://demo.geomoose.org/2.9) will be shutdown and the development team
won't have ready access to develop and test changes to the 2.x series. 
As such, the GeoMoose team recommends upgrading to GeoMoose 3.x.


Details:

GeoMoose 2.x requires old versions of Dojo (1.6) and OpenLayers (2.13). 
Neither of these libraries are currently under development or supported
upstream.  Updating to current versions of these libraries requires
major reworking of the GeoMoose 2.x code.  (In fact, this is what
prompted the development of the GeoMoose 3.x series).

The bigger problem is that PHP services shipped with GeoMoose 2.x
require PHP 5 and PHP MapScript.  These don't exist in recent Linux
distributions (e.g. Debian Stretch/Ubuntu 16.04 and newer).  The April
2019 date is set to coincide with Ubuntu 14.04 EOL.

============================================


_______________________________________________
geomoose-psc mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-psc



Don’t ever wrestle with a pig. You’ll both get dirty, but the pig will enjoy it.
—Cale Yarborough


_______________________________________________
geomoose-psc mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-psc
Reply | Threaded
Open this post in threaded view
|

Re: GeoMoose 2.x retirement

James Klassen-2
Hearing no objections, I will make the announcement.

On 10/16/18 12:30 PM, Basques, Bob (CI-StPaul) wrote:

> +1
>
>> On Oct 15, 2018, at 7:33 PM, Jim Klassen <[hidden email]
>> <mailto:[hidden email]>> wrote:
>>
>> I think it is time to officially retire support for the GeoMoose 2.x
>> series.  To that end, I would like to notify our users (ahead of
>> time) by making an announcement on geomoose-users, and adding
>> appropriate news items/noting the status on appropriate places on the
>> GeoMoose website.
>>
>> What say ye?
>>
>>
>> Draft announcement:
>>
>> ============================================
>>
>> GeoMoose 2.x is getting long in the tooth and plans to retire in
>> April 2019.
>>
>> Summary:
>>
>> Due to GeoMoose 2.x requiring now very old versions of it dependences it
>> is becoming increasingly difficult to support.  As such, the GeoMoose
>> team is announcing retirement for the GeoMoose 2.x series as April 2019.
>>
>> This doesn't mean your older GeoMoose installations will suddenly stop
>> working.  However, the GeoMoose 2.9 demo (on
>> https://demo.geomoose.org/2.9) will be shutdown and the development team
>> won't have ready access to develop and test changes to the 2.x series. 
>> As such, the GeoMoose team recommends upgrading to GeoMoose 3.x.
>>
>>
>> Details:
>>
>> GeoMoose 2.x requires old versions of Dojo (1.6) and OpenLayers (2.13). 
>> Neither of these libraries are currently under development or supported
>> upstream.  Updating to current versions of these libraries requires
>> major reworking of the GeoMoose 2.x code.  (In fact, this is what
>> prompted the development of the GeoMoose 3.x series).
>>
>> The bigger problem is that PHP services shipped with GeoMoose 2.x
>> require PHP 5 and PHP MapScript.  These don't exist in recent Linux
>> distributions (e.g. Debian Stretch/Ubuntu 16.04 and newer).  The April
>> 2019 date is set to coincide with Ubuntu 14.04 EOL.
>>
>> ============================================
>>
>>
>> _______________________________________________
>> geomoose-psc mailing list
>> [hidden email] <mailto:[hidden email]>
>> https://lists.osgeo.org/mailman/listinfo/geomoose-psc
>
>
>
> Don’t ever wrestle with a pig. You’ll both get dirty, but the pig will
> enjoy it.
> —Cale Yarborough
>
_______________________________________________
geomoose-psc mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-psc
Reply | Threaded
Open this post in threaded view
|

Re: GeoMoose 2.x retirement

Dan Little-2
Thanks Jim!

On Tue, Nov 6, 2018, 1:59 PM Jim Klassen <[hidden email] wrote:
Hearing no objections, I will make the announcement.

On 10/16/18 12:30 PM, Basques, Bob (CI-StPaul) wrote:
> +1
>
>> On Oct 15, 2018, at 7:33 PM, Jim Klassen <[hidden email]
>> <mailto:[hidden email]>> wrote:
>>
>> I think it is time to officially retire support for the GeoMoose 2.x
>> series.  To that end, I would like to notify our users (ahead of
>> time) by making an announcement on geomoose-users, and adding
>> appropriate news items/noting the status on appropriate places on the
>> GeoMoose website.
>>
>> What say ye?
>>
>>
>> Draft announcement:
>>
>> ============================================
>>
>> GeoMoose 2.x is getting long in the tooth and plans to retire in
>> April 2019.
>>
>> Summary:
>>
>> Due to GeoMoose 2.x requiring now very old versions of it dependences it
>> is becoming increasingly difficult to support.  As such, the GeoMoose
>> team is announcing retirement for the GeoMoose 2.x series as April 2019.
>>
>> This doesn't mean your older GeoMoose installations will suddenly stop
>> working.  However, the GeoMoose 2.9 demo (on
>> https://demo.geomoose.org/2.9) will be shutdown and the development team
>> won't have ready access to develop and test changes to the 2.x series. 
>> As such, the GeoMoose team recommends upgrading to GeoMoose 3.x.
>>
>>
>> Details:
>>
>> GeoMoose 2.x requires old versions of Dojo (1.6) and OpenLayers (2.13). 
>> Neither of these libraries are currently under development or supported
>> upstream.  Updating to current versions of these libraries requires
>> major reworking of the GeoMoose 2.x code.  (In fact, this is what
>> prompted the development of the GeoMoose 3.x series).
>>
>> The bigger problem is that PHP services shipped with GeoMoose 2.x
>> require PHP 5 and PHP MapScript.  These don't exist in recent Linux
>> distributions (e.g. Debian Stretch/Ubuntu 16.04 and newer).  The April
>> 2019 date is set to coincide with Ubuntu 14.04 EOL.
>>
>> ============================================
>>
>>
>> _______________________________________________
>> geomoose-psc mailing list
>> [hidden email] <mailto:[hidden email]>
>> https://lists.osgeo.org/mailman/listinfo/geomoose-psc
>
>
>
> Don’t ever wrestle with a pig. You’ll both get dirty, but the pig will
> enjoy it.
> —Cale Yarborough
>
_______________________________________________
geomoose-psc mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-psc

_______________________________________________
geomoose-psc mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-psc