Quantcast

GRASS plugin broke only for me?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

GRASS plugin broke only for me?

Pierluigi De Rosa-4
Dear All,

After the upgrading to the GRASS 7.03 I'm not able to have the GRASS plugin working properly.

I'm using ubuntu with all software from repo; in particular I'm using:
repo 1 for qgis http://qgis.org/ubuntugis/
repo 2 for grass: http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu

I noticed that under Plugin -> Grass -> GRASS Option I still have grass 7.0.1 (the last installation) while I'm running GRASS 7.0.3

If I run:
GRASS --version I have:
grass --version
GRASS GIS 7.0.3
Traceback (most recent call last):
  File "/usr/bin/grass", line 1363, in <module>
    parse_cmdline()
  File "/usr/bin/grass", line 1275, in parse_cmdline
    message('\n' + readfile(gfile("etc", "license")))
  File "/usr/bin/grass", line 139, in readfile
    f = open(path, 'r')
IOError: [Errno 2] No such file or directory: '/usr/lib/grass70/etc/license'


Could be that it miss the licence file in the package and this cause the plugin GRASS does not recognize GRASS data?
In fact if I browse into the GRASS directory I'm not able to add any GRASS layer.
If I ask to create e new mapset the QGIS crash

Thank to all
Pierluigi


--


Ing. Pierluigi De Rosa (PhD)
Studio Associato GFOSSERVICES
               
Presso CAMPUS Via F.lli Cairoli 25 - 06127 Perugia (PG)
fax: 075 7823038
cel: 3497558268
web: www.gfosservices.it
skype: pierluigi.derosa


_______________________________________________
Qgis-developer mailing list
[hidden email]
List info: http://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GRASS plugin broke only for me?

Radim Blazek-2
The GRASS provider/plugin only works  if it is run with exactly the same version of GRASS libs it was built with (GRASS init function in GRASS lib is checking svn revision). 

If you run QGIS with a different GRASS version you should get soft message like
"GRASS init error: Problem in GRASS initialization, GRASS provider and plugin will not work : Module built against version $Revision: 64732 $ but trying to use version $Revision: 64007 $. You need to rebuild GRASS GIS or untangle multiple installations."

The provider will load as invalid so you see just a directory structure not GRASS location structure in the browser. 

The plugin loads but all actions/tools are disabled except Options, where you can manually select different GRASS installation (but not libraries the provider/plugin is started with).

The "New mapset" action is left enabled because of bug, fixed in 8353698.

Radim




On Tue, Feb 16, 2016 at 12:36 PM, Ing. Pierluigi De Rosa <[hidden email]> wrote:
Dear All,

After the upgrading to the GRASS 7.03 I'm not able to have the GRASS plugin working properly.

I'm using ubuntu with all software from repo; in particular I'm using:
repo 1 for qgis http://qgis.org/ubuntugis/
repo 2 for grass: http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu

I noticed that under Plugin -> Grass -> GRASS Option I still have grass 7.0.1 (the last installation) while I'm running GRASS 7.0.3

If I run:
GRASS --version I have:
grass --version
GRASS GIS 7.0.3
Traceback (most recent call last):
  File "/usr/bin/grass", line 1363, in <module>
    parse_cmdline()
  File "/usr/bin/grass", line 1275, in parse_cmdline
    message('\n' + readfile(gfile("etc", "license")))
  File "/usr/bin/grass", line 139, in readfile
    f = open(path, 'r')
IOError: [Errno 2] No such file or directory: '/usr/lib/grass70/etc/license'


Could be that it miss the licence file in the package and this cause the plugin GRASS does not recognize GRASS data?
In fact if I browse into the GRASS directory I'm not able to add any GRASS layer.
If I ask to create e new mapset the QGIS crash

Thank to all
Pierluigi


--


Ing. Pierluigi De Rosa (PhD)
Studio Associato GFOSSERVICES
               
Presso CAMPUS Via F.lli Cairoli 25 - 06127 Perugia (PG)
fax: 075 7823038
cel: 3497558268
web: www.gfosservices.it
skype: pierluigi.derosa


_______________________________________________
Qgis-developer mailing list
[hidden email]
List info: http://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-developer


_______________________________________________
Qgis-developer mailing list
[hidden email]
List info: http://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-developer
Loading...