GRASS addon impossible à compiler

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

GRASS addon impossible à compiler

PolHyPro - FluxdO
Bonjour,

J'ai une fedora sur laquelle j'ai installé Qgis 2.1 et Grass 6.4

J'essaie d'installer des grefons mais y a pas moyen. Lors de la
compilation, le système cherche u répertoire et un script inexistants :

g.extension -u extension=v.in.postgis
svnurl=http://svn.osgeo.org/grass/grass-addons/grass6 prefix=/opt/SIG/
Fetching <v.in.postgis> from GRASS-Addons SVN (be patient)...
A    v.in.postgis/v.in.postgis.html
A    v.in.postgis/v.in.postgis.py
A    v.in.postgis/v.in.postgis.sh
A    v.in.postgis/Makefile
 U   v.in.postgis
Compiling <v.in.postgis>...
Makefile:5: /usr/lib64/grass-6.4.4/include/Make/Script.make:
No existe el fichero o el directorio
make: *** No rule to make target
'/usr/lib64/grass-6.4.4/include/Make/Script.make'.  Alto.
ERROR: Compilation failed, sorry. Please check above error messages.

Je ne suis pas le seul à avoir ce soucis :
http://comments.gmane.org/gmane.comp.gis.grass.user/48244

Mais personne n'a de solution semble-t-il. Si j'ai bien compris, il
faudrait changer le script d'installation qui est adapté une Ununtu.

Y a-t-il quelqu'un parmi vous qui aurai la parade ?

Merci.

--

Denis
_______________________________________________
Francophone mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/francophone
Reply | Threaded
Open this post in threaded view
|

Re: GRASS addon impossible à compiler

Etienne DELAY-2
Bonsoir Denis,
Non désolé pas de solutions, j'ai le même problème avec grass7, du coup
j'essaye de faire les choses en R. cela dit je suis intéressé par une
solution :-p

Etienne

Le 08/01/2016 09:33, PolHyPro - FluxdO a écrit :

> Bonjour,
>
> J'ai une fedora sur laquelle j'ai installé Qgis 2.1 et Grass 6.4
>
> J'essaie d'installer des grefons mais y a pas moyen. Lors de la
> compilation, le système cherche u répertoire et un script inexistants :
>
> g.extension -u extension=v.in.postgis
> svnurl=http://svn.osgeo.org/grass/grass-addons/grass6 prefix=/opt/SIG/
> Fetching <v.in.postgis> from GRASS-Addons SVN (be patient)...
> A    v.in.postgis/v.in.postgis.html
> A    v.in.postgis/v.in.postgis.py
> A    v.in.postgis/v.in.postgis.sh
> A    v.in.postgis/Makefile
>   U   v.in.postgis
> Compiling <v.in.postgis>...
> Makefile:5: /usr/lib64/grass-6.4.4/include/Make/Script.make:
> No existe el fichero o el directorio
> make: *** No rule to make target
> '/usr/lib64/grass-6.4.4/include/Make/Script.make'.  Alto.
> ERROR: Compilation failed, sorry. Please check above error messages.
>
> Je ne suis pas le seul à avoir ce soucis :
> http://comments.gmane.org/gmane.comp.gis.grass.user/48244
>
> Mais personne n'a de solution semble-t-il. Si j'ai bien compris, il
> faudrait changer le script d'installation qui est adapté une Ununtu.
>
> Y a-t-il quelqu'un parmi vous qui aurai la parade ?
>
> Merci.
>
_______________________________________________
Francophone mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/francophone
Reply | Threaded
Open this post in threaded view
|

Re: GRASS addon impossible à compiler

Régis Haubourg

Salut,
N'est ce pas parce-que grass n'est pas réellement supporté en 64 bits ?

Régis Haubourg

Le 8 janv. 2016 18:46, Etienne DELAY <[hidden email]> a écrit :
Bonsoir Denis,
Non désolé pas de solutions, j'ai le même problème avec grass7, du coup
j'essaye de faire les choses en R. cela dit je suis intéressé par une
solution :-p

Etienne

Le 08/01/2016 09:33, PolHyPro - FluxdO a écrit :
> Bonjour,
>
> J'ai une fedora sur laquelle j'ai installé Qgis 2.1 et Grass 6.4
>
> J'essaie d'installer des grefons mais y a pas moyen. Lors de la
> compilation, le système cherche u répertoire et un script inexistants :
>
> g.extension -u extension=v.in.postgis
> svnurl=http://cp.mcafee.com/d/1jWVIe6h8qdEIfFFzDQnHCXCQrzASjhOOMqem3qdNOr9EVpsjudET79ICzBBwQsLCQrzAPhOeuvd7b1KfApkUDHp2Hsi8a_mO-Elryn8X6I8vPIjvWSnR2HsiV7oRx3-tyrTTTnnD7-LOrarBQuLsKCOeoVxVdZW_khpmKCHt5zBgY-F6lK1FJ4SOrKrKr01QcMWJ2fRU03x6eQFx6eQEnR12IaohzJae6ToX2Rlytoun8lrxrW0E-l9QWJ2fRU02rvpjpdwLQzh0qmNueMJloDm7CBQQg185y0Mc6y3k4aMd44BlGQF8wvVEwdopGwd42WQz_yrvjdUjI8Ae1Z prefix=/opt/SIG/
> Fetching <v.in.postgis> from GRASS-Addons SVN (be patient)...
> A    v.in.postgis/v.in.postgis.html
> A    v.in.postgis/v.in.postgis.py
> A    v.in.postgis/v.in.postgis.sh
> A    v.in.postgis/Makefile
>   U   v.in.postgis
> Compiling <v.in.postgis>...
> Makefile:5: /usr/lib64/grass-6.4.4/include/Make/Script.make:
> No existe el fichero o el directorio
> make: *** No rule to make target
> '/usr/lib64/grass-6.4.4/include/Make/Script.make'.  Alto.
> ERROR: Compilation failed, sorry. Please check above error messages.
>
> Je ne suis pas le seul à avoir ce soucis :
> http://cp.mcafee.com/d/1jWVIidEIfFFzDQnHCXCQrzASjhOOMqem3qdNOr9EVpsjudET79ICzBBwQsLCQrzAPhOeuvd7b1KfApkUDHp2Hsi8a_mO-Elryn8X6I8vPIjvWSnR2HsiV7oRx3-tyrTTTnnD7-LOrarBQuLsKCOeoVxVdZW_khpmKCHt5zBgY-F6lK1FJcSOrKrKr01HG_2te8GX3-00UhlS7YKJN6le8NSBerFYsoujoodKNS5GH4WMYKgGT2TQ1hYGjFRq4vHM04S-OCOr1vF6y0QJyYtxqGNeIfdbFEw2gb41wod46E8lwq89aHlFih0_Ph0qMPl0q85RF7_4S-CrrImi
>
> Mais personne n'a de solution semble-t-il. Si j'ai bien compris, il
> faudrait changer le script d'installation qui est adapté une Ununtu.
>
> Y a-t-il quelqu'un parmi vous qui aurai la parade ?
>
> Merci.
>
_______________________________________________
Francophone mailing list
[hidden email]
http://cp.mcafee.com/d/5fHCNEe418idEIfFFzDQnHCXCQrzASjhOOMqem3qdNOr9EVpsjudET79ICzBBwQsLCQrzAPhOeuvd7b1KfApkUDHp2Hsi8a_mO-Elryn8X6I8vPIjvWSnR2HsiV7oRx3-tyrTTTnnD7-LOrarBQuLsKCOeoVxVdZW_khpmKCHt5zBgY-F6lK1FJASOrKrKr01DOFeDlEh-L00s4RtxxYGjB1SKeNS5GH4WMYSX7omGIjH3OV2Hsbvg57OFeDlEh-L00jrXar9I5-Aq83iSbNS5GH4WMYQKCy090Ig61wQgqwxm1EwAGJmB943_d41H3dk1EwnmAvYjrWpJ0C6MOJzJNzk

_______________________________________________
Francophone mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/francophone
Reply | Threaded
Open this post in threaded view
|

Re: GRASS addon impossible à compiler

PolHyPro - FluxdO
Merci Étienne pour ta compassion. En R!? .... je ne sais pas faire.

Régis : Non je ne pense pas car j'ai vu sur Internet que d'autres
personnes avaient le même soucis avec un soucis de config du fichier de
compilation, vu que ceux qui ont trouvé une parade, y sont arrivés sur
Ubuntu. D'ailleurs, il y a un ticket qui à été ouvert et ils l'ont fermé
sous prétexte d'avoir fixé le soucis sur une Ubuntu sans vérifier ce
qu'il en est sur les autres distributions.

Lien vers le ticket : http://trac.osgeo.org/grass/ticket/2598

Denis

El 08/01/16 a las 19:52, HAUBOURG escribió:

>
> Salut,
> N'est ce pas parce-que grass n'est pas réellement supporté en 64 bits ?
>
> Régis Haubourg
>
> Le 8 janv. 2016 18:46, Etienne DELAY <[hidden email]> a écrit :
> Bonsoir Denis,
> Non désolé pas de solutions, j'ai le même problème avec grass7, du coup
> j'essaye de faire les choses en R. cela dit je suis intéressé par une
> solution :-p
>
> Etienne
>
> Le 08/01/2016 09:33, PolHyPro - FluxdO a écrit :
> > Bonjour,
> >
> > J'ai une fedora sur laquelle j'ai installé Qgis 2.1 et Grass 6.4
> >
> > J'essaie d'installer des grefons mais y a pas moyen. Lors de la
> > compilation, le système cherche u répertoire et un script inexistants :
> >
> > g.extension -u extension=v.in.postgis
> >
> svnurl=http://cp.mcafee.com/d/1jWVIe6h8qdEIfFFzDQnHCXCQrzASjhOOMqem3qdNOr9EVpsjudET79ICzBBwQsLCQrzAPhOeuvd7b1KfApkUDHp2Hsi8a_mO-Elryn8X6I8vPIjvWSnR2HsiV7oRx3-tyrTTTnnD7-LOrarBQuLsKCOeoVxVdZW_khpmKCHt5zBgY-F6lK1FJ4SOrKrKr01QcMWJ2fRU03x6eQFx6eQEnR12IaohzJae6ToX2Rlytoun8lrxrW0E-l9QWJ2fRU02rvpjpdwLQzh0qmNueMJloDm7CBQQg185y0Mc6y3k4aMd44BlGQF8wvVEwdopGwd42WQz_yrvjdUjI8Ae1Z
> prefix=/opt/SIG/
> > Fetching <v.in.postgis> from GRASS-Addons SVN (be patient)... bit.
> De plus il semble vraiment que je sois un
> > A    v.in.postgis/v.in.postgis.html
> > A    v.in.postgis/v.in.postgis.py
> > A    v.in.postgis/v.in.postgis.sh
> > A    v.in.postgis/Makefile
> >   U   v.in.postgis
> > Compiling <v.in.postgis>...
> > Makefile:5: /usr/lib64/grass-6.4.4/include/Make/Script.make:
> > No existe el fichero o el directorio
> > make: *** No rule to make target
> > '/usr/lib64/grass-6.4.4/include/Make/Script.make'.  Alto.
> > ERROR: Compilation failed, sorry. Please check above error messages.
> >
> > Je ne suis pas le seul à avoir ce soucis :
> >
> http://cp.mcafee.com/d/1jWVIidEIfFFzDQnHCXCQrzASjhOOMqem3qdNOr9EVpsjudET79ICzBBwQsLCQrzAPhOeuvd7b1KfApkUDHp2Hsi8a_mO-Elryn8X6I8vPIjvWSnR2HsiV7oRx3-tyrTTTnnD7-LOrarBQuLsKCOeoVxVdZW_khpmKCHt5zBgY-F6lK1FJcSOrKrKr01HG_2te8GX3-00UhlS7YKJN6le8NSBerFYsoujoodKNS5GH4WMYKgGT2TQ1hYGjFRq4vHM04S-OCOr1vF6y0QJyYtxqGNeIfdbFEw2gb41wod46E8lwq89aHlFih0_Ph0qMPl0q85RF7_4S-CrrImi
> >
> > Mais personne n'a de solution semble-t-il. Si j'ai bien compris, il
> > faudrait changer le script d'installation qui est adapté une Ununtu.
> >
> > Y a-t-il quelqu'un parmi vous qui aurai la parade ?
> >
> > Merci.
> >
> _______________________________________________
> Francophone mailing list
> [hidden email]
> http://cp.mcafee.com/d/5fHCNEe418idEIfFFzDQnHCXCQrzASjhOOMqem3qdNOr9EVpsjudET79ICzBBwQsLCQrzAPhOeuvd7b1KfApkUDHp2Hsi8a_mO-Elryn8X6I8vPIjvWSnR2HsiV7oRx3-tyrTTTnnD7-LOrarBQuLsKCOeoVxVdZW_khpmKCHt5zBgY-F6lK1FJASOrKrKr01DOFeDlEh-L00s4RtxxYGjB1SKeNS5GH4WMYSX7omGIjH3OV2Hsbvg57OFeDlEh-L00jrXar9I5-Aq83iSbNS5GH4WMYQKCy090Ig61wQgqwxm1EwAGJmB943_d41H3dk1EwnmAvYjrWpJ0C6MOJzJNzk
>
>
> _______________________________________________
> Francophone mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/francophone

_______________________________________________
Francophone mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/francophone
Reply | Threaded
Open this post in threaded view
|

Re: GRASS addon impossible à compiler

Sylvain Maillard
Salut,

> Le 08/01/2016 09:33, PolHyPro - FluxdO a écrit :

> > Compiling <v.in.postgis>...
> > Makefile:5: /usr/lib64/grass-6.4.4/include/Make/Script.make:
> > No existe el fichero o el directorio
> > make: *** No rule to make target
> > '/usr/lib64/grass-6.4.4/include/Make/Script.make'.  Alto.
> > ERROR: Compilation failed, sorry. Please check above error messages.

le message d'erreur indique que l'installation à échouée car il manque le fichier /usr/lib64/grass-6.4.4/include/Make/Script.make sur ton système. Ce fichier est essentiel pour installer les extensions, car il contient des détails sur les options de compilation utilisés pour construire le paquet.
Ce type de fichier est habituellement présent dans les paquets -devel ou -dev, mais là il semble absent du paquet grass-devel sur fedora (il est présent dans grass-dev sur ubuntu) ...

Il faudrait sans doute remplir un rapport de bug pour le paquet fedora, en incluant ton message d'erreur en demandant à ce que le dossier include/Make soit intégré dans le paquet grass-devel !


Sylvain



_______________________________________________
Francophone mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/francophone
Reply | Threaded
Open this post in threaded view
|

Re: GRASS addon impossible à compiler

PolHyPro - FluxdO
Bonjour,

Merci pour la réponse. 

Oui je vois bien et le problème n'est pas que pour la fedora mais pour
tout ce qui n'est pas basé sur Ubuntu/kubuntu. Vu la réponse d'un des
développeurs de QGIS (genre j'ai pas le temps démmerdez-vous) ça
m'intéresserai si quelqu'un avait une ubuntu sur laquelle ça fonctionne
de me donner le script que je vois s'il serait possible de l'adapter
quitte à créer le répertoire /include/Make/. Merci.

--

       
       
       
       
       
       







Denis 

El mar, 12-01-2016 a las 23:37 +0100, Sylvain Maillard escribió:

> Salut,
>
> >  > Le 08/01/2016 09:33, PolHyPro - FluxdO a écrit :
> >
> > > > Compiling <v.in.postgis>...
> > > > Makefile:5: /usr/lib64/grass-6.4.4/include/Make/Script.make:
> > > > No existe el fichero o el directorio
> > > > make: *** No rule to make target
> > > > '/usr/lib64/grass-6.4.4/include/Make/Script.make'.  Alto.
> > > > ERROR: Compilation failed, sorry. Please check above error
> > messages.
> le message d'erreur indique que l'installation à échouée car il
> manque le fichier /usr/lib64/grass-6.4.4/include/Make/Script.make sur
> ton système. Ce fichier est essentiel pour installer les extensions,
> car il contient des détails sur les options de compilation utilisés
> pour construire le paquet.
> Ce type de fichier est habituellement présent dans les paquets -devel
> ou -dev, mais là il semble absent du paquet grass-devel sur fedora
> (il est présent dans grass-dev sur ubuntu) ... 
>
> Il faudrait sans doute remplir un rapport de bug pour le paquet
> fedora, en incluant ton message d'erreur en demandant à ce que le
> dossier include/Make soit intégré dans le paquet grass-devel !
>
>
> Sylvain
>
>
>  _______________________________________________
> Francophone mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/francophone
_______________________________________________
Francophone mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/francophone
Reply | Threaded
Open this post in threaded view
|

Re: GRASS addon impossible à compiler

Etienne DELAY-2
Bonjour Denis,
Il faut que je regarde sur ma machine au bureau, mais il me semble que
j'ai aussi le problème quand je compile grass7 (en tout cas j'ai un
problème pour installer des modules).

Je me souviens que j'avais testé une solution du genre ajouter le code
source du module dans un répertoire spécifique avant la compilation pour
en suite produire un bin contenant le module... Mais je ne retrouve plus
la doc! :-S

Etienne


Cordialement

Etienne DELAY (Skype : etienne.delay.tic)
Chaire: Capital environnemental et gestion durable des cours d'eau
laboratoire GEOLAB UMR 6042 CNRS
Université de Limoges, FLSH
39E rue Camille Guérin 87036 Limoges
blog : http://elcep.legtux.org

Le 15/01/2016 12:15, FluxdO a écrit :

> Bonjour,
>
> Merci pour la réponse.
>
> Oui je vois bien et le problème n'est pas que pour la fedora mais pour
> tout ce qui n'est pas basé sur Ubuntu/kubuntu. Vu la réponse d'un des
> développeurs de QGIS (genre j'ai pas le temps démmerdez-vous) ça
> m'intéresserai si quelqu'un avait une ubuntu sur laquelle ça fonctionne
> de me donner le script que je vois s'il serait possible de l'adapter
> quitte à créer le répertoire /include/Make/. Merci.
>
_______________________________________________
Francophone mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/francophone
Reply | Threaded
Open this post in threaded view
|

Re: GRASS addon impossible à compiler

Adrien ANDRÉ
Bonjour,

je n'utilise que GRASS7 (Xubuntu 14.04),
Script.make local est identique à celui du trunk :
https://trac.osgeo.org/grass/browser/grass/trunk/include/Make/Script.make


Pour tester 6.4, quelle est la version de Fedora ?


Cordialement,

Adrien


Le 15/01/2016 23:50, Etienne DELAY a écrit :

> Bonjour Denis,
> Il faut que je regarde sur ma machine au bureau, mais il me semble que
> j'ai aussi le problème quand je compile grass7 (en tout cas j'ai un
> problème pour installer des modules).
>
> Je me souviens que j'avais testé une solution du genre ajouter le code
> source du module dans un répertoire spécifique avant la compilation pour
> en suite produire un bin contenant le module... Mais je ne retrouve plus
> la doc! :-S
>
> Etienne
>
>
> Cordialement
>
> Etienne DELAY (Skype : etienne.delay.tic)
> Chaire: Capital environnemental et gestion durable des cours d'eau
> laboratoire GEOLAB UMR 6042 CNRS
> Université de Limoges, FLSH
> 39E rue Camille Guérin 87036 Limoges
> blog : http://elcep.legtux.org
>
> Le 15/01/2016 12:15, FluxdO a écrit :
>> Bonjour,
>>
>> Merci pour la réponse.
>>
>> Oui je vois bien et le problème n'est pas que pour la fedora mais pour
>> tout ce qui n'est pas basé sur Ubuntu/kubuntu. Vu la réponse d'un des
>> développeurs de QGIS (genre j'ai pas le temps démmerdez-vous) ça
>> m'intéresserai si quelqu'un avait une ubuntu sur laquelle ça fonctionne
>> de me donner le script que je vois s'il serait possible de l'adapter
>> quitte à créer le répertoire /include/Make/. Merci.
>>
> _______________________________________________
> Francophone mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/francophone
_______________________________________________
Francophone mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/francophone
Reply | Threaded
Open this post in threaded view
|

Re: GRASS addon impossible à compiler

PolHyPro - FluxdO
Bonjour,

Merci. Je vais me mettre tous les scripts sur l'ordi et on verra si
j'arrive à en tirer quelque chose mais pas sûr d'avoir les compétences
nécessaires (ça fait bien longtemps que je n'ai pas fait de scripts de
compil) ni le temps de faire ça vite. Si j'obtiens un résultat je vous
le dirai. Si il y a des gens qui savent faire et qui s'ennuient, faut
pas hésiter à m'épargner cette peine.

J'ai une FC21 sur le portable et j'ai virer ma freebsd. Sans doutes que ça marche sur bsd compilé depuis les ports ?

--
-------------------------------------------

Linux magnetic.aboulafia 4.2.8-300.fc23.x86_64 Fedora core 23

El sáb, 16-01-2016 a las 12:35 +0100, Adrien ANDRÉ escribió:

> Bonjour,
>
> je n'utilise que GRASS7 (Xubuntu 14.04),
> Script.make local est identique à celui du trunk :
> https://trac.osgeo.org/grass/browser/grass/trunk/include/Make/Script.
> make
>
>
> Pour tester 6.4, quelle est la version de Fedora ?
>
>
> Cordialement,
>
> Adrien
>
>
> Le 15/01/2016 23:50, Etienne DELAY a écrit :
> > Bonjour Denis,
> > Il faut que je regarde sur ma machine au bureau, mais il me semble
> > que
> > j'ai aussi le problème quand je compile grass7 (en tout cas j'ai un
> > problème pour installer des modules).
> >
> > Je me souviens que j'avais testé une solution du genre ajouter le
> > code
> > source du module dans un répertoire spécifique avant la compilation
> > pour
> > en suite produire un bin contenant le module... Mais je ne retrouve
> > plus
> > la doc! :-S
> >
> > Etienne
> >
> >
> > Cordialement
> >
> > Etienne DELAY (Skype : etienne.delay.tic)
> > Chaire: Capital environnemental et gestion durable des cours d'eau
> > laboratoire GEOLAB UMR 6042 CNRS
> > Université de Limoges, FLSH
> > 39E rue Camille Guérin 87036 Limoges
> > blog : http://elcep.legtux.org
> >
> > Le 15/01/2016 12:15, FluxdO a écrit :
> > > Bonjour,
> > >
> > > Merci pour la réponse.
> > >
> > > Oui je vois bien et le problème n'est pas que pour la fedora mais
> > > pour
> > > tout ce qui n'est pas basé sur Ubuntu/kubuntu. Vu la réponse d'un
> > > des
> > > développeurs de QGIS (genre j'ai pas le temps démmerdez-vous) ça
> > > m'intéresserai si quelqu'un avait une ubuntu sur laquelle ça
> > > fonctionne
> > > de me donner le script que je vois s'il serait possible de
> > > l'adapter
> > > quitte à créer le répertoire /include/Make/. Merci.
> > >
> > _______________________________________________
> > Francophone mailing list
> > [hidden email]
> > http://lists.osgeo.org/mailman/listinfo/francophone
> _______________________________________________
> Francophone mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/francophone
_______________________________________________
Francophone mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/francophone
Reply | Threaded
Open this post in threaded view
|

Re: GRASS addon impossible à compiler

PolHyPro - FluxdO
In reply to this post by Adrien ANDRÉ
Est-ce que par hasard, le fichier Platform.make et Platform.make.in  se
raient identiques ? Le script appelle le premier, or seul le segond est
dispo sur le trunk de cette version.


Sinon j'ai fait deux choses (histoire de tout tracer sans rien oublier)
:- wget --mirror -p  https://trac.osgeo.org/grass/browser/grass/trunk/in
clude/Make/- et un lien : ln -s /usr/share/doc/grass/docs/html  /usr/lib64/grass-
6.4.4/docs/



Denis 

El sáb, 16-01-2016 a las 12:35 +0100, Adrien ANDRÉ escribió:

> Bonjour,
>
> je n'utilise que GRASS7 (Xubuntu 14.04),
> Script.make local est identique à celui du trunk :
> https://trac.osgeo.org/grass/browser/grass/trunk/include/Make/Script.
> make
>
>
> Pour tester 6.4, quelle est la version de Fedora ?
>
>
> Cordialement,
>
> Adrien
>
>
> Le 15/01/2016 23:50, Etienne DELAY a écrit :
> > Bonjour Denis,
> > Il faut que je regarde sur ma machine au bureau, mais il me semble
> > que
> > j'ai aussi le problème quand je compile grass7 (en tout cas j'ai un
> > problème pour installer des modules).
> >
> > Je me souviens que j'avais testé une solution du genre ajouter le
> > code
> > source du module dans un répertoire spécifique avant la compilation
> > pour
> > en suite produire un bin contenant le module... Mais je ne retrouve
> > plus
> > la doc! :-S
> >
> > Etienne
> >
> >
> > Cordialement
> >
> > Etienne DELAY (Skype : etienne.delay.tic)
> > Chaire: Capital environnemental et gestion durable des cours d'eau
> > laboratoire GEOLAB UMR 6042 CNRS
> > Université de Limoges, FLSH
> > 39E rue Camille Guérin 87036 Limoges
> > blog : http://elcep.legtux.org
> >
> > Le 15/01/2016 12:15, FluxdO a écrit :
> > > Bonjour,
> > >
> > > Merci pour la réponse.
> > >
> > > Oui je vois bien et le problème n'est pas que pour la fedora mais
> > > pour
> > > tout ce qui n'est pas basé sur Ubuntu/kubuntu. Vu la réponse d'un
> > > des
> > > développeurs de QGIS (genre j'ai pas le temps démmerdez-vous) ça
> > > m'intéresserai si quelqu'un avait une ubuntu sur laquelle ça
> > > fonctionne
> > > de me donner le script que je vois s'il serait possible de
> > > l'adapter
> > > quitte à créer le répertoire /include/Make/. Merci.
> > >
> > _______________________________________________
> > Francophone mailing list
> > [hidden email]
> > http://lists.osgeo.org/mailman/listinfo/francophone
> _______________________________________________
> Francophone mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/francophone
_______________________________________________
Francophone mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/francophone
Reply | Threaded
Open this post in threaded view
|

Re: GRASS addon impossible à compiler

Sylvain Maillard
Attention à prendre les bonnes versions des scripts !

Trunk = développement = 7.0.3 ...

pour GRASS 6.4, le dossier Make est dispo ici : https://trac.osgeo.org/grass/browser/grass/branches/releasebranch_6_4/include/Make
à priori il suffit de créer le répertoire au bon endroit et d'y copier tous les scripts ...


Sylvain


Le 16 janvier 2016 à 19:23, FluxdO <[hidden email]> a écrit :
Est-ce que par hasard, le fichier Platform.make et Platform.make.in  se
raient identiques ? Le script appelle le premier, or seul le segond est
dispo sur le trunk de cette version.


Sinon j'ai fait deux choses (histoire de tout tracer sans rien oublier)
:- wget --mirror -p  <a href="https://trac.osgeo.org/grass/browser/grass/trunk/in clude/Make/-" rel="noreferrer" target="_blank">https://trac.osgeo.org/grass/browser/grass/trunk/in
clude/Make/- et un lien : ln -s /usr/share/doc/grass/docs/html  /usr/lib64/grass-
6.4.4/docs/



Denis 

El sáb, 16-01-2016 a las 12:35 +0100, Adrien ANDRÉ escribió:
> Bonjour,
>
> je n'utilise que GRASS7 (Xubuntu 14.04),
> Script.make local est identique à celui du trunk :
> https://trac.osgeo.org/grass/browser/grass/trunk/include/Make/Script.
> make
>
>
> Pour tester 6.4, quelle est la version de Fedora ?
>
>
> Cordialement,
>
> Adrien
>
>
> Le 15/01/2016 23:50, Etienne DELAY a écrit :
> > Bonjour Denis,
> > Il faut que je regarde sur ma machine au bureau, mais il me semble
> > que
> > j'ai aussi le problème quand je compile grass7 (en tout cas j'ai un
> > problème pour installer des modules).
> >
> > Je me souviens que j'avais testé une solution du genre ajouter le
> > code
> > source du module dans un répertoire spécifique avant la compilation
> > pour
> > en suite produire un bin contenant le module... Mais je ne retrouve
> > plus
> > la doc! :-S
> >
> > Etienne
> >
> >
> > Cordialement
> >
> > Etienne DELAY (Skype : etienne.delay.tic)
> > Chaire: Capital environnemental et gestion durable des cours d'eau
> > laboratoire GEOLAB UMR 6042 CNRS
> > Université de Limoges, FLSH
> > 39E rue Camille Guérin 87036 Limoges
> > blog : http://elcep.legtux.org
> >
> > Le 15/01/2016 12:15, FluxdO a écrit :
> > > Bonjour,
> > >
> > > Merci pour la réponse.
> > >
> > > Oui je vois bien et le problème n'est pas que pour la fedora mais
> > > pour
> > > tout ce qui n'est pas basé sur Ubuntu/kubuntu. Vu la réponse d'un
> > > des
> > > développeurs de QGIS (genre j'ai pas le temps démmerdez-vous) ça
> > > m'intéresserai si quelqu'un avait une ubuntu sur laquelle ça
> > > fonctionne
> > > de me donner le script que je vois s'il serait possible de
> > > l'adapter
> > > quitte à créer le répertoire /include/Make/. Merci.
> > >
> > _______________________________________________
> > Francophone mailing list
> > [hidden email]
> > http://lists.osgeo.org/mailman/listinfo/francophone
> _______________________________________________
> Francophone mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/francophone
_______________________________________________
Francophone mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/francophone


_______________________________________________
Francophone mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/francophone
Reply | Threaded
Open this post in threaded view
|

Re: GRASS addon impossible à compiler

PolHyPro - FluxdO
Bonjour,

Oui en effet merci pour cette précision, j'avais omis ce «détail».

Ceci dit, détail en question corrigé, pour la compilation il faut avoir
un fichier grass.make or il n'y a qu'un grass.make.in
Quelles différences entre les deux ? Est-ce que je peux changer ans les
scripts les include grass.make en grass.make.in ?


El sáb, 16-01-2016 a las 21:29 +0100, Sylvain Maillard escribió:

> Attention à prendre les bonnes versions des scripts !
>
> Trunk = développement = 7.0.3 ...
>
> pour GRASS 6.4, le dossier Make est dispo ici : https://trac.osgeo.or
> g/grass/browser/grass/branches/releasebranch_6_4/include/Make
> à priori il suffit de créer le répertoire au bon endroit et d'y
> copier tous les scripts ...
>
>
> Sylvain
>
>
> Le 16 janvier 2016 à 19:23, FluxdO <[hidden email]> a écrit :
> > Est-ce que par hasard, le fichier Platform.make
> > et Platform.make.in  se
> > raient identiques ? Le script appelle le premier, or seul le segond
> > est
> > dispo sur le trunk de cette version.
> >
> >
> > Sinon j'ai fait deux choses (histoire de tout tracer sans rien
> > oublier)
> > :- wget --mirror -p  https://trac.osgeo.org/grass/browser/grass/tru
> > nk/in
> > clude/Make/- et un lien : ln -s
> > /usr/share/doc/grass/docs/html  /usr/lib64/grass-
> > 6.4.4/docs/
> >
> >
> >
> > Denis 
> >
> > El sáb, 16-01-2016 a las 12:35 +0100, Adrien ANDRÉ escribió:
> > > Bonjour,
> > >
> > > je n'utilise que GRASS7 (Xubuntu 14.04),
> > > Script.make local est identique à celui du trunk :
> > > https://trac.osgeo.org/grass/browser/grass/trunk/include/Make/Scr
> > ipt.
> > > make
> > >
> > >
> > > Pour tester 6.4, quelle est la version de Fedora ?
> > >
> > >
> > > Cordialement,
> > >
> > > Adrien
> > >
> > >
> > > Le 15/01/2016 23:50, Etienne DELAY a écrit :
> > > > Bonjour Denis,
> > > > Il faut que je regarde sur ma machine au bureau, mais il me
> > semble
> > > > que
> > > > j'ai aussi le problème quand je compile grass7 (en tout cas
> > j'ai un
> > > > problème pour installer des modules).
> > > >
> > > > Je me souviens que j'avais testé une solution du genre ajouter
> > le
> > > > code
> > > > source du module dans un répertoire spécifique avant la
> > compilation
> > > > pour
> > > > en suite produire un bin contenant le module... Mais je ne
> > retrouve
> > > > plus
> > > > la doc! :-S
> > > >
> > > > Etienne
> > > >
> > > >
> > > > Cordialement
> > > >
> > > > Etienne DELAY (Skype : etienne.delay.tic)
> > > > Chaire: Capital environnemental et gestion durable des cours
> > d'eau
> > > > laboratoire GEOLAB UMR 6042 CNRS
> > > > Université de Limoges, FLSH
> > > > 39E rue Camille Guérin 87036 Limoges
> > > > blog : http://elcep.legtux.org
> > > >
> > > > Le 15/01/2016 12:15, FluxdO a écrit :
> > > > > Bonjour,
> > > > >
> > > > > Merci pour la réponse.
> > > > >
> > > > > Oui je vois bien et le problème n'est pas que pour la fedora
> > mais
> > > > > pour
> > > > > tout ce qui n'est pas basé sur Ubuntu/kubuntu. Vu la réponse
> > d'un
> > > > > des
> > > > > développeurs de QGIS (genre j'ai pas le temps démmerdez-vous)
> > ça
> > > > > m'intéresserai si quelqu'un avait une ubuntu sur laquelle ça
> > > > > fonctionne
> > > > > de me donner le script que je vois s'il serait possible de
> > > > > l'adapter
> > > > > quitte à créer le répertoire /include/Make/. Merci.
> > > > >
> > > > _______________________________________________
> > > > Francophone mailing list
> > > > [hidden email]
> > > > http://lists.osgeo.org/mailman/listinfo/francophone
> > > _______________________________________________
> > > Francophone mailing list
> > > [hidden email]
> > > http://lists.osgeo.org/mailman/listinfo/francophone
> > _______________________________________________
> > Francophone mailing list
> > [hidden email]
> > http://lists.osgeo.org/mailman/listinfo/francophone
> >
> _______________________________________________
> Francophone mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/francophone
_______________________________________________
Francophone mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/francophone