[Fwd: Gusty update problem]

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Fwd: Gusty update problem]

mccue
  I answered Tim directly but I think I'm supposed to reply to the list
also.

------------------------------ Original Message ------------------------------
Subject: Re: [Qgis-developer] gusty update problem
From:    [hidden email]
Date:    Sun, January 6, 2008 9:50 am
To:      "Tim Sutton" <[hidden email]>
------------------------------------------------------------------------------

> Hi
>
> Yes you have multiple copies of qgis installed.
>
> 1) Does explicitly running /usr/bin/qgis work correctly?

Yes
>
> 2) Please show me the result of:
>
> dpkg -l | grep qgis

% dpkg -l | grep qgis
rc  libqgis0                                   0.7.4-5ubuntu1
   QGIS Geographic Information System - shared
ii  libqgis1                                   0.9.1-2
   QGIS Geographic Information System - shared
ii  libqgis1-dev                               0.9.1-2
   QGIS Geographic Information System - develop
ii  qgis                                       0.9.1-2
   Geographic Information System (GIS)
ii  qgis-plugin-grass                          0.9.1-2
   Plugin for accessing GRASS data from QGIS

I should note that I thought I had 9.0 as the old version but I really have
7.4, if I'm reading the above correctly.


>
> Regards
>
> Tim
>
> 2008/1/6, [hidden email] <[hidden email]>:
>>   An installation problem (leaving behind old version of qgis)
>>
>> Version of ubuntu
>>
>>   \etc\debian_version
>>   lenny/sid
>>
>> Make certain we are uptodate on qgis
>>
>>   % sudo apt-get install qgis qgis-plugin-grass
>>   Reading package lists... Done
>>   Building dependency tree
>>   Reading state information... Done
>>   qgis is already the newest version.
>>   qgis-plugin-grass is already the newest version.
>>   0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
>>
>> Run qgis
>>
>>   % qgis
>>   qgis:   error  while  loading  shared  libraries:   libgdal1.3.2.so.1:
cannot open shared object file:  No such file or directory
>>
>> Check out libgdal
>>
>>   % apt-cache search libgdal
>>   libgdal-doc - Documentation for the Geospatial Data Abstraction Library
libgdal1-1.4.0 - Geospatial Data Abstraction Library
>>   libgdal1-1.4.0-grass - GRASS extension for the Geospatial Data Abstraction
>> Lib
>>   libgdal1-dev - Geospatial Data Abstraction Library - Development files
>>
>> Check out qgis location
>>
>>   % whereis qgis
>>   qgis:       /usr/bin/qgis       /usr/lib/qgis      /usr/local/bin/qgis
/usr/local/lib/qgis /usr/include/qgis /usr/share/qgis
>>
>> Likely culprits
>>
>>   % lws /usr/local/bin/qgis
>>   -rwxr-xr-x 1 root root 3173399 2007-09-17 14:54 /usr/local/bin/qgis % lw
/usr/bin/qgis
>>   -rwxr-xr-x 1 root root 2688160 2007-12-21 05:23 /usr/bin/qgis
>>
>> Check $PATH order
>>
>>   echo $PATH
>>   /home/mccue/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:\
/bin:/usr/games:/home/mccue/bin:/usr/software/bin:\
>>   /home/mccue/projects/mixmod/MIXMOD/BIN
>>
>> Test out /usr/bin/qgis
>>
>>   /usr/bin/qgis  --help
>>   Quantum GIS - 0.9.1-Ganymede 'Ganymede' (unknown), plus more stuff
>>
>> Analysis:   qgis in  /usr/local/bin executed  first  and  is old (9.0)
version, which doesn't run under gusty but did under feisty,  as 1.3.2 was the
 version of libgdall used  for it.  I'm not  enough of a linux geek  to
 know  whether  my  upgrade to gusty from feisty  wasn't done correctly, or
whether the  qgis  install is supposed to remove the old version.   If the
latter, it should be fixed.  If the former, I should know more about linux.

>>
>> Ken McCue
>>
>>
>>
>> _______________________________________________
>> Qgis-developer mailing list
>> [hidden email]
>> http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-developer
>>
>
>
> --
> Tim Sutton
> QGIS Project Steering Committee Member - Release  Manager
> Visit http://qgis.org for a great open source GIS
> openModeller Desktop Developer
> Visit http://openModeller.sf.net for a great open source ecological niche
modelling tool
> Home Page: http://tim.linfiniti.com
> Skype: timlinux
> Irc: timlinux on #qgis at freenode.net
>






_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: [Fwd: Gusty update problem]

Tim Sutton
Hi

Sorry if I ever replied to your last email  - I lost track of where I
was in the conversation thread :-)

Ok so an oooolder deb on your system may explain it because the newer
ones all install to /usr not /usr/local.

Did you ever build yourself from source? Either way you will need to
clear out the qgis files from your /usr/local tree. I think if you do:

sudo rm /usr/local/bin/*qgis*
sudo rm -rf /usr/local/include/qgis
sudo rm /usr/local/lib/*qgis*
sudo rm -rf /usr/local/share/qgis

You should get it all removed. Please note the above commands perform
wildcard and recursive deletes on your system as root. Please check
carefully before you issue them and I dont take any responsibility if
something bad happens.

Regards

Tim


2008/1/7, [hidden email] <[hidden email]>:

>   I answered Tim directly but I think I'm supposed to reply to the list
> also.
>
> ------------------------------ Original Message ------------------------------
> Subject: Re: [Qgis-developer] gusty update problem
> From:    [hidden email]
> Date:    Sun, January 6, 2008 9:50 am
> To:      "Tim Sutton" <[hidden email]>
> ------------------------------------------------------------------------------
>
> > Hi
> >
> > Yes you have multiple copies of qgis installed.
> >
> > 1) Does explicitly running /usr/bin/qgis work correctly?
>
> Yes
> >
> > 2) Please show me the result of:
> >
> > dpkg -l | grep qgis
>
> % dpkg -l | grep qgis
> rc  libqgis0                                   0.7.4-5ubuntu1
>    QGIS Geographic Information System - shared
> ii  libqgis1                                   0.9.1-2
>    QGIS Geographic Information System - shared
> ii  libqgis1-dev                               0.9.1-2
>    QGIS Geographic Information System - develop
> ii  qgis                                       0.9.1-2
>    Geographic Information System (GIS)
> ii  qgis-plugin-grass                          0.9.1-2
>    Plugin for accessing GRASS data from QGIS
>
> I should note that I thought I had 9.0 as the old version but I really have
> 7.4, if I'm reading the above correctly.
>
>
> >
> > Regards
> >
> > Tim
> >
> > 2008/1/6, [hidden email] <[hidden email]>:
> >>   An installation problem (leaving behind old version of qgis)
> >>
> >> Version of ubuntu
> >>
> >>   \etc\debian_version
> >>   lenny/sid
> >>
> >> Make certain we are uptodate on qgis
> >>
> >>   % sudo apt-get install qgis qgis-plugin-grass
> >>   Reading package lists... Done
> >>   Building dependency tree
> >>   Reading state information... Done
> >>   qgis is already the newest version.
> >>   qgis-plugin-grass is already the newest version.
> >>   0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
> >>
> >> Run qgis
> >>
> >>   % qgis
> >>   qgis:   error  while  loading  shared  libraries:   libgdal1.3.2.so.1:
> cannot open shared object file:  No such file or directory
> >>
> >> Check out libgdal
> >>
> >>   % apt-cache search libgdal
> >>   libgdal-doc - Documentation for the Geospatial Data Abstraction Library
> libgdal1-1.4.0 - Geospatial Data Abstraction Library
> >>   libgdal1-1.4.0-grass - GRASS extension for the Geospatial Data Abstraction
> >> Lib
> >>   libgdal1-dev - Geospatial Data Abstraction Library - Development files
> >>
> >> Check out qgis location
> >>
> >>   % whereis qgis
> >>   qgis:       /usr/bin/qgis       /usr/lib/qgis      /usr/local/bin/qgis
> /usr/local/lib/qgis /usr/include/qgis /usr/share/qgis
> >>
> >> Likely culprits
> >>
> >>   % lws /usr/local/bin/qgis
> >>   -rwxr-xr-x 1 root root 3173399 2007-09-17 14:54 /usr/local/bin/qgis % lw
> /usr/bin/qgis
> >>   -rwxr-xr-x 1 root root 2688160 2007-12-21 05:23 /usr/bin/qgis
> >>
> >> Check $PATH order
> >>
> >>   echo $PATH
> >>   /home/mccue/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:\
> /bin:/usr/games:/home/mccue/bin:/usr/software/bin:\
> >>   /home/mccue/projects/mixmod/MIXMOD/BIN
> >>
> >> Test out /usr/bin/qgis
> >>
> >>   /usr/bin/qgis  --help
> >>   Quantum GIS - 0.9.1-Ganymede 'Ganymede' (unknown), plus more stuff
> >>
> >> Analysis:   qgis in  /usr/local/bin executed  first  and  is old (9.0)
> version, which doesn't run under gusty but did under feisty,  as 1.3.2 was the
>  version of libgdall used  for it.  I'm not  enough of a linux geek  to
>  know  whether  my  upgrade to gusty from feisty  wasn't done correctly, or
> whether the  qgis  install is supposed to remove the old version.   If the
> latter, it should be fixed.  If the former, I should know more about linux.
> >>
> >> Ken McCue
> >>
> >>
> >>
> >> _______________________________________________
> >> Qgis-developer mailing list
> >> [hidden email]
> >> http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-developer
> >>
> >
> >
> > --
> > Tim Sutton
> > QGIS Project Steering Committee Member - Release  Manager
> > Visit http://qgis.org for a great open source GIS
> > openModeller Desktop Developer
> > Visit http://openModeller.sf.net for a great open source ecological niche
> modelling tool
> > Home Page: http://tim.linfiniti.com
> > Skype: timlinux
> > Irc: timlinux on #qgis at freenode.net
> >
>
>
>
>
>
>
> _______________________________________________
> Qgis-developer mailing list
> [hidden email]
> http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-developer
>


--
Tim Sutton
QGIS Project Steering Committee Member - Release  Manager
Visit http://qgis.org for a great open source GIS
openModeller Desktop Developer
Visit http://openModeller.sf.net for a great open source ecological
niche modelling tool
Home Page: http://tim.linfiniti.com
Skype: timlinux
Irc: timlinux on #qgis at freenode.net
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: [Fwd: Gusty update problem]

mccue
> Hi
>
> Sorry if I ever replied to your last email  - I lost track of where I
> was in the conversation thread :-)
>
> Ok so an oooolder deb on your system may explain it because the newer
> ones all install to /usr not /usr/local.

>
> Did you ever build yourself from source?

I must have at one point though 7.4 is pretty old, which seems to be
the version of the old qgis (the dates were September of 2007 which
would have been 9.0 at the time).

> Either way you will need to
> clear out the qgis files from your /usr/local tree. I think if you do:
>
> sudo rm /usr/local/bin/*qgis*
> sudo rm -rf /usr/local/include/qgis
> sudo rm /usr/local/lib/*qgis*
> sudo rm -rf /usr/local/share/qgis

This worked. The third command

> sudo rm /usr/local/lib/*qgis*

had to be changed to

> sudo rm -rf /usr/local/lib/qgis/*


>
> You should get it all removed. Please note the above commands perform
> wildcard and recursive deletes on your system as root. Please check
> carefully before you issue them and I dont take any responsibility if
> something bad happens.
>
> Regards
>
> Tim
>
>
> 2008/1/7, [hidden email] <[hidden email]>:
>>   I answered Tim directly but I think I'm supposed to reply to the list
>> also.
>>
>> ------------------------------ Original Message
>> ------------------------------
>> Subject: Re: [Qgis-developer] gusty update problem
>> From:    [hidden email]
>> Date:    Sun, January 6, 2008 9:50 am
>> To:      "Tim Sutton" <[hidden email]>
>> ------------------------------------------------------------------------------
>>
>> > Hi
>> >
>> > Yes you have multiple copies of qgis installed.
>> >
>> > 1) Does explicitly running /usr/bin/qgis work correctly?
>>
>> Yes
>> >
>> > 2) Please show me the result of:
>> >
>> > dpkg -l | grep qgis
>>
>> % dpkg -l | grep qgis
>> rc  libqgis0                                   0.7.4-5ubuntu1
>>    QGIS Geographic Information System - shared
>> ii  libqgis1                                   0.9.1-2
>>    QGIS Geographic Information System - shared
>> ii  libqgis1-dev                               0.9.1-2
>>    QGIS Geographic Information System - develop
>> ii  qgis                                       0.9.1-2
>>    Geographic Information System (GIS)
>> ii  qgis-plugin-grass                          0.9.1-2
>>    Plugin for accessing GRASS data from QGIS
>>
>> I should note that I thought I had 9.0 as the old version but I really have
>> 7.4, if I'm reading the above correctly.
>>
>>
>> >
>> > Regards
>> >
>> > Tim
>> >
>> > 2008/1/6, [hidden email] <[hidden email]>:
>> >>   An installation problem (leaving behind old version of qgis)
>> >>
>> >> Version of ubuntu
>> >>
>> >>   \etc\debian_version
>> >>   lenny/sid
>> >>
>> >> Make certain we are uptodate on qgis
>> >>
>> >>   % sudo apt-get install qgis qgis-plugin-grass
>> >>   Reading package lists... Done
>> >>   Building dependency tree
>> >>   Reading state information... Done
>> >>   qgis is already the newest version.
>> >>   qgis-plugin-grass is already the newest version.
>> >>   0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
>> >>
>> >> Run qgis
>> >>
>> >>   % qgis
>> >>   qgis:   error  while  loading  shared  libraries:   libgdal1.3.2.so.1:
>> cannot open shared object file:  No such file or directory
>> >>
>> >> Check out libgdal
>> >>
>> >>   % apt-cache search libgdal
>> >>   libgdal-doc - Documentation for the Geospatial Data Abstraction Library
>> libgdal1-1.4.0 - Geospatial Data Abstraction Library
>> >>   libgdal1-1.4.0-grass - GRASS extension for the Geospatial Data
>> Abstraction
>> >> Lib
>> >>   libgdal1-dev - Geospatial Data Abstraction Library - Development files
>> >>
>> >> Check out qgis location
>> >>
>> >>   % whereis qgis
>> >>   qgis:       /usr/bin/qgis       /usr/lib/qgis      /usr/local/bin/qgis
>> /usr/local/lib/qgis /usr/include/qgis /usr/share/qgis
>> >>
>> >> Likely culprits
>> >>
>> >>   % lws /usr/local/bin/qgis
>> >>   -rwxr-xr-x 1 root root 3173399 2007-09-17 14:54 /usr/local/bin/qgis %
>> lw
>> /usr/bin/qgis
>> >>   -rwxr-xr-x 1 root root 2688160 2007-12-21 05:23 /usr/bin/qgis
>> >>
>> >> Check $PATH order
>> >>
>> >>   echo $PATH
>> >>   /home/mccue/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:\
>> /bin:/usr/games:/home/mccue/bin:/usr/software/bin:\
>> >>   /home/mccue/projects/mixmod/MIXMOD/BIN
>> >>
>> >> Test out /usr/bin/qgis
>> >>
>> >>   /usr/bin/qgis  --help
>> >>   Quantum GIS - 0.9.1-Ganymede 'Ganymede' (unknown), plus more stuff
>> >>
>> >> Analysis:   qgis in  /usr/local/bin executed  first  and  is old (9.0)
>> version, which doesn't run under gusty but did under feisty,  as 1.3.2 was
>> the
>>  version of libgdall used  for it.  I'm not  enough of a linux geek  to
>>  know  whether  my  upgrade to gusty from feisty  wasn't done correctly, or
>> whether the  qgis  install is supposed to remove the old version.   If the
>> latter, it should be fixed.  If the former, I should know more about linux.
>> >>
>> >> Ken McCue
>> >>
>> >>
>> >>
>> >> _______________________________________________
>> >> Qgis-developer mailing list
>> >> [hidden email]
>> >> http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-developer
>> >>
>> >
>> >
>> > --
>> > Tim Sutton
>> > QGIS Project Steering Committee Member - Release  Manager
>> > Visit http://qgis.org for a great open source GIS
>> > openModeller Desktop Developer
>> > Visit http://openModeller.sf.net for a great open source ecological niche
>> modelling tool
>> > Home Page: http://tim.linfiniti.com
>> > Skype: timlinux
>> > Irc: timlinux on #qgis at freenode.net
>> >
>>
>>
>>
>>
>>
>>
>> _______________________________________________
>> Qgis-developer mailing list
>> [hidden email]
>> http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-developer
>>
>
>
> --
> Tim Sutton
> QGIS Project Steering Committee Member - Release  Manager
> Visit http://qgis.org for a great open source GIS
> openModeller Desktop Developer
> Visit http://openModeller.sf.net for a great open source ecological
> niche modelling tool
> Home Page: http://tim.linfiniti.com
> Skype: timlinux
> Irc: timlinux on #qgis at freenode.net
>


_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-developer