First Steps in mapserver

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

First Steps in mapserver

deegree deegree
Hi!!!

I'm starting to work with mapserver in Windows. And I find the next error:

loadWeb(): Unknown identifier. Parsing error near (C):(line 1)

I don't find  the answer for this mistake.

I enclose below the code, that I think it doesn't work

 WEB
    HEADER ms4w/apps/siglibre/templates/header.html
    TEMPLATE ms4w/apps/siglibre/index.html
    FOOTER 'ms4w/apps/siglibre/templates/footer_querymap.html'
    MINSCALE 1000
    MAXSCALE 4000000
    IMAGEPATH "/ms4w/apache/htdocs/tmp/"
    IMAGEURL "/tmp/"
  END


Thanks
_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: First Steps in mapserver

Bart van den Eijnden (OSGIS)-2
Use (double) quotes around your HEADER and TEMPLATES values.

Best regards,
Bart

--
Bart van den Eijnden
OSGIS, Open Source GIS
http://www.osgis.nl


--------- Oorspronkelijk bericht --------
Van: deegree deegree <[hidden email]>
Naar: [hidden email] <[hidden email]>
Onderwerp: [mapserver-users] First Steps in mapserver
Datum: 01/04/08 06:51

> Hi!!!
>
> I&#39;m starting to work with mapserver in Windows. And I find the next
error:

>
>
> loadWeb(): Unknown identifier. Parsing error near (C):(line 1)
>
> I don&#39;t find&nbsp; the answer for this mistake.
>
> I enclose below the code, that I think it doesn&#39;t work
>
> &nbsp;WEB
> &nbsp;&nbsp;&nbsp; HEADER ms4w/apps/siglibre/templates/header.html
> &nbsp;&nbsp;&nbsp; TEMPLATE ms4w/apps/siglibre/index.html
> &nbsp;&nbsp;&nbsp; FOOTER
&#39;ms4w/apps/siglibre/templates/footer_querymap.html&#39;

> &nbsp;&nbsp;&nbsp; MINSCALE 1000
> &nbsp;&nbsp;&nbsp; MAXSCALE 4000000
> &nbsp;&nbsp;&nbsp; IMAGEPATH &quot;/ms4w/apache/htdocs/tmp/&quot;
> &nbsp;&nbsp;&nbsp; IMAGEURL &quot;/tmp/&quot;
> &nbsp; END
>
>
> Thanks
>
>
>
>
>
> _______________________________________________
> mapserver-users mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/mapserver-users
>



_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: First Steps in mapserver

D_Guidi
In reply to this post by deegree deegree
>  I'm starting to work with mapserver in Windows. And I find the next error:
>  loadWeb(): Unknown identifier. Parsing error near (C):(line 1)
>  I don't find  the answer for this mistake.

http://www.google.com/search?client=safari&rls=en&q=%2Bmapserver%20%2Bmapfile&ie=UTF-8&oe=UTF-8
Enjoy the readings ;)
_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: First Steps in mapserver

gregoriomunoz
In reply to this post by deegree deegree
Try using double quotes:

  WEB
    HEADER "ms4w/apps/siglibre/templates/header.html"
    TEMPLATE "ms4w/apps/siglibre/index.html"
    FOOTER "ms4w/apps/siglibre/templates/footer_querymap.html"
    MINSCALE 1000
    MAXSCALE 4000000
    IMAGEPATH "/ms4w/apache/htdocs/tmp/"
    IMAGEURL "/tmp/"
  END


2008/4/1, deegree deegree <[hidden email]>:
Hi!!!

I'm starting to work with mapserver in Windows. And I find the next error:

loadWeb(): Unknown identifier. Parsing error near (C):(line 1)

I don't find  the answer for this mistake.

I enclose below the code, that I think it doesn't work

 WEB
    HEADER ms4w/apps/siglibre/templates/header.html
    TEMPLATE ms4w/apps/siglibre/index.html
    FOOTER 'ms4w/apps/siglibre/templates/footer_querymap.html'
    MINSCALE 1000
    MAXSCALE 4000000
    IMAGEPATH "/ms4w/apache/htdocs/tmp/"
    IMAGEURL "/tmp/"
  END


Thanks
_______________________________________________
mapserver-users mailing list
[hidden email]
<a onclick="return top.js.OpenExtLink(window,event,this)" href="http://lists.osgeo.org/mailman/listinfo/mapserver-users" target="_blank">http://lists.osgeo.org/mailman/listinfo/mapserver-users



_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: First Steps in mapserver

Jeff McKenna-2
In reply to this post by deegree deegree
There were changes in MapServer 5.0 for CGI mode in the way you declare
variables in the URL, causing your "parse error line 1" problems.  See
the "URL Configuration Changes" in:
http://trac.osgeo.org/mapserver/browser/branches/branch-5-0/mapserver/MIGRATION_GUIDE.TXT

For example, in your CGI template you might have a variable that looks like:

<input type="hidden" name="map_web" value="imagepath /ms4w/tmp/ms_tmp/
imageurl /ms_tmp/">


-jeff




deegree deegree wrote:

> Hi!!!
>
> I'm starting to work with mapserver in Windows. And I find the next error:
>
> loadWeb(): Unknown identifier. Parsing error near (C):(line 1)
>
> I don't find  the answer for this mistake.
>
> I enclose below the code, that I think it doesn't work
>
>  WEB
>     HEADER ms4w/apps/siglibre/templates/header.html
>     TEMPLATE ms4w/apps/siglibre/index.html
>     FOOTER 'ms4w/apps/siglibre/templates/footer_querymap.html'
>     MINSCALE 1000
>     MAXSCALE 4000000
>     IMAGEPATH "/ms4w/apache/htdocs/tmp/"
>     IMAGEURL "/tmp/"
>   END
>
>
> Thanks
>
_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: First Steps in mapserver

Jeff McKenna-2
In reply to this post by deegree deegree



_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users

GWAVA_1#message.txt (1K) Download Attachment
GWAVADAT.TXT (40 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: First Steps in mapserver

Jeff McKenna-2
In reply to this post by deegree deegree



_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users

GWAVA_1#message.txt (1K) Download Attachment
GWAVADAT.TXT (40 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: First Steps in mapserver

Jeff McKenna-2
In reply to this post by deegree deegree



_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users

GWAVA_1#message.txt (1K) Download Attachment
GWAVADAT.TXT (40 bytes) Download Attachment