Filter exception question

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Filter exception question

dblasby
Eli,

queries:
  Query []
   feature type: stvu:waypoints_2d&FILTER=<Filter xmlns="http://
www.opengis.net/ogc" xmlns:gml="http://www.opengis.net/
gml"><PropertyIsEqualTo><PropertyName>target_id</PropertyName>
<Literal>2</Literal>
</PropertyIsEqualTo>
</Filter>

Its appears that it thinks your feature type is
"stvu:waypoints_2d&FILTER=<Filter xmlns="http:// www.opengis.net/ogc"
xmlns:gml="http://www.opengis.net/
gml"><PropertyIsEqualTo><PropertyName>target_id</PropertyName>
<Literal>2</Literal>
</PropertyIsEqualTo>
</Filter> "

Which is very strange:
1. check that the url you are issuing your request with is correct (it
you are not double-url encoding the "&".  What is the URL you are using
to query with?
2. try it using XML POST


dave



----------------------------------------------------------
This mail sent through IMP: https://webmail.limegroup.com/


-------------------------------------------------------
SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
from IBM. Find simple to follow Roadmaps, straightforward articles,
informative Webcasts and more! Get everything you need to get up to
speed, fast. http://ads.osdn.com/?ad_id=7477&alloc_id=16492&op=click
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users