Noch eine Anmerkung: Sie können die Inhalte des Cache-Verzeichnisses
löschen und den Befehl nochmal ausführen.
In der Doku steht der Ort der Cache-Verzeichnisse innerhalb von
Mapbender3 (app/cache). Dort finden sie ein prod- und eventuell ein
dev-Unterverzeichnis. Diese beiden Verzeichnisse können Sie löschen.
in english, also for the other readers of this mailing-list. I was in
contact with Mr. Kellermann and we looked a bit deeper into the issue.
Here are the results.
In general the problem occurs because of the PHP 5.3 version which has
reached the "end of life" status in August 2014. Unfortunetaly Ubuntu 12
delivers 5.3.10 (latest 5.3 is 5.3.29) but offers no official repository
for newer PHP versions.
Mapbender requires PHP 5.4 or newer. Although MB 126.96.36.199 is running
on the system, the doctrine-cache library, which throws the error, was
updated during the versions and leads to the error message at the
You could replace the vendor/doctrine/cache directory with the 188.8.131.52
version but this is only a workaround and doesn't change the issue with
the outdated PHP version and may lead to runtime-errors. The PHP 5.3
also has some errors with the composer update mechanism and needs more
RAM than using composer with PHP 5.4.
I'm sorry that I can't give you a better solution.
Von: Mapbender_users [mailto:[hidden email]]
Im Auftrag von Armin Retterath Gesendet: Dienstag, 16. Februar 2016 21:22 An: Mapbender User List Betreff: Re: [Mapbender-users] Fehlermeldung update mapbender184.108.40.206
also doch en grund endlich zu debian zu wechseln ;-)
I understand the question and I understand that you, Marc, cannot update
easily to another system than SuSe. SLES 11.4 seems to be supported by
Suse until 2019 and at that time PHP 5.3 is "end of life" for nearly 5
years. I wouldn't be "abgeneigt" also (personal opinion).
But however. I cannot answer the technical details of the compatibility
of MB3 right now. The compatiblity of 3.0.5 is on PHP 5.4 and I will ask
our architect next week about the background behind it. I will keep you
informed about that.
The question of PHP 5.3 is a bit complicated to answer but with a simple
solution: Mapbender3 is running under PHP 5.3 but with some remarks.
Some libraries require PHP 5.3.19 or greater but they are only needed
for the Development-mode (app_dev.php) of Mapbender. Therefore it's
possible to run Mapbender on PHP > 5.3.19 and for versions below that
it's possible but has to be build a special way (see the Technobabble
Our Mapbender Code is written compliant to PHP 5.3. Our base for this
decision is the Symfony Framework that we use. If we are going to change
that version we have to switch to a higher PHP version.
Second: The libraries in the vendor directory are downloaded with
Composer (composer.phar update). Which version Composer will download
depends on the PHP version on which that command is called. For greater
PHP version composer will download newer versions than on older PHP
versions. These libraries get updated by the specific companies or
developers and we don't have a influence on them.
If you run that on PHP 5.3 you will see that the library
facebook/webdriver needs PHP >= 5.3.19. This is a library we need in the
dev-mode and which is referred under "require-dev" in composer.json.
With lower PHP versions composer cannot download that library and the
command will not finish successfully. You can run composer update with
the command: "composer update -o --no-dev" and this will update the
necessary vendor packages but not the ones under require-dev and
therefore not the facebook/webdriver. Sometimes this command will lead
to a memory error on PHP 5.3 (proc_open(): fork failed). This is
something related to the PHP 5.3 issues and doesn't happen with higher
PHP versions. You can run composer update on PHP 5.4 to avoid that
issues. The facebook driver will be compliant to 5.3.19.
I hope that helps you out and clears some of the views about it.
WhereGroup GmbH & Co. KG