Fehlermeldung Mapbender <-> Mapserver

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Fehlermeldung Mapbender <-> Mapserver

WPGIS

Hallo Liste,

 

ich habe in unser Mapbender-Projekt einige WMS-Dienste mit dem Mapserver eingebunden und bekomme unten stehende Fehlermeldung. Ich konnte bisher weder identifizieren wann die Meldung kommt noch was sie mir sagen will.


WP  WPgis

 

Im Log der Map stehen sehr viele Einträge wie z.b:

 

[Wed Apr 25 09:29:07 2018].919000 msGEOSError(): GEOS library error. ÌÕ

 

Könnte das der Fehler sein? Und wenn ja, weiss jemand wie ich das behebe? Wenn ich mir das Projekt im app_dev anschaue kommt die Fehlermeldung übrigens nicht (zumindest bisher nicht), die update_mapbender_web.bat habe ich bereits ausgeführt.

 

Vielen Dank und Gruß,

Markus


_______________________________________________
Mapbender_users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_users
Reply | Threaded
Open this post in threaded view
|

Re: Fehlermeldung Mapbender <-> Mapserver

Charlotte Toma

Hallo Markus,

die Fehlermeldungen zu GEOS oder Shapely kenne ich bisher unter Windows nur vom MapProxy... Da muss man das einfach im Nachgang installieren und es läuft.

  • Was steht denn im Mapbender Log-File unter app/logs/ - kommen hier andere Fehlermeldungen?
  • Kannst du die Dienste in QGIS laden oder in einer anderen Mapbender-Installation, z.B. unter demo.mapbender.org? 
  • Kannst du die Dienste in der Mapbender-Administration als Dienstquelle laden und erst beim Aufruf in der Anwendung kommt der Fehler oder hast du deine Dienste über den Button in der Anwendungsoberfläche getestet und dann kam der Fehler?

Du kannst dich gern mal bei mir melden ~ ich vermute mal es liegt nicht am Mapbender sondern fehlerhafter Einrichtung des Systems/ Mapfile : )

Viele Grüße

Charly

-- 
Mit freundlichen Grüßen

Charlotte Toma
GIS-Consultant

-----------------------------------
Aufwind durch Wissen!
Qualifizierte Open-Source-Schulungen
bei der www.foss-academy.com
-----------------------------------

Charlotte Toma
WhereGroup GmbH & Co.KG
Eifelstraße 7
53119 Bonn
Germany

Fon: +49(0)228 90 90 38 - 24
Fax: +49(0)228 90 90 38 - 11

[hidden email]
www.wheregroup.com
Amtsgericht Bonn, HRA 6788
-------------------------------
Komplementärin:
WhereGroup Verwaltungs GmbH
vertreten durch:
Olaf Knopp, Peter Stamm
Am 25.04.2018 um 12:02 schrieb Markus Lütke Brintrup:

Hallo Liste,

 

ich habe in unser Mapbender-Projekt einige WMS-Dienste mit dem Mapserver eingebunden und bekomme unten stehende Fehlermeldung. Ich konnte bisher weder identifizieren wann die Meldung kommt noch was sie mir sagen will.


 

Im Log der Map stehen sehr viele Einträge wie z.b:

 

[Wed Apr 25 09:29:07 2018].919000 msGEOSError(): GEOS library error. ÌÕ

 

Könnte das der Fehler sein? Und wenn ja, weiss jemand wie ich das behebe? Wenn ich mir das Projekt im app_dev anschaue kommt die Fehlermeldung übrigens nicht (zumindest bisher nicht), die update_mapbender_web.bat habe ich bereits ausgeführt.

 

Vielen Dank und Gruß,

Markus




_______________________________________________
Mapbender_users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_users
Reply | Threaded
Open this post in threaded view
|

Re: Fehlermeldung Mapbender <-> Mapserver

WPGIS

Guten Morgen,

 

ich hatte gerade wieder die Fehlermeldung und habe direkt in das Log-File unter app/logs/ geschaut, da steht nichts mit dem heutigen Datum.

Der WMS-Dienst funktioniert in QGIS einwandfrei und in der Mapbender-Administration kann ich den ohne Weiteres laden/aktualisieren, der Fehler kommt erst in der Anwendung. Wann der genau kommt konnte ich noch nicht feststellen, aber der tritt erst auf seitdem ich mehrere Mapserver-WMS eingebaut hatte, und dann während ich rein oder raus scrolle. Allerdings habe ich zusammen mit Astrid vor längerer Zeit einen Mapserver-WMS eingebaut, da kam der Fehler nicht, also muss es eigentlich an den neuen Map-Dateien liegen.

 

Extern kann ich den WMS-Dienst nicht einbinden, der ist nur für den internen Gebrauch ausgelegt. Ich habe aber inzwischen bei der Fehlersuche gemerkt, dass der Fehler nur auftaucht, wenn ich von meinem PC aus Mapbender (mit Firefox) ansteuere. Wenn ich auf dem Server bin, auf dem Mapbender und Mapserver installiert sind, kommt der Fehler nicht, das erklärt auch warum der Fehler im app_dev-Modus nicht auftritt.

 

Viele Grüße,

Markus

 

 

Von: Charlotte Toma [mailto:[hidden email]]
Gesendet: Mittwoch, 25. April 2018 13:17
An: Mapbender User List <[hidden email]>; Markus Lütke Brintrup <[hidden email]>
Betreff: Re: [Mapbender-users] Fehlermeldung Mapbender <-> Mapserver

 

Hallo Markus,

die Fehlermeldungen zu GEOS oder Shapely kenne ich bisher unter Windows nur vom MapProxy... Da muss man das einfach im Nachgang installieren und es läuft.

  • Was steht denn im Mapbender Log-File unter app/logs/ - kommen hier andere Fehlermeldungen?
  • Kannst du die Dienste in QGIS laden oder in einer anderen Mapbender-Installation, z.B. unter demo.mapbender.org? 
  • Kannst du die Dienste in der Mapbender-Administration als Dienstquelle laden und erst beim Aufruf in der Anwendung kommt der Fehler oder hast du deine Dienste über den Button in der Anwendungsoberfläche getestet und dann kam der Fehler?

Du kannst dich gern mal bei mir melden ~ ich vermute mal es liegt nicht am Mapbender sondern fehlerhafter Einrichtung des Systems/ Mapfile : )

Viele Grüße

Charly

-- 
Mit freundlichen Grüßen
 
Charlotte Toma
GIS-Consultant
 
-----------------------------------
Aufwind durch Wissen!
Qualifizierte Open-Source-Schulungen
bei der www.foss-academy.com
-----------------------------------
 
Charlotte Toma
WhereGroup GmbH & Co.KG
Eifelstraße 7
53119 Bonn
Germany
 
Fon: +49(0)228 90 90 38 - 24
Fax: +49(0)228 90 90 38 - 11
 
[hidden email]
www.wheregroup.com
Amtsgericht Bonn, HRA 6788
-------------------------------
Komplementärin:
WhereGroup Verwaltungs GmbH
vertreten durch:
Olaf Knopp, Peter Stamm

Am 25.04.2018 um 12:02 schrieb Markus Lütke Brintrup:

Hallo Liste,

 

ich habe in unser Mapbender-Projekt einige WMS-Dienste mit dem Mapserver eingebunden und bekomme unten stehende Fehlermeldung. Ich konnte bisher weder identifizieren wann die Meldung kommt noch was sie mir sagen will.



 

Im Log der Map stehen sehr viele Einträge wie z.b:

 

[Wed Apr 25 09:29:07 2018].919000 msGEOSError(): GEOS library error. ÌÕ

 

Könnte das der Fehler sein? Und wenn ja, weiss jemand wie ich das behebe? Wenn ich mir das Projekt im app_dev anschaue kommt die Fehlermeldung übrigens nicht (zumindest bisher nicht), die update_mapbender_web.bat habe ich bereits ausgeführt.

 

Vielen Dank und Gruß,

Markus

 

 


_______________________________________________
Mapbender_users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_users