FeatureInfo not working on Android and IOs

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

FeatureInfo not working on Android and IOs

Hardy
Hi,

when using FeatureInfo with Tablet based on Android or IOs we get no
information.
Only text "XML Document".
Tried with simple html "Hello World" or iframe.
No featureinfo will be displayed.
On windows it's working fine.

Any hint?

Regards
Hardy



--
Sent from: http://osgeo-org.1560.x6.nabble.com/mapbender-users-f4220788.html
_______________________________________________
Mapbender_users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_users
Reply | Threaded
Open this post in threaded view
|

Re: FeatureInfo not working on Android and IOs

Astrid Emde (WhereGroup)
Hello Hardy,

does this behaviour appear in one application or in two different
applications?

Please check the infoformat of the WMS-Instance. It should say
text/html.

And please check with F12 whether you get an error message.

Regards
Astrid


Am 2020-04-25 14:34, schrieb Hardy:

> Hi,
>
> when using FeatureInfo with Tablet based on Android or IOs we get no
> information.
> Only text "XML Document".
> Tried with simple html "Hello World" or iframe.
> No featureinfo will be displayed.
> On windows it's working fine.
>
> Any hint?
>
> Regards
> Hardy
>
>
>
> --
> Sent from:
> http://osgeo-org.1560.x6.nabble.com/mapbender-users-f4220788.html
> _______________________________________________
> Mapbender_users mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/mapbender_users

--
Mit freundlichen Grüßen

Astrid Emde
GIS-Consultant

   Astrid Emde
   WhereGroup GmbH
   Eifelstraße 7
   53119 Bonn
   Germany

   Fon: +49(0)228 90 90 38 - 22
   Fax: +49(0)228 90 90 38 - 11

   [hidden email]
   www.wheregroup.com

   Folgen Sie der WhereGroup auf twitter:
http://twitter.com/WhereGroup_com

Geschäftsführer:
Olaf Knopp, Peter Stamm
Amtsgericht Bonn, HRB 9885
-------------------------------
_______________________________________________
Mapbender_users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_users
Reply | Threaded
Open this post in threaded view
|

Re: FeatureInfo not working on Android and IOs

Hardy
Hi Astrid,

format is set to text/html.

The error appears on different applications. Build in and user defined.
Even the mobile one.

I have checked wms from different server (map server, geoserver) and from
different machines (WinServer2016).
Any time the same error "[object XML Document]" on Chrome / Android.
On IOs there is no message. Only a blank area.
Windows browser (edge, chrome, opera,firefox) are displaying fine.

What's wrong?

Hardy



--
Sent from: http://osgeo-org.1560.x6.nabble.com/mapbender-users-f4220788.html
_______________________________________________
Mapbender_users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_users