Fdo 3.7 is based on .net framework 3.5 not 2.0?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Fdo 3.7 is based on .net framework 3.5 not 2.0?

lifan-tg
This post has NOT been accepted by the mailing list yet.
Hi all,

I have downloaded Fdo 3.7 from svn, after I build the code, I found the dlls are .net framework 3.5, however I remember the original Fdo assemblies are .net framework 2.0, and my application is also 2.0, now fdo is 3.5 that my application couldn't run any more.

Does anyone know how to build fdo still in .net framework 2.0?

Thanks,
James
Reply | Threaded
Open this post in threaded view
|

Re: Fdo 3.7 is based on .net framework 3.5 not 2.0?

Jackie Ng
Is there anything stopping you from moving your code to .net Framework 3.5?

3.5 uses the same CLR as 2.0

The supported .net version for FDO is dictated by which version of Visual Studio we have project files for.

For 3.7 we only maintain VS 2008 and VS 2010 project files, meaning our supported .net versions are 3.5 and 4.0. Though for official binary releases, we build using VS 2010 so the official .net version is actually 4.0

- Jackie