Failing installing GDAL extension

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Failing installing GDAL extension

Stefano Iacovella
Hi all,

I am finding troubles getting the GDAL extension to work.
I am working on an ubuntu machine with GDAL 1.11

stefano@ubuntu1204x64vm:~/temp$ gdalinfo --version
GDAL 1.11.0, released 2014/04/16

I compiled them from source.

GeoServer is instaleld as a war deployed on Tomcat 7.0.42 with this JRE:

stefano@ubuntu1204x64vm:~/temp$ java -version
java version "1.6.0_37"
Java(TM) SE Runtime Environment (build 1.6.0_37-b06)
Java HotSpot(TM) 64-Bit Server VM (build 20.12-b01, mixed mode)

I tried to follow the instructions here http://docs.geoserver.org/stable/en/user/data/raster/gdal.html, adapting them at my GDAL release.
As stated I downloaded the GDAL extension and saved all the jar files in the lib folder under geoserver.
Then downloaded the imageio-ext-1.1.10-jars.zip archive and copied the jar contained again in the lib folder. This step is a little confusing to me as most of the jar contained are already in the GDAL extension archive.

I modified the startup script for GeoServer, /etc/init.d/tomcat including this two variables:

export GDAL_DATA=/usr/local/share/gdal
export LD_LIBRARY_PATH=/usr/local/lib

Then started again GeoServer. I can't find any error in the log, that is included at this message, but the GDAl formats are not shown in the web interface.
Am I missing something?

Thank you for your hints

Stefano
---------------------------------------------------
41.95581N 12.52854E


http://www.linkedin.com/in/stefanoiacovella

http://twitter.com/#!/Iacovellas

------------------------------------------------------------------------------
Want fast and easy access to all the code in your enterprise? Index and
search up to 200,000 lines of code with a free copy of Black Duck
Code Sight - the same software that powers the world's largest code
search on Ohloh, the Black Duck Open Hub! Try it now.
http://p.sf.net/sfu/bds
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users

geoserver.log (20K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Failing installing GDAL extension

Daniele Romagnoli-3
Hi Stefano,
please read below...





On Mon, Jul 21, 2014 at 12:08 PM, Stefano Iacovella <[hidden email]> wrote:
Hi all,

I am finding troubles getting the GDAL extension to work.
I am working on an ubuntu machine with GDAL 1.11

stefano@ubuntu1204x64vm:~/temp$ gdalinfo --version
GDAL 1.11.0, released 2014/04/16

I compiled them from source.

GeoServer is instaleld as a war deployed on Tomcat 7.0.42 with this JRE:

stefano@ubuntu1204x64vm:~/temp$ java -version
java version "1.6.0_37"
Java(TM) SE Runtime Environment (build 1.6.0_37-b06)
Java HotSpot(TM) 64-Bit Server VM (build 20.12-b01, mixed mode)

I tried to follow the instructions here http://docs.geoserver.org/stable/en/user/data/raster/gdal.html, adapting them at my GDAL release.
As stated I downloaded the GDAL extension and saved all the jar files in the lib folder under geoserver.
Then downloaded the imageio-ext-1.1.10-jars.zip archive and copied the jar contained again in the lib folder. This step is a little confusing to me as most of the jar contained are already in the GDAL extension archive.
That step is not needed indeed. The documentation provides instructions to install the CRS definitions and native libs since the JARs are already available in the GeoServer extension.
That being said, the imageio-ext has been developed/tested against GDAL 1.9.2. Not sure if it will work against a newer version of GDAL (native bindings/methods signature may have been changed since that version).
However, let's move to the next question...
 

I modified the startup script for GeoServer, /etc/init.d/tomcat including this two variables:

export GDAL_DATA=/usr/local/share/gdal
export LD_LIBRARY_PATH=/usr/local/lib

Then started again GeoServer. I can't find any error in the log, that is included at this message, but the GDAl formats are not shown in the web interface.
That's strange. You should have seen something like "GDAL version X has been loaded" in case of success OR "WARNING: Unable to load GDAL native libs" in case of failures.
Could you report us (through an "ls") the list of jars available on your webapps/geoserver/WEB-INF/lib folder?


Cheers,
Daniele
 
Am I missing something?

 

Thank you for your hints

Stefano
---------------------------------------------------
41.95581N 12.52854E


http://www.linkedin.com/in/stefanoiacovella

http://twitter.com/#!/Iacovellas

------------------------------------------------------------------------------
Want fast and easy access to all the code in your enterprise? Index and
search up to 200,000 lines of code with a free copy of Black Duck
Code Sight - the same software that powers the world's largest code
search on Ohloh, the Black Duck Open Hub! Try it now.
http://p.sf.net/sfu/bds
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users



------------------------------------------------------------------------------
Want fast and easy access to all the code in your enterprise? Index and
search up to 200,000 lines of code with a free copy of Black Duck
Code Sight - the same software that powers the world's largest code
search on Ohloh, the Black Duck Open Hub! Try it now.
http://p.sf.net/sfu/bds
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: Failing installing GDAL extension

Stefano Iacovella

2014-07-21 12:40 GMT+02:00 Daniele Romagnoli <[hidden email]>:
That step is not needed indeed. The documentation provides instructions to install the CRS definitions and native libs since the JARs are already available in the GeoServer extension.
Ok, maybe I misunderstood the instructions, thank for letting me know it.
 
That being said, the imageio-ext has been developed/tested against GDAL 1.9.2. Not sure if it will work against a newer version of GDAL (native bindings/methods signature may have been changed since that version).
I was thinking about it as I see that archives from http://demo.geo-solutions.it/share/github/imageio-ext/releases/1.1.X/1.1.10/native/gdal/linux/ are all for 1.9.2
 
However, let's move to the next question...
 

I modified the startup script for GeoServer, /etc/init.d/tomcat including this two variables:

export GDAL_DATA=/usr/local/share/gdal
export LD_LIBRARY_PATH=/usr/local/lib

Then started again GeoServer. I can't find any error in the log, that is included at this message, but the GDAl formats are not shown in the web interface.
That's strange. You should have seen something like "GDAL version X has been loaded" in case of success OR "WARNING: Unable to load GDAL native libs" in case of failures.
Could you report us (through an "ls") the list of jars available on your webapps/geoserver/WEB-INF/lib folder?

I have included a text file with the result of the ls operation.

Thank you very much for your help

Cheers,

Stefano

---------------------------------------------------
41.95581N 12.52854E


http://www.linkedin.com/in/stefanoiacovella

http://twitter.com/#!/Iacovellas

------------------------------------------------------------------------------
Want fast and easy access to all the code in your enterprise? Index and
search up to 200,000 lines of code with a free copy of Black Duck
Code Sight - the same software that powers the world's largest code
search on Ohloh, the Black Duck Open Hub! Try it now.
http://p.sf.net/sfu/bds
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users

jars.txt (28K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Failing installing GDAL extension

Daniele Romagnoli-3
Hi Stefano,
note that you have mixed imageio-ext dependencies: a 1.1.9 set from geoserver-gdal extension as well as 1.1.10 set from the manual install you did copying them from the imageio-ext download section.
Not sure if they are the cause of your issues but I would do a cleanup before trying again.
I think it's safe to delete all imageio-ext-1.1.10 artifacts (and the imageio-ext-kakadujni too) and try again to see if you get any useful logging message.
Cheers,
Daniele


==
GeoServer Professional Services from the experts! Visit
http://goo.gl/NWWaa2 for more information.
==

Ing. Daniele Romagnoli
Senior Software Engineer

GeoSolutions S.A.S.
Via Poggio alle Viti 1187
55054  Massarosa (LU)
Italy
phone: +39 0584 962313
fax:      +39 0584 1660272

http://www.geo-solutions.it
http://twitter.com/geosolutions_it

-------------------------------------------------------


On Mon, Jul 21, 2014 at 12:47 PM, Stefano Iacovella <[hidden email]> wrote:

2014-07-21 12:40 GMT+02:00 Daniele Romagnoli <[hidden email]>:

That step is not needed indeed. The documentation provides instructions to install the CRS definitions and native libs since the JARs are already available in the GeoServer extension.
Ok, maybe I misunderstood the instructions, thank for letting me know it.
 
That being said, the imageio-ext has been developed/tested against GDAL 1.9.2. Not sure if it will work against a newer version of GDAL (native bindings/methods signature may have been changed since that version).
I was thinking about it as I see that archives from http://demo.geo-solutions.it/share/github/imageio-ext/releases/1.1.X/1.1.10/native/gdal/linux/ are all for 1.9.2
 
However, let's move to the next question...
 

I modified the startup script for GeoServer, /etc/init.d/tomcat including this two variables:

export GDAL_DATA=/usr/local/share/gdal
export LD_LIBRARY_PATH=/usr/local/lib

Then started again GeoServer. I can't find any error in the log, that is included at this message, but the GDAl formats are not shown in the web interface.
That's strange. You should have seen something like "GDAL version X has been loaded" in case of success OR "WARNING: Unable to load GDAL native libs" in case of failures.
Could you report us (through an "ls") the list of jars available on your webapps/geoserver/WEB-INF/lib folder?

I have included a text file with the result of the ls operation.

Thank you very much for your help

Cheers,

Stefano

---------------------------------------------------
41.95581N 12.52854E


http://www.linkedin.com/in/stefanoiacovella

http://twitter.com/#!/Iacovellas


------------------------------------------------------------------------------
Want fast and easy access to all the code in your enterprise? Index and
search up to 200,000 lines of code with a free copy of Black Duck
Code Sight - the same software that powers the world's largest code
search on Ohloh, the Black Duck Open Hub! Try it now.
http://p.sf.net/sfu/bds
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: Failing installing GDAL extension

Stefano Iacovella

2014-07-21 14:00 GMT+02:00 Daniele Romagnoli <[hidden email]>:
Hi Stefano,
note that you have mixed imageio-ext dependencies: a 1.1.9 set from geoserver-gdal extension as well as 1.1.10 set from the manual install you did copying them from the imageio-ext download section.
Not sure if they are the cause of your issues but I would do a cleanup before trying again.
I think it's safe to delete all imageio-ext-1.1.10 artifacts (and the imageio-ext-kakadujni too) and try again to see if you get any useful logging message

I did the cleanup and tried a restart but again I can't find any error in the log. I also tried to raise the detail in the log, switching to GEOSERVER_DEVELOPER mode but it didn't help.
Anyway I am pasting the log file in case I missed noting something important.

Ciao

Stefano

---------------------------------------------------
41.95581N 12.52854E


http://www.linkedin.com/in/stefanoiacovella

http://twitter.com/#!/Iacovellas

------------------------------------------------------------------------------
Want fast and easy access to all the code in your enterprise? Index and
search up to 200,000 lines of code with a free copy of Black Duck
Code Sight - the same software that powers the world's largest code
search on Ohloh, the Black Duck Open Hub! Try it now.
http://p.sf.net/sfu/bds
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users

geoserver.log (78K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Failing installing GDAL extension

Daniele Romagnoli-3
Mmm... that's strange.
I will download a GS 2.5.1 as well as the GDAL-extension to see how things work on my instance.

Daniele

==
GeoServer Professional Services from the experts! Visit
http://goo.gl/NWWaa2 for more information.
==

Ing. Daniele Romagnoli
Senior Software Engineer

GeoSolutions S.A.S.
Via Poggio alle Viti 1187
55054  Massarosa (LU)
Italy
phone: +39 0584 962313
fax:      +39 0584 1660272

http://www.geo-solutions.it
http://twitter.com/geosolutions_it

-------------------------------------------------------


On Mon, Jul 21, 2014 at 2:22 PM, Stefano Iacovella <[hidden email]> wrote:

2014-07-21 14:00 GMT+02:00 Daniele Romagnoli <[hidden email]>:

Hi Stefano,
note that you have mixed imageio-ext dependencies: a 1.1.9 set from geoserver-gdal extension as well as 1.1.10 set from the manual install you did copying them from the imageio-ext download section.
Not sure if they are the cause of your issues but I would do a cleanup before trying again.
I think it's safe to delete all imageio-ext-1.1.10 artifacts (and the imageio-ext-kakadujni too) and try again to see if you get any useful logging message

I did the cleanup and tried a restart but again I can't find any error in the log. I also tried to raise the detail in the log, switching to GEOSERVER_DEVELOPER mode but it didn't help.
Anyway I am pasting the log file in case I missed noting something important.

Ciao

Stefano

---------------------------------------------------
41.95581N 12.52854E


http://www.linkedin.com/in/stefanoiacovella

http://twitter.com/#!/Iacovellas


------------------------------------------------------------------------------
Want fast and easy access to all the code in your enterprise? Index and
search up to 200,000 lines of code with a free copy of Black Duck
Code Sight - the same software that powers the world's largest code
search on Ohloh, the Black Duck Open Hub! Try it now.
http://p.sf.net/sfu/bds
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: Failing installing GDAL extension

Stefano Iacovella

2014-07-21 16:25 GMT+02:00 Daniele Romagnoli <[hidden email]>:
Mmm... that's strange.
I will download a GS 2.5.1 as well as the GDAL-extension to see how things work on my instance.

I have been trying it myself this afternoon.
On a different machine, a Windows 7 with JRE 7 and Tomcat, I installed a fresh 2.5.1 GeoServer with GDAL extension.
After adding the GDAL_DATA environment variable and adding the lib path to PATH I started the Tomcat.
It works and I can see the additional formats available.
I guess in the other machine the compiled GDAL does not work with the Java binding, I am just doubtful about the absence of any message in the log.

Ciao

Stefano


---------------------------------------------------
41.95581N 12.52854E


http://www.linkedin.com/in/stefanoiacovella

http://twitter.com/#!/Iacovellas

------------------------------------------------------------------------------
Want fast and easy access to all the code in your enterprise? Index and
search up to 200,000 lines of code with a free copy of Black Duck
Code Sight - the same software that powers the world's largest code
search on Ohloh, the Black Duck Open Hub! Try it now.
http://p.sf.net/sfu/bds
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: Failing installing GDAL extension

Daniele Romagnoli-3
Hi Stefano,

On Mon, Jul 21, 2014 at 4:41 PM, Stefano Iacovella <[hidden email]> wrote:

2014-07-21 16:25 GMT+02:00 Daniele Romagnoli <[hidden email]>:

Mmm... that's strange.
I will download a GS 2.5.1 as well as the GDAL-extension to see how things work on my instance.

I have been trying it myself this afternoon.
On a different machine, a Windows 7 with JRE 7 and Tomcat, I installed a fresh 2.5.1 GeoServer with GDAL extension.
After adding the GDAL_DATA environment variable and adding the lib path to PATH I started the Tomcat.
It works and I can see the additional formats available.
I guess in the other machine the compiled GDAL does not work with the Java binding, I am just doubtful about the absence of any message in the log.
Any chance you have customized the logging config/properties files?
Still no idea of why you didn't see neither a successfully load log nor a warning (missing lib) log.

Cheers,
Daniele
 

Ciao

Stefano


---------------------------------------------------
41.95581N 12.52854E


http://www.linkedin.com/in/stefanoiacovella

http://twitter.com/#!/Iacovellas


------------------------------------------------------------------------------
Want fast and easy access to all the code in your enterprise? Index and
search up to 200,000 lines of code with a free copy of Black Duck
Code Sight - the same software that powers the world's largest code
search on Ohloh, the Black Duck Open Hub! Try it now.
http://p.sf.net/sfu/bds
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: Failing installing GDAL extension

Stefano Iacovella

2014-07-23 16:33 GMT+02:00 Daniele Romagnoli <[hidden email]>:
I guess in the other machine the compiled GDAL does not work with the Java binding, I am just doubtful about the absence of any message in the log.
Any chance you have customized the logging config/properties files?
Still no idea of why you didn't see neither a successfully load log nor a warning (missing lib) log.

Hi Daniele,

I am sure I didn't edit the logging config/properties files.
Is indeed odd it doesn't show anything as if the jar was ignored.
As soon as possible I will try with a fresh GeoServer instance on the same machine.
Thank you for your help

Stefano

---------------------------------------------------
41.95581N 12.52854E


http://www.linkedin.com/in/stefanoiacovella

http://twitter.com/#!/Iacovellas

------------------------------------------------------------------------------
Want fast and easy access to all the code in your enterprise? Index and
search up to 200,000 lines of code with a free copy of Black Duck
Code Sight - the same software that powers the world's largest code
search on Ohloh, the Black Duck Open Hub! Try it now.
http://p.sf.net/sfu/bds
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users