FW: r.out.xyz: Output error

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

FW: r.out.xyz: Output error

Stephen Brearley
Hi Helmut

Not clear what you mean by separator. Recognise '|' as the pipe symbol in
Unix. I'm running Windows, and the module enters a ' ' (space) or I do this
manually when I type in the command. Note that the '@' symbol seems to have
got changed to ' AT ' by the parser. Tried manually typing the command with
'@' instead of ' AT ' all this and get the same result.

Is this a bug, and could it be present in other modules, say if the code has
been copied and pasted, since 'output' is a rather common parameter?
Do we have a fix?

Thanks
  Stephen

-----Original Message-----
From: Helmut Kudrnovsky [mailto:[hidden email]]
Sent: 30 March 2013 21:40
To: [hidden email]
Subject: Re: [GRASS-user] r.out.xyz: Output error

>if the separator is given manually instead the default one, r.out.xyz
works:

it seems given Default: | breaks the script, because also manually given |
stopps the script...



-----
best regards
Helmut
--
View this message in context:
http://osgeo-org.1560.n6.nabble.com/r-out-xyz-Output-error-tp5043808p5043821
.html
Sent from the Grass - Users mailing list archive at Nabble.com.


_______________________________________________
grass-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-user
Reply | Threaded
Open this post in threaded view
|

Re: FW: r.out.xyz: Output error

Helmut Kudrnovsky
>Not clear what you mean by separator.

have a look at the manual:
http://grass.osgeo.org/grass70/manuals/r.out.xyz.html

separator=character
    Field separator
    Special characters: newline, space, comma, tab
    Default: |

> I'm running Windows,

tested here with
GRASS version: 7.0.svn                                                          
GRASS SVN Revision: 55573
[...]
Platform: Windows-Vista-6.0.6002-SP2 (OSGeo4W)  

> Is this a bug,

see
http://lists.osgeo.org/pipermail/grass-user/2013-March/067602.html

r.out.xyz input=elevation@ERMANENT output=J:\wd\routxyz\test2.csv separator=,  
(Sat Mar 30 22:26:32 2013) Command finished (3 sec)  

r.out.xyz input=elevation@PERMANENT output=J:\wd\routxyz\test3.csv separator=;  
(Sat Mar 30 22:28:00 2013) Command finished (2 sec)  

please try another separator (e.g. ; or , or you can also type separator=space) with your data

>say if the code has
>been copied and pasted, since 'output' is a rather common parameter?

it seems that 'output' isn't the problem, but the seperator...

>Do we have a fix?

please test on your platform with  a sample data set
(http://grass.osgeo.org/download/sample-data/)

and the example from the manual
(http://grass.osgeo.org/grass70/manuals/r.out.xyz.html)

and when it fails, open a bug ticket
(http://trac.osgeo.org/grass/)


best regards
Helmut