[FOSSGIS-Talk] Ubuntu 16.04 - PostgreSQL und PostGIS Installation

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[FOSSGIS-Talk] Ubuntu 16.04 - PostgreSQL und PostGIS Installation

R. Reiterer
Hallo,

hat jemand in letzter Zeit PostgreSQL und PostGIS auf einem Ubuntu 16.04
Rechner installiert? Ich habe schon alle möglichen Anleitungen probiert
(jeweils auf einem frischen Ubuntu vom USB Stick) und erhalte ständig
Fehlermeldungen, z.B.:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
  postgis : Hängt ab von: libgdal1i (>= 1.9.0) ist aber nicht
installierbar
            Hängt ab von: liblwgeom-2.4-0 (>= 2.0.0) soll aber nicht
installiert werden
            Empfiehlt: postgresql-9.6-postgis-2.4 soll aber nicht
installiert werden
            Empfiehlt: postgis-doc soll aber nicht installiert werden
  postgresql-9.6-postgis-2.3 : Hängt ab von: libgdal1i (>= 1.9.0) ist
aber nicht installierbar
                               Hängt ab von: liblwgeom-2.3-0 (>= 2.3.0)
soll aber nicht installiert werden
                               Hängt ab von: libproj9 (>= 4.9.0) ist aber
nicht installierbar
                               Hängt ab von: libsfcgal1 (>= 1.2.0) ist
aber nicht installierbar
                               Empfiehlt:
postgresql-9.6-postgis-2.3-scripts soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene
defekte Pakete.

Weiß jemand Rat? Die letzte Installation vor ein paar Monaten ging
völlig problemlos.

Danke und schöne Grüße, Reinhard

--
....................................................................
FOSSGIS 2018, die Konferenz für Open Source GIS mit OpenData und
OpenStreetMap in Bonn!
21.-24. März 2018 an der Universität Bonn
https://fossgis-konferenz.de/2018/

FOSSGIS e.V, der Verein zur Förderung von Freier Software aus dem
GIS-Bereich und Freier Geodaten!
https://www.fossgis.de/             https://twitter.com/fossgis_eV

____________________________________________________________________
FOSSGIS-Talk-Liste mailing list
[hidden email]
https://lists.fossgis.de/mailman/listinfo/fossgis-talk-liste
Reply | Threaded
Open this post in threaded view
|

Re: [FOSSGIS-Talk] Ubuntu 16.04 - PostgreSQL und PostGIS Installation

Burghardt.Scholle
Hallo Reinhard,

ich hatte beim Upgrade auf 16.04 ähnliche Fehlermeldungen. Ich musste zunächst die installierte (veraltete) Version von libgdal deinstallieren. Dabei wurde etliche weitere Pakete deinstalliert (u.a. PostGIS, QGIS, gdal-bin etc. pp.). Erst danach konnte ich die aktuelle libgdal installieren und damit auch alle anderen Pakete. Hört sich bei Dir nach einem ähnlichen Problem an. Vielleicht schaust Du mal nach, ob die bei Dir installierte libgdal-Version aktualisierbar ist. Nutzt Du für PostgreSQL/PostGIS ein PPA?

Viele Grüße
Burghardt

> -----Ursprüngliche Nachricht-----
> Von: FOSSGIS-Talk-Liste [mailto:[hidden email]] Im
> Auftrag von R. Reiterer
> Gesendet: Donnerstag, 5. Oktober 2017 18:48
> An: Fossgis talk liste
> Betreff: [FOSSGIS-Talk] Ubuntu 16.04 - PostgreSQL und PostGIS Installation
>
> Hallo,
>
> hat jemand in letzter Zeit PostgreSQL und PostGIS auf einem Ubuntu 16.04
> Rechner installiert? Ich habe schon alle möglichen Anleitungen probiert
> (jeweils auf einem frischen Ubuntu vom USB Stick) und erhalte ständig
> Fehlermeldungen, z.B.:
>
> Die folgenden Pakete haben unerfüllte Abhängigkeiten:
>   postgis : Hängt ab von: libgdal1i (>= 1.9.0) ist aber nicht installierbar
>             Hängt ab von: liblwgeom-2.4-0 (>= 2.0.0) soll aber nicht installiert
> werden
>             Empfiehlt: postgresql-9.6-postgis-2.4 soll aber nicht installiert werden
>             Empfiehlt: postgis-doc soll aber nicht installiert werden
>   postgresql-9.6-postgis-2.3 : Hängt ab von: libgdal1i (>= 1.9.0) ist aber nicht
> installierbar
>                                Hängt ab von: liblwgeom-2.3-0 (>= 2.3.0) soll aber nicht
> installiert werden
>                                Hängt ab von: libproj9 (>= 4.9.0) ist aber nicht installierbar
>                                Hängt ab von: libsfcgal1 (>= 1.2.0) ist aber nicht installierbar
>                                Empfiehlt:
> postgresql-9.6-postgis-2.3-scripts soll aber nicht installiert werden
> E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene
> defekte Pakete.
>
> Weiß jemand Rat? Die letzte Installation vor ein paar Monaten ging völlig
> problemlos.
>
> Danke und schöne Grüße, Reinhard
>
> --
> ....................................................................
> FOSSGIS 2018, die Konferenz für Open Source GIS mit OpenData und
> OpenStreetMap in Bonn!
> 21.-24. März 2018 an der Universität Bonn https://fossgis-
> konferenz.de/2018/
>
> FOSSGIS e.V, der Verein zur Förderung von Freier Software aus dem GIS-
> Bereich und Freier Geodaten!
> https://www.fossgis.de/             https://twitter.com/fossgis_eV
>
> __________________________________________________________
> __________
> FOSSGIS-Talk-Liste mailing list
> [hidden email]
> https://lists.fossgis.de/mailman/listinfo/fossgis-talk-liste
--
....................................................................
FOSSGIS 2018, die Konferenz für Open Source GIS mit OpenData und
OpenStreetMap in Bonn!
21.-24. März 2018 an der Universität Bonn
https://fossgis-konferenz.de/2018/

FOSSGIS e.V, der Verein zur Förderung von Freier Software aus dem
GIS-Bereich und Freier Geodaten!
https://www.fossgis.de/             https://twitter.com/fossgis_eV

____________________________________________________________________
FOSSGIS-Talk-Liste mailing list
[hidden email]
https://lists.fossgis.de/mailman/listinfo/fossgis-talk-liste