FIX: default values for variable substitution in WEB section

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

FIX: default values for variable substitution in WEB section

Martin Icking
Currently a default value for substitution variables in the map's WEB section
is ignored. I've created a fix to this, pls see this pull request:
https://github.com/mapserver/mapserver/pull/5516
This enables you now to set a default value for e.g. the ows_onlineresource
setting as illustrated below.
Use case: have a correct capabilities reply behind a proxy software (with
dynamic URI's)

  WEB
        VALIDATION
                'default_ows_onlineresource' 'https://defaultserver/defaultpath'
                'ows_onlineresource' '^https://[a-z0-9/:.?&=]+$'
        END
    METADATA
      'ows_onlineresource' '%ows_onlineresource%'
    END # METADATA
  END # WEB




--
Sent from: http://osgeo-org.1560.x6.nabble.com/Mapserver-Dev-f4252683.html
_______________________________________________
mapserver-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-dev
Reply | Threaded
Open this post in threaded view
|

Re: FIX: default values for variable substitution in WEB section

jmckenna
Administrator
Thanks for this Martin.  I have merged this, and asked if you can
contribute a note about this for the docs.  -jeff



On 2017-11-10 10:26 AM, Martin Icking wrote:

> Currently a default value for substitution variables in the map's WEB section
> is ignored. I've created a fix to this, pls see this pull request:
> https://github.com/mapserver/mapserver/pull/5516
> This enables you now to set a default value for e.g. the ows_onlineresource
> setting as illustrated below.
> Use case: have a correct capabilities reply behind a proxy software (with
> dynamic URI's)
>
>    WEB
> VALIDATION
> 'default_ows_onlineresource' 'https://defaultserver/defaultpath'
> 'ows_onlineresource' '^https://[a-z0-9/:.?&=]+$'
> END
>      METADATA
>        'ows_onlineresource' '%ows_onlineresource%'
>      END # METADATA
>    END # WEB
>
>
>
_______________________________________________
mapserver-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-dev
Reply | Threaded
Open this post in threaded view
|

Re: FIX: default values for variable substitution in WEB section

Martin Icking
Hi Jeff, added a note on this to the documentation - see pull request #203
Tx
Martin



--
Sent from: http://osgeo-org.1560.x6.nabble.com/Mapserver-Dev-f4252683.html
_______________________________________________
mapserver-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-dev
Reply | Threaded
Open this post in threaded view
|

Re: FIX: default values for variable substitution in WEB section

jmckenna
Administrator
oh, thanks Martin!  -jeff



On 2017-11-15 2:02 PM, Martin Icking wrote:
> Hi Jeff, added a note on this to the documentation - see pull request #203
> Tx
> Martin
>
_______________________________________________
mapserver-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-dev