FDOToolbox (64)

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

FDOToolbox (64)

benjanmin
This post has NOT been accepted by the mailing list yet.
Hi! I just installed the FDOToolbox, but the Postgresql/ PostGIS cannot be clicked. Has anyone know how to do? Thanks.

Reply | Threaded
Open this post in threaded view
|

Re: FDOToolbox (64)

Jackie Ng
FDO Toolbox does not bundle libpq.dll, so the PostgreSQL provider is disabled.

Put this dll in to the directory where FDO dlls reside or add the directory where libpq.dll is to your PATH environment variable

- Jackie
Reply | Threaded
Open this post in threaded view
|

Re: FDOToolbox (64)

benjanmin
This post has NOT been accepted by the mailing list yet.
Thanks Jacky

It still didn't work! I have copied the libpq.dll and set the PATH environment variable. Is there anything was missing? Thanks. :)

Reply | Threaded
Open this post in threaded view
|

Re: FDOToolbox (64)

Jackie Ng
Check that the PostgreSQL provider has been registered in providers.xml

Failing that, load PostgreSQLProvider.dll into Dependency Walker. It will probably tell you about a dll that you don't have there.

- Jackie
Reply | Threaded
Open this post in threaded view
|

Re: FDOToolbox (64)

benjanmin
This post has NOT been accepted by the mailing list yet.
Thanks. Jackie

Actually the provider.xml is already updated and added the PostgreSQLProvider! The capability of create and connect to PostgreSQL is still not available of my FDO toolbar. Is this caused by the version of PostsqlSQL is 9.1(No install version - it initial start by typing command) and the postGIS is 2.0.3? The postgreSQL is working now. The Autodesk Map3D 2014 and PgAdminIII can access without problem, but the Map 3D cannot create data store. It can do bulkcopy only. I've capture the xml as below:

<FeatureProvider>
    <Name>OSGeo.PostgreSQL.3.8</Name>
    <DisplayName>OSGeo FDO Provider for PostgreSQL/PostGIS</DisplayName>
    <Description>Read/write access to PostgreSQL/PostGIS-based data store. Supports spatial data types and spatial query operations.</Description>
    <IsManaged>False</IsManaged>
    <Version>3.8.0.0</Version>
    <FeatureDataObjectsVersion>3.8.0.0</FeatureDataObjectsVersion>
    <LibraryPath>.\PostgreSQLProvider.dll</LibraryPath>
</FeatureProvider>

What should I do and test now?