FDO component exception RDBMS

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

FDO component exception RDBMS

kgrootendorst

Hello,
Using MGOS 1.1, FDO 3.2, MySQL 5.0.22, Win2000...
When setting up a MySQL connection through Studio, I keep getting the following error:  
An exception occurred in FDO component.  RDBMS: Using unsupported buffer type: 0  (parameter: 1)
Below is a dump from the server log.  Does anybody have any idea as to how to fix this?

Error: An exception occurred in FDO component.
        RDBMS: Using unsupported buffer type: 0  (parameter: 1)
 StackTrace:
  - MgFeatureServiceHandler.ProcessOperation line 83 file c:\build_bond_area\mapguide_open_source\build_3.1\mgdev\server\src\services\feature\FeatureServiceHandler.cpp
  - MgOpTestFeatureSourceConnection.Execute line 103 file c:\build_bond_area\mapguide_open_source\build_3.1\mgdev\server\src\services\feature\OpTestFeatureSourceConnection.cpp
  - MgFdoConnectionManager.Open line 815 file c:\build_bond_area\mapguide_open_source\build_3.1\mgdev\server\src\common\manager\FdoConnectionManager.cpp        An exception occurred in FDO component.
RDBMS: Using unsupported buffer type: 0  (parameter: 1)

Thanks in advance.

Kevin
_______________________________________________
fdo-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/fdo-users
Reply | Threaded
Open this post in threaded view
|

RE: FDO component exception RDBMS

Jason Birch
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

FW: FDO component exception RDBMS

Brent Robinson
In reply to this post by kgrootendorst

Not sure if it went to the whole group so forwarding ...

 

-----Original Message-----
From: Brent Robinson
Sent:
Wednesday, May 02, 2007 10:24 AM
To: '[hidden email]'
Subject: RE: [fdo-users] FDO component exception RDBMS

 

Hi,

 

One case where this can happen is if the mysql client library (libmysql.dll) is version 4 or earlier. Due to some data types that are new to MySQL 5, a version 4 client can get the

“Using unsupported buffer type” error when talking to a version 5 server.

 

If this is the case, then replacing libmysql.dll with a version 5 one should fix it. For a MapGuide installation, I’m not sure of the exact location if libmysql but someone else on the [fdo_users] group would likely know.

 

If you’re sure you have the right version of libmysql, there’s also the chance that a libmysql from another directory is being picked up before it, depending on the current path.

 

Brent.

 

-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of [hidden email]
Sent:
Tuesday, May 01, 2007 12:36 PM
To: [hidden email]
Subject: [fdo-users] FDO component exception RDBMS

 


Hello,
Using MGOS 1.1, FDO 3.2, MySQL 5.0.22, Win2000...
When setting up a MySQL connection through Studio, I keep getting the following error:  
An exception occurred in FDO component.  RDBMS: Using unsupported buffer type: 0  (parameter: 1)
Below is a dump from the server log.  Does anybody have any idea as to how to fix this?

Error: An exception occurred in FDO component.
        RDBMS: Using unsupported buffer type: 0  (parameter: 1)
 StackTrace:
  - MgFeatureServiceHandler.ProcessOperation line 83 file c:\build_bond_area\mapguide_open_source\build_3.1\mgdev\server\src\services\feature\FeatureServiceHandler.cpp
  - MgOpTestFeatureSourceConnection.Execute line 103 file c:\build_bond_area\mapguide_open_source\build_3.1\mgdev\server\src\services\feature\OpTestFeatureSourceConnection.cpp
  - MgFdoConnectionManager.Open line 815 file c:\build_bond_area\mapguide_open_source\build_3.1\mgdev\server\src\common\manager\FdoConnectionManager.cpp        An exception occurred in FDO component.
RDBMS: Using unsupported buffer type: 0  (parameter: 1)

Thanks in advance.

Kevin


_______________________________________________
fdo-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/fdo-users
Reply | Threaded
Open this post in threaded view
|

RE: FDO component exception RDBMS

kgrootendorst
In reply to this post by kgrootendorst

Brent,
Indeed you were right.  I believe I may have been using a version 4 dll, and it was being picked up in another directory.
To fix my specific problem, I copied the 'libmysql.dll' from my MySQL folder (Program Files\MySQL\MySQL Server 5.0\bin) and placed in \Program Files\MapGuideOpenSource\Server\Bin.
I also removed a copy of the dll that I had in my WINNT\System32 folder (another user had suggested I place a copy there).
The MySQL connection is now working properly.
Thanks.

Kevin




"Brent Robinson" <[hidden email]>

05/02/2007 10:24 AM

To
<[hidden email]>
cc
Subject
RE: [fdo-users] FDO component exception RDBMS





Hi,
 
One case where this can happen is if the mysql client library (libmysql.dll) is version 4 or earlier. Due to some data types that are new to MySQL 5, a version 4 client can get the
“Using unsupported buffer type” error when talking to a version 5 server.
 
If this is the case, then replacing libmysql.dll with a version 5 one should fix it. For a MapGuide installation, I’m not sure of the exact location if libmysql but someone else on the [fdo_users] group would likely know.
 
If you’re sure you have the right version of libmysql, there’s also the chance that a libmysql from another directory is being picked up before it, depending on the current path.
 
Brent.
 
-----Original Message-----
From:
[hidden email] [mailto:[hidden email]] On Behalf Of [hidden email]
Sent:
Tuesday, May 01, 2007 12:36 PM
To:
[hidden email]
Subject:
[fdo-users] FDO component exception RDBMS

 

Hello,

Using MGOS 1.1, FDO 3.2, MySQL 5.0.22, Win2000...

When setting up a MySQL connection through Studio, I keep getting the following error:  

An exception occurred in FDO component.  RDBMS: Using unsupported buffer type: 0  (parameter: 1)
Below is a dump from the server log.  Does anybody have any idea as to how to fix this?


Error: An exception occurred in FDO component.

       RDBMS: Using unsupported buffer type: 0  (parameter: 1)
StackTrace:

 - MgFeatureServiceHandler.ProcessOperation line 83 file c:\build_bond_area\mapguide_open_source\build_3.1\mgdev\server\src\services\feature\FeatureServiceHandler.cpp

 - MgOpTestFeatureSourceConnection.Execute line 103 file c:\build_bond_area\mapguide_open_source\build_3.1\mgdev\server\src\services\feature\OpTestFeatureSourceConnection.cpp

 - MgFdoConnectionManager.Open line 815 file c:\build_bond_area\mapguide_open_source\build_3.1\mgdev\server\src\common\manager\FdoConnectionManager.cpp        An exception occurred in FDO component.

RDBMS: Using unsupported buffer type: 0  (parameter: 1)


Thanks in advance.


Kevin


_______________________________________________
fdo-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/fdo-users