Exception in thread "http-bio-8080-exec-7" java.lang.UnknownError: msDrawMap(): Image handling error. Failed to draw layer named 'borewell'.;msOracleSpatialLayerOpen(): OracleSpatial error. Cannot create OCI Handlers. Connection failure. Check the connection string. Error: ORA-06413: Connection not open.

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Exception in thread "http-bio-8080-exec-7" java.lang.UnknownError: msDrawMap(): Image handling error. Failed to draw layer named 'borewell'.;msOracleSpatialLayerOpen(): OracleSpatial error. Cannot create OCI Handlers. Connection failure. Check the connection string. Error: ORA-06413: Connection not open.

shiva.sk4
This post has NOT been accepted by the mailing list yet.
Hello Everybody,

This query may have been posted already but none of the solutions previously mentioned on this forum solve my problem. I am running ms4w v 3.0.3 with Java JDK 1.6.0.45, Tomcat 7.0.41 with the spatial data stored in Oracle 11.2 on Windows 7 64bit OS. I followed all the steps mentioned in the following link to enable MapServer support for Oracle Spatial. Link : http://www.maptools.org/ms4w/?page=README_INSTALL.html#oracle-10g-11g 

The mapserv -v command returns a string that contains INPUT=ORACLESPATIAL and also ogrinfo --formats returns OCI format appended to the first in the list. Further I even tested the query string using ogrinfo OCI:username/password@service which returned all the tables in the oracle schema. Also, tested the mapfile using the shp2img utility, which generated a map image. The problem occurs if I try to use the mapfile with Java web application deployed in Tomcat. Is there any other setting I need to do?

Regards,
Shiva Shankar
Reply | Threaded
Open this post in threaded view
|

Re: Exception in thread "http-bio-8080-exec-7" java.lang.UnknownError: msDrawMap(): Image handling error. Failed to draw layer named 'borewell'.;msOracleSpatialLayerOpen(): OracleSpatial error. Cannot create OCI Handlers. Connection failure. Check the connection string. Error: ORA-06413: Connection not open.

shiva.sk4
This post has NOT been accepted by the mailing list yet.
Hello Everybody,

This issue is now solved.

The spatial data was on Oracle 11g 64 bit and I was running Oracle 10g (not client) on the machine which was running MS4W. I removed it and then installed Oracle 11g 64 bit client, but then the mapserv -v did not work with it. Then I deinstalled it and installed the Oracle 11g 32 bit client which fixed the problem.

Regards,
Shiva Shankar