Error gvSIG-1.11 on PostGIS layer

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Error gvSIG-1.11 on PostGIS layer

nachouve
Hi everyone,

I've found a a weird error today in gvSIG-1.11. Everything works fine accesing to PostGIS, except some layers (attached the sql to dump with a example of postgis layer).
It is very strange, because it gives an error and not display the points. However I can zoom to the features, open NavTable even export to SHP without problem.

Any idea of what is happend?

Cheers,
Nacho V.

_______________________________________________
gvSIG-desktop-devel mailing list
[hidden email]
https://lists.forge.osor.eu/listinfo/gvsig-desktop-devel

capa_postgis_falla.sql (33K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Error gvSIG-1.11 on PostGIS layer

nachouve
I've found the problem.
"the_geom" field is set as ID_FIELD on the geodb connection dialog.

Maybe it is a good idea that gvSIG try to auto-search a fieldname like "gid", "GID", "ID", "FID" if the first column of the table does not look as a valid ID.

Regards,
Nacho V.


2011/3/14 Nacho Uve <[hidden email]>
Hi everyone,

I've found a a weird error today in gvSIG-1.11. Everything works fine accesing to PostGIS, except some layers (attached the sql to dump with a example of postgis layer).
It is very strange, because it gives an error and not display the points. However I can zoom to the features, open NavTable even export to SHP without problem.

Any idea of what is happend?

Cheers,
Nacho V.


_______________________________________________
gvSIG-desktop-devel mailing list
[hidden email]
https://lists.forge.osor.eu/listinfo/gvsig-desktop-devel
Reply | Threaded
Open this post in threaded view
|

Re: Error gvSIG-1.11 on PostGIS layer

Jorge Sanz (gvSIG)
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

El 14/03/11 14:32, Nacho Uve escribió:
> I've found the problem.
> "the_geom" field is set as ID_FIELD on the geodb connection dialog.
>
> Maybe it is a good idea that gvSIG try to auto-search a fieldname like
> "gid", "GID", "ID", "FID" if the first column of the table does not look
> as a valid ID.
>

hard to say... there is no "first column" on a relational database, it
depends on the way yo do the query, maybe you should look for a primary
key but I've never did that with JDBC.

my 2cts

- --
Jorge Gaspar Sanz Salinas
gvSIG Team at Prodevelop
Technical Collaborations Manager
http://www.gvsig.org
http://www.gvsig.com
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBAgAGBQJNfkF9AAoJEAOYD75lvHdBLXgH/R+DZ1qhG5edks30aQwQZs3l
FHbcjbNOpta+HwHAeQbVZDtlSCa9DXRhJwLMnn6OjyGk+8ClbGSMT+5NSYCIozaj
l/9czrtT4OVt/jJvuQibYDV1t0f45fFtdR0E2AWwraO8ogLBN/H+lXOKM0RsCM3T
rbhlQS2efphlR+8eqYFEPC/5tDWpUEtY34UEWkqetvGvVrMzS2TDzCYreo/mXdbS
YEM6H4HiGC9QCLfFcjpFUjReNwLXU1Z6/hsW/dhDeXLZ3ZoqP3EakLHaJH29vLSP
tQtLewtq3fShbfMn2oynKRhhICsgAorXWJOnI9mm29eZhaz6KF81VyuyEGf8zrU=
=uzyn
-----END PGP SIGNATURE-----
_______________________________________________
gvSIG-desktop-devel mailing list
[hidden email]
https://lists.forge.osor.eu/listinfo/gvsig-desktop-devel
Reply | Threaded
Open this post in threaded view
|

Re: Error gvSIG-1.11 on PostGIS layer

Javier Estévez-2
In reply to this post by nachouve
On 14/03/11 14:32, Nacho Uve wrote:
> Maybe it is a good idea that gvSIG try to auto-search a fieldname like
> "gid", "GID", "ID", "FID" if the first column of the table does not look
> as a valid ID.

There was a feature request about this [1]. Although it's closed now, it
seems that the applied solution doesn't work :(

[1] http://forge.osor.eu/tracker/?func=detail&group_id=89&aid=14847&atid=790


_______________________________________________
gvSIG-desktop-devel mailing list
[hidden email]
https://lists.forge.osor.eu/listinfo/gvsig-desktop-devel
Reply | Threaded
Open this post in threaded view
|

Re: Error gvSIG-1.11 on PostGIS layer

nachouve
Maybe, for gvSIG-1.12 we can ask for re-open and search a improved solution (at least, they should report in a dialogue on possible causes of the error).

Regards,
Nacho V.



El 14 de marzo de 2011 17:36, Javier Estévez <[hidden email]> escribió:
On 14/03/11 14:32, Nacho Uve wrote:
> Maybe it is a good idea that gvSIG try to auto-search a fieldname like
> "gid", "GID", "ID", "FID" if the first column of the table does not look
> as a valid ID.

There was a feature request about this [1]. Although it's closed now, it
seems that the applied solution doesn't work :(

[1] http://forge.osor.eu/tracker/?func=detail&group_id=89&aid=14847&atid=790


_______________________________________________
gvSIG-desktop-devel mailing list
[hidden email]
https://lists.forge.osor.eu/listinfo/gvsig-desktop-devel


_______________________________________________
gvSIG-desktop-devel mailing list
[hidden email]
https://lists.forge.osor.eu/listinfo/gvsig-desktop-devel