Quantcast

Error creating virtual-CSW in Geonetwork 3.2

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Error creating virtual-CSW in Geonetwork 3.2

SteveDonegan
Hi All,

I am having issues creating a new virtual-csw in geonetwork 3.2.  No matter what filter I apply, or any other change I get an error flag "oops, error creating the virtualCSW".  There is nothing to suggest what is happening in the either the geonetwork or tomcat log.  Any ideas?  I can make adjustments to the main csw entry no problem.

Thanks,

Steve
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Error creating virtual-CSW in Geonetwork 3.2

SteveDonegan
Hi All,

I've made some progress with this - the error only seems to be returned when using Chrome.  I tried doing the same action with Firefox and the virtual-CSW saved ok.

However, I found that if using the "add filter" button and adding in the values this information would be lost.  If viewing that virtual-CSW again the filter entered this way would be lost/not shown - if you click save to get out of this window this removes the filter.  BUT - if a filter is entered using the "advanced" button and the lucene query syntax, the information is retained.  I guess this is a bug.

Thanks,

Steve
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Error creating virtual-CSW in Geonetwork 3.2

Francois Prunayre
Hi Steve, it's now fixed see
https://github.com/geonetwork/core-geonetwork/issues/1725 and will be
available in coming minor release.

Cheers.

Francois



2017-02-01 13:01 GMT+01:00 SteveDonegan <[hidden email]>:

> Hi All,
>
> I've made some progress with this - the error only seems to be returned
> when
> using Chrome.  I tried doing the same action with Firefox and the
> virtual-CSW saved ok.
>
> However, I found that if using the "add filter" button and adding in the
> values this information would be lost.  If viewing that virtual-CSW again
> the filter entered this way would be lost/not shown - if you click save to
> get out of this window this removes the filter.  BUT - if a filter is
> entered using the "advanced" button and the lucene query syntax, the
> information is retained.  I guess this is a bug.
>
> Thanks,
>
> Steve
>
>
>
> --
> View this message in context: http://osgeo-org.1560.x6.
> nabble.com/Error-creating-virtual-CSW-in-Geonetwork-3-2-
> tp5305513p5305735.html
> Sent from the GeoNetwork users mailing list archive at Nabble.com.
>
> ------------------------------------------------------------
> ------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, SlashDot.org! http://sdm.link/slashdot
> _______________________________________________
> GeoNetwork-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-users
> GeoNetwork OpenSource is maintained at http://sourceforge.net/
> projects/geonetwork
>
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Loading...