Quantcast

ERROR - "The procedure entry point sqlite3_open_v2 could not be located in the dynamic link library sqlite3.dll" when running QGIS 1.7 and 1.8 after OSGEO4w installation

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

ERROR - "The procedure entry point sqlite3_open_v2 could not be located in the dynamic link library sqlite3.dll" when running QGIS 1.7 and 1.8 after OSGEO4w installation

Filipe Dias-2
Dear all

I reinstalled QGIS today via osgeo4w and now I get this error when I run QGIS 1.7 and 1.8

Best
F.

_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ERROR - "The procedure entry point sqlite3_open_v2 could not be located in the dynamic link library sqlite3.dll" when running QGIS 1.7 and 1.8 after OSGEO4w installation

jbogdani
I had the same problem in win 7.
Telling osgeo4w to reinstall sqlite lib (osgeo4w, advanced mode) solved my problem.

Hope this helps

On 15 Jun 2012, at 19:29 , Filipe Silva Dias wrote:

Dear all

I reinstalled QGIS today via osgeo4w and now I get this error when I run QGIS 1.7 and 1.8

Best
F.
_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user


_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ERROR - "The procedure entry point sqlite3_open_v2 could not be located in the dynamic link library sqlite3.dll" when running QGIS 1.7 and 1.8 after OSGEO4w installation

Filipe Dias-2
Do you mean Libs->sqlite3 ? I tried reinstalling and going back to the previous version but it didnt solve the problem.

Thks


On Fri, Jun 15, 2012 at 6:32 PM, Julian Bogdani <[hidden email]> wrote:
I had the same problem in win 7.
Telling osgeo4w to reinstall sqlite lib (osgeo4w, advanced mode) solved my problem.

Hope this helps

On 15 Jun 2012, at 19:29 , Filipe Silva Dias wrote:

Dear all

I reinstalled QGIS today via osgeo4w and now I get this error when I run QGIS 1.7 and 1.8

Best
F.
_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user



_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ERROR - "The procedure entry point sqlite3_open_v2 could not be located in the dynamic link library sqlite3.dll" when running QGIS 1.7 and 1.8 after OSGEO4w installation

jbogdani
I have not a win now; sqlite3 should be the lib.
I did not downgrade the lib, just reinstalled it.

On 15 Jun 2012, at 19:47 , Filipe Silva Dias wrote:

Do you mean Libs->sqlite3 ? I tried reinstalling and going back to the previous version but it didnt solve the problem.

Thks


On Fri, Jun 15, 2012 at 6:32 PM, Julian Bogdani <[hidden email]> wrote:
I had the same problem in win 7.
Telling osgeo4w to reinstall sqlite lib (osgeo4w, advanced mode) solved my problem.

Hope this helps

On 15 Jun 2012, at 19:29 , Filipe Silva Dias wrote:

Dear all

I reinstalled QGIS today via osgeo4w and now I get this error when I run QGIS 1.7 and 1.8

Best
F.
_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user




_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ERROR - "The procedure entry point sqlite3_open_v2 could not be located in the dynamic link library sqlite3.dll" when running QGIS 1.7 and 1.8 after OSGEO4w installation

Filipe Dias-2
Reinstalling didnt work.

I also tried deleting c./osgeo4w and reinstalling everything again and that also didnt solve the problem

On Fri, Jun 15, 2012 at 6:50 PM, Julian Bogdani <[hidden email]> wrote:
I have not a win now; sqlite3 should be the lib.
I did not downgrade the lib, just reinstalled it.
On 15 Jun 2012, at 19:47 , Filipe Silva Dias wrote:

Do you mean Libs->sqlite3 ? I tried reinstalling and going back to the previous version but it didnt solve the problem.

Thks


On Fri, Jun 15, 2012 at 6:32 PM, Julian Bogdani <[hidden email]> wrote:
I had the same problem in win 7.
Telling osgeo4w to reinstall sqlite lib (osgeo4w, advanced mode) solved my problem.

Hope this helps

On 15 Jun 2012, at 19:29 , Filipe Silva Dias wrote:

Dear all

I reinstalled QGIS today via osgeo4w and now I get this error when I run QGIS 1.7 and 1.8

Best
F.
_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user





_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ERROR - "The procedure entry point sqlite3_open_v2 could not be located in the dynamic link library sqlite3.dll" when running QGIS 1.7 and 1.8 after OSGEO4w installation

Giuseppe Sucameli
Hi Filipe,

On Fri, Jun 15, 2012 at 6:59 PM, Filipe Silva Dias
<[hidden email]> wrote:
> Reinstalling didnt work.
>
> I also tried deleting c./osgeo4w and reinstalling everything again and that
> also didnt solve the problem

maybe you have another sqlite3 lib in your system which hides the one
shipped with osgeo4w.

Try to remove the sqlite3 lib from the osgeo4w installation and then run
QGis again. If the error persists then it's using a wrong sqlite3 lib.

Regards.

>
>
> On Fri, Jun 15, 2012 at 6:50 PM, Julian Bogdani <[hidden email]> wrote:
>>
>> I have not a win now; sqlite3 should be the lib.
>> I did not downgrade the lib, just reinstalled it.
>>
>>
>>
>> -----
>> Julian Bogdani
>> [hidden email]
>> http://bradypus.net
>>
>>
>>
>>
>>
>> On 15 Jun 2012, at 19:47 , Filipe Silva Dias wrote:
>>
>> Do you mean Libs->sqlite3 ? I tried reinstalling and going back to the
>> previous version but it didnt solve the problem.
>>
>> Thks
>>
>>
>> On Fri, Jun 15, 2012 at 6:32 PM, Julian Bogdani <[hidden email]>
>> wrote:
>>>
>>> I had the same problem in win 7.
>>> Telling osgeo4w to reinstall sqlite lib (osgeo4w, advanced mode) solved
>>> my problem.
>>>
>>> Hope this helps
>>>
>>>
>>> -----
>>> Julian Bogdani
>>> [hidden email]
>>> http://bradypus.net
>>>
>>>
>>>
>>>
>>>
>>> On 15 Jun 2012, at 19:29 , Filipe Silva Dias wrote:
>>>
>>> Dear all
>>>
>>> I reinstalled QGIS today via osgeo4w and now I get this error when I run
>>> QGIS 1.7 and 1.8
>>>
>>> Best
>>> F.
>>> _______________________________________________
>>> Qgis-user mailing list
>>> [hidden email]
>>> http://lists.osgeo.org/mailman/listinfo/qgis-user
>>>
>>>
>>
>>
>
>
> _______________________________________________
> Qgis-user mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/qgis-user
>



--
Giuseppe Sucameli
_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ERROR - "The procedure entry point sqlite3_open_v2 could not be located in the dynamic link library sqlite3.dll" when running QGIS 1.7 and 1.8 after OSGEO4w installation

Filipe Dias-2
Hi Giuseppe
I removed it (despite the installer complaining about dependencies), run QGIS again and got the same error. What else can I try?
This had never happened. I just reinstalled Windows 7 and I didnt install any software that I didnt have before.

I have some important things to do with QGIS and Im getting quite worried...

Thanks


On Fri, Jun 15, 2012 at 11:54 PM, Giuseppe Sucameli <[hidden email]> wrote:
Hi Filipe,

On Fri, Jun 15, 2012 at 6:59 PM, Filipe Silva Dias
<[hidden email]> wrote:
> Reinstalling didnt work.
>
> I also tried deleting c./osgeo4w and reinstalling everything again and that
> also didnt solve the problem

maybe you have another sqlite3 lib in your system which hides the one
shipped with osgeo4w.

Try to remove the sqlite3 lib from the osgeo4w installation and then run
QGis again. If the error persists then it's using a wrong sqlite3 lib.

Regards.

>
>
> On Fri, Jun 15, 2012 at 6:50 PM, Julian Bogdani <[hidden email]> wrote:
>>
>> I have not a win now; sqlite3 should be the lib.
>> I did not downgrade the lib, just reinstalled it.
>>
>>
>>
>> -----
>> Julian Bogdani
>> [hidden email]
>> http://bradypus.net
>>
>>
>>
>>
>>
>> On 15 Jun 2012, at 19:47 , Filipe Silva Dias wrote:
>>
>> Do you mean Libs->sqlite3 ? I tried reinstalling and going back to the
>> previous version but it didnt solve the problem.
>>
>> Thks
>>
>>
>> On Fri, Jun 15, 2012 at 6:32 PM, Julian Bogdani <[hidden email]>
>> wrote:
>>>
>>> I had the same problem in win 7.
>>> Telling osgeo4w to reinstall sqlite lib (osgeo4w, advanced mode) solved
>>> my problem.
>>>
>>> Hope this helps
>>>
>>>
>>> -----
>>> Julian Bogdani
>>> [hidden email]
>>> http://bradypus.net
>>>
>>>
>>>
>>>
>>>
>>> On 15 Jun 2012, at 19:29 , Filipe Silva Dias wrote:
>>>
>>> Dear all
>>>
>>> I reinstalled QGIS today via osgeo4w and now I get this error when I run
>>> QGIS 1.7 and 1.8
>>>
>>> Best
>>> F.
>>> _______________________________________________
>>> Qgis-user mailing list
>>> [hidden email]
>>> http://lists.osgeo.org/mailman/listinfo/qgis-user
>>>
>>>
>>
>>
>
>
> _______________________________________________
> Qgis-user mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/qgis-user
>



--
Giuseppe Sucameli


_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ERROR - "The procedure entry point sqlite3_open_v2 could not be located in the dynamic link library sqlite3.dll" when running QGIS 1.7 and 1.8 after OSGEO4w installation

Filipe Dias-2
I tried installing QGIS via "QGIS-OSGeo4W-1.7.4-d211b16-Setup.exe" and it works.

I only get the message with QGIS installed from osgeo4w


On Sat, Jun 16, 2012 at 9:54 AM, Filipe Silva Dias <[hidden email]> wrote:
Hi Giuseppe
I removed it (despite the installer complaining about dependencies), run QGIS again and got the same error. What else can I try?
This had never happened. I just reinstalled Windows 7 and I didnt install any software that I didnt have before.

I have some important things to do with QGIS and Im getting quite worried...

Thanks



On Fri, Jun 15, 2012 at 11:54 PM, Giuseppe Sucameli <[hidden email]> wrote:
Hi Filipe,

On Fri, Jun 15, 2012 at 6:59 PM, Filipe Silva Dias
<[hidden email]> wrote:
> Reinstalling didnt work.
>
> I also tried deleting c./osgeo4w and reinstalling everything again and that
> also didnt solve the problem

maybe you have another sqlite3 lib in your system which hides the one
shipped with osgeo4w.

Try to remove the sqlite3 lib from the osgeo4w installation and then run
QGis again. If the error persists then it's using a wrong sqlite3 lib.

Regards.

>
>
> On Fri, Jun 15, 2012 at 6:50 PM, Julian Bogdani <[hidden email]> wrote:
>>
>> I have not a win now; sqlite3 should be the lib.
>> I did not downgrade the lib, just reinstalled it.
>>
>>
>>
>> -----
>> Julian Bogdani
>> [hidden email]
>> http://bradypus.net
>>
>>
>>
>>
>>
>> On 15 Jun 2012, at 19:47 , Filipe Silva Dias wrote:
>>
>> Do you mean Libs->sqlite3 ? I tried reinstalling and going back to the
>> previous version but it didnt solve the problem.
>>
>> Thks
>>
>>
>> On Fri, Jun 15, 2012 at 6:32 PM, Julian Bogdani <[hidden email]>
>> wrote:
>>>
>>> I had the same problem in win 7.
>>> Telling osgeo4w to reinstall sqlite lib (osgeo4w, advanced mode) solved
>>> my problem.
>>>
>>> Hope this helps
>>>
>>>
>>> -----
>>> Julian Bogdani
>>> [hidden email]
>>> http://bradypus.net
>>>
>>>
>>>
>>>
>>>
>>> On 15 Jun 2012, at 19:29 , Filipe Silva Dias wrote:
>>>
>>> Dear all
>>>
>>> I reinstalled QGIS today via osgeo4w and now I get this error when I run
>>> QGIS 1.7 and 1.8
>>>
>>> Best
>>> F.
>>> _______________________________________________
>>> Qgis-user mailing list
>>> [hidden email]
>>> http://lists.osgeo.org/mailman/listinfo/qgis-user
>>>
>>>
>>
>>
>
>
> _______________________________________________
> Qgis-user mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/qgis-user
>



--
Giuseppe Sucameli



_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ERROR - "The procedure entry point sqlite3_open_v2 could not be located in the dynamic link library sqlite3.dll" when running QGIS 1.7 and 1.8 after OSGEO4w installation

Ramon Andiñach
In reply to this post by Filipe Dias-2
I'd have probably gone the other way around.

The one supplied with windows is now a bit old.

Either way. The error message is that QGIS can find more than one copy of the sqlite3.dll, and they're different versions - so its (understandably) confused and doesn't know which one to use.

For example see:
http://lists.osgeo.org/pipermail/qgis-user/2012-March/016296.html
and various other points in the mailing list.

-ramon.

On 16/06/2012, at 16:54 , Filipe Silva Dias wrote:

> Hi Giuseppe
> I removed it (despite the installer complaining about dependencies), run QGIS again and got the same error. What else can I try?
> This had never happened. I just reinstalled Windows 7 and I didnt install any software that I didnt have before.
>
> I have some important things to do with QGIS and Im getting quite worried...
>
> Thanks
>
>
> On Fri, Jun 15, 2012 at 11:54 PM, Giuseppe Sucameli <[hidden email]> wrote:
> Hi Filipe,
>
> On Fri, Jun 15, 2012 at 6:59 PM, Filipe Silva Dias
> <[hidden email]> wrote:
> > Reinstalling didnt work.
> >
> > I also tried deleting c./osgeo4w and reinstalling everything again and that
> > also didnt solve the problem
>
> maybe you have another sqlite3 lib in your system which hides the one
> shipped with osgeo4w.
>
> Try to remove the sqlite3 lib from the osgeo4w installation and then run
> QGis again. If the error persists then it's using a wrong sqlite3 lib.
>
> Regards.
>
> >
> >
> > On Fri, Jun 15, 2012 at 6:50 PM, Julian Bogdani <[hidden email]> wrote:
> >>
> >> I have not a win now; sqlite3 should be the lib.
> >> I did not downgrade the lib, just reinstalled it.
> >>
> >>
> >>
> >> -----
> >> Julian Bogdani
> >> [hidden email]
> >> http://bradypus.net
> >>
> >>
> >>
> >>
> >>
> >> On 15 Jun 2012, at 19:47 , Filipe Silva Dias wrote:
> >>
> >> Do you mean Libs->sqlite3 ? I tried reinstalling and going back to the
> >> previous version but it didnt solve the problem.
> >>
> >> Thks
> >>
> >>
> >> On Fri, Jun 15, 2012 at 6:32 PM, Julian Bogdani <[hidden email]>
> >> wrote:
> >>>
> >>> I had the same problem in win 7.
> >>> Telling osgeo4w to reinstall sqlite lib (osgeo4w, advanced mode) solved
> >>> my problem.
> >>>
> >>> Hope this helps
> >>>
> >>>
> >>> -----
> >>> Julian Bogdani
> >>> [hidden email]
> >>> http://bradypus.net
> >>>
> >>>
> >>>
> >>>
> >>>
> >>> On 15 Jun 2012, at 19:29 , Filipe Silva Dias wrote:
> >>>
> >>> Dear all
> >>>
> >>> I reinstalled QGIS today via osgeo4w and now I get this error when I run
> >>> QGIS 1.7 and 1.8
> >>>
> >>> Best
> >>> F.
_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ERROR - "The procedure entry point sqlite3_open_v2 could not be located in the dynamic link library sqlite3.dll" when running QGIS 1.7 and 1.8 after OSGEO4w installation

Filipe Dias-2
Ok, I was able to solve this by renaming "sqlite3.dll" to "sqlite31.dll" located in:

C:\Windows\SysWOW64

Thanks for your help
Regards

On Sat, Jun 16, 2012 at 11:00 AM, Ramon Andiñach <[hidden email]> wrote:
I'd have probably gone the other way around.

The one supplied with windows is now a bit old.

Either way. The error message is that QGIS can find more than one copy of the sqlite3.dll, and they're different versions - so its (understandably) confused and doesn't know which one to use.

For example see:
http://lists.osgeo.org/pipermail/qgis-user/2012-March/016296.html
and various other points in the mailing list.

-ramon.

On 16/06/2012, at 16:54 , Filipe Silva Dias wrote:

> Hi Giuseppe
> I removed it (despite the installer complaining about dependencies), run QGIS again and got the same error. What else can I try?
> This had never happened. I just reinstalled Windows 7 and I didnt install any software that I didnt have before.
>
> I have some important things to do with QGIS and Im getting quite worried...
>
> Thanks
>
>
> On Fri, Jun 15, 2012 at 11:54 PM, Giuseppe Sucameli <[hidden email]> wrote:
> Hi Filipe,
>
> On Fri, Jun 15, 2012 at 6:59 PM, Filipe Silva Dias
> <[hidden email]> wrote:
> > Reinstalling didnt work.
> >
> > I also tried deleting c./osgeo4w and reinstalling everything again and that
> > also didnt solve the problem
>
> maybe you have another sqlite3 lib in your system which hides the one
> shipped with osgeo4w.
>
> Try to remove the sqlite3 lib from the osgeo4w installation and then run
> QGis again. If the error persists then it's using a wrong sqlite3 lib.
>
> Regards.
>
> >
> >
> > On Fri, Jun 15, 2012 at 6:50 PM, Julian Bogdani <[hidden email]> wrote:
> >>
> >> I have not a win now; sqlite3 should be the lib.
> >> I did not downgrade the lib, just reinstalled it.
> >>
> >>
> >>
> >> -----
> >> Julian Bogdani
> >> [hidden email]
> >> http://bradypus.net
> >>
> >>
> >>
> >>
> >>
> >> On 15 Jun 2012, at 19:47 , Filipe Silva Dias wrote:
> >>
> >> Do you mean Libs->sqlite3 ? I tried reinstalling and going back to the
> >> previous version but it didnt solve the problem.
> >>
> >> Thks
> >>
> >>
> >> On Fri, Jun 15, 2012 at 6:32 PM, Julian Bogdani <[hidden email]>
> >> wrote:
> >>>
> >>> I had the same problem in win 7.
> >>> Telling osgeo4w to reinstall sqlite lib (osgeo4w, advanced mode) solved
> >>> my problem.
> >>>
> >>> Hope this helps
> >>>
> >>>
> >>> -----
> >>> Julian Bogdani
> >>> [hidden email]
> >>> http://bradypus.net
> >>>
> >>>
> >>>
> >>>
> >>>
> >>> On 15 Jun 2012, at 19:29 , Filipe Silva Dias wrote:
> >>>
> >>> Dear all
> >>>
> >>> I reinstalled QGIS today via osgeo4w and now I get this error when I run
> >>> QGIS 1.7 and 1.8
> >>>
> >>> Best
> >>> F.
_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user


_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ERROR - "The procedure entry point sqlite3_open_v2 could not be located in the dynamic link library sqlite3.dll" when running QGIS 1.7 and 1.8 after OSGEO4w installation

jbogdani
Hello,
I'm reopening this topic, because I'm not succeeding in installing qgis in a second Windows (Vista) machine.
During installation I get an error relative to crssync (CRSSYNC.exe stopped working).
Once installed I get the "The procedure entry point sqlite3_open_v2 could not be located in the dynamic link library sqlite3.dll" error!

Deleted everything, reinstalled, the same problem occurs. Renamed all occurrences of sqlite.dll in my system did not solve the problem. Removed Osgeo4w and installed the standalone version does not work at all. Same message error during the installation, no error shown on qgis start, and qgis does not start at all!

I've nstalled qgis 1.8 in several PC: both vista and 7. This is the first time I can not get it work.
Master version 1.9 does open but crashes as soon as I try to open my project file (based on spatialite vectors)!
Any help is appreciated! I need it work as soon as possible :(
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ERROR - "The procedure entry point sqlite3_open_v2 could not be located in the dynamic link library sqlite3.dll" when running QGIS 1.7 and 1.8 after OSGEO4w installation

jbogdani
Manually copyiung sqlite.dll from C:\osgeo4w\bin to C:\osgeo4w\apps\qgis\bin DID SOLVE my problem.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ERROR - "The procedure entry point sqlite3_open_v2 could not be located in the dynamic link library sqlite3.dll" when running QGIS 1.7 and 1.8 after OSGEO4w installation

Alessandro Donati
This post has NOT been accepted by the mailing list yet.
jbogdani wrote
Manually copyiung sqlite.dll from C:\osgeo4w\bin to C:\osgeo4w\apps\qgis\bin DID SOLVE my problem.
I did similar as jbogdani and I solve the problem. In particular I copied sqlite.dll from C:\Quantum GIS Lisboa\bin to C:\Quantum GIS Lisboa\apps\qgis\bin ... it works!
Loading...