[Dutch] PostGIS installeren op Ubuntu server 12.10

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

[Dutch] PostGIS installeren op Ubuntu server 12.10

Paul Meems (Top-X)
Goedenavond allen,

Ik ben bezig een nieuwe server aan het optuigen met GeoServer en PostGIS.
Als OS heb ik  Ubuntu server 12.10 (Quantal Quetzal) draaien.
Ik heb al een server draaien met Ubuntu server 12.04 en daarop heb ik PostGreSql en PostGIS als volgt geinstalleerd:
# Eerst de Python-software-properties installeren:
sudo apt-get install python-software-properties
# Install postgresql with official ppa
sudo apt-add-repository ppa:pitti/postgresql
sudo apt-add-repository ppa:sharpie/for-science
sudo apt-add-repository ppa:sharpie/postgis-stable
sudo apt-add-repository ppa:ubuntugis/ubuntugis-
unstable
sudo apt-get update
sudo apt-get install postgresql-9.1
sudo apt-get install postgresql-contrib-9.1
sudo apt-get install postgresql-9.1-postgis2
Voor de nieuwe server heb ik hetzelfde geprobeerd. Alleerst moet ik ook software-properties-common installeren, anders werkt apt-add-repository niet.
Als ik nu install postgresql-9.1-postgis2 doe, krijg ik de volgende foutmelding:
E: Unable to locate package postgresql-9.1-postgis2
E: Couldn't find any package by regex 'postgresql-9.1-postgis2'

Als ik apt-get update doe, krijg ik ook een aantal 404.
Het lijkt erop dat de postgresql/postgis repro's nog niet geschikt zijn voor de nieuwste Ubuntu.

Weet iemand van jullie welke repro ik moet gebruiken om PostGIS2 te installeren.
Eventueel voor PostGreSQL 9.2, maar dat is me op de andere server ook nooit gelukt.

Alvast bedankt.

Groeten,

Paul

_______________________________________________
Dutch mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/dutch
Reply | Threaded
Open this post in threaded view
|

Re: [Dutch] PostGIS installeren op Ubuntu server 12.10

Bart van den Eijnden (OSGIS)-2
Hoi Paul,

heb je weleens overwogen om gewoon de OpenGeo Suite packages te installeren?


Groeten,
Bart

-- 
Bart van den Eijnden
OSGIS - http://osgis.nl

On Feb 5, 2013, at 9:48 PM, Paul Meems <[hidden email]> wrote:

Goedenavond allen,

Ik ben bezig een nieuwe server aan het optuigen met GeoServer en PostGIS.
Als OS heb ik  Ubuntu server 12.10 (Quantal Quetzal) draaien.
Ik heb al een server draaien met Ubuntu server 12.04 en daarop heb ik PostGreSql en PostGIS als volgt geinstalleerd:
# Eerst de Python-software-properties installeren:
sudo apt-get install python-software-properties
# Install postgresql with official ppa
sudo apt-add-repository ppa:pitti/postgresql
sudo apt-add-repository ppa:sharpie/for-science
sudo apt-add-repository ppa:sharpie/postgis-stable
sudo apt-add-repository ppa:ubuntugis/ubuntugis-
unstable
sudo apt-get update
sudo apt-get install postgresql-9.1
sudo apt-get install postgresql-contrib-9.1
sudo apt-get install postgresql-9.1-postgis2
Voor de nieuwe server heb ik hetzelfde geprobeerd. Alleerst moet ik ook software-properties-common installeren, anders werkt apt-add-repository niet.
Als ik nu install postgresql-9.1-postgis2 doe, krijg ik de volgende foutmelding:
E: Unable to locate package postgresql-9.1-postgis2
E: Couldn't find any package by regex 'postgresql-9.1-postgis2'

Als ik apt-get update doe, krijg ik ook een aantal 404.
Het lijkt erop dat de postgresql/postgis repro's nog niet geschikt zijn voor de nieuwste Ubuntu.

Weet iemand van jullie welke repro ik moet gebruiken om PostGIS2 te installeren.
Eventueel voor PostGreSQL 9.2, maar dat is me op de andere server ook nooit gelukt.

Alvast bedankt.

Groeten,

Paul
_______________________________________________
Dutch mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/dutch


_______________________________________________
Dutch mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/dutch
Reply | Threaded
Open this post in threaded view
|

Re: [Dutch] PostGIS installeren op Ubuntu server 12.10

Meine Toonen
In reply to this post by Paul Meems (Top-X)
Ik weet dat het mij ook even kostte om het te installeren. Ik kan vanavond even kijken of ik iets kan vinden op mijn laptop.
Misschien dat onderstaande link helpt?
http://trac.osgeo.org/postgis/wiki/UsersWikiPostGIS20Ubuntu1210


Met vriendelijke groet,

Meine Toonen
B3Partners BV
Tel: 030 214 2083

From: Paul Meems [mailto:[hidden email]]
To: dutch [mailto:[hidden email]]
Sent: Tue, 05 Feb 2013 21:48:58 +0100
Subject: [Dutch] PostGIS installeren op Ubuntu server 12.10

Goedenavond allen,

Ik ben bezig een nieuwe server aan het optuigen met GeoServer en PostGIS.
Als OS heb ik  Ubuntu server 12.10 (Quantal Quetzal) draaien.
Ik heb al een server draaien met Ubuntu server 12.04 en daarop heb ik PostGreSql en PostGIS als volgt geinstalleerd:
# Eerst de Python-software-properties installeren:
sudo apt-get install python-software-properties
# Install postgresql with official ppa
sudo apt-add-repository ppa:pitti/postgresql
sudo apt-add-repository ppa:sharpie/for-science
sudo apt-add-repository ppa:sharpie/postgis-stable
sudo apt-add-repository ppa:ubuntugis/ubuntugis-
unstable
sudo apt-get update
sudo apt-get install postgresql-9.1
sudo apt-get install postgresql-contrib-9.1
sudo apt-get install postgresql-9.1-postgis2
Voor de nieuwe server heb ik hetzelfde geprobeerd. Alleerst moet ik ook software-properties-common installeren, anders werkt apt-add-repository niet.
Als ik nu install postgresql-9.1-postgis2 doe, krijg ik de volgende foutmelding:
E: Unable to locate package postgresql-9.1-postgis2
E: Couldn't find any package by regex 'postgresql-9.1-postgis2'

Als ik apt-get update doe, krijg ik ook een aantal 404.
Het lijkt erop dat de postgresql/postgis repro's nog niet geschikt zijn voor de nieuwste Ubuntu.

Weet iemand van jullie welke repro ik moet gebruiken om PostGIS2 te installeren.
Eventueel voor PostGreSQL 9.2, maar dat is me op de andere server ook nooit gelukt.

Alvast bedankt.

Groeten,

Paul

_______________________________________________
Dutch mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/dutch
Reply | Threaded
Open this post in threaded view
|

Re: [Dutch] PostGIS installeren op Ubuntu server 12.10

Just van den Broecke
In reply to this post by Bart van den Eijnden (OSGIS)-2
Hoi Paul,

Ik kan je (en iedereen hier) aanraden om de UbuntuGIS repo te
installeren. Vreemd, want PostGIS2 zou beschikbaar moeten zijn voor
Ubuntu 12.10 (Quantal Quetzal). Zie ook:
https://launchpad.net/~ubuntugis/+archive/ubuntugis-unstable/+index?batch=75&memo=75&start=75.
Mogelijk een andere package naam?
Je kunt de maintainers van UbuntuGIS anders verwittigen.

Ik sta toevallig op het punt om ook op 12.10 een open geostack te
installeren dus ik zal laten weten indien succes/fail.

groeten,

Just
On 05-02-13 22:08, Bart van den Eijnden wrote:

> Hoi Paul,
>
> heb je weleens overwogen om gewoon de OpenGeo Suite packages te installeren?
>
> http://suite.opengeo.org/opengeo-docs/installation/linux/ubuntu/suite.html
>
> Groeten,
> Bart
>
> --
> Bart van den Eijnden
> OSGIS - http://osgis.nl
>
> On Feb 5, 2013, at 9:48 PM, Paul Meems <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>> Goedenavond allen,
>>
>> Ik ben bezig een nieuwe server aan het optuigen met GeoServer en PostGIS.
>> Als OS heb ik  Ubuntu server 12.10 (Quantal Quetzal) draaien.
>> Ik heb al een server draaien met Ubuntu server 12.04 en daarop heb ik
>> PostGreSql en PostGIS als volgt geinstalleerd:
>> # Eerst de Python-software-properties installeren:
>> sudo apt-get install python-software-properties
>> # Install postgresql with official ppa
>> sudo apt-add-repository ppa:pitti/postgresql
>> sudo apt-add-repository ppa:sharpie/for-science
>> sudo apt-add-repository ppa:sharpie/postgis-stable
>> sudo apt-add-repository ppa:ubuntugis/ubuntugis-
>> unstable
>> sudo apt-get update
>> sudo apt-get install postgresql-9.1
>> sudo apt-get install postgresql-contrib-9.1
>> sudo apt-get install postgresql-9.1-postgis2
>> Zoals verteld op
>> http://trac.osgeo.org/postgis/wiki/UsersWikiPostGIS20Ubuntu1204
>>
>> Voor de nieuwe server heb ik hetzelfde geprobeerd. Alleerst moet ik
>> ook software-properties-common installeren, anders werkt
>> apt-add-repository niet.
>> Als ik nu install postgresql-9.1-postgis2 doe, krijg ik de volgende
>> foutmelding:
>> E: Unable to locate package postgresql-9.1-postgis2
>> E: Couldn't find any package by regex 'postgresql-9.1-postgis2'
>>
>> Als ik apt-get update doe, krijg ik ook een aantal 404.
>> Het lijkt erop dat de postgresql/postgis repro's nog niet geschikt
>> zijn voor de nieuwste Ubuntu.
>>
>> Weet iemand van jullie welke repro ik moet gebruiken om PostGIS2 te
>> installeren.
>> Eventueel voor PostGreSQL 9.2, maar dat is me op de andere server ook
>> nooit gelukt.
>>
>> Alvast bedankt.
>>
>> Groeten,
>>
>> Paul
>> _______________________________________________
>> Dutch mailing list
>> [hidden email] <mailto:[hidden email]>
>> http://lists.osgeo.org/mailman/listinfo/dutch
>
>
>
> _______________________________________________
> Dutch mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/dutch
>




_______________________________________________
Dutch mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/dutch
Reply | Threaded
Open this post in threaded view
|

Re: [Dutch] PostGIS installeren op Ubuntu server 12.10

Just van den Broecke
Hoi Paul,

Is mij net gelukt om PostGIS 2 te installeren op Ubuntu 12.10 (Quantal
Quetzal), 2 stappen:

sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable
sudo apt-get install postgis

Verder geen andere extra repos. Door install van "postgis" package
installeren gelijk alle deps: PostgreSQL 9.1, GDAL 1.9.2, Proj, GEOS
etc. dus sowieso een mooie shortcut ipv eerst alle deps te apt-getten.

Dus ik denk dat de de package-naam "postgis" moet zijn en/of mogelijk is
er een conflict met een van je andere extra repo's.

groeten,

Just

On 06-02-13 08:36, Just van den Broecke wrote:

> Hoi Paul,
>
> Ik kan je (en iedereen hier) aanraden om de UbuntuGIS repo te
> installeren. Vreemd, want PostGIS2 zou beschikbaar moeten zijn voor
> Ubuntu 12.10 (Quantal Quetzal). Zie ook:
> https://launchpad.net/~ubuntugis/+archive/ubuntugis-unstable/+index?batch=75&memo=75&start=75.
> Mogelijk een andere package naam?
> Je kunt de maintainers van UbuntuGIS anders verwittigen.
>
> Ik sta toevallig op het punt om ook op 12.10 een open geostack te
> installeren dus ik zal laten weten indien succes/fail.
>
> groeten,
>
> Just
> On 05-02-13 22:08, Bart van den Eijnden wrote:
>> Hoi Paul,
>>
>> heb je weleens overwogen om gewoon de OpenGeo Suite packages te
>> installeren?
>>
>> http://suite.opengeo.org/opengeo-docs/installation/linux/ubuntu/suite.html
>>
>>
>> Groeten,
>> Bart
>>
>> --
>> Bart van den Eijnden
>> OSGIS - http://osgis.nl
>>
>> On Feb 5, 2013, at 9:48 PM, Paul Meems <[hidden email]
>> <mailto:[hidden email]>> wrote:
>>
>>> Goedenavond allen,
>>>
>>> Ik ben bezig een nieuwe server aan het optuigen met GeoServer en
>>> PostGIS.
>>> Als OS heb ik  Ubuntu server 12.10 (Quantal Quetzal) draaien.
>>> Ik heb al een server draaien met Ubuntu server 12.04 en daarop heb ik
>>> PostGreSql en PostGIS als volgt geinstalleerd:
>>> # Eerst de Python-software-properties installeren:
>>> sudo apt-get install python-software-properties
>>> # Install postgresql with official ppa
>>> sudo apt-add-repository ppa:pitti/postgresql
>>> sudo apt-add-repository ppa:sharpie/for-science
>>> sudo apt-add-repository ppa:sharpie/postgis-stable
>>> sudo apt-add-repository ppa:ubuntugis/ubuntugis-
>>> unstable
>>> sudo apt-get update
>>> sudo apt-get install postgresql-9.1
>>> sudo apt-get install postgresql-contrib-9.1
>>> sudo apt-get install postgresql-9.1-postgis2
>>> Zoals verteld op
>>> http://trac.osgeo.org/postgis/wiki/UsersWikiPostGIS20Ubuntu1204
>>>
>>> Voor de nieuwe server heb ik hetzelfde geprobeerd. Alleerst moet ik
>>> ook software-properties-common installeren, anders werkt
>>> apt-add-repository niet.
>>> Als ik nu install postgresql-9.1-postgis2 doe, krijg ik de volgende
>>> foutmelding:
>>> E: Unable to locate package postgresql-9.1-postgis2
>>> E: Couldn't find any package by regex 'postgresql-9.1-postgis2'
>>>
>>> Als ik apt-get update doe, krijg ik ook een aantal 404.
>>> Het lijkt erop dat de postgresql/postgis repro's nog niet geschikt
>>> zijn voor de nieuwste Ubuntu.
>>>
>>> Weet iemand van jullie welke repro ik moet gebruiken om PostGIS2 te
>>> installeren.
>>> Eventueel voor PostGreSQL 9.2, maar dat is me op de andere server ook
>>> nooit gelukt.
>>>
>>> Alvast bedankt.
>>>
>>> Groeten,
>>>
>>> Paul
>>> _______________________________________________
>>> Dutch mailing list
>>> [hidden email] <mailto:[hidden email]>
>>> http://lists.osgeo.org/mailman/listinfo/dutch
>>
>>
>>
>> _______________________________________________
>> Dutch mailing list
>> [hidden email]
>> http://lists.osgeo.org/mailman/listinfo/dutch
>>
>
>
>
>
> _______________________________________________
> Dutch mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/dutch
>





_______________________________________________
Dutch mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/dutch
Reply | Threaded
Open this post in threaded view
|

Re: [Dutch] PostGIS installeren op Ubuntu server 12.10

Paul Meems (Top-X)
In reply to this post by Just van den Broecke
Just,

Ik gebruik een Cloud Server van RackSpace en ik ben weer geswitched naar Ubuntu 12.04 en dan werken deze wel:
sudo apt-get install postgresql-9.1
sudo apt-get install postgresql-contrib-9.1
sudo apt-get install postgresql-9.1-postgis2

Bij toeval kwam ik ook uit op een ppa voor Oracle Java 7 die wel werkt: http://www.webupd8.org/2012/01/install-oracle-java-jdk-7-in-ubuntu-via.html

Mocht je PostGIS2 en PostGreSql9.2 op Ubuntu 10.20 geinstalleerd krijgen, dan hoor ik graag welke package namen je daar voor hebt gebruikt.

Met vriendelijke groet,



Paul Meems


Op 6 februari 2013 08:36 schreef Just van den Broecke <[hidden email]> het volgende:
Hoi Paul,

Ik kan je (en iedereen hier) aanraden om de UbuntuGIS repo te installeren. Vreemd, want PostGIS2 zou beschikbaar moeten zijn voor
Ubuntu 12.10 (Quantal Quetzal). Zie ook:
https://launchpad.net/~ubuntugis/+archive/ubuntugis-unstable/+index?batch=75&memo=75&start=75. Mogelijk een andere package naam?
Je kunt de maintainers van UbuntuGIS anders verwittigen.

Ik sta toevallig op het punt om ook op 12.10 een open geostack te installeren dus ik zal laten weten indien succes/fail.

groeten,

Just

On 05-02-13 22:08, Bart van den Eijnden wrote:
Hoi Paul,

heb je weleens overwogen om gewoon de OpenGeo Suite packages te installeren?

http://suite.opengeo.org/opengeo-docs/installation/linux/ubuntu/suite.html

Groeten,
Bart

--
Bart van den Eijnden
OSGIS - http://osgis.nl

On Feb 5, 2013, at 9:48 PM, Paul Meems <[hidden email]
<mailto:[hidden email]>> wrote:

Goedenavond allen,

Ik ben bezig een nieuwe server aan het optuigen met GeoServer en PostGIS.
Als OS heb ik  Ubuntu server 12.10 (Quantal Quetzal) draaien.
Ik heb al een server draaien met Ubuntu server 12.04 en daarop heb ik
PostGreSql en PostGIS als volgt geinstalleerd:
# Eerst de Python-software-properties installeren:
sudo apt-get install python-software-properties
# Install postgresql with official ppa
sudo apt-add-repository ppa:pitti/postgresql
sudo apt-add-repository ppa:sharpie/for-science
sudo apt-add-repository ppa:sharpie/postgis-stable
sudo apt-add-repository ppa:ubuntugis/ubuntugis-
unstable
sudo apt-get update
sudo apt-get install postgresql-9.1
sudo apt-get install postgresql-contrib-9.1
sudo apt-get install postgresql-9.1-postgis2
Zoals verteld op
http://trac.osgeo.org/postgis/wiki/UsersWikiPostGIS20Ubuntu1204

Voor de nieuwe server heb ik hetzelfde geprobeerd. Alleerst moet ik
ook software-properties-common installeren, anders werkt
apt-add-repository niet.
Als ik nu install postgresql-9.1-postgis2 doe, krijg ik de volgende
foutmelding:
E: Unable to locate package postgresql-9.1-postgis2
E: Couldn't find any package by regex 'postgresql-9.1-postgis2'

Als ik apt-get update doe, krijg ik ook een aantal 404.
Het lijkt erop dat de postgresql/postgis repro's nog niet geschikt
zijn voor de nieuwste Ubuntu.

Weet iemand van jullie welke repro ik moet gebruiken om PostGIS2 te
installeren.
Eventueel voor PostGreSQL 9.2, maar dat is me op de andere server ook
nooit gelukt.

Alvast bedankt.

Groeten,

Paul
_______________________________________________
Dutch mailing list
[hidden email] <mailto:[hidden email]>
http://lists.osgeo.org/mailman/listinfo/dutch



_______________________________________________
Dutch mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/dutch





_______________________________________________
Dutch mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/dutch



_______________________________________________
Dutch mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/dutch
Reply | Threaded
Open this post in threaded view
|

Re: [Dutch] PostGIS installeren op Ubuntu server 12.10

Just van den Broecke
Paul,

Je hebt mogelijk een mail van mij gemist. Ik herhaal:

"Is mij net gelukt om PostGIS 2 te installeren op Ubuntu 12.10 (Quantal
Quetzal), 2 stappen:

sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable
sudo apt-get install postgis

Verder geen andere extra repos. Door install van "postgis" package
installeren gelijk alle deps: PostgreSQL 9.1, GDAL 1.9.2, Proj, GEOS
etc. dus sowieso een mooie shortcut ipv eerst alle deps te apt-getten.

Dus ik denk dat de de package-naam "postgis" moet zijn en/of mogelijk is
er een conflict met een van je andere extra repo's."

Welliswaar geen postgresql 9.2 maar 9.1, maar dat lijkt mij minor. Maar
goed Ubuntu 12.04 is vanwege de LTS
(http://en.wikipedia.org/wiki/List_of_Ubuntu_releases) en mogelijke
andere install issues een veilige keuze. groeten,

Just


On 06-02-13 11:15, Paul Meems wrote:

> Just,
>
> Ik gebruik een Cloud Server van RackSpace en ik ben weer geswitched naar
> Ubuntu 12.04 en dan werken deze wel:
> sudo apt-get install postgresql-9.1
> sudo apt-get install postgresql-contrib-9.1
> sudo apt-get install postgresql-9.1-postgis2
>
> Bij toeval kwam ik ook uit op een ppa voor Oracle Java 7 die wel werkt:
> http://www.webupd8.org/2012/01/install-oracle-java-jdk-7-in-ubuntu-via.html
>
> Mocht je PostGIS2 en PostGreSql9.2 op Ubuntu 10.20 geinstalleerd
> krijgen, dan hoor ik graag welke package namen je daar voor hebt gebruikt.
>
> Met vriendelijke groet,
>
>
>
> Paul Meems
>
>
> Op 6 februari 2013 08:36 schreef Just van den Broecke
> <[hidden email] <mailto:[hidden email]>> het volgende:
>
>     Hoi Paul,
>
>     Ik kan je (en iedereen hier) aanraden om de UbuntuGIS repo te
>     installeren. Vreemd, want PostGIS2 zou beschikbaar moeten zijn voor
>     Ubuntu 12.10 (Quantal Quetzal). Zie ook:
>     https://launchpad.net/~ubuntugis/+archive/ubuntugis-unstable/+index?batch=75&memo=75&start=75.
>     Mogelijk een andere package naam?
>     Je kunt de maintainers van UbuntuGIS anders verwittigen.
>
>     Ik sta toevallig op het punt om ook op 12.10 een open geostack te
>     installeren dus ik zal laten weten indien succes/fail.
>
>     groeten,
>
>     Just
>
>     On 05-02-13 22:08, Bart van den Eijnden wrote:
>
>         Hoi Paul,
>
>         heb je weleens overwogen om gewoon de OpenGeo Suite packages te
>         installeren?
>
>         http://suite.opengeo.org/opengeo-docs/installation/linux/ubuntu/suite.html
>
>         Groeten,
>         Bart
>
>         --
>         Bart van den Eijnden
>         OSGIS - http://osgis.nl
>
>         On Feb 5, 2013, at 9:48 PM, Paul Meems <[hidden email]
>         <mailto:[hidden email]>
>         <mailto:[hidden email] <mailto:[hidden email]>>>
>         wrote:
>
>             Goedenavond allen,
>
>             Ik ben bezig een nieuwe server aan het optuigen met
>             GeoServer en PostGIS.
>             Als OS heb ik  Ubuntu server 12.10 (Quantal Quetzal) draaien.
>             Ik heb al een server draaien met Ubuntu server 12.04 en
>             daarop heb ik
>             PostGreSql en PostGIS als volgt geinstalleerd:
>             # Eerst de Python-software-properties installeren:
>             sudo apt-get install python-software-properties
>             # Install postgresql with official ppa
>             sudo apt-add-repository ppa:pitti/postgresql
>             sudo apt-add-repository ppa:sharpie/for-science
>             sudo apt-add-repository ppa:sharpie/postgis-stable
>             sudo apt-add-repository ppa:ubuntugis/ubuntugis-
>             unstable
>             sudo apt-get update
>             sudo apt-get install postgresql-9.1
>             sudo apt-get install postgresql-contrib-9.1
>             sudo apt-get install postgresql-9.1-postgis2
>             Zoals verteld op
>             http://trac.osgeo.org/postgis/wiki/UsersWikiPostGIS20Ubuntu1204
>
>             Voor de nieuwe server heb ik hetzelfde geprobeerd. Alleerst
>             moet ik
>             ook software-properties-common installeren, anders werkt
>             apt-add-repository niet.
>             Als ik nu install postgresql-9.1-postgis2 doe, krijg ik de
>             volgende
>             foutmelding:
>             E: Unable to locate package postgresql-9.1-postgis2
>             E: Couldn't find any package by regex 'postgresql-9.1-postgis2'
>
>             Als ik apt-get update doe, krijg ik ook een aantal 404.
>             Het lijkt erop dat de postgresql/postgis repro's nog niet
>             geschikt
>             zijn voor de nieuwste Ubuntu.
>
>             Weet iemand van jullie welke repro ik moet gebruiken om
>             PostGIS2 te
>             installeren.
>             Eventueel voor PostGreSQL 9.2, maar dat is me op de andere
>             server ook
>             nooit gelukt.
>
>             Alvast bedankt.
>
>             Groeten,
>
>             Paul
>             _______________________________________________
>             Dutch mailing list
>             [hidden email] <mailto:[hidden email]>
>             <mailto:[hidden email] <mailto:[hidden email]>>
>             http://lists.osgeo.org/mailman/listinfo/dutch
>
>
>
>
>         _______________________________________________
>         Dutch mailing list
>         [hidden email] <mailto:[hidden email]>
>         http://lists.osgeo.org/mailman/listinfo/dutch
>
>
>
>
>
>     _______________________________________________
>     Dutch mailing list
>     [hidden email] <mailto:[hidden email]>
>     http://lists.osgeo.org/mailman/listinfo/dutch
>
>
>
>
> _______________________________________________
> Dutch mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/dutch
>




_______________________________________________
Dutch mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/dutch
Reply | Threaded
Open this post in threaded view
|

Re: [Dutch] PostGIS installeren op Ubuntu server 12.10

Marc Coevoet-3
In reply to this post by Paul Meems (Top-X)
On 06-02-13 11:15, Paul Meems wrote:

> Just,
>
> Ik gebruik een Cloud Server van RackSpace en ik ben weer geswitched naar
> Ubuntu 12.04 en dan werken deze wel:
> sudo apt-get install postgresql-9.1
> sudo apt-get install postgresql-contrib-9.1
> sudo apt-get install postgresql-9.1-postgis2
>
> Bij toeval kwam ik ook uit op een ppa voor Oracle Java 7 die wel werkt:
> http://www.webupd8.org/2012/01/install-oracle-java-jdk-7-in-ubuntu-via.html
>
> Mocht je PostGIS2 en PostGreSql9.2 op Ubuntu 10.20 geinstalleerd
> krijgen, dan hoor ik graag welke package namen je daar voor hebt gebruikt.
>

Op de site van de db zie ikjwel degeljk 9.2 staan, in de testing:

http://www.postgresql.org/download/linux/ubuntu/

De apt toevoegen, en ?

PostgreSQL Apt Repository

If the version included in your version of Debian is not the one you
want, you can use the PostgreSQL Apt Repository. This repository will
integrate with your normal systems and patch management, and provide
automatic updates for all supported versions of PostgreSQL throughout
the support lifetime of PostgreSQL.

Not all Ubuntu releases are currently supported in the apt repository.
For an up to date list of supported releases, please see the apt page on
the wiki.

To use the apt repository, follow these steps:

     Import the repository signing key wget -O -
http://apt.postgresql.org/pub/repos/apt/ACCC4CF8.asc | sudo apt-key add -
     Edit the file /etc/apt/sources.list.d/pgdg.list, and add a line for
the repository, substituting the proper "codename" for your release deb
http://apt.postgresql.org/pub/repos/apt/ precise-pgdg main
     Configure apt's package pinning to prefer the PGDG packages over
the standard ones in /etc/apt/preferences.d/pgdg.pref Package: *
     Pin: release o=apt.postgresql.org
     Pin-Priority: 500
     Update the package lists, and install the pgdg-keyring package to
automatically get repository key updates sudo apt-get update
     sudo apt-get install pgdg-keyring

For more information about the apt repository, including answers to
frequent questions, please see the apt page on the wiki.


Marc

--
The "Penguin" has arrived - and he's not going away - ever.
What's on Shortwave guide: choose an hour, go!
http://shortwave dot tk
700+ Radio Stations on SW http://swstations dot tk
300+ languages on SW http://radiolanguages dot tk
_______________________________________________
Dutch mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/dutch