Digitizer/Markierung

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Digitizer/Markierung

Stephan Reber-2
Hallo,

ich habe in meiner Anwendung zweimal den Digitizer integriert und einmal
das Element Suchen. Wenn alles aktiviert ist, funktioniert die
Markierung beim Überfahren der Geometrien nicht mehr. Wenn ich nur
einmal den Digitizer aktiviert habe funktioniert, die Markierung im
Kartenfenster wieder.

Kann man da in Mapbender was machen, dass das auch bei allen aktivierten
Elementen funktioniert? Oder ist der Flaschenhals bei PostGIS?

Danke und Viele Grüße

Stephan

_______________________________________________
Mapbender_users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_users
Reply | Threaded
Open this post in threaded view
|

Re: Digitizer/Markierung

Toma, Charlotte
Hallo Stephan,

ich vermute du musst noch den Parameter "displayOnInactive: true" setzen, damit die Anzeige der Digitizer-Objekte in der Karte permanent aktiv ist. Pro Erfassungsmaske brauchst du jedoch dann ein Digitizer-Element in deiner Anwendung. Wenn du zwei Erfassungsmasken in ein Digitizer-Element packst (poi, line und polygon in der Doku - hier hast du dann die Auswahlbox), dann ist immer nur das erste Element sichtbar.

Der Parameter "displayOnInactive: true" kommt auf die gleiche Ebene, wie "searchType: currentExtent" oder "allowDelete: false".

Grüße und schönes Wochenende
Charly


Mit freundlichen Grüßen
im Auftrag
Charlotte Toma
Landeshauptstadt Wiesbaden
-Der Magistrat-
Stadtplanungsamt
-610230-
Gustav-Stresemann-Ring 15
65189 Wiesbaden
Tel.: 0611 31-3436
Fax: 0611 31-3917
E-Mail: [hidden email]
Internet: www.wiesbaden.de
Diese Nachricht könnte vertrauliche und/oder rechtlich geschützte Inhalte haben. In jedem Fall ist sie nur für diese Adresse bestimmt; anderen ist es also nicht gestattet, sie zu lesen, zu kopieren oder zu verwenden. Sollten Sie diese Nachricht irrtümlich erhalten haben, bitten wir Sie, sich umgehend mit uns in Verbindung zu setzen und sie umgehend von Ihrem Datenträger zu entfernen. Bitte überlegen Sie, ob das Ausdrucken dieser E-Mail notwendig ist.


-----Ursprüngliche Nachricht-----
Von: Mapbender_users [mailto:[hidden email]] Im Auftrag von Stephan Reber
Gesendet: Freitag, 28. Februar 2020 11:45
An: [hidden email]
Betreff: [Mapbender-users] Digitizer/Markierung

Hallo,

ich habe in meiner Anwendung zweimal den Digitizer integriert und einmal das Element Suchen. Wenn alles aktiviert ist, funktioniert die Markierung beim Überfahren der Geometrien nicht mehr. Wenn ich nur einmal den Digitizer aktiviert habe funktioniert, die Markierung im Kartenfenster wieder.

Kann man da in Mapbender was machen, dass das auch bei allen aktivierten Elementen funktioniert? Oder ist der Flaschenhals bei PostGIS?

Danke und Viele Grüße

Stephan

_______________________________________________
Mapbender_users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_users
_______________________________________________
Mapbender_users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_users