Deploying Geoserver 2.14 on JBOSS EAP 6.4

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Deploying Geoserver 2.14 on JBOSS EAP 6.4

pradeep2751
I am working on Geoserver migration from 2.8 to 2.14. This migration is
happening on JBOSS but as we don't want to disturb existing Sandbox and Dev
environment, I have created separate instance of JBOSS and deploying
Geoserver 2.14 on it. I am able to deploy it on Jboss but not sure what port
it using to launch GUI for further configuration.
Does anyone else faced similar problem in deploying Geoserver on Jboss ?

Regards,
Pradeep



--
Sent from: http://osgeo-org.1560.x6.nabble.com/GeoServer-Dev-f3819232.html


_______________________________________________
Geoserver-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-devel
Reply | Threaded
Open this post in threaded view
|

Re: Deploying Geoserver 2.14 on JBOSS EAP 6.4

Imran Rajjad
Hi Pradeep,

Sounds like you need to lookup the default JBOSS ports in documentation, Geoserver runs inside the container and is port agnostic 

regards,
Imran

On Wed, Jun 19, 2019 at 7:26 PM pradeep2751 <[hidden email]> wrote:
I am working on Geoserver migration from 2.8 to 2.14. This migration is
happening on JBOSS but as we don't want to disturb existing Sandbox and Dev
environment, I have created separate instance of JBOSS and deploying
Geoserver 2.14 on it. I am able to deploy it on Jboss but not sure what port
it using to launch GUI for further configuration.
Does anyone else faced similar problem in deploying Geoserver on Jboss ?

Regards,
Pradeep



--
Sent from: http://osgeo-org.1560.x6.nabble.com/GeoServer-Dev-f3819232.html


_______________________________________________
Geoserver-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-devel


--
I.R


_______________________________________________
Geoserver-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-devel
Reply | Threaded
Open this post in threaded view
|

Re: Deploying Geoserver 2.14 on JBOSS EAP 6.4

pradeep2751
Hi Imran,

I am not able to launch geoserver URL from http port defined in standalone.xml. Is there someother file which needs to be modified to launch application ?
Steps that I followed
1. Installed Jboss 6.4 EAP
2. Configured Standalone.xml
3. Modifed geoserver.war by adding files as per instructions
4. Deployed war file in deployment directory. 

Restarted jboss server and try to connect geoserver on http port defined in Jboss configuration file but nothing is happening.
While installing using windows installer it did ask for userid, password and port configuration but while installing on Jboss there is no instruction to for userid and password and even port.

Did you have well written instruction for installing it on Jboss ? Spent almost 2 days on this issue and now want to solution for it.


Regards,
Pradeep

On Wed, Jun 19, 2019 at 6:00 PM Imran Rajjad <[hidden email]> wrote:
Hi Pradeep,

Sounds like you need to lookup the default JBOSS ports in documentation, Geoserver runs inside the container and is port agnostic 

regards,
Imran

On Wed, Jun 19, 2019 at 7:26 PM pradeep2751 <[hidden email]> wrote:
I am working on Geoserver migration from 2.8 to 2.14. This migration is
happening on JBOSS but as we don't want to disturb existing Sandbox and Dev
environment, I have created separate instance of JBOSS and deploying
Geoserver 2.14 on it. I am able to deploy it on Jboss but not sure what port
it using to launch GUI for further configuration.
Does anyone else faced similar problem in deploying Geoserver on Jboss ?

Regards,
Pradeep



--
Sent from: http://osgeo-org.1560.x6.nabble.com/GeoServer-Dev-f3819232.html


_______________________________________________
Geoserver-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-devel


--
I.R


--
Things should be made as simple as possible and not one bit simpler


_______________________________________________
Geoserver-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-devel
Reply | Threaded
Open this post in threaded view
|

Re: Deploying Geoserver 2.14 on JBOSS EAP 6.4

Brad Hards
In reply to this post by pradeep2751
Jboss is not used by many (perhaps any) of the core developers.
This question would be more appropriate on the geoserver users' list, where
you might find someone who is familiar with it.

Brad




_______________________________________________
Geoserver-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-devel