Default GetCapabilities Version Not Working

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Default GetCapabilities Version Not Working

mcechini

All,

   We are running MapServer version 7.0.1 and attempting to use the MAP > WEB > METADATA > wms_getcapabilities_version configuration value to support GetCapabilities requests that do not supply the VERSION parameter.  Unfortunately, even if we do add this value to our mapserver configuration file, we continue to see the following service exception.  Any suggestions?

 

msOWSParseVersionString(): OWS error. Invalid version (). Version must be in the format 'x.y' or 'x.y.z'

 

   Here is our METADATA block:

 

  WEB

    METADATA

      "wms_enable_request"     "GetMap GetCapabilities"

      "wms_title"              "Some Text"

      "wms_abstract"           "Some Text"

      "wms_onlineresource"     "https://our_url?"

      "wms_srs"                "epsg:4326"

      "wms_getcapabilities_version"  "1.3.0"

      "wms_connectiontimeout"  "180"

     END                 

  END

 

Thanks,

Matt

.................................................................

Matthew Cechini

Contractor, Science Systems and Applications, Inc.

NASA GIBS Systems/Software Engineer

410.205.6272


_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: Default GetCapabilities Version Not Working

Lime, Steve D (MNIT)

Hi Matthew: Looking at the code MapServer 7.0 defaults to 1.3.0 already for GetCapabilties requests – you shouldn’t need that line. That said, it should work… --Steve

 

From: mapserver-users [mailto:[hidden email]] On Behalf Of Cechini, Matthew F. (GSFC-423.0)[Science Systems & Applications, Inc.]
Sent: Wednesday, May 16, 2018 4:22 PM
To: mapserver-users <[hidden email]>
Subject: [mapserver-users] Default GetCapabilities Version Not Working

 

All,

   We are running MapServer version 7.0.1 and attempting to use the MAP > WEB > METADATA > wms_getcapabilities_version configuration value to support GetCapabilities requests that do not supply the VERSION parameter.  Unfortunately, even if we do add this value to our mapserver configuration file, we continue to see the following service exception.  Any suggestions?

 

msOWSParseVersionString(): OWS error. Invalid version (). Version must be in the format 'x.y' or 'x.y.z'

 

   Here is our METADATA block:

 

  WEB

    METADATA

      "wms_enable_request"     "GetMap GetCapabilities"

      "wms_title"              "Some Text"

      "wms_abstract"           "Some Text"

      "wms_onlineresource"     "https://our_url?"

      "wms_srs"                "epsg:4326"

      "wms_getcapabilities_version"  "1.3.0"

      "wms_connectiontimeout"  "180"

     END                 

  END

 

Thanks,

Matt

.................................................................

Matthew Cechini

Contractor, Science Systems and Applications, Inc.

NASA GIBS Systems/Software Engineer

410.205.6272


_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: Default GetCapabilities Version Not Working

Lime, Steve D (MNIT)

I tried it locally with 7.0.4 and it works as expected. I can switch between a default of 1.1.1 or 1.3.0 easily with that metadata element. I can’t create the exception you’re seeing with the metadata regardless of what I set it to – it defaults back to 1.3.0. I can create the exception via URL. Are you sure clients aren’t passing bad versions as opposed to no version?

 

--Steve

 

From: mapserver-users [mailto:[hidden email]] On Behalf Of Lime, Steve D (MNIT)
Sent: Thursday, May 17, 2018 1:32 PM
To: Cechini, Matthew F. (GSFC-423.0)[Science Systems & Applications, Inc.] <[hidden email]>; mapserver-users <[hidden email]>
Subject: Re: [mapserver-users] Default GetCapabilities Version Not Working

 

Hi Matthew: Looking at the code MapServer 7.0 defaults to 1.3.0 already for GetCapabilties requests – you shouldn’t need that line. That said, it should work… --Steve

 

From: mapserver-users [[hidden email]] On Behalf Of Cechini, Matthew F. (GSFC-423.0)[Science Systems & Applications, Inc.]
Sent: Wednesday, May 16, 2018 4:22 PM
To: mapserver-users <[hidden email]>
Subject: [mapserver-users] Default GetCapabilities Version Not Working

 

All,

   We are running MapServer version 7.0.1 and attempting to use the MAP > WEB > METADATA > wms_getcapabilities_version configuration value to support GetCapabilities requests that do not supply the VERSION parameter.  Unfortunately, even if we do add this value to our mapserver configuration file, we continue to see the following service exception.  Any suggestions?

 

msOWSParseVersionString(): OWS error. Invalid version (). Version must be in the format 'x.y' or 'x.y.z'

 

   Here is our METADATA block:

 

  WEB

    METADATA

      "wms_enable_request"     "GetMap GetCapabilities"

      "wms_title"              "Some Text"

      "wms_abstract"           "Some Text"

      "wms_onlineresource"     "https://our_url?"

      "wms_srs"                "epsg:4326"

      "wms_getcapabilities_version"  "1.3.0"

      "wms_connectiontimeout"  "180"

     END                 

  END

 

Thanks,

Matt

.................................................................

Matthew Cechini

Contractor, Science Systems and Applications, Inc.

NASA GIBS Systems/Software Engineer

410.205.6272


_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users