Consulta OsGeo Live GeoServer OpenLayers

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Consulta OsGeo Live GeoServer OpenLayers

Jorge Luis Schmukler

Buenos días a todos los miembros de la lista, mi nombre es Jorge Schmukler soy de Parana Entre Rios Argentina; y les quiero consultar y comentar lo siguiente:

disculpen las molestias, recurro a las capacidades y experiencia de ustedes para que nos ayuden a resolver el siguiente problema que tenemos:

Objetivo: implementar un IDE y que utilice WMS, en principio a nivel localhost a través de una maquina virtual

Escenario y punto de inicio:
Instalacion y configuracion de la máquina virtual OSGeo Live 12 (ubuntu).

Por lo tanto, en dicha maquina tenemos:
GeoServer en http://localhost:8082/geoserver funcionando.
GeoNode en http://localhost:80/geonode funcionando.

Ahora estamos  agregando sobre la misma máquina virtual un visualizar con GeoExt ExtJS y OpenLayers sobre la misma maquina virtual y visualizar las capas WMS que nos prevee el geoserver, además tambien debemos tener la posibilidad de agregar capas WMS externas de otros proveedores.

http://localhost/visualizador.  --> virtualhost creado para prueba visor.web

Preguntas:

1. Porque no vemos las capas WMS del Geoserver, cuando las mismas son llamadas desde el visualizador ?  observamos que ustedes hablan de un proxy... y en muchos sitios comentan acerca del proxy de OpenLayers.

Una prueba que he realizado es ingresar en el navegador la URL completa con todos sus parámetros del WMS y la URL se visualiza correctamente.

2. Es factible esa arquitectura que hemos armado ? Alguna sugerencia...

3. Nos falta configurar algo, en el Apache quizás ?

Muchas gracias y Saludos
Un gusto


--
Jorge Luis Schmukler

_______________________________________________
Spanish mailing list
https://lists.osgeo.org/mailman/listinfo/spanish
http://es.osgeo.org
http://twitter.com/osgeoes
Reply | Threaded
Open this post in threaded view
|

Re: Consulta OsGeo Live GeoServer OpenLayers

Luis Franco Vázquez-2
Hola Jorge:

Revisa la consola de javascript para ver los mensajes de error y
asegúrate de que realmente está funcionando el servicios WMS haciendo
una petición getcapabilities a mano.

El vie., 15 feb. 2019 a las 16:54, Jorge Luis Schmukler
(<[hidden email]>) escribió:

>
>
> Buenos días a todos los miembros de la lista, mi nombre es Jorge Schmukler soy de Parana Entre Rios Argentina; y les quiero consultar y comentar lo siguiente:
>
> disculpen las molestias, recurro a las capacidades y experiencia de ustedes para que nos ayuden a resolver el siguiente problema que tenemos:
>
> Objetivo: implementar un IDE y que utilice WMS, en principio a nivel localhost a través de una maquina virtual
>
> Escenario y punto de inicio:
> Instalacion y configuracion de la máquina virtual OSGeo Live 12 (ubuntu).
>
> Por lo tanto, en dicha maquina tenemos:
> GeoServer en http://localhost:8082/geoserver funcionando.
> GeoNode en http://localhost:80/geonode funcionando.
>
> Ahora estamos  agregando sobre la misma máquina virtual un visualizar con GeoExt ExtJS y OpenLayers sobre la misma maquina virtual y visualizar las capas WMS que nos prevee el geoserver, además tambien debemos tener la posibilidad de agregar capas WMS externas de otros proveedores.
>
> http://localhost/visualizador.  --> virtualhost creado para prueba visor.web
>
> Preguntas:
>
> 1. Porque no vemos las capas WMS del Geoserver, cuando las mismas son llamadas desde el visualizador ?  observamos que ustedes hablan de un proxy... y en muchos sitios comentan acerca del proxy de OpenLayers.
>
> Una prueba que he realizado es ingresar en el navegador la URL completa con todos sus parámetros del WMS y la URL se visualiza correctamente.
>
> 2. Es factible esa arquitectura que hemos armado ? Alguna sugerencia...
>
> 3. Nos falta configurar algo, en el Apache quizás ?
>
> Muchas gracias y Saludos
> Un gusto
>
>
> --
> Jorge Luis Schmukler
> _______________________________________________
> Spanish mailing list
> https://lists.osgeo.org/mailman/listinfo/spanish
> http://es.osgeo.org
> http://twitter.com/osgeoes
_______________________________________________
Spanish mailing list
https://lists.osgeo.org/mailman/listinfo/spanish
http://es.osgeo.org
http://twitter.com/osgeoes
Reply | Threaded
Open this post in threaded view
|

Re: Consulta OsGeo Live GeoServer OpenLayers

David Pérez Herranz
Toda aplicación web debe llamar a los servicios en la misma dirección:puerto si el visualizador está en el puerto 80 y los servicios (geoserver) en el 8082 es necesario un proxy. Este puede ser mediante el Apache mismo o mediante un php.

El vie., 15 feb. 2019 18:27, Luis Franco Vázquez <[hidden email]> escribió:
Hola Jorge:

Revisa la consola de javascript para ver los mensajes de error y
asegúrate de que realmente está funcionando el servicios WMS haciendo
una petición getcapabilities a mano.

El vie., 15 feb. 2019 a las 16:54, Jorge Luis Schmukler
(<[hidden email]>) escribió:
>
>
> Buenos días a todos los miembros de la lista, mi nombre es Jorge Schmukler soy de Parana Entre Rios Argentina; y les quiero consultar y comentar lo siguiente:
>
> disculpen las molestias, recurro a las capacidades y experiencia de ustedes para que nos ayuden a resolver el siguiente problema que tenemos:
>
> Objetivo: implementar un IDE y que utilice WMS, en principio a nivel localhost a través de una maquina virtual
>
> Escenario y punto de inicio:
> Instalacion y configuracion de la máquina virtual OSGeo Live 12 (ubuntu).
>
> Por lo tanto, en dicha maquina tenemos:
> GeoServer en http://localhost:8082/geoserver funcionando.
> GeoNode en http://localhost:80/geonode funcionando.
>
> Ahora estamos  agregando sobre la misma máquina virtual un visualizar con GeoExt ExtJS y OpenLayers sobre la misma maquina virtual y visualizar las capas WMS que nos prevee el geoserver, además tambien debemos tener la posibilidad de agregar capas WMS externas de otros proveedores.
>
> http://localhost/visualizador.  --> virtualhost creado para prueba visor.web
>
> Preguntas:
>
> 1. Porque no vemos las capas WMS del Geoserver, cuando las mismas son llamadas desde el visualizador ?  observamos que ustedes hablan de un proxy... y en muchos sitios comentan acerca del proxy de OpenLayers.
>
> Una prueba que he realizado es ingresar en el navegador la URL completa con todos sus parámetros del WMS y la URL se visualiza correctamente.
>
> 2. Es factible esa arquitectura que hemos armado ? Alguna sugerencia...
>
> 3. Nos falta configurar algo, en el Apache quizás ?
>
> Muchas gracias y Saludos
> Un gusto
>
>
> --
> Jorge Luis Schmukler
> _______________________________________________
> Spanish mailing list
> https://lists.osgeo.org/mailman/listinfo/spanish
> http://es.osgeo.org
> http://twitter.com/osgeoes
_______________________________________________
Spanish mailing list
https://lists.osgeo.org/mailman/listinfo/spanish
http://es.osgeo.org
http://twitter.com/osgeoes

_______________________________________________
Spanish mailing list
https://lists.osgeo.org/mailman/listinfo/spanish
http://es.osgeo.org
http://twitter.com/osgeoes