Como configurar buscador para que reconozca tíldes en las búsquedas.

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Como configurar buscador para que reconozca tíldes en las búsquedas.

AlbertoP
Buenos días:

Estamos intentando afinar las búsquedas sobre los títulos, abstract y Keywords de metadatos tanto de datos como de servicios y no conseguimos que devuelvan resultados cuando incluimos una tílde o algún caracter específico del español ("ñ"). Sabemos que tiene que ver con la codificación preestablecida en Geonetwork (no es la Encoding 8859-1) aunque no terminamos de estar seguros de como personalizar dichas búsquedas para que devuelvan resultados.

Lo curioso es que ante determinados criterios de búsqueda con tílde (por ejemplo Andalucía) si que devuelve resultados mientras que para la mayoría no.

La versión que hemos implantado es la 2.10.3 con vistas a pasar a la 2.10.4.

Otra cuestión es saber si podriamos conseguir resultados de búsqueda de una palabra incompleta sin incluir algún comodin del tipo "*" o "?". Las pruebas que hemos realizado tampoco nos devuelven resultados (por ejemplo "Andal").

Agradeciendo de antemano el interés

Un saludo
Reply | Threaded
Open this post in threaded view
|

Re: Como configurar buscador para que reconozca tíldes en las búsquedas.

Jose Garcia
Hola Alberto

Estás usando Tomcat? Aseguraté que el Connector tiene esto:

 URIEncoding="UTF-8"

Saludos,
Jose García

2015-02-16 11:22 GMT+01:00 AlbertoP <[hidden email]>:

> Buenos días:
>
> Estamos intentando afinar las búsquedas sobre los títulos, abstract y
> Keywords de metadatos tanto de datos como de servicios y no conseguimos que
> devuelvan resultados cuando incluimos una tílde o algún caracter específico
> del español ("ñ"). Sabemos que tiene que ver con la codificación
> preestablecida en Geonetwork (no es la Encoding 8859-1) aunque no
> terminamos
> de estar seguros de como personalizar dichas búsquedas para que devuelvan
> resultados.
>
> Lo curioso es que ante determinados criterios de búsqueda con tílde (por
> ejemplo Andalucía) si que devuelve resultados mientras que para la mayoría
> no.
>
> La versión que hemos implantado es la 2.10.3 con vistas a pasar a la
> 2.10.4.
>
> Otra cuestión es saber si podriamos conseguir resultados de búsqueda de una
> palabra incompleta sin incluir algún comodin del tipo "*" o "?". Las
> pruebas
> que hemos realizado tampoco nos devuelven resultados (por ejemplo "Andal").
>
> Agradeciendo de antemano el interés
>
> Un saludo
>
>
>
> --
> View this message in context:
> http://osgeo-org.1560.x6.nabble.com/Como-configurar-buscador-para-que-reconozca-tildes-en-las-busquedas-tp5187835.html
> Sent from the GeoNetwork users español mailing list archive at Nabble.com.
>
>
> ------------------------------------------------------------------------------
> Download BIRT iHub F-Type - The Free Enterprise-Grade BIRT Server
> from Actuate! Instantly Supercharge Your Business Reports and Dashboards
> with Interactivity, Sharing, Native Excel Exports, App Integration & more
> Get technology previously reserved for billion-dollar corporations, FREE
>
> http://pubads.g.doubleclick.net/gampad/clk?id=190641631&iu=/4140/ostg.clktrk
> _______________________________________________
> GeoNetwork-usuarios-es mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-usuarios-es
>



--

*GeoCat Bridge for ArcGIS allows instant publishing of data and metadata on
GeoServer and GeoNetwork. Visit http://geocat.net <http://geocat.net/> for
details. _________________________Jose GarcíaGeoCat bvVeenderweg 136721 WD
BennekomThe Netherlandshttp://GeoCat.net <http://geocat.net/>*
------------------------------------------------------------------------------
Download BIRT iHub F-Type - The Free Enterprise-Grade BIRT Server
from Actuate! Instantly Supercharge Your Business Reports and Dashboards
with Interactivity, Sharing, Native Excel Exports, App Integration & more
Get technology previously reserved for billion-dollar corporations, FREE
http://pubads.g.doubleclick.net/gampad/clk?id=190641631&iu=/4140/ostg.clktrk
_______________________________________________
GeoNetwork-usuarios-es mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-usuarios-es
Reply | Threaded
Open this post in threaded view
|

Re: Como configurar buscador para que reconozca tíldes en las búsquedas.

AlbertoP
Hola Jose:

si, configuramos el conector con los siguientes parámetros:

    <Connector port="8080" protocol="HTTP/1.1" proxyPort="443" scheme="https"
               connectionTimeout="20000" URIEnconding="UTF-8"
               URIredirectPort="8443" />

Pero nos siguen sin devolver resultados cuando incluimos tildes
Reply | Threaded
Open this post in threaded view
|

Re: Como configurar buscador para que reconozca tíldes en las búsquedas.

Kiko
In reply to this post by AlbertoP
Buenos dias,

Recientemente hemos desplegado en JBoss la versión de Geonetwork 2.10.4 y tenemos problemas con algunas búsquedas con acentos. Por ejemplo, tenemos un metadato de servicio que contiene la palabra 'Límits'.
El tema es que en las búsquedas no encuentra 'Límits' pero si 'Limits' (sin acento). Además no puede buscar por keywords acentuados.

He probado cambiar la codificación del Conector, URIEncoding="UTF-8", pero tampoco funciona.

Me gustaria saber a ver si alguien ha podido refinar estas búsquedas con acentos.

Muchas gracias
Reply | Threaded
Open this post in threaded view
|

Re: Como configurar buscador para que reconozca tíldes en las búsquedas.

Jose Garcia
Hola

No se que versión de JBoss usais, si es la 5 parece ser que lo del
Connector debería de funcionar, pero en versiones posteriores se ha de
configurar en otro fichero. Echale un vistazo a esto por si te puede servir:

http://stackoverflow.com/questions/15502707/jboss-as-7-1-request-parameters-encoding

Saludos,
Jose García

2015-07-13 12:57 GMT+02:00 Kiko <[hidden email]>:

> Buenos dias,
>
> Recientemente hemos desplegado en JBoss la versión de Geonetwork 2.10.4 y
> tenemos problemas con algunas búsquedas con acentos. Por ejemplo, tenemos
> un
> metadato de servicio que contiene la palabra 'Límits'.
> El tema es que en las búsquedas no encuentra 'Límits' pero si 'Limits' (sin
> acento). Además no puede buscar por keywords acentuados.
>
> He probado cambiar la codificación del Conector, URIEncoding="UTF-8", pero
> tampoco funciona.
>
> Me gustaria saber a ver si alguien ha podido refinar estas búsquedas con
> acentos.
>
> Muchas gracias
>
>
>
>
> --
> View this message in context:
> http://osgeo-org.1560.x6.nabble.com/Como-configurar-buscador-para-que-reconozca-tildes-en-las-busquedas-tp5187835p5215397.html
> Sent from the GeoNetwork users español mailing list archive at Nabble.com.
>
>
> ------------------------------------------------------------------------------
> Don't Limit Your Business. Reach for the Cloud.
> GigeNET's Cloud Solutions provide you with the tools and support that
> you need to offload your IT needs and focus on growing your business.
> Configured For All Businesses. Start Your Cloud Today.
> https://www.gigenetcloud.com/
> _______________________________________________
> GeoNetwork-usuarios-es mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-usuarios-es
>



--

*GeoCat Bridge for ArcGIS allows instant publishing of data and metadata on
GeoServer and GeoNetwork. Visit http://geocat.net <http://geocat.net/> for
details. _________________________Jose GarcíaGeoCat bvVeenderweg 136721 WD
BennekomThe Netherlandshttp://GeoCat.net <http://geocat.net/>*
------------------------------------------------------------------------------
Don't Limit Your Business. Reach for the Cloud.
GigeNET's Cloud Solutions provide you with the tools and support that
you need to offload your IT needs and focus on growing your business.
Configured For All Businesses. Start Your Cloud Today.
https://www.gigenetcloud.com/
_______________________________________________
GeoNetwork-usuarios-es mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-usuarios-es
Reply | Threaded
Open this post in threaded view
|

Re: Como configurar buscador para que reconozca tíldes en las búsquedas.

Kiko
Buenas Jose,

ya nos funcionan las búsquedas con acentos en Geonetwork.
Para mi JBoss 5.2 EAP he tenido que modificar/añadir el archivo:
jboss-eap-5.2/jboss-as/server/<instancia>/deploy/jbossweb.sar/server.xml

<Connector acceptCount="100" address="${jboss.bind.address}" connectionTimeout="20000" disableUploadTimeout="true"
emptySessionPath="true" enableLookups="false" maxHttpHeaderSize="8192" maxThreads="250" port="8080" protocol="HTTP/1.1" redirectPort="8443"
URIEncoding="UTF-8" useBodyEncodingForURI="true"/>

He parado JBoss, borrado los temporales y he vuelto a arrancar y funciona.

También he cambiado la codificación del index.html de Geonetwork añadiendo el meta:
<meta http-equiv="content-type" content="text/html; charset=utf-8">
pero dudo que afecte a las búsquedas.

Muchas gracias Jose por tu ayuda.

Saludos
Kiko