Code Submission Notification: fixed protected version defect in ArcSDE Provider

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Code Submission Notification: fixed protected version defect in ArcSDE Provider

Pierre Dalcourt

Fixed protected version defect in ArcSDE Provider.

The ArcSDE Provider was being too strict in preventing users from accessing non-public

versions that they do not own.  ArcSDE supports "protected" versions that

are writable by the owner and at least read-only by others.  I have verified this

in ArcMap.  Removed an explicit check that prevents users from accessing protected

versions they do not own.  Also removed a check when deleting versions if the

state fails to be deleted; this is because states can be shared among many

versions and thus the provider could succeed in deleting a version but fail to

delete the corresponding state if it's in use by other versions.

 

FILES MODIFIED IN BRANCHES\3.2.x and trunk :

 

Src/Provider/ArcSDEConnection.cpp

Src/Provider/ArcSDELongTransactionUtility.cpp

Src/UnitTest/LongTransactionTests.cpp

Src/UnitTest/LongTransactionTests.h

 


_______________________________________________
fdo-internals mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/fdo-internals