Can not install qgis-mapserver on CentOS 7

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Can not install qgis-mapserver on CentOS 7

jbogdani
Hello everybody,
I’m trying to setup a QGis server on a CentOS (7.3.1611) server, following the official guide: http://hub.qgis.org/projects/quantum-gis/wiki/QGIS_Server_Tutorial

I followed the instructions and added EPEL:
yum install epel-release

Then I added ELGIS:

And finally tried to install qgis-mapserver:
yum install qgis-mapserver

But this last command did not work, because some dependencies were not met:

Error: Package: qgis-1.8.0-9_0.el6.x86_64 (elgis)
           Requires: libqwt.so.5()(64bit)
Error: Package: qgis-1.8.0-9_0.el6.x86_64 (elgis)
           Requires: libqwtpolar.so.0()(64bit)
Error: Package: mod_fcgid-2.3.9-4.el7.x86_64 (base)
           Requires: httpd-mmn = 20120211x8664
Error: Package: qgis-1.8.0-9_0.el6.x86_64 (elgis)
           Requires: libspatialindex.so.1()(64bit)
Error: Package: qgis-mapserver-1.8.0-9_0.el6.x86_64 (elgis)
           Requires: libspatialindex.so.1()(64bit)

Am I missing anything? Should I install these dependencies manually? Or should I install some other package before?

Any help would be much appreciated,

Thank you


_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: Can not install qgis-mapserver on CentOS 7

Steve.Toutant
I would consider using docker on centos7
I didn't try any of these image yet so I can't suggest any
https://hub.docker.com/search/?isAutomated=0&isOfficial=0&page=1&pullCount=0&q=qgis-server&starCount=0




De :        Julian Bogdani <[hidden email]>
A :        [hidden email]
Date :        2017-04-12 13:53
Objet :        [Qgis-user] Can not install qgis-mapserver on CentOS 7
Envoyé par :        "Qgis-user" <[hidden email]>




Hello everybody,
I’m trying to setup a QGis server on a CentOS (7.3.1611) server, following the official guide: http://hub.qgis.org/projects/quantum-gis/wiki/QGIS_Server_Tutorial

I followed the instructions and added EPEL:
yum install epel-release

Then I added ELGIS:
rpm -Uvh http://elgis.argeo.org/repos/6/elgis-release-6-6_0.noarch.rpm

And finally tried to install qgis-mapserver:
yum install qgis-mapserver

But this last command did not work, because some dependencies were not met:

Error: Package: qgis-1.8.0-9_0.el6.x86_64 (elgis)
          Requires: libqwt.so.5()(64bit)
Error: Package: qgis-1.8.0-9_0.el6.x86_64 (elgis)
          Requires: libqwtpolar.so.0()(64bit)
Error: Package: mod_fcgid-2.3.9-4.el7.x86_64 (base)
          Requires: httpd-mmn = 20120211x8664
Error: Package: qgis-1.8.0-9_0.el6.x86_64 (elgis)
          Requires: libspatialindex.so.1()(64bit)
Error: Package: qgis-mapserver-1.8.0-9_0.el6.x86_64 (elgis)
          Requires: libspatialindex.so.1()(64bit)


Am I missing anything? Should I install these dependencies manually? Or should I install some other package before?

Any help would be much appreciated,

Thank you


-----
Julian Bogdani
jbogdani@...
http://bradypus.net




_______________________________________________
Qgis-user mailing list
[hidden email]
List info:
https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe:
https://lists.osgeo.org/mailman/listinfo/qgis-user

_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: Can not install qgis-mapserver on CentOS 7

Nicolas Boisteault
In reply to this post by jbogdani

Hi Julian,

This guide is old and I think not updated. The version 1.8 of QGIS is too old. You should use http://docs.qgis.org/testing/en/docs/user_manual/working_with_ogc/ogc_server_support.html. Unfortunately the installation is explained for Ubuntu.

You can try this too https://www.qgis.org/fr/site/forusers/alldownloads.html#id17

Le 2017-04-12 19:53, Julian Bogdani a écrit :

Hello everybody,
I'm trying to setup a QGis server on a CentOS (7.3.1611) server, following the official guide: http://hub.qgis.org/projects/quantum-gis/wiki/QGIS_Server_Tutorial
 
I followed the instructions and added EPEL:
yum install epel-release
 
Then I added ELGIS:
 
And finally tried to install qgis-mapserver:
yum install qgis-mapserver
 
But this last command did not work, because some dependencies were not met:
 
Error: Package: qgis-1.8.0-9_0.el6.x86_64 (elgis)
           Requires: libqwt.so.5()(64bit)
Error: Package: qgis-1.8.0-9_0.el6.x86_64 (elgis)
           Requires: libqwtpolar.so.0()(64bit)
Error: Package: mod_fcgid-2.3.9-4.el7.x86_64 (base)
           Requires: httpd-mmn = 20120211x8664
Error: Package: qgis-1.8.0-9_0.el6.x86_64 (elgis)
           Requires: libspatialindex.so.1()(64bit)
Error: Package: qgis-mapserver-1.8.0-9_0.el6.x86_64 (elgis)
           Requires: libspatialindex.so.1()(64bit)
 
Am I missing anything? Should I install these dependencies manually? Or should I install some other package before?
 
Any help would be much appreciated,
 
Thank you
 
-----
Julian Bogdani


_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user

_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: Can not install qgis-mapserver on CentOS 7

Burghardt.Scholle
In reply to this post by jbogdani

Hi Julian,

in the past few weeks I have also experimented with CentOS 7 and QGIS /QGIS server. My experience has shown that manual compilation of the required software components / libraries under CentOS was necessary to get an efficient and productive work environment. I have proceeded as follows:

·         Compile Proj4

·         Compile GDAL

·         Compile GEOS

·         Compile PostGIS (if needed, you can take PostgreSQL from the repository http://yum.postgresql.org/repopackages.php)

·         Compile GRASS (if needed)

·         Compile QGIS Desktop / Server

 

After that you have a current running QGIS environment and can determine many settings by yourself.

 

By the way: the Docker proposal from Steve sounds very interesting.

 

Hope this helps

Burghardt

 

Von: Qgis-user [[hidden email]] Im Auftrag von Julian Bogdani
Gesendet: Mittwoch, 12. April 2017 19:53
An: [hidden email]
Betreff: [Qgis-user] Can not install qgis-mapserver on CentOS 7

 

Hello everybody,

I’m trying to setup a QGis server on a CentOS (7.3.1611) server, following the official guide: http://hub.qgis.org/projects/quantum-gis/wiki/QGIS_Server_Tutorial

 

I followed the instructions and added EPEL:

yum install epel-release

 

Then I added ELGIS:

 

And finally tried to install qgis-mapserver:

yum install qgis-mapserver

 

But this last command did not work, because some dependencies were not met:

 

Error: Package: qgis-1.8.0-9_0.el6.x86_64 (elgis)
           Requires: libqwt.so.5()(64bit)
Error: Package: qgis-1.8.0-9_0.el6.x86_64 (elgis)
           Requires: libqwtpolar.so.0()(64bit)
Error: Package: mod_fcgid-2.3.9-4.el7.x86_64 (base)
           Requires: httpd-mmn = 20120211x8664
Error: Package: qgis-1.8.0-9_0.el6.x86_64 (elgis)
           Requires: libspatialindex.so.1()(64bit)
Error: Package: qgis-mapserver-1.8.0-9_0.el6.x86_64 (elgis)
           Requires: libspatialindex.so.1()(64bit)

 

Am I missing anything? Should I install these dependencies manually? Or should I install some other package before?

 

Any help would be much appreciated,

 

Thank you

 

-----

Julian Bogdani

 

 



 


_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: Can not install qgis-mapserver on CentOS 7

Richard Duivenvoorde
In reply to this post by jbogdani
On 12-04-17 19:53, Julian Bogdani wrote:

> Am I missing anything? Should I install these dependencies manually? Or
> should I install some other package before?
>
> Any help would be much appreciated,

FYI: there is a rpm directory in the QGIS repo:

https://github.com/qgis/QGIS/tree/master/rpm

it contains some docs and spec files to be used to find dependencies.

I used the spec file some time ago to build QGIS-Desktop on CentOS 7:

http://zuidt.nl/blog/html/2015/10/12/build_qgis_master_with_oracle_provider_yourself_on_centos7.html

Note that master is currently to become 3.0 so you probably use 2.18 or
2.14 branch

Regards,

Richard
_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user