Button Background Color?

classic Classic list List threaded Threaded
5 messages Options
ivo
Reply | Threaded
Open this post in threaded view
|

Button Background Color?

ivo
Hallo Liste,

ich habe eine vermutlich einfache Frage, leider finde ich dazu nichts in der Mapbender-Doku (oder ich habe an der falschen Stelle gesucht).

In der Mapbender Demo Map mapbender_user werden die aktiven Button mit einer Hintergrundfarbe hinterlegt. Welche Einstellungen muss man denn dafür setzen?
Vorab schon einmal Danke für Hinweise.

In the Mapbender Demo Map mapbender_user the active button with a background color is stored. What settings do you have to set?
Previously, thank you for hints.

VG
Ivo
Reply | Threaded
Open this post in threaded view
|

Re: Button Background Color?

Astrid Emde (WhereGroup)
Hallo Ivo,

stimmt - die Info ist nicht leicht zu finden ;)

Damit aktive Buttons mit einer Hintergrundfarbe hinterlegt werden, musst
du ihnen eine Gruppe zuweisen.

1. Button Angabe unter Group irgendein Wort eingeben "Steuerung" -
diesen Begriff bei allen Buttons eintragen, die als Gruppe gesteuert
werden sollen
* siehe Screenshot Group
https://doc.mapbender3.org/en/bundles/Mapbender/CoreBundle/elements/button.html
* Group: Adds the element to a group. Only one button of the group may
be activated.

2. für diesen Aktivstatus kann eine Farbe definiert werden

.toolBar .toolBarItemActive {
     background-color: #ff00ff; <----------------------
     color: #0000ff;
     -webkit-border-radius: 3px;
     -moz-border-radius: 3px;
     -ms-border-radius: 3px;
     -o-border-radius: 3px;
     border-radius: 3px;
}

Schönen Gruß Astrid

Am 2017-06-02 11:41, schrieb ivo:

> Hallo Liste,
>
> ich habe eine vermutlich einfache Frage, leider finde ich dazu nichts
> in der
> Mapbender-Doku (oder ich habe an der falschen Stelle gesucht).
>
> In der Mapbender Demo Map mapbender_user werden die aktiven Button mit
> einer
> Hintergrundfarbe hinterlegt. Welche Einstellungen muss man denn dafür
> setzen?
> Vorab schon einmal Danke für Hinweise.
>
> In the Mapbender Demo Map mapbender_user the active button with a
> background
> color is stored. What settings do you have to set?
> Previously, thank you for hints.
>
> VG
> Ivo
>
>
>
>
> --
> View this message in context:
> http://osgeo-org.1560.x6.nabble.com/Button-Background-Color-tp5322785.html
> Sent from the mapbender-users mailing list archive at Nabble.com.
> _______________________________________________
> Mapbender_users mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/mapbender_users

--
Mit freundlichen Grüßen

Astrid Emde
GIS-Consultant

---------------------------------------
Aufwind durch Wissen!
Qualifizierte OpenSource-GIS-Schulungen
bei der www.foss-academy.com
---------------------------------------

  Astrid Emde
  WhereGroup GmbH & Co.KG
  Eifelstraße 7
  53119 Bonn
  Germany

  Fon: +49(0)228 90 90 38 - 22
  Fax: +49(0)228 90 90 38 - 11

  [hidden email]
  www.wheregroup.com

  Folgen Sie der WhereGroup auf twitter:
http://twitter.com/WhereGroup_com

Amtsgericht Bonn, HRA 6788
-------------------------------
Komplementärin:
WhereGroup Verwaltungs GmbH
vertreten durch:
Olaf Knopp, Peter Stamm
-------------------------------
_______________________________________________
Mapbender_users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_users
ivo
Reply | Threaded
Open this post in threaded view
|

Re: Button Background Color?

ivo
Hallo Astrid,

vielen Dank für die schnelle Hilfe ...

VG & Schöne Pfingsten
Ivo
ivo
Reply | Threaded
Open this post in threaded view
|

Re: Button Background Color?

ivo
In reply to this post by Astrid Emde (WhereGroup)
Hallo Astrid,

mir ist aufgefallen, dass sich die die Button-Hintergrundfarbe bei der Funktion POI nach Beenden der Funktion oder Abbruch nicht mehr deaktiviert.

Bei allen anderen Funktionen (wie  Feature Info, Line/Area Ruler, WMS laden) die ich in einer Button-Guppe vereint habe funktioniert dies.
Liegt es vielleicht daran das die POI-Funktion einen "Mehrstufigen Pupup-Dialog nutzt oder muss man bei dieser Funktion noch andere einstellungen treffen?

SG Ivo
Reply | Threaded
Open this post in threaded view
|

Re: Button Background Color?

Charlotte Toma
In reply to this post by ivo


Hallo,

die Hervorhebung eines Gruppen-Buttons über die Hintergrundfarbe sollte
eigentlich immer nach dem Deaktivieren des Buttons verschwinden.
Ich habe testweise mal eine Demoanwendung[1] auf dem demo.mapbender3.org
Server erstellt, um das Verhalten nachzustellen.
Hier tritt das Verhalten auch auf, es scheint also ein Bug in der neuen
Mapbender3 Version zu sein.
Ich habe den Fehler dem Mapbender3-Team bereits gemeldet [2].


[1] https://demo.mapbender3.org/application/buttons_group
[2] https://github.com/mapbender/mapbender/issues/549

----------------------------------------------------------------------

Hello,

The highlighting of a grouped button over the background color should
actually always disappear after the deactivation of the button.
I created a demo application [1] on the demo.mapbender3.org server, in
order to test the behavior.
Here is the behavior, so it seems to be a bug in the new Mapbender3 version.
I have already reported the bug to the Mapbender3 team [2].


[1] https://demo.mapbender3.org/application/buttons_group
[2] https://github.com/mapbender/mapbender/issues/549

--
Mit freundlichen Grüßen

Charlotte Toma
GIS-Consultant

**********************************
AGIT 2017
5.-7. Juli 2017 in Salzburg
Besuchen Sie uns an Stand Nr. 31
www.agit.at
**********************************

 Charlotte Toma
 WhereGroup GmbH & Co.KG
 Eifelstraße 7
 53119 Bonn
 Germany

 Fon: +49(0)228 90 90 38 - 24
 Fax: +49(0)228 90 90 38 - 11

 [hidden email]
 www.wheregroup.com

 Folgen Sie der WhereGroup auf twitter: http://twitter.com/WhereGroup_com

Amtsgericht Bonn, HRA 6788
-------------------------------
Komplementärin:
WhereGroup Verwaltungs GmbH
vertreten durch:
Olaf Knopp, Peter Stamm
-------------------------------

Am 22.06.2017 um 11:56 schrieb ivo:

> Hallo Astrid,
>
> mir ist aufgefallen, dass sich die die Button-Hintergrundfarbe bei der
> Funktion POI nach Beenden der Funktion oder Abbruch nicht mehr deaktiviert.
>
> Bei allen anderen Funktionen (wie  Feature Info, Line/Area Ruler, WMS laden)
> die ich in einer Button-Guppe vereint habe funktioniert dies.
> Liegt es vielleicht daran das die POI-Funktion einen "Mehrstufigen
> Pupup-Dialog nutzt oder muss man bei dieser Funktion noch andere
> einstellungen treffen?
>
> SG Ivo
>
>
>
> --
> View this message in context: http://osgeo-org.1560.x6.nabble.com/Button-Background-Color-tp5322785p5325143.html
> Sent from the mapbender-users mailing list archive at Nabble.com.
> _______________________________________________
> Mapbender_users mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/mapbender_users

_______________________________________________
Mapbender_users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_users